]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- merged system-libcacard patch from qemu-kvm
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - qemu-system-ppc -hda ac-ppc.img says:
3 #   qemu: could not open disk image ac-ppc.img: error "Success"
4 #   qemu-0.12.2-2.x86_64.rpm - broken
5 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
6 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
7 #   qemu-0.11.1-*.x86_64.rpm - OK
8 #
9 # Conditional build:
10 %bcond_without  sdl             # SDL UI and audio support
11 %bcond_without  opengl          # OpenGL support
12 %bcond_without  ceph            # Ceph/RBD support
13 %bcond_without  spice           # SPICE support
14 %bcond_with     esd             # EsounD audio support
15 %bcond_without  oss             # OSS audio support
16 %bcond_without  pulseaudio      # PulseAudio audio support
17 %bcond_without  xen             # Xen backend driver support
18
19 Summary:        QEMU CPU Emulator
20 Summary(pl.UTF-8):      QEMU - emulator procesora
21 Name:           qemu
22 Version:        1.2.0
23 Release:        6
24 License:        GPL v2+
25 Group:          Applications/Emulators
26 Source0:        http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
27 # Source0-md5:  78eb1e984f4532aa9f2bdd3c127b5b61
28 Patch0:         %{name}-cflags.patch
29 Patch1:         vgabios-widescreens.patch
30 Patch2:         %{name}-usbredir.patch
31 Patch3:         %{name}-whitelist.patch
32 Patch4:         %{name}-system-libcacard.patch
33 # Proof of concept, for reference, do not remove
34 Patch5:         %{name}-kde_virtual_workspaces_hack.patch
35 URL:            http://www.qemu-project.org/
36 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
37 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
38 BuildRequires:  alsa-lib-devel
39 BuildRequires:  bluez-libs-devel
40 BuildRequires:  brlapi-devel
41 %{?with_ceph:BuildRequires:     ceph-devel}
42 BuildRequires:  curl-devel
43 BuildRequires:  cyrus-sasl-devel >= 2
44 %{?with_esd:BuildRequires:      esound-devel}
45 BuildRequires:  glib2-devel >= 1:2.12
46 BuildRequires:  gnutls-devel
47 BuildRequires:  libaio-devel
48 BuildRequires:  libcacard-devel
49 BuildRequires:  libcap-devel
50 BuildRequires:  libcap-ng-devel
51 BuildRequires:  libfdt-devel
52 BuildRequires:  libiscsi-devel
53 BuildRequires:  libjpeg-devel
54 BuildRequires:  libpng-devel
55 BuildRequires:  libseccomp-devel
56 BuildRequires:  libuuid-devel
57 BuildRequires:  ncurses-devel
58 BuildRequires:  nss-devel >= 3.12.8
59 BuildRequires:  perl-Encode
60 BuildRequires:  perl-tools-pod
61 BuildRequires:  pkgconfig
62 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
63 BuildRequires:  sed >= 4.0
64 %if %{with spice}
65 BuildRequires:  spice-protocol >= 0.8.0
66 BuildRequires:  spice-server-devel >= 0.8.2
67 %endif
68 BuildRequires:  texi2html
69 BuildRequires:  texinfo
70 BuildRequires:  usbredir-devel >= 0.3.4
71 BuildRequires:  vde2-devel
72 BuildRequires:  which
73 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
74 BuildRequires:  xfsprogs-devel
75 BuildRequires:  xorg-lib-libX11-devel
76 BuildRequires:  zlib-devel
77 Requires:       %{name}-img = %{version}-%{release}
78 Requires:       %{name}-system-alpha = %{version}-%{release}
79 Requires:       %{name}-system-arm = %{version}-%{release}
80 Requires:       %{name}-system-cris = %{version}-%{release}
81 Requires:       %{name}-system-lm32 = %{version}-%{release}
82 Requires:       %{name}-system-m68k = %{version}-%{release}
83 Requires:       %{name}-system-microblaze = %{version}-%{release}
84 Requires:       %{name}-system-mips = %{version}-%{release}
85 Requires:       %{name}-system-or32 = %{version}-%{release}
86 Requires:       %{name}-system-ppc = %{version}-%{release}
87 Requires:       %{name}-system-s390x = %{version}-%{release}
88 Requires:       %{name}-system-sh4 = %{version}-%{release}
89 Requires:       %{name}-system-sparc = %{version}-%{release}
90 Requires:       %{name}-system-unicore32 = %{version}-%{release}
91 Requires:       %{name}-system-x86 = %{version}-%{release}
92 Requires:       %{name}-system-xtensa = %{version}-%{release}
93 Requires:       %{name}-user = %{version}-%{release}
94 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
96 %define systempkg_req \
97 Requires:       SDL >= 1.2.1
98
99 # some PPC/SPARC boot image in ELF format
100 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
101
102 %description
103 QEMU is a FAST! processor emulator. By using dynamic translation it
104 achieves a reasonnable speed while being easy to port on new host
105 CPUs. QEMU has two operating modes:
106
107 - User mode emulation. In this mode, QEMU can launch Linux processes
108   compiled for one CPU on another CPU. Linux system calls are converted
109   because of endianness and 32/64 bit mismatches. Wine (Windows
110   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
111
112 - Full system emulation. In this mode, QEMU emulates a full system,
113   including a processor and various peripherials. It can also be used to
114   provide virtual hosting of several virtual PC on a single server.
115
116 %description -l pl.UTF-8
117 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
118 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
119 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
120
121 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
122   procesy linuksowe skompilowane dla jednego procesora na innym
123   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
124   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
125   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
126   cele QEMU.
127
128 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
129   włączając w to procesor i różne urządzenia peryferyjne. Może być także
130   używane do wirtualnego hostowania kilku wirtualnych pecetów na
131   pojedynczym serwerze.
132
133 %package common
134 Summary:        QEMU common files needed by all QEMU targets
135 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
136 Group:          Development/Tools
137 Requires:       glib2 >= 1:2.12
138 Conflicts:      qemu < 1.0-2
139
140 %description common
141 QEMU is a generic and open source processor emulator which achieves a
142 good emulation speed by using dynamic translation.
143
144 This package provides the common files needed by all QEMU targets.
145
146 %description common -l pl.UTF-8
147 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
148 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
149
150 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
151 środowiska QEMU.
152
153 %package img
154 Summary:        QEMU command line tool for manipulating disk images
155 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
156 Group:          Development/Tools
157 Conflicts:      qemu < 1.0-2
158
159 %description img
160 This package provides a command line tool for manipulating disk
161 images.
162
163 %description img -l pl.UTF-8
164 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
165 na obrazach dysków.
166
167 %package user
168 Summary:        QEMU user mode emulation of qemu targets
169 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
170 Group:          Development/Tools
171 Requires:       %{name}-common = %{version}-%{release}
172
173 %description user
174 QEMU is a generic and open source processor emulator which achieves a
175 good emulation speed by using dynamic translation.
176
177 This package provides the user mode emulation of QEMU targets.
178
179 %description user -l pl.UTF-8
180 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
181 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
182
183 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
184
185 %package system-alpha
186 Summary:        QEMU system emulator for Alpha
187 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
188 Group:          Development/Tools
189 Requires:       %{name}-common = %{version}-%{release}
190 %systempkg_req
191
192 %description system-alpha
193 QEMU is a generic and open source processor emulator which achieves a
194 good emulation speed by using dynamic translation.
195
196 This package provides the system emulator with Alpha CPU.
197
198 %description system-alpha -l pl.UTF-8
199 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
200 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
201
202 Ten pakiet zawiera emulator systemu z procesorem Alpha.
203
204 %package system-arm
205 Summary:        QEMU system emulator for ARM
206 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
207 Group:          Development/Tools
208 Requires:       %{name}-common = %{version}-%{release}
209 %systempkg_req
210
211 %description system-arm
212 QEMU is a generic and open source processor emulator which achieves a
213 good emulation speed by using dynamic translation.
214
215 This package provides the system emulator for ARM.
216
217 %description system-arm -l pl.UTF-8
218 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
219 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
220
221 Ten pakiet zawiera emulator systemu z procesorem ARM.
222
223 %package system-cris
224 Summary:        QEMU system emulator for CRIS
225 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
226 Group:          Development/Tools
227 Requires:       %{name}-common = %{version}-%{release}
228 %systempkg_req
229
230 %description system-cris
231 QEMU is a generic and open source processor emulator which achieves a
232 good emulation speed by using dynamic translation.
233
234 This package provides the system emulator with CRIS CPU.
235
236 %description system-cris -l pl.UTF-8
237 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
238 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
239
240 Ten pakiet zawiera emulator systemu z procesorem CRIS.
241
242 %package system-lm32
243 Summary:        QEMU system emulator for LM32
244 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
245 Group:          Development/Tools
246 Requires:       %{name}-common = %{version}-%{release}
247 %systempkg_req
248
249 %description system-lm32
250 QEMU is a generic and open source processor emulator which achieves a
251 good emulation speed by using dynamic translation.
252
253 This package provides the system emulator with LM32 CPU.
254
255 %description system-lm32 -l pl.UTF-8
256 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
257 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
258
259 Ten pakiet zawiera emulator systemu z procesorem LM32.
260
261 %package system-m68k
262 Summary:        QEMU system emulator for m68k
263 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
264 Group:          Development/Tools
265 Requires:       %{name}-common = %{version}-%{release}
266 %systempkg_req
267
268 %description system-m68k
269 QEMU is a generic and open source processor emulator which achieves a
270 good emulation speed by using dynamic translation.
271
272 This package provides the system emulator with m68k CPU.
273
274 %description system-m68k -l pl.UTF-8
275 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
276 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
277
278 Ten pakiet zawiera emulator systemu z procesorem m68k.
279
280 %package system-microblaze
281 Summary:        QEMU system emulator for MicroBlaze
282 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
283 Group:          Development/Tools
284 Requires:       %{name}-common = %{version}-%{release}
285 %systempkg_req
286
287 %description system-microblaze
288 QEMU is a generic and open source processor emulator which achieves a
289 good emulation speed by using dynamic translation.
290
291 This package provides the system emulator with MicroBlaze CPU.
292
293 %description system-microblaze -l pl.UTF-8
294 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
295 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
296
297 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
298
299 %package system-mips
300 Summary:        QEMU system emulator for MIPS
301 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
302 Group:          Development/Tools
303 Requires:       %{name}-common = %{version}-%{release}
304 %systempkg_req
305
306 %description system-mips
307 QEMU is a generic and open source processor emulator which achieves a
308 good emulation speed by using dynamic translation.
309
310 This package provides the system emulator with MIPS CPU.
311
312 %description system-mips -l pl.UTF-8
313 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
314 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
315
316 Ten pakiet zawiera emulator systemu z procesorem MIPS.
317
318 %package system-or32
319 Summary:        QEMU system emulator for OpenRISC
320 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
321 Group:          Development/Tools
322 Requires:       %{name}-common = %{version}-%{release}
323 %systempkg_req
324
325 %description system-or32
326 QEMU is a generic and open source processor emulator which achieves a
327 good emulation speed by using dynamic translation.
328
329 This package provides the system emulator with OpenRISC CPU.
330
331 %description system-or32 -l pl.UTF-8
332 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
333 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
334
335 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
336
337 %package system-ppc
338 Summary:        QEMU system emulator for PowerPC
339 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
340 Group:          Development/Tools
341 Requires:       %{name}-common = %{version}-%{release}
342 %systempkg_req
343
344 %description system-ppc
345 QEMU is a generic and open source processor emulator which achieves a
346 good emulation speed by using dynamic translation.
347
348 This package provides the system emulator with PowerPC CPU.
349
350 %description system-ppc -l pl.UTF-8
351 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
352 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
353
354 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
355
356 %package system-s390x
357 Summary:        QEMU system emulator for S390
358 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
359 Group:          Development/Tools
360 Requires:       %{name}-common = %{version}-%{release}
361 %systempkg_req
362
363 %description system-s390x
364 QEMU is a generic and open source processor emulator which achieves a
365 good emulation speed by using dynamic translation.
366
367 This package provides the system emulator with S390 CPU.
368
369 %description system-s390x -l pl.UTF-8
370 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
371 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
372
373 Ten pakiet zawiera emulator systemu z procesorem S390.
374
375 %package system-sh4
376 Summary:        QEMU system emulator for SH4
377 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
378 Group:          Development/Tools
379 Requires:       %{name}-common = %{version}-%{release}
380 %systempkg_req
381
382 %description system-sh4
383 QEMU is a generic and open source processor emulator which achieves a
384 good emulation speed by using dynamic translation.
385
386 This package provides the system emulator with SH4 CPU.
387
388 %description system-sh4 -l pl.UTF-8
389 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
390 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
391
392 Ten pakiet zawiera emulator systemu z procesorem SH4.
393
394 %package system-sparc
395 Summary:        QEMU system emulator for SPARC
396 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
397 Group:          Development/Tools
398 Requires:       %{name}-common = %{version}-%{release}
399 %systempkg_req
400
401 %description system-sparc
402 QEMU is a generic and open source processor emulator which achieves a
403 good emulation speed by using dynamic translation.
404
405 This package provides the system emulator with SPARC/SPARC64 CPU.
406
407 %description system-sparc -l pl.UTF-8
408 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
409 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
410
411 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
412
413 %package system-unicore32
414 Summary:        QEMU system emulator for UniCore32
415 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
416 Group:          Development/Tools
417 Requires:       %{name}-common = %{version}-%{release}
418 %systempkg_req
419
420 %description system-unicore32
421 QEMU is a generic and open source processor emulator which achieves a
422 good emulation speed by using dynamic translation.
423
424 This package provides the system emulator with UniCore32 CPU.
425
426 %description system-unicore32 -l pl.UTF-8
427 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
428 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
429
430 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
431
432 %package system-x86
433 Summary:        QEMU system emulator for x86
434 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
435 Group:          Development/Tools
436 Requires:       %{name}-common = %{version}-%{release}
437 %systempkg_req
438
439 %description system-x86
440 QEMU is a generic and open source processor emulator which achieves a
441 good emulation speed by using dynamic translation.
442
443 %description system-x86 -l pl.UTF-8
444 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
445 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
446
447 %package system-xtensa
448 Summary:        QEMU system emulator for Xtensa
449 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
450 Group:          Development/Tools
451 Requires:       %{name}-common = %{version}-%{release}
452 %systempkg_req
453
454 %description system-xtensa
455 QEMU is a generic and open source processor emulator which achieves a
456 good emulation speed by using dynamic translation.
457
458 This package provides the system emulator with Xtensa CPU.
459
460 %description system-xtensa -l pl.UTF-8
461 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
462 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
463
464 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
465
466 %prep
467 %setup -q
468 %patch0 -p1
469 %patch1 -p1
470 %patch2 -p1
471 %patch3 -p0
472 %patch4 -p1
473
474 %{__mv} libcacard libcacard-use-system-lib
475
476 # workaround for conflict with alsa/error.h
477 ln -s ../error.h qapi/error.h
478
479 %build
480 ./configure \
481         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
482         --extra-ldflags="%{rpmldflags}" \
483         --prefix=%{_prefix} \
484         --sysconfdir=%{_sysconfdir} \
485         --cc="%{__cc}" \
486         --host-cc="%{__cc}" \
487         --disable-strip \
488         --enable-attr \
489         --enable-bluez \
490         --enable-brlapi \
491         --enable-cap-ng \
492         --enable-curl \
493         --enable-curses \
494         --enable-docs \
495         --enable-fdt \
496         --enable-libiscsi \
497         --enable-mixemu \
498         %{__enable_disable opengl} \
499         %{__enable_disable ceph rbd} \
500         %{__enable_disable sdl} \
501         --enable-seccomp \
502         %{__enable_disable spice} \
503         --enable-smartcard \
504         --enable-smartcard-nss \
505         --enable-usb-redir \
506         --enable-uuid \
507         --enable-vde \
508         --enable-virtfs \
509         --enable-vnc-jpeg \
510         --enable-vnc-png \
511         --enable-vnc-sasl \
512         --enable-vnc-tls \
513         %{__enable_disable xen} \
514         --audio-card-list="ac97,es1370,sb16,cs4231a,adlib,gus,hda" \
515         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
516         --interp-prefix=%{_libdir}/qemu/lib-%%M
517 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
518 # --libexecdir in configure is nop
519 %{__make} \
520         V=1 \
521         CONFIG_QEMU_HELPERDIR="%{_libdir}"
522
523 # rebuild patched vesa tables with additional widescreen modes.
524 %{__make} -C roms/vgabios stdvga-bios
525
526 %install
527 rm -rf $RPM_BUILD_ROOT
528
529 %{__make} install \
530         DESTDIR=$RPM_BUILD_ROOT \
531         libexecdir=%{_libdir}
532
533 install -d $RPM_BUILD_ROOT%{_sysconfdir}
534 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
535 #!/bin/sh
536
537 EOF
538
539 # already packaged
540 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
541 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
542
543 # install patched vesa tables with additional widescreen modes.
544 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
545
546 %clean
547 rm -rf $RPM_BUILD_ROOT
548
549 %files
550 %defattr(644,root,root,755)
551
552 %files common
553 %defattr(644,root,root,755)
554 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
555 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
556 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
557 %dir %{_sysconfdir}/qemu
558 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
559 %attr(755,root,root) %{_bindir}/qemu-nbd
560 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
561 %{_mandir}/man1/qemu.1*
562 %{_mandir}/man1/virtfs-proxy-helper.1*
563 %{_mandir}/man8/qemu-nbd.8*
564
565 %dir %{_datadir}/qemu
566 %{_datadir}/%{name}/cpus-*.conf
567 %{_datadir}/%{name}/keymaps
568 %{_datadir}/%{name}/qemu-icon.bmp
569 # various bios images
570 %{_datadir}/%{name}/*.bin
571 %{_datadir}/%{name}/*.rom
572 %{_datadir}/%{name}/*.dtb
573 %{_datadir}/%{name}/openbios-ppc
574 %{_datadir}/%{name}/openbios-sparc*
575 %{_datadir}/%{name}/palcode-clipper
576
577 %files img
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{_bindir}/qemu-img
580 %{_mandir}/man1/qemu-img.1*
581
582 %files user
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_bindir}/qemu-alpha
585 %attr(755,root,root) %{_bindir}/qemu-arm
586 %attr(755,root,root) %{_bindir}/qemu-armeb
587 %attr(755,root,root) %{_bindir}/qemu-cris
588 %attr(755,root,root) %{_bindir}/qemu-ga
589 %attr(755,root,root) %{_bindir}/qemu-i386
590 %attr(755,root,root) %{_bindir}/qemu-io
591 %attr(755,root,root) %{_bindir}/qemu-m68k
592 %attr(755,root,root) %{_bindir}/qemu-microblaze
593 %attr(755,root,root) %{_bindir}/qemu-microblazeel
594 %attr(755,root,root) %{_bindir}/qemu-mips
595 %attr(755,root,root) %{_bindir}/qemu-mipsel
596 %attr(755,root,root) %{_bindir}/qemu-or32
597 %attr(755,root,root) %{_bindir}/qemu-ppc
598 %attr(755,root,root) %{_bindir}/qemu-ppc64
599 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
600 %attr(755,root,root) %{_bindir}/qemu-s390x
601 %attr(755,root,root) %{_bindir}/qemu-sh4
602 %attr(755,root,root) %{_bindir}/qemu-sh4eb
603 %attr(755,root,root) %{_bindir}/qemu-sparc
604 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
605 %attr(755,root,root) %{_bindir}/qemu-sparc64
606 %attr(755,root,root) %{_bindir}/qemu-unicore32
607 %attr(755,root,root) %{_bindir}/qemu-x86_64
608
609 %files system-alpha
610 %defattr(644,root,root,755)
611 %attr(755,root,root) %{_bindir}/qemu-system-alpha
612
613 %files system-arm
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_bindir}/qemu-system-arm
616
617 %files system-cris
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_bindir}/qemu-system-cris
620
621 %files system-lm32
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_bindir}/qemu-system-lm32
624
625 %files system-m68k
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_bindir}/qemu-system-m68k
628
629 %files system-microblaze
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
632 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
633
634 %files system-mips
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_bindir}/qemu-system-mips
637 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
638 %attr(755,root,root) %{_bindir}/qemu-system-mips64
639 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
640
641 %files system-or32
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_bindir}/qemu-system-or32
644
645 %files system-ppc
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_bindir}/qemu-system-ppc
648 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
649 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
650
651 %files system-s390x
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_bindir}/qemu-system-s390x
654
655 %files system-sh4
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_bindir}/qemu-system-sh4
658 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
659
660 %files system-sparc
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_bindir}/qemu-system-sparc
663 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
664
665 %files system-unicore32
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
668
669 %files system-x86
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_bindir}/qemu-system-i386
672 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
673
674 %files system-xtensa
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
677 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.102217 seconds and 3 git commands to generate.