]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- updated to 1.7.1
[packages/qemu.git] / qemu.spec
1 #
2 # Conditional build:
3 %bcond_without  sdl             # SDL UI and audio support
4 %bcond_without  glx             # OpenGL/GLX support
5 %bcond_without  ceph            # Ceph/RBD support
6 %bcond_without  glusterfs       # GlusterFS backend
7 %bcond_without  rdma            # RDMA-based migration support
8 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
9 %bcond_without  spice           # SPICE support
10 %bcond_with     esd             # EsounD audio support
11 %bcond_without  oss             # OSS audio support
12 %bcond_without  pulseaudio      # PulseAudio audio support
13 %bcond_without  xen             # Xen backend driver support
14
15 Summary:        QEMU CPU Emulator
16 Summary(pl.UTF-8):      QEMU - emulator procesora
17 Name:           qemu
18 Version:        1.7.1
19 Release:        1
20 License:        GPL v2+
21 Group:          Applications/Emulators
22 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
23 # Source0-md5:  9541063d999cf9659ed7fdce71314f31
24 Source2:        %{name}.binfmt
25 # Loads kvm kernel modules at boot
26 Source3:        kvm-modules-load.conf
27 # Creates /dev/kvm
28 Source4:        80-kvm.rules
29 # KSM control scripts
30 Source5:        ksm.service
31 Source6:        ksm.sysconfig
32 Source7:        ksmctl.c
33 Source8:        ksmtuned.service
34 Source9:        ksmtuned
35 Source10:       ksmtuned.conf
36 Source11:       %{name}-guest-agent.service
37 Source12:       99-%{name}-guest-agent.rules
38 Patch0:         %{name}-cflags.patch
39 Patch1:         vgabios-widescreens.patch
40 Patch2:         %{name}-whitelist.patch
41 Patch3:         %{name}-system-libcacard.patch
42 Patch4:         vmdk3ro.patch
43 Patch5:         %{name}-xattr.patch
44 # Proof of concept, for reference, do not remove
45 Patch400:       %{name}-kde_virtual_workspaces_hack.patch
46 URL:            http://www.qemu-project.org/
47 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
48 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
49 BuildRequires:  alsa-lib-devel
50 BuildRequires:  bcc
51 BuildRequires:  bluez-libs-devel
52 BuildRequires:  brlapi-devel
53 %{?with_ceph:BuildRequires:     ceph-devel}
54 BuildRequires:  curl-devel
55 BuildRequires:  cyrus-sasl-devel >= 2
56 %{?with_esd:BuildRequires:      esound-devel}
57 BuildRequires:  glib2-devel >= 1:2.12
58 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
59 BuildRequires:  gnutls-devel
60 BuildRequires:  libaio-devel
61 BuildRequires:  libcacard-devel
62 BuildRequires:  libcap-devel
63 BuildRequires:  libcap-ng-devel
64 BuildRequires:  libfdt-devel
65 %{?with_rdma:BuildRequires:     libibverbs-devel}
66 BuildRequires:  libiscsi-devel
67 BuildRequires:  libjpeg-devel
68 BuildRequires:  libpng-devel
69 %{?with_rdma:BuildRequires:     librdmacm-devel}
70 BuildRequires:  libseccomp-devel
71 BuildRequires:  libssh2-devel >= 1.2.8
72 # for usb passthrough, when available
73 #BuildRequires: libusb-devel >= 1.0.13
74 BuildRequires:  libuuid-devel
75 BuildRequires:  ncurses-devel
76 BuildRequires:  nss-devel >= 3.12.8
77 BuildRequires:  perl-Encode
78 BuildRequires:  perl-tools-pod
79 BuildRequires:  pkgconfig
80 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
81 BuildRequires:  rpmbuild(macros) >= 1.644
82 BuildRequires:  sed >= 4.0
83 %if %{with spice}
84 BuildRequires:  spice-protocol >= 0.12.0
85 BuildRequires:  spice-server-devel >= 0.12.0
86 %endif
87 BuildRequires:  texi2html
88 BuildRequires:  texinfo
89 BuildRequires:  usbredir-devel >= 0.6
90 BuildRequires:  vde2-devel
91 BuildRequires:  which
92 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
93 BuildRequires:  xfsprogs-devel
94 BuildRequires:  xorg-lib-libX11-devel
95 BuildRequires:  zlib-devel
96 %if %{with gtk2}
97 BuildRequires:  gtk+2-devel >= 2:2.18.0
98 BuildRequires:  vte0-devel >= 0.24.0
99 %else
100 BuildRequires:  gtk+3-devel >= 3.0.0
101 BuildRequires:  vte-devel >= 0.32.0
102 %endif
103 Requires:       %{name}-img = %{version}-%{release}
104 Requires:       %{name}-system-alpha = %{version}-%{release}
105 Requires:       %{name}-system-arm = %{version}-%{release}
106 Requires:       %{name}-system-cris = %{version}-%{release}
107 Requires:       %{name}-system-lm32 = %{version}-%{release}
108 Requires:       %{name}-system-m68k = %{version}-%{release}
109 Requires:       %{name}-system-microblaze = %{version}-%{release}
110 Requires:       %{name}-system-mips = %{version}-%{release}
111 Requires:       %{name}-system-moxie = %{version}-%{release}
112 Requires:       %{name}-system-or32 = %{version}-%{release}
113 Requires:       %{name}-system-ppc = %{version}-%{release}
114 Requires:       %{name}-system-s390x = %{version}-%{release}
115 Requires:       %{name}-system-sh4 = %{version}-%{release}
116 Requires:       %{name}-system-sparc = %{version}-%{release}
117 Requires:       %{name}-system-unicore32 = %{version}-%{release}
118 Requires:       %{name}-system-x86 = %{version}-%{release}
119 Requires:       %{name}-system-xtensa = %{version}-%{release}
120 Requires:       %{name}-user = %{version}-%{release}
121 Obsoletes:      qemu-kvm
122 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
123
124 %define systempkg_req \
125 Requires:       SDL >= 1.2.1 \
126 Requires:       usbredir >= 0.6 \
127 %if %{with gtk2} \
128 Requires:       gtk+2 >= 2:2.18.0 \
129 Requires:       vte0 >= 0.24.0 \
130 %else \
131 Requires:       gtk+3 >= 3.0.0 \
132 Requires:       vte >= 0.32.0 \
133 %endif
134
135 # some PPC/SPARC boot image in ELF format
136 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
137
138 %description
139 QEMU is a FAST! processor emulator. By using dynamic translation it
140 achieves a reasonnable speed while being easy to port on new host
141 CPUs. QEMU has two operating modes:
142
143 - User mode emulation. In this mode, QEMU can launch Linux processes
144   compiled for one CPU on another CPU. Linux system calls are converted
145   because of endianness and 32/64 bit mismatches. Wine (Windows
146   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
147
148 - Full system emulation. In this mode, QEMU emulates a full system,
149   including a processor and various peripherials. It can also be used to
150   provide virtual hosting of several virtual PC on a single server.
151
152 %description -l pl.UTF-8
153 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
154 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
155 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
156
157 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
158   procesy linuksowe skompilowane dla jednego procesora na innym
159   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
160   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
161   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
162   cele QEMU.
163
164 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
165   włączając w to procesor i różne urządzenia peryferyjne. Może być także
166   używane do wirtualnego hostowania kilku wirtualnych pecetów na
167   pojedynczym serwerze.
168
169 %package common
170 Summary:        QEMU common files needed by all QEMU targets
171 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
172 Group:          Development/Tools
173 Requires(post,preun,postun):    systemd-units >= 38
174 Requires(postun):       /usr/sbin/groupdel
175 Requires(postun):       /usr/sbin/userdel
176 Requires(pre):  /bin/id
177 Requires(pre):  /usr/bin/getgid
178 Requires(pre):  /usr/sbin/groupadd
179 Requires(pre):  /usr/sbin/useradd
180 Requires:       glib2 >= 1:2.12
181 Requires:       libssh2 >= 1.2.8
182 Requires:       systemd-units >= 38
183 Provides:       group(qemu)
184 Provides:       user(qemu)
185 Obsoletes:      qemu-kvm-common
186 Conflicts:      qemu < 1.0-2
187
188 %description common
189 QEMU is a generic and open source processor emulator which achieves a
190 good emulation speed by using dynamic translation.
191
192 This package provides the common files needed by all QEMU targets.
193
194 %description common -l pl.UTF-8
195 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
196 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
197
198 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
199 środowiska QEMU.
200
201 %package img
202 Summary:        QEMU command line tool for manipulating disk images
203 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
204 Group:          Development/Tools
205 Obsoletes:      qemu-kvm-img
206 Conflicts:      qemu < 1.0-2
207
208 %description img
209 This package provides a command line tool for manipulating disk
210 images.
211
212 %description img -l pl.UTF-8
213 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
214 na obrazach dysków.
215
216 %package user
217 Summary:        QEMU user mode emulation of qemu targets
218 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
219 Group:          Development/Tools
220 Requires:       %{name}-common = %{version}-%{release}
221 Requires(post,postun):  systemd-units >= 38
222 Requires:       systemd-units >= 38
223 Obsoletes:      qemu-kvm-user
224
225 %description user
226 QEMU is a generic and open source processor emulator which achieves a
227 good emulation speed by using dynamic translation.
228
229 This package provides the user mode emulation of QEMU targets.
230
231 %description user -l pl.UTF-8
232 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
233 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
234
235 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
236
237 %package system-alpha
238 Summary:        QEMU system emulator for Alpha
239 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
240 Group:          Development/Tools
241 Requires:       %{name}-common = %{version}-%{release}
242 %systempkg_req
243 Obsoletes:      qemu-kvm-system-alpha
244
245 %description system-alpha
246 QEMU is a generic and open source processor emulator which achieves a
247 good emulation speed by using dynamic translation.
248
249 This package provides the system emulator with Alpha CPU.
250
251 %description system-alpha -l pl.UTF-8
252 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
253 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
254
255 Ten pakiet zawiera emulator systemu z procesorem Alpha.
256
257 %package system-arm
258 Summary:        QEMU system emulator for ARM
259 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
260 Group:          Development/Tools
261 Requires:       %{name}-common = %{version}-%{release}
262 %systempkg_req
263 Obsoletes:      qemu-kvm-system-arm
264
265 %description system-arm
266 QEMU is a generic and open source processor emulator which achieves a
267 good emulation speed by using dynamic translation.
268
269 This package provides the system emulator for ARM.
270
271 %description system-arm -l pl.UTF-8
272 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
273 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
274
275 Ten pakiet zawiera emulator systemu z procesorem ARM.
276
277 %package system-cris
278 Summary:        QEMU system emulator for CRIS
279 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
280 Group:          Development/Tools
281 Requires:       %{name}-common = %{version}-%{release}
282 %systempkg_req
283 Obsoletes:      qemu-kvm-system-cris
284
285 %description system-cris
286 QEMU is a generic and open source processor emulator which achieves a
287 good emulation speed by using dynamic translation.
288
289 This package provides the system emulator with CRIS CPU.
290
291 %description system-cris -l pl.UTF-8
292 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
293 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
294
295 Ten pakiet zawiera emulator systemu z procesorem CRIS.
296
297 %package system-lm32
298 Summary:        QEMU system emulator for LM32
299 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
300 Group:          Development/Tools
301 Requires:       %{name}-common = %{version}-%{release}
302 %systempkg_req
303 Obsoletes:      qemu-kvm-system-lm32
304
305 %description system-lm32
306 QEMU is a generic and open source processor emulator which achieves a
307 good emulation speed by using dynamic translation.
308
309 This package provides the system emulator with LM32 CPU.
310
311 %description system-lm32 -l pl.UTF-8
312 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
313 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
314
315 Ten pakiet zawiera emulator systemu z procesorem LM32.
316
317 %package system-m68k
318 Summary:        QEMU system emulator for m68k
319 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
320 Group:          Development/Tools
321 Requires:       %{name}-common = %{version}-%{release}
322 %systempkg_req
323 Obsoletes:      qemu-kvm-system-m68k
324
325 %description system-m68k
326 QEMU is a generic and open source processor emulator which achieves a
327 good emulation speed by using dynamic translation.
328
329 This package provides the system emulator with m68k CPU.
330
331 %description system-m68k -l pl.UTF-8
332 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
333 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
334
335 Ten pakiet zawiera emulator systemu z procesorem m68k.
336
337 %package system-microblaze
338 Summary:        QEMU system emulator for MicroBlaze
339 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
340 Group:          Development/Tools
341 Requires:       %{name}-common = %{version}-%{release}
342 %systempkg_req
343 Obsoletes:      qemu-kvm-system-microblaze
344
345 %description system-microblaze
346 QEMU is a generic and open source processor emulator which achieves a
347 good emulation speed by using dynamic translation.
348
349 This package provides the system emulator with MicroBlaze CPU.
350
351 %description system-microblaze -l pl.UTF-8
352 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
353 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
354
355 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
356
357 %package system-mips
358 Summary:        QEMU system emulator for MIPS
359 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
360 Group:          Development/Tools
361 Requires:       %{name}-common = %{version}-%{release}
362 %systempkg_req
363 Obsoletes:      qemu-kvm-system-mips
364
365 %description system-mips
366 QEMU is a generic and open source processor emulator which achieves a
367 good emulation speed by using dynamic translation.
368
369 This package provides the system emulator with MIPS CPU.
370
371 %description system-mips -l pl.UTF-8
372 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
373 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
374
375 Ten pakiet zawiera emulator systemu z procesorem MIPS.
376
377 %package system-moxie
378 Summary:        QEMU system emulator for Moxie
379 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
380 Group:          Development/Tools
381 Requires:       %{name}-common = %{version}-%{release}
382 %systempkg_req
383
384 %description system-moxie
385 QEMU is a generic and open source processor emulator which achieves a
386 good emulation speed by using dynamic translation.
387
388 This package provides the system emulator with Moxie CPU.
389
390 %description system-moxie -l pl.UTF-8
391 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
392 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
393
394 Ten pakiet zawiera emulator systemu z procesorem Moxie.
395
396 %package system-or32
397 Summary:        QEMU system emulator for OpenRISC
398 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
399 Group:          Development/Tools
400 Requires:       %{name}-common = %{version}-%{release}
401 %systempkg_req
402 Obsoletes:      qemu-kvm-system-or32
403
404 %description system-or32
405 QEMU is a generic and open source processor emulator which achieves a
406 good emulation speed by using dynamic translation.
407
408 This package provides the system emulator with OpenRISC CPU.
409
410 %description system-or32 -l pl.UTF-8
411 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
412 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
413
414 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
415
416 %package system-ppc
417 Summary:        QEMU system emulator for PowerPC
418 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
419 Group:          Development/Tools
420 Requires:       %{name}-common = %{version}-%{release}
421 %systempkg_req
422 Obsoletes:      qemu-kvm-system-ppc
423
424 %description system-ppc
425 QEMU is a generic and open source processor emulator which achieves a
426 good emulation speed by using dynamic translation.
427
428 This package provides the system emulator with PowerPC CPU.
429
430 %description system-ppc -l pl.UTF-8
431 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
432 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
433
434 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
435
436 %package system-s390x
437 Summary:        QEMU system emulator for S390
438 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
439 Group:          Development/Tools
440 Requires:       %{name}-common = %{version}-%{release}
441 %systempkg_req
442 Obsoletes:      qemu-kvm-system-s390x
443
444 %description system-s390x
445 QEMU is a generic and open source processor emulator which achieves a
446 good emulation speed by using dynamic translation.
447
448 This package provides the system emulator with S390 CPU.
449
450 %description system-s390x -l pl.UTF-8
451 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
452 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
453
454 Ten pakiet zawiera emulator systemu z procesorem S390.
455
456 %package system-sh4
457 Summary:        QEMU system emulator for SH4
458 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
459 Group:          Development/Tools
460 Requires:       %{name}-common = %{version}-%{release}
461 %systempkg_req
462 Obsoletes:      qemu-kvm-system-sh4
463
464 %description system-sh4
465 QEMU is a generic and open source processor emulator which achieves a
466 good emulation speed by using dynamic translation.
467
468 This package provides the system emulator with SH4 CPU.
469
470 %description system-sh4 -l pl.UTF-8
471 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
472 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
473
474 Ten pakiet zawiera emulator systemu z procesorem SH4.
475
476 %package system-sparc
477 Summary:        QEMU system emulator for SPARC
478 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
479 Group:          Development/Tools
480 Requires:       %{name}-common = %{version}-%{release}
481 %systempkg_req
482 Obsoletes:      qemu-kvm-system-sparc
483
484 %description system-sparc
485 QEMU is a generic and open source processor emulator which achieves a
486 good emulation speed by using dynamic translation.
487
488 This package provides the system emulator with SPARC/SPARC64 CPU.
489
490 %description system-sparc -l pl.UTF-8
491 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
492 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
493
494 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
495
496 %package system-unicore32
497 Summary:        QEMU system emulator for UniCore32
498 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
499 Group:          Development/Tools
500 Requires:       %{name}-common = %{version}-%{release}
501 %systempkg_req
502 Obsoletes:      qemu-kvm-system-unicore32
503
504 %description system-unicore32
505 QEMU is a generic and open source processor emulator which achieves a
506 good emulation speed by using dynamic translation.
507
508 This package provides the system emulator with UniCore32 CPU.
509
510 %description system-unicore32 -l pl.UTF-8
511 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
512 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
513
514 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
515
516 %package system-x86
517 Summary:        QEMU system emulator for x86
518 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
519 Group:          Development/Tools
520 Requires:       %{name}-common = %{version}-%{release}
521 %systempkg_req
522 Obsoletes:      kvm
523 Obsoletes:      qemu-kvm-system-x86
524
525 %description system-x86
526 QEMU is a generic and open source processor emulator which achieves a
527 good emulation speed by using dynamic translation.
528
529 %description system-x86 -l pl.UTF-8
530 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
531 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
532
533 %package system-xtensa
534 Summary:        QEMU system emulator for Xtensa
535 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
536 Group:          Development/Tools
537 Requires:       %{name}-common = %{version}-%{release}
538 %systempkg_req
539 Obsoletes:      qemu-kvm-system-xtensa
540
541 %description system-xtensa
542 QEMU is a generic and open source processor emulator which achieves a
543 good emulation speed by using dynamic translation.
544
545 This package provides the system emulator with Xtensa CPU.
546
547 %description system-xtensa -l pl.UTF-8
548 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
549 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
550
551 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
552
553 %package guest-agent
554 Summary:        QEMU guest agent
555 Summary(pl.UTF-8):      Agent gościa QEMU
556 Group:          Daemons
557 Requires(post,preun,postun):    systemd-units >= 38
558 Requires:       glib2 >= 1:2.12
559 Requires:       systemd-units >= 38
560 Obsoletes:      qemu-kvm-guest-agent
561
562 %description guest-agent
563 QEMU is a generic and open source processor emulator which achieves a
564 good emulation speed by using dynamic translation.
565
566 This package provides an agent to run inside guests, which
567 communicates with the host over a virtio-serial channel named
568 "org.qemu.guest_agent.0".
569
570 This package does not need to be installed on the host OS.
571
572 %description guest-agent -l pl.UTF-8
573 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
574 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
575
576 Ten pakiet udostępnia agenta przeznaczonego do uruchomienia w
577 systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
578 "org.qemu.guest_agent.0".
579
580 Ten pakiet nie musi być zainstalowany w systemie hosta.
581
582 %prep
583 %setup -q
584 %patch0 -p1
585 %patch1 -p1
586 %patch2 -p0
587 %patch3 -p1
588 %patch4 -p1
589 %patch5 -p1
590
591 %{__mv} libcacard libcacard-use-system-lib
592
593 # workaround for conflict with alsa/error.h
594 ln -s ../error.h qapi/error.h
595
596 %build
597 ./configure \
598         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
599         --extra-ldflags="%{rpmldflags}" \
600         --prefix=%{_prefix} \
601         --sysconfdir=%{_sysconfdir} \
602         --cc="%{__cc}" \
603         --host-cc="%{__cc}" \
604         --disable-strip \
605         --enable-attr \
606         --enable-bluez \
607         --enable-brlapi \
608         --enable-cap-ng \
609         --enable-curl \
610         --enable-curses \
611         --enable-docs \
612         --enable-fdt \
613         %{__enable_disable glusterfs} \
614         --enable-libiscsi \
615         %{__enable_disable glx} \
616         %{__enable_disable ceph rbd} \
617         %{__enable_disable rdma} \
618         %{__enable_disable sdl} \
619         --enable-seccomp \
620         %{__enable_disable spice} \
621         --enable-smartcard-nss \
622         --enable-tpm \
623         --enable-usb-redir \
624         --enable-uuid \
625         --enable-vde \
626         --enable-virtfs \
627         --enable-vnc-jpeg \
628         --enable-vnc-png \
629         --enable-vnc-sasl \
630         --enable-vnc-tls \
631         --enable-kvm \
632         %{__enable_disable xen} \
633         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
634         --interp-prefix=%{_libdir}/qemu/lib-%%M \
635         --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
636
637 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
638 # --libexecdir in configure is nop
639 %{__make} \
640         V=1 \
641         CONFIG_QEMU_HELPERDIR="%{_libdir}"
642
643 # rebuild patched vesa tables with additional widescreen modes.
644 %{__make} -C roms/vgabios stdvga-bios
645
646 %{__cc} %{SOURCE7} %{rpmcflags} -o ksmctl
647
648 %install
649 rm -rf $RPM_BUILD_ROOT
650 install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
651         $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
652         $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
653
654 %{__make} install \
655         DESTDIR=$RPM_BUILD_ROOT \
656         libexecdir=%{_libdir}
657
658 install -d $RPM_BUILD_ROOT%{_sysconfdir}
659 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
660 #!/bin/sh
661
662 EOF
663
664 install -p qemu.sasl $RPM_BUILD_ROOT%{_sysconfdir}/sasl/qemu.conf
665
666 %ifarch %{ix86} %{x8664}
667 install -p scripts/kvm/kvm_stat $RPM_BUILD_ROOT%{_bindir}
668 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/modules-load.d/kvm.conf
669 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
670 %endif
671
672 install -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/ksm.service
673 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/ksm
674 install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
675
676 install -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/ksmtuned.service
677 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
678 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
679
680 # For the qemu-guest-agent subpackage install the systemd
681 # service and udev rules.
682 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
683 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
684
685 for i in dummy \
686 %ifnarch %{ix86} %{x8664}
687         qemu-i386 \
688 %endif
689 %ifnarch arm
690         qemu-arm \
691 %endif
692 %ifnarch ppc ppc64
693         qemu-ppc \
694 %endif
695 %ifnarch sparc sparc64
696         qemu-sparc \
697 %endif
698 %ifnarch sh4
699         qemu-sh4 \
700 %endif
701 ; do
702         test $i = dummy && continue
703         grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i.conf
704 done < %{SOURCE2}
705
706 # packaged as %doc
707 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
708 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
709
710 # install patched vesa tables with additional widescreen modes.
711 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
712
713 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{de_DE,de}
714 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
715 %find_lang %{name}
716
717 %clean
718 rm -rf $RPM_BUILD_ROOT
719
720 %pre common
721 %groupadd -g 160 kvm
722 %groupadd -g 276 qemu
723 %useradd -u 276 -g qemu -G kvm -c "QEMU User" qemu
724
725 %post common
726 %systemd_post ksm.service
727 %systemd_post ksmtuned.service
728
729 %preun common
730 %systemd_preun ksm.service
731 %systemd_preun ksmtuned.service
732
733 %postun common
734 if [ "$1" = "0" ]; then
735         %userremove qemu
736         %groupremove qemu
737         %groupremove kvm
738 fi
739 %systemd_reload
740
741 %triggerpostun common -- qemu-common < 1.6.1-4
742 %systemd_trigger ksm.service
743 %systemd_trigger ksmtuned.service
744
745 %post user
746 %systemd_service_restart systemd-binfmt.service
747
748 %postun user
749 %systemd_service_restart systemd-binfmt.service
750
751 %post guest-agent
752 %systemd_reload
753
754 %preun guest-agent
755 %systemd_preun qemu-guest-agent.service
756
757 %postun guest-agent
758 %systemd_reload
759
760 %files
761 %defattr(644,root,root,755)
762
763 %files common -f %{name}.lang
764 %defattr(644,root,root,755)
765 %doc README qemu-doc.html qemu-tech.html qmp-commands.txt
766 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
767 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
768 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
769 %config(noreplace) %verify(not md5 mtime size) /etc/sasl/qemu.conf
770 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
771 %{systemdunitdir}/ksm.service
772 %{systemdunitdir}/ksmtuned.service
773 %dir %{_sysconfdir}/qemu
774 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
775 %attr(755,root,root) %{_bindir}/qemu-nbd
776 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
777 %attr(755,root,root) %{_sbindir}/ksmctl
778 %attr(755,root,root) %{_sbindir}/ksmtuned
779 %{_mandir}/man1/qemu.1*
780 %{_mandir}/man1/virtfs-proxy-helper.1*
781 %{_mandir}/man8/qemu-nbd.8*
782
783 %dir %{_datadir}/qemu
784 %{_datadir}/%{name}/keymaps
785 %{_datadir}/%{name}/qemu-icon.bmp
786 # various bios images
787 %{_datadir}/%{name}/*.aml
788 %{_datadir}/%{name}/*.bin
789 %{_datadir}/%{name}/*.rom
790 %{_datadir}/%{name}/*.dtb
791 %{_datadir}/%{name}/qemu_logo_no_text.svg
792 %{_datadir}/%{name}/openbios-ppc
793 %{_datadir}/%{name}/openbios-sparc*
794 %{_datadir}/%{name}/palcode-clipper
795 %{_datadir}/%{name}/s390-ccw.img
796
797 %files img
798 %defattr(644,root,root,755)
799 %attr(755,root,root) %{_bindir}/qemu-img
800 %{_mandir}/man1/qemu-img.1*
801
802 %files user
803 %defattr(644,root,root,755)
804 /usr/lib/binfmt.d/qemu-*.conf
805 %attr(755,root,root) %{_bindir}/qemu-alpha
806 %attr(755,root,root) %{_bindir}/qemu-arm
807 %attr(755,root,root) %{_bindir}/qemu-armeb
808 %attr(755,root,root) %{_bindir}/qemu-cris
809 %attr(755,root,root) %{_bindir}/qemu-i386
810 %attr(755,root,root) %{_bindir}/qemu-io
811 %attr(755,root,root) %{_bindir}/qemu-m68k
812 %attr(755,root,root) %{_bindir}/qemu-microblaze
813 %attr(755,root,root) %{_bindir}/qemu-microblazeel
814 %attr(755,root,root) %{_bindir}/qemu-mips
815 %attr(755,root,root) %{_bindir}/qemu-mipsel
816 %attr(755,root,root) %{_bindir}/qemu-mips64
817 %attr(755,root,root) %{_bindir}/qemu-mips64el
818 %attr(755,root,root) %{_bindir}/qemu-mipsn32
819 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
820 %attr(755,root,root) %{_bindir}/qemu-or32
821 %attr(755,root,root) %{_bindir}/qemu-ppc
822 %attr(755,root,root) %{_bindir}/qemu-ppc64
823 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
824 %attr(755,root,root) %{_bindir}/qemu-s390x
825 %attr(755,root,root) %{_bindir}/qemu-sh4
826 %attr(755,root,root) %{_bindir}/qemu-sh4eb
827 %attr(755,root,root) %{_bindir}/qemu-sparc
828 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
829 %attr(755,root,root) %{_bindir}/qemu-sparc64
830 %attr(755,root,root) %{_bindir}/qemu-unicore32
831 %attr(755,root,root) %{_bindir}/qemu-x86_64
832
833 %files system-alpha
834 %defattr(644,root,root,755)
835 %attr(755,root,root) %{_bindir}/qemu-system-alpha
836
837 %files system-arm
838 %defattr(644,root,root,755)
839 %attr(755,root,root) %{_bindir}/qemu-system-arm
840
841 %files system-cris
842 %defattr(644,root,root,755)
843 %attr(755,root,root) %{_bindir}/qemu-system-cris
844
845 %files system-lm32
846 %defattr(644,root,root,755)
847 %attr(755,root,root) %{_bindir}/qemu-system-lm32
848
849 %files system-m68k
850 %defattr(644,root,root,755)
851 %attr(755,root,root) %{_bindir}/qemu-system-m68k
852
853 %files system-microblaze
854 %defattr(644,root,root,755)
855 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
856 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
857
858 %files system-mips
859 %defattr(644,root,root,755)
860 %attr(755,root,root) %{_bindir}/qemu-system-mips
861 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
862 %attr(755,root,root) %{_bindir}/qemu-system-mips64
863 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
864
865 %files system-moxie
866 %defattr(644,root,root,755)
867 %attr(755,root,root) %{_bindir}/qemu-system-moxie
868
869 %files system-or32
870 %defattr(644,root,root,755)
871 %attr(755,root,root) %{_bindir}/qemu-system-or32
872
873 %files system-ppc
874 %defattr(644,root,root,755)
875 %attr(755,root,root) %{_bindir}/qemu-system-ppc
876 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
877 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
878
879 %files system-s390x
880 %defattr(644,root,root,755)
881 %attr(755,root,root) %{_bindir}/qemu-system-s390x
882
883 %files system-sh4
884 %defattr(644,root,root,755)
885 %attr(755,root,root) %{_bindir}/qemu-system-sh4
886 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
887
888 %files system-sparc
889 %defattr(644,root,root,755)
890 %attr(755,root,root) %{_bindir}/qemu-system-sparc
891 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
892
893 %files system-unicore32
894 %defattr(644,root,root,755)
895 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
896
897 %files system-x86
898 %defattr(644,root,root,755)
899 %attr(755,root,root) %{_bindir}/qemu-system-i386
900 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
901 %ifarch %{ix86} %{x8664}
902 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/kvm.conf
903 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/80-kvm.rules
904 %attr(755,root,root) %{_bindir}/kvm_stat
905 %endif
906
907 %files system-xtensa
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
910 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
911
912 %files guest-agent
913 %defattr(644,root,root,755)
914 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
915 %{systemdunitdir}/qemu-guest-agent.service
916 %attr(755,root,root) %{_bindir}/qemu-ga
This page took 0.152915 seconds and 3 git commands to generate.