]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
cee340b665dbd150ab9c9cf6190d555ea9ce1a62
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - merge missing bits from qemu-kvm
3 # - --enable-glusterfs when glusterfs 3.4 is out
4 # - qemu-system-ppc -hda ac-ppc.img says:
5 #   qemu: could not open disk image ac-ppc.img: error "Success"
6 #   qemu-0.12.2-2.x86_64.rpm - broken
7 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
8 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
9 #   qemu-0.11.1-*.x86_64.rpm - OK
10 #
11 # Conditional build:
12 %bcond_without  sdl             # SDL UI and audio support
13 %bcond_without  glx             # OpenGL support
14 %bcond_without  ceph            # Ceph/RBD support
15 %bcond_with     glusterfs       # GlusterFS backend
16 %bcond_without  spice           # SPICE support
17 %bcond_with     esd             # EsounD audio support
18 %bcond_without  oss             # OSS audio support
19 %bcond_without  pulseaudio      # PulseAudio audio support
20 %bcond_without  xen             # Xen backend driver support
21
22 Summary:        QEMU CPU Emulator
23 Summary(pl.UTF-8):      QEMU - emulator procesora
24 Name:           qemu
25 Version:        1.5.0
26 Release:        0.1
27 License:        GPL v2+
28 Group:          Applications/Emulators
29 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
30 # Source0-md5:  b6f3265b8ed39d77e8f354f35cc26e16
31 Patch0:         %{name}-cflags.patch
32 Patch1:         vgabios-widescreens.patch
33 Patch2:         %{name}-whitelist.patch
34 Patch3:         %{name}-system-libcacard.patch
35 # Proof of concept, for reference, do not remove
36 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
37 URL:            http://www.qemu-project.org/
38 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
39 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  bcc
42 BuildRequires:  bluez-libs-devel
43 BuildRequires:  brlapi-devel
44 %{?with_ceph:BuildRequires:     ceph-devel}
45 BuildRequires:  curl-devel
46 BuildRequires:  cyrus-sasl-devel >= 2
47 %{?with_esd:BuildRequires:      esound-devel}
48 BuildRequires:  glib2-devel >= 1:2.12
49 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
50 BuildRequires:  gnutls-devel
51 BuildRequires:  libaio-devel
52 BuildRequires:  libcacard-devel
53 BuildRequires:  libcap-devel
54 BuildRequires:  libcap-ng-devel
55 BuildRequires:  libfdt-devel
56 BuildRequires:  libiscsi-devel
57 BuildRequires:  libjpeg-devel
58 BuildRequires:  libpng-devel
59 BuildRequires:  libseccomp-devel
60 BuildRequires:  libuuid-devel
61 BuildRequires:  ncurses-devel
62 BuildRequires:  nss-devel >= 3.12.8
63 BuildRequires:  perl-Encode
64 BuildRequires:  perl-tools-pod
65 BuildRequires:  pkgconfig
66 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
67 BuildRequires:  rpmbuild(macros) >= 1.202
68 BuildRequires:  sed >= 4.0
69 %if %{with spice}
70 BuildRequires:  spice-protocol >= 0.12.0
71 BuildRequires:  spice-server-devel >= 0.12.0
72 %endif
73 BuildRequires:  texi2html
74 BuildRequires:  texinfo
75 BuildRequires:  usbredir-devel >= 0.6
76 BuildRequires:  vde2-devel
77 BuildRequires:  which
78 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
79 BuildRequires:  xfsprogs-devel
80 BuildRequires:  xorg-lib-libX11-devel
81 BuildRequires:  zlib-devel
82 Requires:       %{name}-img = %{version}-%{release}
83 Requires:       %{name}-system-alpha = %{version}-%{release}
84 Requires:       %{name}-system-arm = %{version}-%{release}
85 Requires:       %{name}-system-cris = %{version}-%{release}
86 Requires:       %{name}-system-lm32 = %{version}-%{release}
87 Requires:       %{name}-system-m68k = %{version}-%{release}
88 Requires:       %{name}-system-microblaze = %{version}-%{release}
89 Requires:       %{name}-system-mips = %{version}-%{release}
90 Requires:       %{name}-system-moxie = %{version}-%{release}
91 Requires:       %{name}-system-or32 = %{version}-%{release}
92 Requires:       %{name}-system-ppc = %{version}-%{release}
93 Requires:       %{name}-system-s390x = %{version}-%{release}
94 Requires:       %{name}-system-sh4 = %{version}-%{release}
95 Requires:       %{name}-system-sparc = %{version}-%{release}
96 Requires:       %{name}-system-unicore32 = %{version}-%{release}
97 Requires:       %{name}-system-x86 = %{version}-%{release}
98 Requires:       %{name}-system-xtensa = %{version}-%{release}
99 Requires:       %{name}-user = %{version}-%{release}
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define systempkg_req \
103 Requires:       SDL >= 1.2.1 \
104 Requires:       usbredir >= 0.6
105
106 # some PPC/SPARC boot image in ELF format
107 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
108
109 %description
110 QEMU is a FAST! processor emulator. By using dynamic translation it
111 achieves a reasonnable speed while being easy to port on new host
112 CPUs. QEMU has two operating modes:
113
114 - User mode emulation. In this mode, QEMU can launch Linux processes
115   compiled for one CPU on another CPU. Linux system calls are converted
116   because of endianness and 32/64 bit mismatches. Wine (Windows
117   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
118
119 - Full system emulation. In this mode, QEMU emulates a full system,
120   including a processor and various peripherials. It can also be used to
121   provide virtual hosting of several virtual PC on a single server.
122
123 %description -l pl.UTF-8
124 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
125 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
126 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
127
128 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
129   procesy linuksowe skompilowane dla jednego procesora na innym
130   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
131   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
132   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
133   cele QEMU.
134
135 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
136   włączając w to procesor i różne urządzenia peryferyjne. Może być także
137   używane do wirtualnego hostowania kilku wirtualnych pecetów na
138   pojedynczym serwerze.
139
140 %package common
141 Summary:        QEMU common files needed by all QEMU targets
142 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
143 Group:          Development/Tools
144 Requires:       glib2 >= 1:2.12
145 Requires(postun):       /usr/sbin/groupdel
146 Requires(postun):       /usr/sbin/userdel
147 Requires(pre):  /bin/id
148 Requires(pre):  /usr/bin/getgid
149 Requires(pre):  /usr/sbin/groupadd
150 Requires(pre):  /usr/sbin/useradd
151 Provides:       group(qemu)
152 Provides:       user(qemu)
153 Conflicts:      qemu < 1.0-2
154
155 %description common
156 QEMU is a generic and open source processor emulator which achieves a
157 good emulation speed by using dynamic translation.
158
159 This package provides the common files needed by all QEMU targets.
160
161 %description common -l pl.UTF-8
162 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
163 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
164
165 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
166 środowiska QEMU.
167
168 %package img
169 Summary:        QEMU command line tool for manipulating disk images
170 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
171 Group:          Development/Tools
172 Conflicts:      qemu < 1.0-2
173
174 %description img
175 This package provides a command line tool for manipulating disk
176 images.
177
178 %description img -l pl.UTF-8
179 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
180 na obrazach dysków.
181
182 %package user
183 Summary:        QEMU user mode emulation of qemu targets
184 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
185 Group:          Development/Tools
186 Requires:       %{name}-common = %{version}-%{release}
187
188 %description user
189 QEMU is a generic and open source processor emulator which achieves a
190 good emulation speed by using dynamic translation.
191
192 This package provides the user mode emulation of QEMU targets.
193
194 %description user -l pl.UTF-8
195 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
196 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
197
198 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
199
200 %package system-alpha
201 Summary:        QEMU system emulator for Alpha
202 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
203 Group:          Development/Tools
204 Requires:       %{name}-common = %{version}-%{release}
205 %systempkg_req
206
207 %description system-alpha
208 QEMU is a generic and open source processor emulator which achieves a
209 good emulation speed by using dynamic translation.
210
211 This package provides the system emulator with Alpha CPU.
212
213 %description system-alpha -l pl.UTF-8
214 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
215 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
216
217 Ten pakiet zawiera emulator systemu z procesorem Alpha.
218
219 %package system-arm
220 Summary:        QEMU system emulator for ARM
221 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
222 Group:          Development/Tools
223 Requires:       %{name}-common = %{version}-%{release}
224 %systempkg_req
225
226 %description system-arm
227 QEMU is a generic and open source processor emulator which achieves a
228 good emulation speed by using dynamic translation.
229
230 This package provides the system emulator for ARM.
231
232 %description system-arm -l pl.UTF-8
233 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
234 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
235
236 Ten pakiet zawiera emulator systemu z procesorem ARM.
237
238 %package system-cris
239 Summary:        QEMU system emulator for CRIS
240 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
241 Group:          Development/Tools
242 Requires:       %{name}-common = %{version}-%{release}
243 %systempkg_req
244
245 %description system-cris
246 QEMU is a generic and open source processor emulator which achieves a
247 good emulation speed by using dynamic translation.
248
249 This package provides the system emulator with CRIS CPU.
250
251 %description system-cris -l pl.UTF-8
252 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
253 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
254
255 Ten pakiet zawiera emulator systemu z procesorem CRIS.
256
257 %package system-lm32
258 Summary:        QEMU system emulator for LM32
259 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
260 Group:          Development/Tools
261 Requires:       %{name}-common = %{version}-%{release}
262 %systempkg_req
263
264 %description system-lm32
265 QEMU is a generic and open source processor emulator which achieves a
266 good emulation speed by using dynamic translation.
267
268 This package provides the system emulator with LM32 CPU.
269
270 %description system-lm32 -l pl.UTF-8
271 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
272 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
273
274 Ten pakiet zawiera emulator systemu z procesorem LM32.
275
276 %package system-m68k
277 Summary:        QEMU system emulator for m68k
278 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
279 Group:          Development/Tools
280 Requires:       %{name}-common = %{version}-%{release}
281 %systempkg_req
282
283 %description system-m68k
284 QEMU is a generic and open source processor emulator which achieves a
285 good emulation speed by using dynamic translation.
286
287 This package provides the system emulator with m68k CPU.
288
289 %description system-m68k -l pl.UTF-8
290 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
291 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
292
293 Ten pakiet zawiera emulator systemu z procesorem m68k.
294
295 %package system-microblaze
296 Summary:        QEMU system emulator for MicroBlaze
297 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
298 Group:          Development/Tools
299 Requires:       %{name}-common = %{version}-%{release}
300 %systempkg_req
301
302 %description system-microblaze
303 QEMU is a generic and open source processor emulator which achieves a
304 good emulation speed by using dynamic translation.
305
306 This package provides the system emulator with MicroBlaze CPU.
307
308 %description system-microblaze -l pl.UTF-8
309 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
310 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
311
312 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
313
314 %package system-mips
315 Summary:        QEMU system emulator for MIPS
316 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
317 Group:          Development/Tools
318 Requires:       %{name}-common = %{version}-%{release}
319 %systempkg_req
320
321 %description system-mips
322 QEMU is a generic and open source processor emulator which achieves a
323 good emulation speed by using dynamic translation.
324
325 This package provides the system emulator with MIPS CPU.
326
327 %description system-mips -l pl.UTF-8
328 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
329 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
330
331 Ten pakiet zawiera emulator systemu z procesorem MIPS.
332
333 %package system-moxie
334 Summary:        QEMU system emulator for Moxie
335 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
336 Group:          Development/Tools
337 Requires:       %{name}-common = %{version}-%{release}
338 %systempkg_req
339
340 %description system-moxie
341 QEMU is a generic and open source processor emulator which achieves a
342 good emulation speed by using dynamic translation.
343
344 This package provides the system emulator with Moxie CPU.
345
346 %description system-moxie -l pl.UTF-8
347 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
348 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
349
350 Ten pakiet zawiera emulator systemu z procesorem Moxie.
351
352 %package system-or32
353 Summary:        QEMU system emulator for OpenRISC
354 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
355 Group:          Development/Tools
356 Requires:       %{name}-common = %{version}-%{release}
357 %systempkg_req
358
359 %description system-or32
360 QEMU is a generic and open source processor emulator which achieves a
361 good emulation speed by using dynamic translation.
362
363 This package provides the system emulator with OpenRISC CPU.
364
365 %description system-or32 -l pl.UTF-8
366 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
367 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
368
369 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
370
371 %package system-ppc
372 Summary:        QEMU system emulator for PowerPC
373 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
374 Group:          Development/Tools
375 Requires:       %{name}-common = %{version}-%{release}
376 %systempkg_req
377
378 %description system-ppc
379 QEMU is a generic and open source processor emulator which achieves a
380 good emulation speed by using dynamic translation.
381
382 This package provides the system emulator with PowerPC CPU.
383
384 %description system-ppc -l pl.UTF-8
385 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
386 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
387
388 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
389
390 %package system-s390x
391 Summary:        QEMU system emulator for S390
392 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
393 Group:          Development/Tools
394 Requires:       %{name}-common = %{version}-%{release}
395 %systempkg_req
396
397 %description system-s390x
398 QEMU is a generic and open source processor emulator which achieves a
399 good emulation speed by using dynamic translation.
400
401 This package provides the system emulator with S390 CPU.
402
403 %description system-s390x -l pl.UTF-8
404 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
405 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
406
407 Ten pakiet zawiera emulator systemu z procesorem S390.
408
409 %package system-sh4
410 Summary:        QEMU system emulator for SH4
411 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
412 Group:          Development/Tools
413 Requires:       %{name}-common = %{version}-%{release}
414 %systempkg_req
415
416 %description system-sh4
417 QEMU is a generic and open source processor emulator which achieves a
418 good emulation speed by using dynamic translation.
419
420 This package provides the system emulator with SH4 CPU.
421
422 %description system-sh4 -l pl.UTF-8
423 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
424 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
425
426 Ten pakiet zawiera emulator systemu z procesorem SH4.
427
428 %package system-sparc
429 Summary:        QEMU system emulator for SPARC
430 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
431 Group:          Development/Tools
432 Requires:       %{name}-common = %{version}-%{release}
433 %systempkg_req
434
435 %description system-sparc
436 QEMU is a generic and open source processor emulator which achieves a
437 good emulation speed by using dynamic translation.
438
439 This package provides the system emulator with SPARC/SPARC64 CPU.
440
441 %description system-sparc -l pl.UTF-8
442 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
443 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
444
445 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
446
447 %package system-unicore32
448 Summary:        QEMU system emulator for UniCore32
449 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
450 Group:          Development/Tools
451 Requires:       %{name}-common = %{version}-%{release}
452 %systempkg_req
453
454 %description system-unicore32
455 QEMU is a generic and open source processor emulator which achieves a
456 good emulation speed by using dynamic translation.
457
458 This package provides the system emulator with UniCore32 CPU.
459
460 %description system-unicore32 -l pl.UTF-8
461 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
462 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
463
464 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
465
466 %package system-x86
467 Summary:        QEMU system emulator for x86
468 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
469 Group:          Development/Tools
470 Requires:       %{name}-common = %{version}-%{release}
471 %systempkg_req
472
473 %description system-x86
474 QEMU is a generic and open source processor emulator which achieves a
475 good emulation speed by using dynamic translation.
476
477 %description system-x86 -l pl.UTF-8
478 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
479 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
480
481 %package system-xtensa
482 Summary:        QEMU system emulator for Xtensa
483 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
484 Group:          Development/Tools
485 Requires:       %{name}-common = %{version}-%{release}
486 %systempkg_req
487
488 %description system-xtensa
489 QEMU is a generic and open source processor emulator which achieves a
490 good emulation speed by using dynamic translation.
491
492 This package provides the system emulator with Xtensa CPU.
493
494 %description system-xtensa -l pl.UTF-8
495 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
496 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
497
498 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
499
500 %prep
501 %setup -q
502 %patch0 -p1
503 %patch1 -p1
504 %patch2 -p0
505 %patch3 -p1
506
507 %{__mv} libcacard libcacard-use-system-lib
508
509 # workaround for conflict with alsa/error.h
510 ln -s ../error.h qapi/error.h
511
512 %build
513 ./configure \
514         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
515         --extra-ldflags="%{rpmldflags}" \
516         --prefix=%{_prefix} \
517         --sysconfdir=%{_sysconfdir} \
518         --cc="%{__cc}" \
519         --host-cc="%{__cc}" \
520         --disable-strip \
521         --enable-attr \
522         --enable-bluez \
523         --enable-brlapi \
524         --enable-cap-ng \
525         --enable-curl \
526         --enable-curses \
527         --enable-docs \
528         --enable-fdt \
529         %{__enable_disable glusterfs} \
530         --enable-libiscsi \
531         --enable-mixemu \
532         %{__enable_disable glx} \
533         %{__enable_disable ceph rbd} \
534         %{__enable_disable sdl} \
535         --enable-seccomp \
536         %{__enable_disable spice} \
537         --enable-smartcard-nss \
538         --enable-usb-redir \
539         --enable-uuid \
540         --enable-vde \
541         --enable-virtfs \
542         --enable-vnc-jpeg \
543         --enable-vnc-png \
544         --enable-vnc-sasl \
545         --enable-vnc-tls \
546         %{__enable_disable xen} \
547         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
548         --interp-prefix=%{_libdir}/qemu/lib-%%M
549 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
550 # --libexecdir in configure is nop
551 %{__make} \
552         V=1 \
553         CONFIG_QEMU_HELPERDIR="%{_libdir}"
554
555 # rebuild patched vesa tables with additional widescreen modes.
556 %{__make} -C roms/vgabios stdvga-bios
557
558 %install
559 rm -rf $RPM_BUILD_ROOT
560
561 %{__make} install \
562         DESTDIR=$RPM_BUILD_ROOT \
563         libexecdir=%{_libdir}
564
565 install -d $RPM_BUILD_ROOT%{_sysconfdir}
566 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
567 #!/bin/sh
568
569 EOF
570
571 # already packaged
572 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
573 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
574
575 # install patched vesa tables with additional widescreen modes.
576 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
577
578 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
579 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
580 %find_lang %{name}
581
582 %clean
583 rm -rf $RPM_BUILD_ROOT
584
585 %pre common
586 %groupadd -g 276 qemu
587 %useradd -u 276 -g qemu -c "QEMU User" qemu
588
589 %postun common
590 if [ "$1" = "0" ]; then
591         %userremove qemu
592         %groupremove qemu
593 fi
594
595 %files
596 %defattr(644,root,root,755)
597
598 %files common -f %{name}.lang
599 %defattr(644,root,root,755)
600 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
601 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
602 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
603 %dir %{_sysconfdir}/qemu
604 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
605 %attr(755,root,root) %{_bindir}/qemu-nbd
606 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
607 %{_mandir}/man1/qemu.1*
608 %{_mandir}/man1/virtfs-proxy-helper.1*
609 %{_mandir}/man8/qemu-nbd.8*
610
611 %dir %{_datadir}/qemu
612 %{_datadir}/%{name}/keymaps
613 %{_datadir}/%{name}/qemu-icon.bmp
614 # various bios images
615 %{_datadir}/%{name}/*.aml
616 %{_datadir}/%{name}/*.bin
617 %{_datadir}/%{name}/*.rom
618 %{_datadir}/%{name}/*.dtb
619 %{_datadir}/%{name}/openbios-ppc
620 %{_datadir}/%{name}/openbios-sparc*
621 %{_datadir}/%{name}/palcode-clipper
622 %{_datadir}/%{name}/s390-ccw.img
623
624 %files img
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_bindir}/qemu-img
627 %{_mandir}/man1/qemu-img.1*
628
629 %files user
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_bindir}/qemu-alpha
632 %attr(755,root,root) %{_bindir}/qemu-arm
633 %attr(755,root,root) %{_bindir}/qemu-armeb
634 %attr(755,root,root) %{_bindir}/qemu-cris
635 %attr(755,root,root) %{_bindir}/qemu-ga
636 %attr(755,root,root) %{_bindir}/qemu-i386
637 %attr(755,root,root) %{_bindir}/qemu-io
638 %attr(755,root,root) %{_bindir}/qemu-m68k
639 %attr(755,root,root) %{_bindir}/qemu-microblaze
640 %attr(755,root,root) %{_bindir}/qemu-microblazeel
641 %attr(755,root,root) %{_bindir}/qemu-mips
642 %attr(755,root,root) %{_bindir}/qemu-mipsel
643 %attr(755,root,root) %{_bindir}/qemu-mips64
644 %attr(755,root,root) %{_bindir}/qemu-mips64el
645 %attr(755,root,root) %{_bindir}/qemu-mipsn32
646 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
647 %attr(755,root,root) %{_bindir}/qemu-or32
648 %attr(755,root,root) %{_bindir}/qemu-ppc
649 %attr(755,root,root) %{_bindir}/qemu-ppc64
650 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
651 %attr(755,root,root) %{_bindir}/qemu-s390x
652 %attr(755,root,root) %{_bindir}/qemu-sh4
653 %attr(755,root,root) %{_bindir}/qemu-sh4eb
654 %attr(755,root,root) %{_bindir}/qemu-sparc
655 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
656 %attr(755,root,root) %{_bindir}/qemu-sparc64
657 %attr(755,root,root) %{_bindir}/qemu-unicore32
658 %attr(755,root,root) %{_bindir}/qemu-x86_64
659
660 %files system-alpha
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_bindir}/qemu-system-alpha
663
664 %files system-arm
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_bindir}/qemu-system-arm
667
668 %files system-cris
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_bindir}/qemu-system-cris
671
672 %files system-lm32
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_bindir}/qemu-system-lm32
675
676 %files system-m68k
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_bindir}/qemu-system-m68k
679
680 %files system-microblaze
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
683 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
684
685 %files system-mips
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_bindir}/qemu-system-mips
688 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
689 %attr(755,root,root) %{_bindir}/qemu-system-mips64
690 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
691
692 %files system-moxie
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_bindir}/qemu-system-moxie
695
696 %files system-or32
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_bindir}/qemu-system-or32
699
700 %files system-ppc
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_bindir}/qemu-system-ppc
703 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
704 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
705
706 %files system-s390x
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_bindir}/qemu-system-s390x
709
710 %files system-sh4
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_bindir}/qemu-system-sh4
713 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
714
715 %files system-sparc
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_bindir}/qemu-system-sparc
718 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
719
720 %files system-unicore32
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
723
724 %files system-x86
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_bindir}/qemu-system-i386
727 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
728
729 %files system-xtensa
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
732 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.06728 seconds and 2 git commands to generate.