]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- glusterfs support needs glusterfs 3.4+ (no official releases yet)
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - --enable-glusterfs when glusterfs 3.4 is out
3 # - qemu-system-ppc -hda ac-ppc.img says:
4 #   qemu: could not open disk image ac-ppc.img: error "Success"
5 #   qemu-0.12.2-2.x86_64.rpm - broken
6 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
7 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
8 #   qemu-0.11.1-*.x86_64.rpm - OK
9 #
10 # Conditional build:
11 %bcond_without  sdl             # SDL UI and audio support
12 %bcond_without  opengl          # OpenGL support
13 %bcond_without  ceph            # Ceph/RBD support
14 %bcond_with     glusterfs       # GlusterFS backend
15 %bcond_without  spice           # SPICE support
16 %bcond_with     esd             # EsounD audio support
17 %bcond_without  oss             # OSS audio support
18 %bcond_without  pulseaudio      # PulseAudio audio support
19 %bcond_without  xen             # Xen backend driver support
20
21 Summary:        QEMU CPU Emulator
22 Summary(pl.UTF-8):      QEMU - emulator procesora
23 Name:           qemu
24 Version:        1.3.0
25 Release:        0.1
26 License:        GPL v2+
27 Group:          Applications/Emulators
28 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
29 # Source0-md5:  a4030ddd2ba324152a97d65d3c0b247d
30 Patch0:         %{name}-cflags.patch
31 Patch1:         vgabios-widescreens.patch
32 Patch2:         %{name}-whitelist.patch
33 Patch3:         %{name}-system-libcacard.patch
34 # Proof of concept, for reference, do not remove
35 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
36 URL:            http://www.qemu-project.org/
37 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
38 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
39 BuildRequires:  alsa-lib-devel
40 BuildRequires:  bluez-libs-devel
41 BuildRequires:  brlapi-devel
42 %{?with_ceph:BuildRequires:     ceph-devel}
43 BuildRequires:  curl-devel
44 BuildRequires:  cyrus-sasl-devel >= 2
45 %{?with_esd:BuildRequires:      esound-devel}
46 BuildRequires:  glib2-devel >= 1:2.12
47 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
48 BuildRequires:  gnutls-devel
49 BuildRequires:  libaio-devel
50 BuildRequires:  libcacard-devel
51 BuildRequires:  libcap-devel
52 BuildRequires:  libcap-ng-devel
53 BuildRequires:  libfdt-devel
54 BuildRequires:  libiscsi-devel
55 BuildRequires:  libjpeg-devel
56 BuildRequires:  libpng-devel
57 BuildRequires:  libseccomp-devel
58 BuildRequires:  libuuid-devel
59 BuildRequires:  ncurses-devel
60 BuildRequires:  nss-devel >= 3.12.8
61 BuildRequires:  perl-Encode
62 BuildRequires:  perl-tools-pod
63 BuildRequires:  pkgconfig
64 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
65 BuildRequires:  sed >= 4.0
66 %if %{with spice}
67 BuildRequires:  spice-protocol >= 0.8.0
68 BuildRequires:  spice-server-devel >= 0.8.2
69 %endif
70 BuildRequires:  texi2html
71 BuildRequires:  texinfo
72 BuildRequires:  usbredir-devel >= 0.5.3
73 BuildRequires:  vde2-devel
74 BuildRequires:  which
75 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
76 BuildRequires:  xfsprogs-devel
77 BuildRequires:  xorg-lib-libX11-devel
78 BuildRequires:  zlib-devel
79 Requires:       %{name}-img = %{version}-%{release}
80 Requires:       %{name}-system-alpha = %{version}-%{release}
81 Requires:       %{name}-system-arm = %{version}-%{release}
82 Requires:       %{name}-system-cris = %{version}-%{release}
83 Requires:       %{name}-system-lm32 = %{version}-%{release}
84 Requires:       %{name}-system-m68k = %{version}-%{release}
85 Requires:       %{name}-system-microblaze = %{version}-%{release}
86 Requires:       %{name}-system-mips = %{version}-%{release}
87 Requires:       %{name}-system-or32 = %{version}-%{release}
88 Requires:       %{name}-system-ppc = %{version}-%{release}
89 Requires:       %{name}-system-s390x = %{version}-%{release}
90 Requires:       %{name}-system-sh4 = %{version}-%{release}
91 Requires:       %{name}-system-sparc = %{version}-%{release}
92 Requires:       %{name}-system-unicore32 = %{version}-%{release}
93 Requires:       %{name}-system-x86 = %{version}-%{release}
94 Requires:       %{name}-system-xtensa = %{version}-%{release}
95 Requires:       %{name}-user = %{version}-%{release}
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %define systempkg_req \
99 Requires:       SDL >= 1.2.1 \
100 Requires:       usbredir >= 0.5.3
101
102 # some PPC/SPARC boot image in ELF format
103 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
104
105 %description
106 QEMU is a FAST! processor emulator. By using dynamic translation it
107 achieves a reasonnable speed while being easy to port on new host
108 CPUs. QEMU has two operating modes:
109
110 - User mode emulation. In this mode, QEMU can launch Linux processes
111   compiled for one CPU on another CPU. Linux system calls are converted
112   because of endianness and 32/64 bit mismatches. Wine (Windows
113   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
114
115 - Full system emulation. In this mode, QEMU emulates a full system,
116   including a processor and various peripherials. It can also be used to
117   provide virtual hosting of several virtual PC on a single server.
118
119 %description -l pl.UTF-8
120 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
121 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
122 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
123
124 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
125   procesy linuksowe skompilowane dla jednego procesora na innym
126   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
127   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
128   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
129   cele QEMU.
130
131 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
132   włączając w to procesor i różne urządzenia peryferyjne. Może być także
133   używane do wirtualnego hostowania kilku wirtualnych pecetów na
134   pojedynczym serwerze.
135
136 %package common
137 Summary:        QEMU common files needed by all QEMU targets
138 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
139 Group:          Development/Tools
140 Requires:       glib2 >= 1:2.12
141 Conflicts:      qemu < 1.0-2
142
143 %description common
144 QEMU is a generic and open source processor emulator which achieves a
145 good emulation speed by using dynamic translation.
146
147 This package provides the common files needed by all QEMU targets.
148
149 %description common -l pl.UTF-8
150 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
151 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
152
153 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
154 środowiska QEMU.
155
156 %package img
157 Summary:        QEMU command line tool for manipulating disk images
158 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
159 Group:          Development/Tools
160 Conflicts:      qemu < 1.0-2
161
162 %description img
163 This package provides a command line tool for manipulating disk
164 images.
165
166 %description img -l pl.UTF-8
167 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
168 na obrazach dysków.
169
170 %package user
171 Summary:        QEMU user mode emulation of qemu targets
172 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
173 Group:          Development/Tools
174 Requires:       %{name}-common = %{version}-%{release}
175
176 %description user
177 QEMU is a generic and open source processor emulator which achieves a
178 good emulation speed by using dynamic translation.
179
180 This package provides the user mode emulation of QEMU targets.
181
182 %description user -l pl.UTF-8
183 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
184 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
185
186 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
187
188 %package system-alpha
189 Summary:        QEMU system emulator for Alpha
190 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
191 Group:          Development/Tools
192 Requires:       %{name}-common = %{version}-%{release}
193 %systempkg_req
194
195 %description system-alpha
196 QEMU is a generic and open source processor emulator which achieves a
197 good emulation speed by using dynamic translation.
198
199 This package provides the system emulator with Alpha CPU.
200
201 %description system-alpha -l pl.UTF-8
202 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
203 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
204
205 Ten pakiet zawiera emulator systemu z procesorem Alpha.
206
207 %package system-arm
208 Summary:        QEMU system emulator for ARM
209 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
210 Group:          Development/Tools
211 Requires:       %{name}-common = %{version}-%{release}
212 %systempkg_req
213
214 %description system-arm
215 QEMU is a generic and open source processor emulator which achieves a
216 good emulation speed by using dynamic translation.
217
218 This package provides the system emulator for ARM.
219
220 %description system-arm -l pl.UTF-8
221 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
222 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
223
224 Ten pakiet zawiera emulator systemu z procesorem ARM.
225
226 %package system-cris
227 Summary:        QEMU system emulator for CRIS
228 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
229 Group:          Development/Tools
230 Requires:       %{name}-common = %{version}-%{release}
231 %systempkg_req
232
233 %description system-cris
234 QEMU is a generic and open source processor emulator which achieves a
235 good emulation speed by using dynamic translation.
236
237 This package provides the system emulator with CRIS CPU.
238
239 %description system-cris -l pl.UTF-8
240 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
241 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
242
243 Ten pakiet zawiera emulator systemu z procesorem CRIS.
244
245 %package system-lm32
246 Summary:        QEMU system emulator for LM32
247 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
248 Group:          Development/Tools
249 Requires:       %{name}-common = %{version}-%{release}
250 %systempkg_req
251
252 %description system-lm32
253 QEMU is a generic and open source processor emulator which achieves a
254 good emulation speed by using dynamic translation.
255
256 This package provides the system emulator with LM32 CPU.
257
258 %description system-lm32 -l pl.UTF-8
259 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
260 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
261
262 Ten pakiet zawiera emulator systemu z procesorem LM32.
263
264 %package system-m68k
265 Summary:        QEMU system emulator for m68k
266 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
267 Group:          Development/Tools
268 Requires:       %{name}-common = %{version}-%{release}
269 %systempkg_req
270
271 %description system-m68k
272 QEMU is a generic and open source processor emulator which achieves a
273 good emulation speed by using dynamic translation.
274
275 This package provides the system emulator with m68k CPU.
276
277 %description system-m68k -l pl.UTF-8
278 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
279 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
280
281 Ten pakiet zawiera emulator systemu z procesorem m68k.
282
283 %package system-microblaze
284 Summary:        QEMU system emulator for MicroBlaze
285 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
286 Group:          Development/Tools
287 Requires:       %{name}-common = %{version}-%{release}
288 %systempkg_req
289
290 %description system-microblaze
291 QEMU is a generic and open source processor emulator which achieves a
292 good emulation speed by using dynamic translation.
293
294 This package provides the system emulator with MicroBlaze CPU.
295
296 %description system-microblaze -l pl.UTF-8
297 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
298 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
299
300 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
301
302 %package system-mips
303 Summary:        QEMU system emulator for MIPS
304 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
305 Group:          Development/Tools
306 Requires:       %{name}-common = %{version}-%{release}
307 %systempkg_req
308
309 %description system-mips
310 QEMU is a generic and open source processor emulator which achieves a
311 good emulation speed by using dynamic translation.
312
313 This package provides the system emulator with MIPS CPU.
314
315 %description system-mips -l pl.UTF-8
316 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
317 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
318
319 Ten pakiet zawiera emulator systemu z procesorem MIPS.
320
321 %package system-or32
322 Summary:        QEMU system emulator for OpenRISC
323 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
324 Group:          Development/Tools
325 Requires:       %{name}-common = %{version}-%{release}
326 %systempkg_req
327
328 %description system-or32
329 QEMU is a generic and open source processor emulator which achieves a
330 good emulation speed by using dynamic translation.
331
332 This package provides the system emulator with OpenRISC CPU.
333
334 %description system-or32 -l pl.UTF-8
335 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
336 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
337
338 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
339
340 %package system-ppc
341 Summary:        QEMU system emulator for PowerPC
342 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
343 Group:          Development/Tools
344 Requires:       %{name}-common = %{version}-%{release}
345 %systempkg_req
346
347 %description system-ppc
348 QEMU is a generic and open source processor emulator which achieves a
349 good emulation speed by using dynamic translation.
350
351 This package provides the system emulator with PowerPC CPU.
352
353 %description system-ppc -l pl.UTF-8
354 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
355 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
356
357 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
358
359 %package system-s390x
360 Summary:        QEMU system emulator for S390
361 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
362 Group:          Development/Tools
363 Requires:       %{name}-common = %{version}-%{release}
364 %systempkg_req
365
366 %description system-s390x
367 QEMU is a generic and open source processor emulator which achieves a
368 good emulation speed by using dynamic translation.
369
370 This package provides the system emulator with S390 CPU.
371
372 %description system-s390x -l pl.UTF-8
373 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
374 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
375
376 Ten pakiet zawiera emulator systemu z procesorem S390.
377
378 %package system-sh4
379 Summary:        QEMU system emulator for SH4
380 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
381 Group:          Development/Tools
382 Requires:       %{name}-common = %{version}-%{release}
383 %systempkg_req
384
385 %description system-sh4
386 QEMU is a generic and open source processor emulator which achieves a
387 good emulation speed by using dynamic translation.
388
389 This package provides the system emulator with SH4 CPU.
390
391 %description system-sh4 -l pl.UTF-8
392 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
393 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
394
395 Ten pakiet zawiera emulator systemu z procesorem SH4.
396
397 %package system-sparc
398 Summary:        QEMU system emulator for SPARC
399 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
400 Group:          Development/Tools
401 Requires:       %{name}-common = %{version}-%{release}
402 %systempkg_req
403
404 %description system-sparc
405 QEMU is a generic and open source processor emulator which achieves a
406 good emulation speed by using dynamic translation.
407
408 This package provides the system emulator with SPARC/SPARC64 CPU.
409
410 %description system-sparc -l pl.UTF-8
411 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
412 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
413
414 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
415
416 %package system-unicore32
417 Summary:        QEMU system emulator for UniCore32
418 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
419 Group:          Development/Tools
420 Requires:       %{name}-common = %{version}-%{release}
421 %systempkg_req
422
423 %description system-unicore32
424 QEMU is a generic and open source processor emulator which achieves a
425 good emulation speed by using dynamic translation.
426
427 This package provides the system emulator with UniCore32 CPU.
428
429 %description system-unicore32 -l pl.UTF-8
430 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
431 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
432
433 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
434
435 %package system-x86
436 Summary:        QEMU system emulator for x86
437 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
438 Group:          Development/Tools
439 Requires:       %{name}-common = %{version}-%{release}
440 %systempkg_req
441
442 %description system-x86
443 QEMU is a generic and open source processor emulator which achieves a
444 good emulation speed by using dynamic translation.
445
446 %description system-x86 -l pl.UTF-8
447 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
448 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
449
450 %package system-xtensa
451 Summary:        QEMU system emulator for Xtensa
452 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
453 Group:          Development/Tools
454 Requires:       %{name}-common = %{version}-%{release}
455 %systempkg_req
456
457 %description system-xtensa
458 QEMU is a generic and open source processor emulator which achieves a
459 good emulation speed by using dynamic translation.
460
461 This package provides the system emulator with Xtensa CPU.
462
463 %description system-xtensa -l pl.UTF-8
464 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
465 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
466
467 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
468
469 %prep
470 %setup -q
471 %patch0 -p1
472 %patch1 -p1
473 %patch2 -p0
474 %patch3 -p1
475
476 %{__mv} libcacard libcacard-use-system-lib
477
478 # workaround for conflict with alsa/error.h
479 ln -s ../error.h qapi/error.h
480
481 %build
482 ./configure \
483         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
484         --extra-ldflags="%{rpmldflags}" \
485         --prefix=%{_prefix} \
486         --sysconfdir=%{_sysconfdir} \
487         --cc="%{__cc}" \
488         --host-cc="%{__cc}" \
489         --disable-strip \
490         --enable-attr \
491         --enable-bluez \
492         --enable-brlapi \
493         --enable-cap-ng \
494         --enable-curl \
495         --enable-curses \
496         --enable-docs \
497         --enable-fdt \
498         %{__enable_disable glusterfs} \
499         --enable-libiscsi \
500         --enable-mixemu \
501         %{__enable_disable opengl} \
502         %{__enable_disable ceph rbd} \
503         %{__enable_disable sdl} \
504         --enable-seccomp \
505         %{__enable_disable spice} \
506         --enable-smartcard \
507         --enable-smartcard-nss \
508         --enable-usb-redir \
509         --enable-uuid \
510         --enable-vde \
511         --enable-virtfs \
512         --enable-vnc-jpeg \
513         --enable-vnc-png \
514         --enable-vnc-sasl \
515         --enable-vnc-tls \
516         %{__enable_disable xen} \
517         --audio-card-list="ac97,es1370,sb16,cs4231a,adlib,gus,hda" \
518         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
519         --interp-prefix=%{_libdir}/qemu/lib-%%M
520 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
521 # --libexecdir in configure is nop
522 %{__make} \
523         V=1 \
524         CONFIG_QEMU_HELPERDIR="%{_libdir}"
525
526 # rebuild patched vesa tables with additional widescreen modes.
527 %{__make} -C roms/vgabios stdvga-bios
528
529 %install
530 rm -rf $RPM_BUILD_ROOT
531
532 %{__make} install \
533         DESTDIR=$RPM_BUILD_ROOT \
534         libexecdir=%{_libdir}
535
536 install -d $RPM_BUILD_ROOT%{_sysconfdir}
537 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
538 #!/bin/sh
539
540 EOF
541
542 # already packaged
543 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
544 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
545
546 # install patched vesa tables with additional widescreen modes.
547 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
548
549 %clean
550 rm -rf $RPM_BUILD_ROOT
551
552 %files
553 %defattr(644,root,root,755)
554
555 %files common
556 %defattr(644,root,root,755)
557 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
558 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
559 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
560 %dir %{_sysconfdir}/qemu
561 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
562 %attr(755,root,root) %{_bindir}/qemu-nbd
563 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
564 %{_mandir}/man1/qemu.1*
565 %{_mandir}/man1/virtfs-proxy-helper.1*
566 %{_mandir}/man8/qemu-nbd.8*
567
568 %dir %{_datadir}/qemu
569 %{_datadir}/%{name}/keymaps
570 %{_datadir}/%{name}/qemu-icon.bmp
571 # various bios images
572 %{_datadir}/%{name}/*.bin
573 %{_datadir}/%{name}/*.rom
574 %{_datadir}/%{name}/*.dtb
575 %{_datadir}/%{name}/openbios-ppc
576 %{_datadir}/%{name}/openbios-sparc*
577 %{_datadir}/%{name}/palcode-clipper
578
579 %files img
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_bindir}/qemu-img
582 %{_mandir}/man1/qemu-img.1*
583
584 %files user
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_bindir}/qemu-alpha
587 %attr(755,root,root) %{_bindir}/qemu-arm
588 %attr(755,root,root) %{_bindir}/qemu-armeb
589 %attr(755,root,root) %{_bindir}/qemu-cris
590 %attr(755,root,root) %{_bindir}/qemu-ga
591 %attr(755,root,root) %{_bindir}/qemu-i386
592 %attr(755,root,root) %{_bindir}/qemu-io
593 %attr(755,root,root) %{_bindir}/qemu-m68k
594 %attr(755,root,root) %{_bindir}/qemu-microblaze
595 %attr(755,root,root) %{_bindir}/qemu-microblazeel
596 %attr(755,root,root) %{_bindir}/qemu-mips
597 %attr(755,root,root) %{_bindir}/qemu-mipsel
598 %attr(755,root,root) %{_bindir}/qemu-or32
599 %attr(755,root,root) %{_bindir}/qemu-ppc
600 %attr(755,root,root) %{_bindir}/qemu-ppc64
601 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
602 %attr(755,root,root) %{_bindir}/qemu-s390x
603 %attr(755,root,root) %{_bindir}/qemu-sh4
604 %attr(755,root,root) %{_bindir}/qemu-sh4eb
605 %attr(755,root,root) %{_bindir}/qemu-sparc
606 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
607 %attr(755,root,root) %{_bindir}/qemu-sparc64
608 %attr(755,root,root) %{_bindir}/qemu-unicore32
609 %attr(755,root,root) %{_bindir}/qemu-x86_64
610
611 %files system-alpha
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_bindir}/qemu-system-alpha
614
615 %files system-arm
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_bindir}/qemu-system-arm
618
619 %files system-cris
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_bindir}/qemu-system-cris
622
623 %files system-lm32
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_bindir}/qemu-system-lm32
626
627 %files system-m68k
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_bindir}/qemu-system-m68k
630
631 %files system-microblaze
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
634 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
635
636 %files system-mips
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_bindir}/qemu-system-mips
639 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
640 %attr(755,root,root) %{_bindir}/qemu-system-mips64
641 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
642
643 %files system-or32
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_bindir}/qemu-system-or32
646
647 %files system-ppc
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_bindir}/qemu-system-ppc
650 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
651 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
652
653 %files system-s390x
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_bindir}/qemu-system-s390x
656
657 %files system-sh4
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_bindir}/qemu-system-sh4
660 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
661
662 %files system-sparc
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_bindir}/qemu-system-sparc
665 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
666
667 %files system-unicore32
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
670
671 %files system-x86
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_bindir}/qemu-system-i386
674 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
675
676 %files system-xtensa
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
679 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.14831 seconds and 3 git commands to generate.