]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
a142f280c03027dea35fae5223e85d8603ddb51f
[packages/qemu.git] / qemu.spec
1 #
2 # Conditional build:
3 %bcond_without  sdl             # SDL UI and audio support
4 %bcond_without  glx             # OpenGL/GLX support
5 %bcond_without  ceph            # Ceph/RBD support
6 %bcond_without  glusterfs       # GlusterFS backend
7 %bcond_without  rdma            # RDMA-based migration support
8 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
9 %bcond_without  spice           # SPICE support
10 %bcond_with     esd             # EsounD audio support
11 %bcond_without  oss             # OSS audio support
12 %bcond_without  pulseaudio      # PulseAudio audio support
13 %bcond_without  xen             # Xen backend driver support
14
15 Summary:        QEMU CPU Emulator
16 Summary(pl.UTF-8):      QEMU - emulator procesora
17 Name:           qemu
18 Version:        1.7.0
19 Release:        4
20 License:        GPL v2+
21 Group:          Applications/Emulators
22 Source0:        http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
23 # Source0-md5:  32893941d40d052a5e649efcf06aca06
24 Source2:        %{name}.binfmt
25 # Loads kvm kernel modules at boot
26 Source3:        kvm-modules-load.conf
27 # Creates /dev/kvm
28 Source4:        80-kvm.rules
29 # KSM control scripts
30 Source5:        ksm.service
31 Source6:        ksm.sysconfig
32 Source7:        ksmctl.c
33 Source8:        ksmtuned.service
34 Source9:        ksmtuned
35 Source10:       ksmtuned.conf
36 Source11:       %{name}-guest-agent.service
37 Source12:       99-%{name}-guest-agent.rules
38 Patch0:         %{name}-cflags.patch
39 Patch1:         vgabios-widescreens.patch
40 Patch2:         %{name}-whitelist.patch
41 Patch3:         %{name}-system-libcacard.patch
42 Patch4:         vmdk3ro.patch
43 # Proof of concept, for reference, do not remove
44 Patch400:       %{name}-kde_virtual_workspaces_hack.patch
45 URL:            http://www.qemu-project.org/
46 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
47 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
48 BuildRequires:  alsa-lib-devel
49 BuildRequires:  bcc
50 BuildRequires:  bluez-libs-devel
51 BuildRequires:  brlapi-devel
52 %{?with_ceph:BuildRequires:     ceph-devel}
53 BuildRequires:  curl-devel
54 BuildRequires:  cyrus-sasl-devel >= 2
55 %{?with_esd:BuildRequires:      esound-devel}
56 BuildRequires:  glib2-devel >= 1:2.12
57 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4}
58 BuildRequires:  gnutls-devel
59 BuildRequires:  libaio-devel
60 BuildRequires:  libcacard-devel
61 BuildRequires:  libcap-devel
62 BuildRequires:  libcap-ng-devel
63 BuildRequires:  libfdt-devel
64 %{?with_rdma:BuildRequires:     libibverbs-devel}
65 BuildRequires:  libiscsi-devel
66 BuildRequires:  libjpeg-devel
67 BuildRequires:  libpng-devel
68 %{?with_rdma:BuildRequires:     librdmacm-devel}
69 BuildRequires:  libseccomp-devel
70 BuildRequires:  libssh2-devel >= 1.2.8
71 # for usb passthrough, when available
72 #BuildRequires: libusb-devel >= 1.0.13
73 BuildRequires:  libuuid-devel
74 BuildRequires:  ncurses-devel
75 BuildRequires:  nss-devel >= 3.12.8
76 BuildRequires:  perl-Encode
77 BuildRequires:  perl-tools-pod
78 BuildRequires:  pkgconfig
79 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
80 BuildRequires:  rpmbuild(macros) >= 1.644
81 BuildRequires:  sed >= 4.0
82 %if %{with spice}
83 BuildRequires:  spice-protocol >= 0.12.0
84 BuildRequires:  spice-server-devel >= 0.12.0
85 %endif
86 BuildRequires:  texi2html
87 BuildRequires:  texinfo
88 BuildRequires:  usbredir-devel >= 0.6
89 BuildRequires:  vde2-devel
90 BuildRequires:  which
91 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
92 BuildRequires:  xfsprogs-devel
93 BuildRequires:  xorg-lib-libX11-devel
94 BuildRequires:  zlib-devel
95 %if %{with gtk2}
96 BuildRequires:  gtk+2-devel >= 2:2.18.0
97 BuildRequires:  vte0-devel >= 0.24.0
98 %else
99 BuildRequires:  gtk+3-devel >= 3.0.0
100 BuildRequires:  vte-devel >= 0.32.0
101 %endif
102 Requires:       %{name}-img = %{version}-%{release}
103 Requires:       %{name}-system-alpha = %{version}-%{release}
104 Requires:       %{name}-system-arm = %{version}-%{release}
105 Requires:       %{name}-system-cris = %{version}-%{release}
106 Requires:       %{name}-system-lm32 = %{version}-%{release}
107 Requires:       %{name}-system-m68k = %{version}-%{release}
108 Requires:       %{name}-system-microblaze = %{version}-%{release}
109 Requires:       %{name}-system-mips = %{version}-%{release}
110 Requires:       %{name}-system-moxie = %{version}-%{release}
111 Requires:       %{name}-system-or32 = %{version}-%{release}
112 Requires:       %{name}-system-ppc = %{version}-%{release}
113 Requires:       %{name}-system-s390x = %{version}-%{release}
114 Requires:       %{name}-system-sh4 = %{version}-%{release}
115 Requires:       %{name}-system-sparc = %{version}-%{release}
116 Requires:       %{name}-system-unicore32 = %{version}-%{release}
117 Requires:       %{name}-system-x86 = %{version}-%{release}
118 Requires:       %{name}-system-xtensa = %{version}-%{release}
119 Requires:       %{name}-user = %{version}-%{release}
120 Obsoletes:      qemu-kvm
121 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123 %define systempkg_req \
124 Requires:       SDL >= 1.2.1 \
125 Requires:       usbredir >= 0.6 \
126 %if %{with gtk2} \
127 Requires:       gtk+2 >= 2:2.18.0 \
128 Requires:       vte0 >= 0.24.0 \
129 %else \
130 Requires:       gtk+3 >= 3.0.0 \
131 Requires:       vte >= 0.32.0 \
132 %endif
133
134 # some PPC/SPARC boot image in ELF format
135 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
136
137 %description
138 QEMU is a FAST! processor emulator. By using dynamic translation it
139 achieves a reasonnable speed while being easy to port on new host
140 CPUs. QEMU has two operating modes:
141
142 - User mode emulation. In this mode, QEMU can launch Linux processes
143   compiled for one CPU on another CPU. Linux system calls are converted
144   because of endianness and 32/64 bit mismatches. Wine (Windows
145   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
146
147 - Full system emulation. In this mode, QEMU emulates a full system,
148   including a processor and various peripherials. It can also be used to
149   provide virtual hosting of several virtual PC on a single server.
150
151 %description -l pl.UTF-8
152 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
153 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
154 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
155
156 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
157   procesy linuksowe skompilowane dla jednego procesora na innym
158   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
159   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
160   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
161   cele QEMU.
162
163 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
164   włączając w to procesor i różne urządzenia peryferyjne. Może być także
165   używane do wirtualnego hostowania kilku wirtualnych pecetów na
166   pojedynczym serwerze.
167
168 %package common
169 Summary:        QEMU common files needed by all QEMU targets
170 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
171 Group:          Development/Tools
172 Requires(post,preun,postun):    systemd-units >= 38
173 Requires(postun):       /usr/sbin/groupdel
174 Requires(postun):       /usr/sbin/userdel
175 Requires(pre):  /bin/id
176 Requires(pre):  /usr/bin/getgid
177 Requires(pre):  /usr/sbin/groupadd
178 Requires(pre):  /usr/sbin/useradd
179 Requires:       glib2 >= 1:2.12
180 Requires:       libssh2 >= 1.2.8
181 Requires:       systemd-units >= 38
182 Provides:       group(qemu)
183 Provides:       user(qemu)
184 Obsoletes:      qemu-kvm-common
185 Conflicts:      qemu < 1.0-2
186
187 %description common
188 QEMU is a generic and open source processor emulator which achieves a
189 good emulation speed by using dynamic translation.
190
191 This package provides the common files needed by all QEMU targets.
192
193 %description common -l pl.UTF-8
194 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
195 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
196
197 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
198 środowiska QEMU.
199
200 %package img
201 Summary:        QEMU command line tool for manipulating disk images
202 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
203 Group:          Development/Tools
204 Obsoletes:      qemu-kvm-img
205 Conflicts:      qemu < 1.0-2
206
207 %description img
208 This package provides a command line tool for manipulating disk
209 images.
210
211 %description img -l pl.UTF-8
212 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
213 na obrazach dysków.
214
215 %package user
216 Summary:        QEMU user mode emulation of qemu targets
217 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
218 Group:          Development/Tools
219 Requires:       %{name}-common = %{version}-%{release}
220 Requires(post,postun):  systemd-units >= 38
221 Requires:       systemd-units >= 38
222 Obsoletes:      qemu-kvm-user
223
224 %description user
225 QEMU is a generic and open source processor emulator which achieves a
226 good emulation speed by using dynamic translation.
227
228 This package provides the user mode emulation of QEMU targets.
229
230 %description user -l pl.UTF-8
231 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
232 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
233
234 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
235
236 %package system-alpha
237 Summary:        QEMU system emulator for Alpha
238 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
239 Group:          Development/Tools
240 Requires:       %{name}-common = %{version}-%{release}
241 %systempkg_req
242 Obsoletes:      qemu-kvm-system-alpha
243
244 %description system-alpha
245 QEMU is a generic and open source processor emulator which achieves a
246 good emulation speed by using dynamic translation.
247
248 This package provides the system emulator with Alpha CPU.
249
250 %description system-alpha -l pl.UTF-8
251 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
252 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
253
254 Ten pakiet zawiera emulator systemu z procesorem Alpha.
255
256 %package system-arm
257 Summary:        QEMU system emulator for ARM
258 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
259 Group:          Development/Tools
260 Requires:       %{name}-common = %{version}-%{release}
261 %systempkg_req
262 Obsoletes:      qemu-kvm-system-arm
263
264 %description system-arm
265 QEMU is a generic and open source processor emulator which achieves a
266 good emulation speed by using dynamic translation.
267
268 This package provides the system emulator for ARM.
269
270 %description system-arm -l pl.UTF-8
271 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
272 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
273
274 Ten pakiet zawiera emulator systemu z procesorem ARM.
275
276 %package system-cris
277 Summary:        QEMU system emulator for CRIS
278 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
279 Group:          Development/Tools
280 Requires:       %{name}-common = %{version}-%{release}
281 %systempkg_req
282 Obsoletes:      qemu-kvm-system-cris
283
284 %description system-cris
285 QEMU is a generic and open source processor emulator which achieves a
286 good emulation speed by using dynamic translation.
287
288 This package provides the system emulator with CRIS CPU.
289
290 %description system-cris -l pl.UTF-8
291 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
292 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
293
294 Ten pakiet zawiera emulator systemu z procesorem CRIS.
295
296 %package system-lm32
297 Summary:        QEMU system emulator for LM32
298 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
299 Group:          Development/Tools
300 Requires:       %{name}-common = %{version}-%{release}
301 %systempkg_req
302 Obsoletes:      qemu-kvm-system-lm32
303
304 %description system-lm32
305 QEMU is a generic and open source processor emulator which achieves a
306 good emulation speed by using dynamic translation.
307
308 This package provides the system emulator with LM32 CPU.
309
310 %description system-lm32 -l pl.UTF-8
311 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
312 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
313
314 Ten pakiet zawiera emulator systemu z procesorem LM32.
315
316 %package system-m68k
317 Summary:        QEMU system emulator for m68k
318 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
319 Group:          Development/Tools
320 Requires:       %{name}-common = %{version}-%{release}
321 %systempkg_req
322 Obsoletes:      qemu-kvm-system-m68k
323
324 %description system-m68k
325 QEMU is a generic and open source processor emulator which achieves a
326 good emulation speed by using dynamic translation.
327
328 This package provides the system emulator with m68k CPU.
329
330 %description system-m68k -l pl.UTF-8
331 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
332 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
333
334 Ten pakiet zawiera emulator systemu z procesorem m68k.
335
336 %package system-microblaze
337 Summary:        QEMU system emulator for MicroBlaze
338 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
339 Group:          Development/Tools
340 Requires:       %{name}-common = %{version}-%{release}
341 %systempkg_req
342 Obsoletes:      qemu-kvm-system-microblaze
343
344 %description system-microblaze
345 QEMU is a generic and open source processor emulator which achieves a
346 good emulation speed by using dynamic translation.
347
348 This package provides the system emulator with MicroBlaze CPU.
349
350 %description system-microblaze -l pl.UTF-8
351 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
352 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
353
354 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
355
356 %package system-mips
357 Summary:        QEMU system emulator for MIPS
358 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
359 Group:          Development/Tools
360 Requires:       %{name}-common = %{version}-%{release}
361 %systempkg_req
362 Obsoletes:      qemu-kvm-system-mips
363
364 %description system-mips
365 QEMU is a generic and open source processor emulator which achieves a
366 good emulation speed by using dynamic translation.
367
368 This package provides the system emulator with MIPS CPU.
369
370 %description system-mips -l pl.UTF-8
371 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
372 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
373
374 Ten pakiet zawiera emulator systemu z procesorem MIPS.
375
376 %package system-moxie
377 Summary:        QEMU system emulator for Moxie
378 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Moxie
379 Group:          Development/Tools
380 Requires:       %{name}-common = %{version}-%{release}
381 %systempkg_req
382
383 %description system-moxie
384 QEMU is a generic and open source processor emulator which achieves a
385 good emulation speed by using dynamic translation.
386
387 This package provides the system emulator with Moxie CPU.
388
389 %description system-moxie -l pl.UTF-8
390 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
391 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
392
393 Ten pakiet zawiera emulator systemu z procesorem Moxie.
394
395 %package system-or32
396 Summary:        QEMU system emulator for OpenRISC
397 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
398 Group:          Development/Tools
399 Requires:       %{name}-common = %{version}-%{release}
400 %systempkg_req
401 Obsoletes:      qemu-kvm-system-or32
402
403 %description system-or32
404 QEMU is a generic and open source processor emulator which achieves a
405 good emulation speed by using dynamic translation.
406
407 This package provides the system emulator with OpenRISC CPU.
408
409 %description system-or32 -l pl.UTF-8
410 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
411 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
412
413 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
414
415 %package system-ppc
416 Summary:        QEMU system emulator for PowerPC
417 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
418 Group:          Development/Tools
419 Requires:       %{name}-common = %{version}-%{release}
420 %systempkg_req
421 Obsoletes:      qemu-kvm-system-ppc
422
423 %description system-ppc
424 QEMU is a generic and open source processor emulator which achieves a
425 good emulation speed by using dynamic translation.
426
427 This package provides the system emulator with PowerPC CPU.
428
429 %description system-ppc -l pl.UTF-8
430 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
431 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
432
433 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
434
435 %package system-s390x
436 Summary:        QEMU system emulator for S390
437 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
438 Group:          Development/Tools
439 Requires:       %{name}-common = %{version}-%{release}
440 %systempkg_req
441 Obsoletes:      qemu-kvm-system-s390x
442
443 %description system-s390x
444 QEMU is a generic and open source processor emulator which achieves a
445 good emulation speed by using dynamic translation.
446
447 This package provides the system emulator with S390 CPU.
448
449 %description system-s390x -l pl.UTF-8
450 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
451 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
452
453 Ten pakiet zawiera emulator systemu z procesorem S390.
454
455 %package system-sh4
456 Summary:        QEMU system emulator for SH4
457 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
458 Group:          Development/Tools
459 Requires:       %{name}-common = %{version}-%{release}
460 %systempkg_req
461 Obsoletes:      qemu-kvm-system-sh4
462
463 %description system-sh4
464 QEMU is a generic and open source processor emulator which achieves a
465 good emulation speed by using dynamic translation.
466
467 This package provides the system emulator with SH4 CPU.
468
469 %description system-sh4 -l pl.UTF-8
470 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
471 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
472
473 Ten pakiet zawiera emulator systemu z procesorem SH4.
474
475 %package system-sparc
476 Summary:        QEMU system emulator for SPARC
477 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
478 Group:          Development/Tools
479 Requires:       %{name}-common = %{version}-%{release}
480 %systempkg_req
481 Obsoletes:      qemu-kvm-system-sparc
482
483 %description system-sparc
484 QEMU is a generic and open source processor emulator which achieves a
485 good emulation speed by using dynamic translation.
486
487 This package provides the system emulator with SPARC/SPARC64 CPU.
488
489 %description system-sparc -l pl.UTF-8
490 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
491 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
492
493 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
494
495 %package system-unicore32
496 Summary:        QEMU system emulator for UniCore32
497 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
498 Group:          Development/Tools
499 Requires:       %{name}-common = %{version}-%{release}
500 %systempkg_req
501 Obsoletes:      qemu-kvm-system-unicore32
502
503 %description system-unicore32
504 QEMU is a generic and open source processor emulator which achieves a
505 good emulation speed by using dynamic translation.
506
507 This package provides the system emulator with UniCore32 CPU.
508
509 %description system-unicore32 -l pl.UTF-8
510 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
511 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
512
513 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
514
515 %package system-x86
516 Summary:        QEMU system emulator for x86
517 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
518 Group:          Development/Tools
519 Requires:       %{name}-common = %{version}-%{release}
520 %systempkg_req
521 Obsoletes:      kvm
522 Obsoletes:      qemu-kvm-system-x86
523
524 %description system-x86
525 QEMU is a generic and open source processor emulator which achieves a
526 good emulation speed by using dynamic translation.
527
528 %description system-x86 -l pl.UTF-8
529 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
530 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
531
532 %package system-xtensa
533 Summary:        QEMU system emulator for Xtensa
534 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
535 Group:          Development/Tools
536 Requires:       %{name}-common = %{version}-%{release}
537 %systempkg_req
538 Obsoletes:      qemu-kvm-system-xtensa
539
540 %description system-xtensa
541 QEMU is a generic and open source processor emulator which achieves a
542 good emulation speed by using dynamic translation.
543
544 This package provides the system emulator with Xtensa CPU.
545
546 %description system-xtensa -l pl.UTF-8
547 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
548 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
549
550 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
551
552 %package guest-agent
553 Summary:        QEMU guest agent
554 Summary(pl.UTF-8):      Agent gościa QEMU
555 Group:          Daemons
556 Requires(post,preun,postun):    systemd-units >= 38
557 Requires:       glib2 >= 1:2.12
558 Requires:       systemd-units >= 38
559 Obsoletes:      qemu-kvm-guest-agent
560
561 %description guest-agent
562 QEMU is a generic and open source processor emulator which achieves a
563 good emulation speed by using dynamic translation.
564
565 This package provides an agent to run inside guests, which
566 communicates with the host over a virtio-serial channel named
567 "org.qemu.guest_agent.0".
568
569 This package does not need to be installed on the host OS.
570
571 %description guest-agent -l pl.UTF-8
572 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
573 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
574
575 Ten pakiet udostępnia agenta przeznaczonego do uruchomienia w
576 systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
577 "org.qemu.guest_agent.0".
578
579 Ten pakiet nie musi być zainstalowany w systemie hosta.
580
581 %prep
582 %setup -q
583 %patch0 -p1
584 %patch1 -p1
585 %patch2 -p0
586 %patch3 -p1
587 %patch4 -p1
588
589 %{__mv} libcacard libcacard-use-system-lib
590
591 # workaround for conflict with alsa/error.h
592 ln -s ../error.h qapi/error.h
593
594 %build
595 ./configure \
596         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
597         --extra-ldflags="%{rpmldflags}" \
598         --prefix=%{_prefix} \
599         --sysconfdir=%{_sysconfdir} \
600         --cc="%{__cc}" \
601         --host-cc="%{__cc}" \
602         --disable-strip \
603         --enable-attr \
604         --enable-bluez \
605         --enable-brlapi \
606         --enable-cap-ng \
607         --enable-curl \
608         --enable-curses \
609         --enable-docs \
610         --enable-fdt \
611         %{__enable_disable glusterfs} \
612         --enable-libiscsi \
613         %{__enable_disable glx} \
614         %{__enable_disable ceph rbd} \
615         %{__enable_disable rdma} \
616         %{__enable_disable sdl} \
617         --enable-seccomp \
618         %{__enable_disable spice} \
619         --enable-smartcard-nss \
620         --enable-tpm \
621         --enable-usb-redir \
622         --enable-uuid \
623         --enable-vde \
624         --enable-virtfs \
625         --enable-vnc-jpeg \
626         --enable-vnc-png \
627         --enable-vnc-sasl \
628         --enable-vnc-tls \
629         --enable-kvm \
630         %{__enable_disable xen} \
631         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
632         --interp-prefix=%{_libdir}/qemu/lib-%%M \
633         --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
634
635 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
636 # --libexecdir in configure is nop
637 %{__make} \
638         V=1 \
639         CONFIG_QEMU_HELPERDIR="%{_libdir}"
640
641 # rebuild patched vesa tables with additional widescreen modes.
642 %{__make} -C roms/vgabios stdvga-bios
643
644 %{__cc} %{SOURCE7} %{rpmcflags} -o ksmctl
645
646 %install
647 rm -rf $RPM_BUILD_ROOT
648 install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
649         $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
650         $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
651
652 %{__make} install \
653         DESTDIR=$RPM_BUILD_ROOT \
654         libexecdir=%{_libdir}
655
656 install -d $RPM_BUILD_ROOT%{_sysconfdir}
657 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
658 #!/bin/sh
659
660 EOF
661
662 install -p qemu.sasl $RPM_BUILD_ROOT%{_sysconfdir}/sasl/qemu.conf
663
664 %ifarch %{ix86} %{x8664}
665 install -p scripts/kvm/kvm_stat $RPM_BUILD_ROOT%{_bindir}
666 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/modules-load.d/kvm.conf
667 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
668 %endif
669
670 install -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/ksm.service
671 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/ksm
672 install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
673
674 install -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/ksmtuned.service
675 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
676 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
677
678 # For the qemu-guest-agent subpackage install the systemd
679 # service and udev rules.
680 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
681 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
682
683 for i in dummy \
684 %ifnarch %{ix86} %{x8664}
685         qemu-i386 \
686 %endif
687 %ifnarch arm
688         qemu-arm \
689 %endif
690 %ifnarch ppc ppc64
691         qemu-ppc \
692 %endif
693 %ifnarch sparc sparc64
694         qemu-sparc \
695 %endif
696 %ifnarch sh4
697         qemu-sh4 \
698 %endif
699 ; do
700         test $i = dummy && continue
701         grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i.conf
702 done < %{SOURCE2}
703
704 # packaged as %doc
705 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
706 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
707
708 # install patched vesa tables with additional widescreen modes.
709 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
710
711 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{de_DE,de}
712 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
713 %find_lang %{name}
714
715 %clean
716 rm -rf $RPM_BUILD_ROOT
717
718 %pre common
719 %groupadd -g 160 kvm
720 %groupadd -g 276 qemu
721 %useradd -u 276 -g qemu -G kvm -c "QEMU User" qemu
722
723 %post common
724 %systemd_post ksm.service
725 %systemd_post ksmtuned.service
726
727 %preun common
728 %systemd_preun ksm.service
729 %systemd_preun ksmtuned.service
730
731 %postun common
732 if [ "$1" = "0" ]; then
733         %userremove qemu
734         %groupremove qemu
735         %groupremove kvm
736 fi
737 %systemd_reload
738
739 %triggerpostun common -- qemu-common < 1.6.1-4
740 %systemd_trigger ksm.service
741 %systemd_trigger ksmtuned.service
742
743 %post user
744 %systemd_service_restart systemd-binfmt.service
745
746 %postun user
747 %systemd_service_restart systemd-binfmt.service
748
749 %post guest-agent
750 %systemd_reload
751
752 %preun guest-agent
753 %systemd_preun qemu-guest-agent.service
754
755 %postun guest-agent
756 %systemd_reload
757
758 %files
759 %defattr(644,root,root,755)
760
761 %files common -f %{name}.lang
762 %defattr(644,root,root,755)
763 %doc README qemu-doc.html qemu-tech.html qmp-commands.txt
764 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
765 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
766 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
767 %config(noreplace) %verify(not md5 mtime size) /etc/sasl/qemu.conf
768 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
769 %{systemdunitdir}/ksm.service
770 %{systemdunitdir}/ksmtuned.service
771 %dir %{_sysconfdir}/qemu
772 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
773 %attr(755,root,root) %{_bindir}/qemu-nbd
774 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
775 %attr(755,root,root) %{_sbindir}/ksmctl
776 %attr(755,root,root) %{_sbindir}/ksmtuned
777 %{_mandir}/man1/qemu.1*
778 %{_mandir}/man1/virtfs-proxy-helper.1*
779 %{_mandir}/man8/qemu-nbd.8*
780
781 %dir %{_datadir}/qemu
782 %{_datadir}/%{name}/keymaps
783 %{_datadir}/%{name}/qemu-icon.bmp
784 # various bios images
785 %{_datadir}/%{name}/*.aml
786 %{_datadir}/%{name}/*.bin
787 %{_datadir}/%{name}/*.rom
788 %{_datadir}/%{name}/*.dtb
789 %{_datadir}/%{name}/qemu_logo_no_text.svg
790 %{_datadir}/%{name}/openbios-ppc
791 %{_datadir}/%{name}/openbios-sparc*
792 %{_datadir}/%{name}/palcode-clipper
793 %{_datadir}/%{name}/s390-ccw.img
794
795 %files img
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_bindir}/qemu-img
798 %{_mandir}/man1/qemu-img.1*
799
800 %files user
801 %defattr(644,root,root,755)
802 /usr/lib/binfmt.d/qemu-*.conf
803 %attr(755,root,root) %{_bindir}/qemu-alpha
804 %attr(755,root,root) %{_bindir}/qemu-arm
805 %attr(755,root,root) %{_bindir}/qemu-armeb
806 %attr(755,root,root) %{_bindir}/qemu-cris
807 %attr(755,root,root) %{_bindir}/qemu-i386
808 %attr(755,root,root) %{_bindir}/qemu-io
809 %attr(755,root,root) %{_bindir}/qemu-m68k
810 %attr(755,root,root) %{_bindir}/qemu-microblaze
811 %attr(755,root,root) %{_bindir}/qemu-microblazeel
812 %attr(755,root,root) %{_bindir}/qemu-mips
813 %attr(755,root,root) %{_bindir}/qemu-mipsel
814 %attr(755,root,root) %{_bindir}/qemu-mips64
815 %attr(755,root,root) %{_bindir}/qemu-mips64el
816 %attr(755,root,root) %{_bindir}/qemu-mipsn32
817 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
818 %attr(755,root,root) %{_bindir}/qemu-or32
819 %attr(755,root,root) %{_bindir}/qemu-ppc
820 %attr(755,root,root) %{_bindir}/qemu-ppc64
821 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
822 %attr(755,root,root) %{_bindir}/qemu-s390x
823 %attr(755,root,root) %{_bindir}/qemu-sh4
824 %attr(755,root,root) %{_bindir}/qemu-sh4eb
825 %attr(755,root,root) %{_bindir}/qemu-sparc
826 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
827 %attr(755,root,root) %{_bindir}/qemu-sparc64
828 %attr(755,root,root) %{_bindir}/qemu-unicore32
829 %attr(755,root,root) %{_bindir}/qemu-x86_64
830
831 %files system-alpha
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{_bindir}/qemu-system-alpha
834
835 %files system-arm
836 %defattr(644,root,root,755)
837 %attr(755,root,root) %{_bindir}/qemu-system-arm
838
839 %files system-cris
840 %defattr(644,root,root,755)
841 %attr(755,root,root) %{_bindir}/qemu-system-cris
842
843 %files system-lm32
844 %defattr(644,root,root,755)
845 %attr(755,root,root) %{_bindir}/qemu-system-lm32
846
847 %files system-m68k
848 %defattr(644,root,root,755)
849 %attr(755,root,root) %{_bindir}/qemu-system-m68k
850
851 %files system-microblaze
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
854 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
855
856 %files system-mips
857 %defattr(644,root,root,755)
858 %attr(755,root,root) %{_bindir}/qemu-system-mips
859 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
860 %attr(755,root,root) %{_bindir}/qemu-system-mips64
861 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
862
863 %files system-moxie
864 %defattr(644,root,root,755)
865 %attr(755,root,root) %{_bindir}/qemu-system-moxie
866
867 %files system-or32
868 %defattr(644,root,root,755)
869 %attr(755,root,root) %{_bindir}/qemu-system-or32
870
871 %files system-ppc
872 %defattr(644,root,root,755)
873 %attr(755,root,root) %{_bindir}/qemu-system-ppc
874 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
875 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
876
877 %files system-s390x
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_bindir}/qemu-system-s390x
880
881 %files system-sh4
882 %defattr(644,root,root,755)
883 %attr(755,root,root) %{_bindir}/qemu-system-sh4
884 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
885
886 %files system-sparc
887 %defattr(644,root,root,755)
888 %attr(755,root,root) %{_bindir}/qemu-system-sparc
889 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
890
891 %files system-unicore32
892 %defattr(644,root,root,755)
893 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
894
895 %files system-x86
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_bindir}/qemu-system-i386
898 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
899 %ifarch %{ix86} %{x8664}
900 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/kvm.conf
901 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/80-kvm.rules
902 %attr(755,root,root) %{_bindir}/kvm_stat
903 %endif
904
905 %files system-xtensa
906 %defattr(644,root,root,755)
907 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
908 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
909
910 %files guest-agent
911 %defattr(644,root,root,755)
912 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
913 %{systemdunitdir}/qemu-guest-agent.service
914 %attr(755,root,root) %{_bindir}/qemu-ga
This page took 0.081388 seconds and 2 git commands to generate.