]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
881759509f206475dc646e7d0cdc4f6c36701a5a
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - update patches
3 # - qemu-system-ppc -hda ac-ppc.img says:
4 #   qemu: could not open disk image ac-ppc.img: error "Success"
5 #   qemu-0.12.2-2.x86_64.rpm - broken
6 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
7 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
8 #   qemu-0.11.1-*.x86_64.rpm - OK
9 #
10 # Conditional build:
11 #
12 Summary:        QEMU CPU Emulator
13 Summary(pl.UTF-8):      QEMU - emulator procesora
14 Name:           qemu
15 Version:        1.2.0
16 Release:        4
17 License:        GPL
18 Group:          Applications/Emulators
19 Source0:        http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
20 # Source0-md5:  78eb1e984f4532aa9f2bdd3c127b5b61
21 Patch0:         %{name}-cflags.patch
22 Patch1:         vgabios-widescreens.patch
23 # Proof of concept, for reference, do not remove
24 Patch8:         %{name}-kde_virtual_workspaces_hack.patch
25 Patch17:        %{name}-whitelist.patch
26 URL:            http://wiki.qemu.org/Index.html
27 BuildRequires:  SDL-devel >= 1.2.1
28 BuildRequires:  alsa-lib-devel
29 BuildRequires:  bluez-libs-devel
30 BuildRequires:  gnutls-devel
31 BuildRequires:  ncurses-devel
32 BuildRequires:  perl-Encode
33 BuildRequires:  perl-tools-pod
34 BuildRequires:  pkgconfig
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  texi2html
37 BuildRequires:  texinfo
38 BuildRequires:  which
39 BuildRequires:  xen-devel
40 BuildRequires:  xorg-lib-libX11-devel
41 Requires:       %{name}-img = %{version}-%{release}
42 Requires:       %{name}-system-alpha = %{version}-%{release}
43 Requires:       %{name}-system-arm = %{version}-%{release}
44 Requires:       %{name}-system-cris = %{version}-%{release}
45 Requires:       %{name}-system-lm32 = %{version}-%{release}
46 Requires:       %{name}-system-m68k = %{version}-%{release}
47 Requires:       %{name}-system-microblaze = %{version}-%{release}
48 Requires:       %{name}-system-mips = %{version}-%{release}
49 Requires:       %{name}-system-ppc = %{version}-%{release}
50 Requires:       %{name}-system-or32 = %{version}-%{release}
51 Requires:       %{name}-system-s390x = %{version}-%{release}
52 Requires:       %{name}-system-sh4 = %{version}-%{release}
53 Requires:       %{name}-system-sparc = %{version}-%{release}
54 Requires:       %{name}-system-unicore32 = %{version}-%{release}
55 Requires:       %{name}-system-x86 = %{version}-%{release}
56 Requires:       %{name}-system-xtensa = %{version}-%{release}
57 Requires:       %{name}-user = %{version}-%{release}
58 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
59 ExclusiveArch:  %{ix86} %{x8664} %{?with_userspace:ppc}
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 # some PPC/SPARC boot image in ELF format
63 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
64
65 %description
66 QEMU is a FAST! processor emulator. By using dynamic translation it
67 achieves a reasonnable speed while being easy to port on new host
68 CPUs. QEMU has two operating modes:
69
70 - User mode emulation. In this mode, QEMU can launch Linux processes
71   compiled for one CPU on another CPU. Linux system calls are converted
72   because of endianness and 32/64 bit mismatches. Wine (Windows
73   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
74
75 - Full system emulation. In this mode, QEMU emulates a full system,
76   including a processor and various peripherials. It can also be used to
77   provide virtual hosting of several virtual PC on a single server.
78
79 %description -l pl.UTF-8
80 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
81 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
82 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
83
84 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
85   procesy linuksowe skompilowane dla jednego procesora na innym
86   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
87   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
88   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
89   cele QEMU.
90
91 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
92   włączając w to procesor i różne urządzenia peryferyjne. Może być także
93   używane do wirtualnego hostowania kilku wirtualnych pecetów na
94   pojedynczym serwerze.
95
96 %package common
97 Summary:        QEMU common files needed by all QEMU targets
98 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
99 Group:          Development/Tools
100 Requires:       SDL >= 1.2.1
101 Conflicts:      qemu < 1.0-2
102
103 %description common
104 QEMU is a generic and open source processor emulator which achieves a
105 good emulation speed by using dynamic translation.
106
107 This package provides the common files needed by all QEMU targets.
108
109 %description common -l pl.UTF-8
110 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
111 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
112
113 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
114 środowiska QEMU.
115
116 %package img
117 Summary:        QEMU command line tool for manipulating disk images
118 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
119 Group:          Development/Tools
120 Conflicts:      qemu < 1.0-2
121
122 %description img
123 This package provides a command line tool for manipulating disk
124 images.
125
126 %description img -l pl.UTF-8
127 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
128 na obrazach dysków.
129
130 %package user
131 Summary:        QEMU user mode emulation of qemu targets
132 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
133 Group:          Development/Tools
134 Requires:       %{name}-common = %{version}-%{release}
135
136 %description user
137 QEMU is a generic and open source processor emulator which achieves a
138 good emulation speed by using dynamic translation.
139
140 This package provides the user mode emulation of QEMU targets.
141
142 %description user -l pl.UTF-8
143 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
144 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
145
146 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
147
148 %package system-alpha
149 Summary:        QEMU system emulator for Alpha
150 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
151 Group:          Development/Tools
152 Requires:       %{name}-common = %{version}-%{release}
153
154 %description system-alpha
155 QEMU is a generic and open source processor emulator which achieves a
156 good emulation speed by using dynamic translation.
157
158 This package provides the system emulator with Alpha CPU.
159
160 %description system-alpha -l pl.UTF-8
161 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
162 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
163
164 Ten pakiet zawiera emulator systemu z procesorem Alpha.
165
166 %package system-arm
167 Summary:        QEMU system emulator for ARM
168 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
169 Group:          Development/Tools
170 Requires:       %{name}-common = %{version}-%{release}
171
172 %description system-arm
173 QEMU is a generic and open source processor emulator which achieves a
174 good emulation speed by using dynamic translation.
175
176 This package provides the system emulator for ARM.
177
178 %description system-arm -l pl.UTF-8
179 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
180 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
181
182 Ten pakiet zawiera emulator systemu z procesorem ARM.
183
184 %package system-cris
185 Summary:        QEMU system emulator for cris
186 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
187 Group:          Development/Tools
188 Requires:       %{name}-common = %{version}-%{release}
189
190 %description system-cris
191 QEMU is a generic and open source processor emulator which achieves a
192 good emulation speed by using dynamic translation.
193
194 This package provides the system emulator with CRIS CPU.
195
196 %description system-cris -l pl.UTF-8
197 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
198 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
199
200 Ten pakiet zawiera emulator systemu z procesorem CRIS.
201
202 %package system-lm32
203 Summary:        QEMU system emulator for LM32
204 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
205 Group:          Development/Tools
206 Requires:       %{name}-common = %{version}-%{release}
207
208 %description system-lm32
209 QEMU is a generic and open source processor emulator which achieves a
210 good emulation speed by using dynamic translation.
211
212 This package provides the system emulator with LM32 CPU.
213
214 %description system-lm32 -l pl.UTF-8
215 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
216 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
217
218 Ten pakiet zawiera emulator systemu z procesorem LM32.
219
220 %package system-m68k
221 Summary:        QEMU system emulator for m68k
222 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
223 Group:          Development/Tools
224 Requires:       %{name}-common = %{version}-%{release}
225
226 %description system-m68k
227 QEMU is a generic and open source processor emulator which achieves a
228 good emulation speed by using dynamic translation.
229
230 This package provides the system emulator with m68k CPU.
231
232 %description system-m68k -l pl.UTF-8
233 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
234 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
235
236 Ten pakiet zawiera emulator systemu z procesorem m68k.
237
238 %package system-microblaze
239 Summary:        QEMU system emulator for MicroBlaze
240 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
241 Group:          Development/Tools
242 Requires:       %{name}-common = %{version}-%{release}
243
244 %description system-microblaze
245 QEMU is a generic and open source processor emulator which achieves a
246 good emulation speed by using dynamic translation.
247
248 This package provides the system emulator with MicroBlaze CPU.
249
250 %description system-microblaze -l pl.UTF-8
251 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
252 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
253
254 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
255
256 %package system-mips
257 Summary:        QEMU system emulator for MIPS
258 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
259 Group:          Development/Tools
260 Requires:       %{name}-common = %{version}-%{release}
261
262 %description system-mips
263 QEMU is a generic and open source processor emulator which achieves a
264 good emulation speed by using dynamic translation.
265
266 This package provides the system emulator with MIPS CPU.
267
268 %description system-mips -l pl.UTF-8
269 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
270 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
271
272 Ten pakiet zawiera emulator systemu z procesorem MIPS.
273
274 %package system-or32
275 Summary:        QEMU system emulator for OpenRISC
276 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
277 Group:          Development/Tools
278 Requires:       %{name}-common = %{version}-%{release}
279
280 %description system-or32
281 QEMU is a generic and open source processor emulator which achieves a
282 good emulation speed by using dynamic translation.
283
284 This package provides the system emulator with OpenRISC CPU.
285
286 %description system-or32 -l pl.UTF-8
287 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
288 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
289
290 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
291
292 %package system-ppc
293 Summary:        QEMU system emulator for PowerPC
294 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
295 Group:          Development/Tools
296 Requires:       %{name}-common = %{version}-%{release}
297
298 %description system-ppc
299 QEMU is a generic and open source processor emulator which achieves a
300 good emulation speed by using dynamic translation.
301
302 This package provides the system emulator with PowerPC CPU.
303
304 %description system-ppc -l pl.UTF-8
305 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
306 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
307
308 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
309
310 %package system-s390x
311 Summary:        QEMU system emulator for S390
312 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
313 Group:          Development/Tools
314 Requires:       %{name}-common = %{version}-%{release}
315
316 %description system-s390x
317 QEMU is a generic and open source processor emulator which achieves a
318 good emulation speed by using dynamic translation.
319
320 This package provides the system emulator with S390 CPU.
321
322 %description system-s390x -l pl.UTF-8
323 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
324 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
325
326 Ten pakiet zawiera emulator systemu z procesorem S390.
327
328 %package system-sh4
329 Summary:        QEMU system emulator for SH4
330 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
331 Group:          Development/Tools
332 Requires:       %{name}-common = %{version}-%{release}
333
334 %description system-sh4
335 QEMU is a generic and open source processor emulator which achieves a
336 good emulation speed by using dynamic translation.
337
338 This package provides the system emulator with SH4 CPU.
339
340 %description system-sh4 -l pl.UTF-8
341 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
342 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
343
344 Ten pakiet zawiera emulator systemu z procesorem SH4.
345
346 %package system-sparc
347 Summary:        QEMU system emulator for SPARC
348 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
349 Group:          Development/Tools
350 Requires:       %{name}-common = %{version}-%{release}
351
352 %description system-sparc
353 QEMU is a generic and open source processor emulator which achieves a
354 good emulation speed by using dynamic translation.
355
356 This package provides the system emulator with SPARC/SPARC64 CPU.
357
358 %description system-sparc -l pl.UTF-8
359 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
360 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
361
362 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
363
364 %package system-unicore32
365 Summary:        QEMU system emulator for UniCore32
366 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
367 Group:          Development/Tools
368 Requires:       %{name}-common = %{version}-%{release}
369
370 %description system-unicore32
371 QEMU is a generic and open source processor emulator which achieves a
372 good emulation speed by using dynamic translation.
373
374 This package provides the system emulator with UniCore32 CPU.
375
376 %description system-unicore32 -l pl.UTF-8
377 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
378 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
379
380 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
381
382 %package system-x86
383 Summary:        QEMU system emulator for x86
384 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
385 Group:          Development/Tools
386 Requires:       %{name}-common = %{version}-%{release}
387
388 %description system-x86
389 QEMU is a generic and open source processor emulator which achieves a
390 good emulation speed by using dynamic translation.
391
392 This package provides the system emulator with x86 CPU. When being run
393 in a x86 machine that supports it, this package also provides the KVM
394 virtualization platform.
395
396 %description system-x86 -l pl.UTF-8
397 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
398 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
399
400 Ten pakiet zawiera emulator systemu z procesorem x86. W przypadku
401 uruchomienia na maszynie x86 pozwalającej na to, ten pakiet udostępnia
402 także platformę wirtualizacji KVM.
403
404 %package system-xtensa
405 Summary:        QEMU system emulator for Xtensa
406 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
407 Group:          Development/Tools
408 Requires:       %{name}-common = %{version}-%{release}
409
410 %description system-xtensa
411 QEMU is a generic and open source processor emulator which achieves a
412 good emulation speed by using dynamic translation.
413
414 This package provides the system emulator with Xtensa CPU.
415
416 %description system-xtensa -l pl.UTF-8
417 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
418 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
419
420 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
421
422 %prep
423 %setup -q
424 %patch0 -p1
425 %patch1 -p1
426 #patch8 -p1
427 %patch17 -p0
428
429 # workaround for conflict with alsa/error.h
430 ln -s ../error.h qapi/error.h
431
432 %build
433 ./configure \
434         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
435         --extra-ldflags="%{rpmldflags}" \
436         --sysconfdir=%{_sysconfdir} \
437         --prefix=%{_prefix} \
438         --cc="%{__cc}" \
439         --host-cc="%{__cc}" \
440         --disable-strip \
441         --enable-mixemu \
442         --audio-drv-list="alsa" \
443         --interp-prefix=%{_libdir}/%{name}
444 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
445 # --libexecdir in configure is nop
446 %{__make} \
447         V=1 \
448         CONFIG_QEMU_HELPERDIR="%{_libdir}"
449
450 # rebuild patched vesa tables with additional widescreen modes.
451 %{__make} -C roms/vgabios stdvga-bios
452
453 %install
454 rm -rf $RPM_BUILD_ROOT
455
456 %{__make} install \
457         DESTDIR=$RPM_BUILD_ROOT \
458         libexecdir=%{_libdir}
459
460 install -d $RPM_BUILD_ROOT%{_sysconfdir}
461 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
462 #!/bin/sh
463
464 EOF
465
466 # already packaged
467 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
468 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
469
470 # install patched vesa tables with additional widescreen modes.
471 install -m 644 roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
472
473 %clean
474 rm -rf $RPM_BUILD_ROOT
475
476 %files
477 %defattr(644,root,root,755)
478
479 %files common
480 %defattr(644,root,root,755)
481 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
482 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
483 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
484 %dir %{_sysconfdir}/qemu
485 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
486 %attr(755,root,root) %{_bindir}/vscclient
487 %attr(755,root,root) %{_bindir}/qemu-nbd
488 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
489 %{_mandir}/man1/qemu.1*
490 %{_mandir}/man1/virtfs-proxy-helper.1*
491 %{_mandir}/man8/qemu-nbd.8*
492
493 %dir %{_datadir}/qemu
494 %{_datadir}/%{name}/cpus-*.conf
495 %{_datadir}/%{name}/keymaps
496 %{_datadir}/%{name}/qemu-icon.bmp
497 # various bios images
498 %{_datadir}/%{name}/*.bin
499 %{_datadir}/%{name}/*.rom
500 %{_datadir}/%{name}/*.dtb
501 %{_datadir}/%{name}/openbios-ppc
502 %{_datadir}/%{name}/openbios-sparc*
503 %{_datadir}/%{name}/palcode-clipper
504
505 %files img
506 %defattr(644,root,root,755)
507 %attr(755,root,root) %{_bindir}/qemu-img
508 %{_mandir}/man1/qemu-img.1*
509
510 %files user
511 %defattr(644,root,root,755)
512 %attr(755,root,root) %{_bindir}/qemu-x86_64
513 %attr(755,root,root) %{_bindir}/qemu-i386
514 %attr(755,root,root) %{_bindir}/qemu-alpha
515 %attr(755,root,root) %{_bindir}/qemu-arm
516 %attr(755,root,root) %{_bindir}/qemu-armeb
517 %attr(755,root,root) %{_bindir}/qemu-cris
518 %attr(755,root,root) %{_bindir}/qemu-ga
519 %attr(755,root,root) %{_bindir}/qemu-io
520 %attr(755,root,root) %{_bindir}/qemu-m68k
521 %attr(755,root,root) %{_bindir}/qemu-microblaze
522 %attr(755,root,root) %{_bindir}/qemu-microblazeel
523 %attr(755,root,root) %{_bindir}/qemu-mips
524 %attr(755,root,root) %{_bindir}/qemu-mipsel
525 %attr(755,root,root) %{_bindir}/qemu-or32
526 %attr(755,root,root) %{_bindir}/qemu-ppc
527 %attr(755,root,root) %{_bindir}/qemu-ppc64
528 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
529 %attr(755,root,root) %{_bindir}/qemu-s390x
530 %attr(755,root,root) %{_bindir}/qemu-sh4
531 %attr(755,root,root) %{_bindir}/qemu-sh4eb
532 %attr(755,root,root) %{_bindir}/qemu-sparc
533 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
534 %attr(755,root,root) %{_bindir}/qemu-sparc64
535 %attr(755,root,root) %{_bindir}/qemu-unicore32
536
537 %files system-alpha
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{_bindir}/qemu-system-alpha
540
541 %files system-arm
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{_bindir}/qemu-system-arm
544
545 %files system-cris
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_bindir}/qemu-system-cris
548
549 %files system-lm32
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{_bindir}/qemu-system-lm32
552
553 %files system-m68k
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_bindir}/qemu-system-m68k
556
557 %files system-microblaze
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
560 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
561
562 %files system-mips
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_bindir}/qemu-system-mips
565 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
566 %attr(755,root,root) %{_bindir}/qemu-system-mips64
567 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
568
569 %files system-or32
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{_bindir}/qemu-system-or32
572
573 %files system-ppc
574 %defattr(644,root,root,755)
575 %attr(755,root,root) %{_bindir}/qemu-system-ppc
576 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
577 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
578
579 %files system-s390x
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_bindir}/qemu-system-s390x
582
583 %files system-sh4
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_bindir}/qemu-system-sh4
586 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
587
588 %files system-sparc
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{_bindir}/qemu-system-sparc
591 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
592
593 %files system-unicore32
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
596
597 %files system-x86
598 %defattr(644,root,root,755)
599 %attr(755,root,root) %{_bindir}/qemu-system-i386
600 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
601
602 %files system-xtensa
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
605 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.079643 seconds and 2 git commands to generate.