]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- options set closer to qemu-kvm.spec
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - qemu-system-ppc -hda ac-ppc.img says:
3 #   qemu: could not open disk image ac-ppc.img: error "Success"
4 #   qemu-0.12.2-2.x86_64.rpm - broken
5 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
6 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
7 #   qemu-0.11.1-*.x86_64.rpm - OK
8 #
9 # Conditional build:
10 %bcond_without  sdl             # SDL UI and audio support
11 %bcond_without  opengl          # OpenGL support
12 %bcond_without  ceph            # Ceph/RBD support
13 %bcond_without  spice           # SPICE support
14 %bcond_with     esd             # EsounD audio support
15 %bcond_without  oss             # OSS audio support
16 %bcond_without  pulseaudio      # PulseAudio audio support
17 %bcond_without  xen             # Xen backend driver support
18 #
19 Summary:        QEMU CPU Emulator
20 Summary(pl.UTF-8):      QEMU - emulator procesora
21 Name:           qemu
22 Version:        1.2.0
23 Release:        5
24 License:        GPL v2+
25 Group:          Applications/Emulators
26 Source0:        http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
27 # Source0-md5:  78eb1e984f4532aa9f2bdd3c127b5b61
28 Patch0:         %{name}-cflags.patch
29 Patch1:         vgabios-widescreens.patch
30 Patch2:         %{name}-usbredir.patch
31 Patch3:         %{name}-whitelist.patch
32 # Proof of concept, for reference, do not remove
33 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
34 URL:            http://wiki.qemu.org/Index.html
35 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
36 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
37 BuildRequires:  alsa-lib-devel
38 BuildRequires:  bluez-libs-devel
39 BuildRequires:  brlapi-devel
40 %{?with_ceph:BuildRequires:     ceph-devel}
41 BuildRequires:  curl-devel
42 BuildRequires:  cyrus-sasl-devel >= 2
43 %{?with_esd:BuildRequires:      esound-devel}
44 BuildRequires:  glib2-devel >= 1:2.12
45 BuildRequires:  gnutls-devel
46 BuildRequires:  libaio-devel
47 BuildRequires:  libcap-devel
48 BuildRequires:  libcap-ng-devel
49 BuildRequires:  libfdt-devel
50 BuildRequires:  libiscsi-devel
51 BuildRequires:  libjpeg-devel
52 BuildRequires:  libpng-devel
53 BuildRequires:  libseccomp-devel
54 BuildRequires:  libuuid-devel
55 BuildRequires:  ncurses-devel
56 BuildRequires:  nss-devel >= 3.12.8
57 BuildRequires:  perl-Encode
58 BuildRequires:  perl-tools-pod
59 BuildRequires:  pkgconfig
60 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
61 BuildRequires:  sed >= 4.0
62 %if %{with spice}
63 BuildRequires:  spice-protocol >= 0.8.0
64 BuildRequires:  spice-server-devel >= 0.8.2
65 %endif
66 BuildRequires:  texi2html
67 BuildRequires:  texinfo
68 BuildRequires:  usbredir-devel >= 0.3.4
69 BuildRequires:  vde2-devel
70 BuildRequires:  which
71 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
72 BuildRequires:  xfsprogs-devel
73 BuildRequires:  xorg-lib-libX11-devel
74 BuildRequires:  zlib-devel
75 Requires:       %{name}-img = %{version}-%{release}
76 Requires:       %{name}-system-alpha = %{version}-%{release}
77 Requires:       %{name}-system-arm = %{version}-%{release}
78 Requires:       %{name}-system-cris = %{version}-%{release}
79 Requires:       %{name}-system-lm32 = %{version}-%{release}
80 Requires:       %{name}-system-m68k = %{version}-%{release}
81 Requires:       %{name}-system-microblaze = %{version}-%{release}
82 Requires:       %{name}-system-mips = %{version}-%{release}
83 Requires:       %{name}-system-ppc = %{version}-%{release}
84 Requires:       %{name}-system-or32 = %{version}-%{release}
85 Requires:       %{name}-system-s390x = %{version}-%{release}
86 Requires:       %{name}-system-sh4 = %{version}-%{release}
87 Requires:       %{name}-system-sparc = %{version}-%{release}
88 Requires:       %{name}-system-unicore32 = %{version}-%{release}
89 Requires:       %{name}-system-x86 = %{version}-%{release}
90 Requires:       %{name}-system-xtensa = %{version}-%{release}
91 Requires:       %{name}-user = %{version}-%{release}
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define systempkg_req \
95 Requires:       SDL >= 1.2.1
96
97 # some PPC/SPARC boot image in ELF format
98 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
99
100 %description
101 QEMU is a FAST! processor emulator. By using dynamic translation it
102 achieves a reasonnable speed while being easy to port on new host
103 CPUs. QEMU has two operating modes:
104
105 - User mode emulation. In this mode, QEMU can launch Linux processes
106   compiled for one CPU on another CPU. Linux system calls are converted
107   because of endianness and 32/64 bit mismatches. Wine (Windows
108   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
109
110 - Full system emulation. In this mode, QEMU emulates a full system,
111   including a processor and various peripherials. It can also be used to
112   provide virtual hosting of several virtual PC on a single server.
113
114 %description -l pl.UTF-8
115 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
116 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
117 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
118
119 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
120   procesy linuksowe skompilowane dla jednego procesora na innym
121   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
122   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
123   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
124   cele QEMU.
125
126 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
127   włączając w to procesor i różne urządzenia peryferyjne. Może być także
128   używane do wirtualnego hostowania kilku wirtualnych pecetów na
129   pojedynczym serwerze.
130
131 %package common
132 Summary:        QEMU common files needed by all QEMU targets
133 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
134 Group:          Development/Tools
135 Requires:       glib2 >= 1:2.12
136 Conflicts:      qemu < 1.0-2
137
138 %description common
139 QEMU is a generic and open source processor emulator which achieves a
140 good emulation speed by using dynamic translation.
141
142 This package provides the common files needed by all QEMU targets.
143
144 %description common -l pl.UTF-8
145 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
146 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
147
148 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
149 środowiska QEMU.
150
151 %package img
152 Summary:        QEMU command line tool for manipulating disk images
153 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
154 Group:          Development/Tools
155 Conflicts:      qemu < 1.0-2
156
157 %description img
158 This package provides a command line tool for manipulating disk
159 images.
160
161 %description img -l pl.UTF-8
162 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
163 na obrazach dysków.
164
165 %package user
166 Summary:        QEMU user mode emulation of qemu targets
167 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
168 Group:          Development/Tools
169 Requires:       %{name}-common = %{version}-%{release}
170
171 %description user
172 QEMU is a generic and open source processor emulator which achieves a
173 good emulation speed by using dynamic translation.
174
175 This package provides the user mode emulation of QEMU targets.
176
177 %description user -l pl.UTF-8
178 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
179 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
180
181 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
182
183 %package system-alpha
184 Summary:        QEMU system emulator for Alpha
185 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
186 Group:          Development/Tools
187 Requires:       %{name}-common = %{version}-%{release}
188 %systempkg_req
189
190 %description system-alpha
191 QEMU is a generic and open source processor emulator which achieves a
192 good emulation speed by using dynamic translation.
193
194 This package provides the system emulator with Alpha CPU.
195
196 %description system-alpha -l pl.UTF-8
197 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
198 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
199
200 Ten pakiet zawiera emulator systemu z procesorem Alpha.
201
202 %package system-arm
203 Summary:        QEMU system emulator for ARM
204 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
205 Group:          Development/Tools
206 Requires:       %{name}-common = %{version}-%{release}
207 %systempkg_req
208
209 %description system-arm
210 QEMU is a generic and open source processor emulator which achieves a
211 good emulation speed by using dynamic translation.
212
213 This package provides the system emulator for ARM.
214
215 %description system-arm -l pl.UTF-8
216 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
217 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
218
219 Ten pakiet zawiera emulator systemu z procesorem ARM.
220
221 %package system-cris
222 Summary:        QEMU system emulator for CRIS
223 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
224 Group:          Development/Tools
225 Requires:       %{name}-common = %{version}-%{release}
226 %systempkg_req
227
228 %description system-cris
229 QEMU is a generic and open source processor emulator which achieves a
230 good emulation speed by using dynamic translation.
231
232 This package provides the system emulator with CRIS CPU.
233
234 %description system-cris -l pl.UTF-8
235 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
236 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
237
238 Ten pakiet zawiera emulator systemu z procesorem CRIS.
239
240 %package system-lm32
241 Summary:        QEMU system emulator for LM32
242 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
243 Group:          Development/Tools
244 Requires:       %{name}-common = %{version}-%{release}
245 %systempkg_req
246
247 %description system-lm32
248 QEMU is a generic and open source processor emulator which achieves a
249 good emulation speed by using dynamic translation.
250
251 This package provides the system emulator with LM32 CPU.
252
253 %description system-lm32 -l pl.UTF-8
254 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
255 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
256
257 Ten pakiet zawiera emulator systemu z procesorem LM32.
258
259 %package system-m68k
260 Summary:        QEMU system emulator for m68k
261 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
262 Group:          Development/Tools
263 Requires:       %{name}-common = %{version}-%{release}
264 %systempkg_req
265
266 %description system-m68k
267 QEMU is a generic and open source processor emulator which achieves a
268 good emulation speed by using dynamic translation.
269
270 This package provides the system emulator with m68k CPU.
271
272 %description system-m68k -l pl.UTF-8
273 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
274 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
275
276 Ten pakiet zawiera emulator systemu z procesorem m68k.
277
278 %package system-microblaze
279 Summary:        QEMU system emulator for MicroBlaze
280 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
281 Group:          Development/Tools
282 Requires:       %{name}-common = %{version}-%{release}
283 %systempkg_req
284
285 %description system-microblaze
286 QEMU is a generic and open source processor emulator which achieves a
287 good emulation speed by using dynamic translation.
288
289 This package provides the system emulator with MicroBlaze CPU.
290
291 %description system-microblaze -l pl.UTF-8
292 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
293 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
294
295 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
296
297 %package system-mips
298 Summary:        QEMU system emulator for MIPS
299 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
300 Group:          Development/Tools
301 Requires:       %{name}-common = %{version}-%{release}
302 %systempkg_req
303
304 %description system-mips
305 QEMU is a generic and open source processor emulator which achieves a
306 good emulation speed by using dynamic translation.
307
308 This package provides the system emulator with MIPS CPU.
309
310 %description system-mips -l pl.UTF-8
311 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
312 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
313
314 Ten pakiet zawiera emulator systemu z procesorem MIPS.
315
316 %package system-or32
317 Summary:        QEMU system emulator for OpenRISC
318 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
319 Group:          Development/Tools
320 Requires:       %{name}-common = %{version}-%{release}
321 %systempkg_req
322
323 %description system-or32
324 QEMU is a generic and open source processor emulator which achieves a
325 good emulation speed by using dynamic translation.
326
327 This package provides the system emulator with OpenRISC CPU.
328
329 %description system-or32 -l pl.UTF-8
330 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
331 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
332
333 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
334
335 %package system-ppc
336 Summary:        QEMU system emulator for PowerPC
337 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
338 Group:          Development/Tools
339 Requires:       %{name}-common = %{version}-%{release}
340 %systempkg_req
341
342 %description system-ppc
343 QEMU is a generic and open source processor emulator which achieves a
344 good emulation speed by using dynamic translation.
345
346 This package provides the system emulator with PowerPC CPU.
347
348 %description system-ppc -l pl.UTF-8
349 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
350 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
351
352 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
353
354 %package system-s390x
355 Summary:        QEMU system emulator for S390
356 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
357 Group:          Development/Tools
358 Requires:       %{name}-common = %{version}-%{release}
359 %systempkg_req
360
361 %description system-s390x
362 QEMU is a generic and open source processor emulator which achieves a
363 good emulation speed by using dynamic translation.
364
365 This package provides the system emulator with S390 CPU.
366
367 %description system-s390x -l pl.UTF-8
368 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
369 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
370
371 Ten pakiet zawiera emulator systemu z procesorem S390.
372
373 %package system-sh4
374 Summary:        QEMU system emulator for SH4
375 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
376 Group:          Development/Tools
377 Requires:       %{name}-common = %{version}-%{release}
378 %systempkg_req
379
380 %description system-sh4
381 QEMU is a generic and open source processor emulator which achieves a
382 good emulation speed by using dynamic translation.
383
384 This package provides the system emulator with SH4 CPU.
385
386 %description system-sh4 -l pl.UTF-8
387 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
388 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
389
390 Ten pakiet zawiera emulator systemu z procesorem SH4.
391
392 %package system-sparc
393 Summary:        QEMU system emulator for SPARC
394 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
395 Group:          Development/Tools
396 Requires:       %{name}-common = %{version}-%{release}
397 %systempkg_req
398
399 %description system-sparc
400 QEMU is a generic and open source processor emulator which achieves a
401 good emulation speed by using dynamic translation.
402
403 This package provides the system emulator with SPARC/SPARC64 CPU.
404
405 %description system-sparc -l pl.UTF-8
406 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
407 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
408
409 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
410
411 %package system-unicore32
412 Summary:        QEMU system emulator for UniCore32
413 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
414 Group:          Development/Tools
415 Requires:       %{name}-common = %{version}-%{release}
416 %systempkg_req
417
418 %description system-unicore32
419 QEMU is a generic and open source processor emulator which achieves a
420 good emulation speed by using dynamic translation.
421
422 This package provides the system emulator with UniCore32 CPU.
423
424 %description system-unicore32 -l pl.UTF-8
425 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
426 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
427
428 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
429
430 %package system-x86
431 Summary:        QEMU system emulator for x86
432 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
433 Group:          Development/Tools
434 Requires:       %{name}-common = %{version}-%{release}
435 %systempkg_req
436
437 %description system-x86
438 QEMU is a generic and open source processor emulator which achieves a
439 good emulation speed by using dynamic translation.
440
441 %description system-x86 -l pl.UTF-8
442 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
443 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
444
445 %package system-xtensa
446 Summary:        QEMU system emulator for Xtensa
447 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
448 Group:          Development/Tools
449 Requires:       %{name}-common = %{version}-%{release}
450 %systempkg_req
451
452 %description system-xtensa
453 QEMU is a generic and open source processor emulator which achieves a
454 good emulation speed by using dynamic translation.
455
456 This package provides the system emulator with Xtensa CPU.
457
458 %description system-xtensa -l pl.UTF-8
459 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
460 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
461
462 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
463
464 %prep
465 %setup -q
466 %patch0 -p1
467 %patch1 -p1
468 %patch2 -p1
469 %patch3 -p0
470 #patch4 -p1
471
472 # workaround for conflict with alsa/error.h
473 ln -s ../error.h qapi/error.h
474
475 %build
476 ./configure \
477         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
478         --extra-ldflags="%{rpmldflags}" \
479         --prefix=%{_prefix} \
480         --sysconfdir=%{_sysconfdir} \
481         --cc="%{__cc}" \
482         --host-cc="%{__cc}" \
483         --disable-strip \
484         --enable-attr \
485         --enable-bluez \
486         --enable-brlapi \
487         --enable-cap-ng \
488         --enable-curl \
489         --enable-curses \
490         --enable-docs \
491         --enable-fdt \
492         --enable-libiscsi \
493         --enable-mixemu \
494         %{__enable_disable opengl} \
495         %{__enable_disable ceph rbd} \
496         %{__enable_disable sdl} \
497         --enable-seccomp \
498         %{__enable_disable spice} \
499         --enable-smartcard \
500         --enable-smartcard-nss \
501         --enable-usb-redir \
502         --enable-uuid \
503         --enable-vde \
504         --enable-virtfs \
505         --enable-vnc-jpeg \
506         --enable-vnc-png \
507         --enable-vnc-sasl \
508         --enable-vnc-tls \
509         %{__enable_disable xen} \
510         --audio-card-list="ac97,es1370,sb16,cs4231a,adlib,gus,hda" \
511         --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
512         --interp-prefix=%{_libdir}/qemu/lib-%%M
513 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
514 # --libexecdir in configure is nop
515 %{__make} \
516         V=1 \
517         CONFIG_QEMU_HELPERDIR="%{_libdir}"
518
519 # rebuild patched vesa tables with additional widescreen modes.
520 %{__make} -C roms/vgabios stdvga-bios
521
522 %install
523 rm -rf $RPM_BUILD_ROOT
524
525 %{__make} install \
526         DESTDIR=$RPM_BUILD_ROOT \
527         libexecdir=%{_libdir}
528
529 install -d $RPM_BUILD_ROOT%{_sysconfdir}
530 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
531 #!/bin/sh
532
533 EOF
534
535 # already packaged
536 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
537 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
538
539 # install patched vesa tables with additional widescreen modes.
540 install -m 644 roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
541
542 %clean
543 rm -rf $RPM_BUILD_ROOT
544
545 %files
546 %defattr(644,root,root,755)
547
548 %files common
549 %defattr(644,root,root,755)
550 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
551 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
552 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
553 %dir %{_sysconfdir}/qemu
554 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
555 %attr(755,root,root) %{_bindir}/vscclient
556 %attr(755,root,root) %{_bindir}/qemu-nbd
557 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
558 %{_mandir}/man1/qemu.1*
559 %{_mandir}/man1/virtfs-proxy-helper.1*
560 %{_mandir}/man8/qemu-nbd.8*
561
562 %dir %{_datadir}/qemu
563 %{_datadir}/%{name}/cpus-*.conf
564 %{_datadir}/%{name}/keymaps
565 %{_datadir}/%{name}/qemu-icon.bmp
566 # various bios images
567 %{_datadir}/%{name}/*.bin
568 %{_datadir}/%{name}/*.rom
569 %{_datadir}/%{name}/*.dtb
570 %{_datadir}/%{name}/openbios-ppc
571 %{_datadir}/%{name}/openbios-sparc*
572 %{_datadir}/%{name}/palcode-clipper
573
574 %files img
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_bindir}/qemu-img
577 %{_mandir}/man1/qemu-img.1*
578
579 %files user
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_bindir}/qemu-alpha
582 %attr(755,root,root) %{_bindir}/qemu-arm
583 %attr(755,root,root) %{_bindir}/qemu-armeb
584 %attr(755,root,root) %{_bindir}/qemu-cris
585 %attr(755,root,root) %{_bindir}/qemu-ga
586 %attr(755,root,root) %{_bindir}/qemu-i386
587 %attr(755,root,root) %{_bindir}/qemu-io
588 %attr(755,root,root) %{_bindir}/qemu-m68k
589 %attr(755,root,root) %{_bindir}/qemu-microblaze
590 %attr(755,root,root) %{_bindir}/qemu-microblazeel
591 %attr(755,root,root) %{_bindir}/qemu-mips
592 %attr(755,root,root) %{_bindir}/qemu-mipsel
593 %attr(755,root,root) %{_bindir}/qemu-or32
594 %attr(755,root,root) %{_bindir}/qemu-ppc
595 %attr(755,root,root) %{_bindir}/qemu-ppc64
596 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
597 %attr(755,root,root) %{_bindir}/qemu-s390x
598 %attr(755,root,root) %{_bindir}/qemu-sh4
599 %attr(755,root,root) %{_bindir}/qemu-sh4eb
600 %attr(755,root,root) %{_bindir}/qemu-sparc
601 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
602 %attr(755,root,root) %{_bindir}/qemu-sparc64
603 %attr(755,root,root) %{_bindir}/qemu-unicore32
604 %attr(755,root,root) %{_bindir}/qemu-x86_64
605
606 %files system-alpha
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_bindir}/qemu-system-alpha
609
610 %files system-arm
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_bindir}/qemu-system-arm
613
614 %files system-cris
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_bindir}/qemu-system-cris
617
618 %files system-lm32
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_bindir}/qemu-system-lm32
621
622 %files system-m68k
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{_bindir}/qemu-system-m68k
625
626 %files system-microblaze
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
629 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
630
631 %files system-mips
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_bindir}/qemu-system-mips
634 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
635 %attr(755,root,root) %{_bindir}/qemu-system-mips64
636 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
637
638 %files system-or32
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_bindir}/qemu-system-or32
641
642 %files system-ppc
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_bindir}/qemu-system-ppc
645 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
646 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
647
648 %files system-s390x
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_bindir}/qemu-system-s390x
651
652 %files system-sh4
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_bindir}/qemu-system-sh4
655 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
656
657 %files system-sparc
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_bindir}/qemu-system-sparc
660 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
661
662 %files system-unicore32
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
665
666 %files system-x86
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_bindir}/qemu-system-i386
669 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
670
671 %files system-xtensa
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
674 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.065696 seconds and 3 git commands to generate.