]> git.pld-linux.org Git - packages/qemu.git/blame_incremental - qemu.spec
- added TODO
[packages/qemu.git] / qemu.spec
... / ...
CommitLineData
1#
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
5# Conditional build:
6%bcond_with kqemu # with QEMU accelerator module
7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
8#
9Summary: QEMU CPU Emulator
10Summary(pl): QEMU - emulator procesora
11Name: qemu
12Version: 0.7.0
13Release: 1.2
14License: GPL
15Group: Applications/Emulators
16#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
17Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
18# Source0-md5: 234e9ace03b00259bb57dc5a9c633056
19%if %{with kqemu}
20Source1: http://fabrice.bellard.free.fr/qemu/kqemu-0.6.2-1.tar.gz
21# NoSource1-md5: c6bb3b40fb3d526d731eb0f1f9dee7ee
22NoSource: 1
23%endif
24Patch0: %{name}-nostatic.patch
25Patch1: %{name}-DESTDIR.patch
26Patch2: %{name}-longjmp.patch
27Patch3: %{name}-dot.patch
28Patch4: %{name}-initrd_load_addr.patch
29Patch5: %{name}-gcc4_x86.patch
30Patch6: %{name}-gcc4_ppc.patch
31URL: http://fabrice.bellard.free.fr/qemu/
32BuildRequires: SDL-devel >= 1.2.1
33BuildRequires: sed >= 4.0
34%if %{with kqemu}
35BuildRequires: kernel-source
36%endif
37ExclusiveArch: %{ix86} %{x8664} ppc
38# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41# some SPARC boot image in ELF format
42%define _noautostrip .*%{_datadir}/qemu/proll.elf
43
44%description
45QEMU is a FAST! processor emulator. By using dynamic translation it
46achieves a reasonnable speed while being easy to port on new host
47CPUs. QEMU has two operating modes:
48
49- User mode emulation. In this mode, QEMU can launch Linux processes
50 compiled for one CPU on another CPU. Linux system calls are converted
51 because of endianness and 32/64 bit mismatches. Wine (Windows
52 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
53
54- Full system emulation. In this mode, QEMU emulates a full system,
55 including a processor and various peripherials.
56 It can also be used to provide virtual hosting of several
57 virtual PC on a single server.
58
59%description -l pl
60