]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
up to 0.15.1
[packages/qemu.git] / qemu.spec
CommitLineData
0b920c52 1# TODO:
98a1a188 2# - update patches
01b9430c
ER
3# - qemu-system-ppc -hda ac-ppc.img says:
4# qemu: could not open disk image ac-ppc.img: Success
5# qemu-0.12.2-2.x86_64.rpm - broken
cef095a4 6# qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
01b9430c 7# qemu-0.11.1-7k.x86_64.rpm - OK
0b920c52 8#
6aef4654 9# Conditional build:
161ffd93 10%bcond_with cflags_passing # with passing rpmcflags to Makefiles
b4d7fbfb 11%bcond_with dosguest # add special patch when use with DOS as guest os
a6d3659e 12%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
007877cb 13
cd19124e 14Summary: QEMU CPU Emulator
eec0535a 15Summary(pl.UTF-8): QEMU - emulator procesora
7b81d160 16Name: qemu
aea92c1b
GP
17Version: 0.15.1
18Release: 1
5a2da1d0
JB
19License: GPL
20Group: Applications/Emulators
c4b12b8b 21# Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
06dce779
GP
22#Source0: http://download.savannah.gnu.org/releases/qemu/%{name}-%{version}.tar.gz
23Source0: http://wiki.qemu.org/download/%{name}-%{version}.tar.gz
aea92c1b 24# Source0-md5: 34f17737baaf1b3495c89cd6d4a607ed
7b81d160 25Patch0: %{name}-ncurses.patch
26Patch6: %{name}-nosdlgui.patch
81a493f2 27# Proof of concept, for reference, do not remove
7b81d160 28Patch8: %{name}-kde_virtual_workspaces_hack.patch
ba4329df 29#Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
7b81d160 30Patch13: %{name}-dosguest.patch
31Patch14: %{name}-ppc_old_binutils.patch
32Patch15: %{name}-isa-bios-ram.patch
c9c22e78
ER
33# below one fixes problems with passing ram size to bios/bootloader
34# which affects coreboot/linuxbios
7b81d160 35Patch16: %{name}-piix-ram-size.patch
ba4329df 36Patch17: %{name}-whitelist.patch
d6bd22e9 37URL: http://wiki.qemu.org/Index.html
867764ba 38BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 39BuildRequires: alsa-lib-devel
b99b1652
AM
40BuildRequires: bluez-libs-devel
41BuildRequires: gnutls-devel
98a1a188 42BuildRequires: ncurses-devel
995bac8b 43BuildRequires: perl-Encode
2fb8ea02 44BuildRequires: perl-tools-pod
ba84a935 45BuildRequires: pkgconfig
8bb1261c 46BuildRequires: sed >= 4.0
a1146336 47BuildRequires: texi2html
cad677a4 48BuildRequires: which
ba84a935 49BuildRequires: xorg-lib-libX11-devel
8bb1261c 50Requires: SDL >= 1.2.1
2ef13cb9 51# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
007877cb 52ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
cd19124e 53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
98a1a188
AM
55# some PPC/SPARC boot image in ELF format
56%define _noautostrip .*%{_datadir}/qemu/openbios-.*
a154aede 57
cd19124e 58%description
59QEMU is a FAST! processor emulator. By using dynamic translation it
60achieves a reasonnable speed while being easy to port on new host
61CPUs. QEMU has two operating modes:
62
63- User mode emulation. In this mode, QEMU can launch Linux processes
64 compiled for one CPU on another CPU. Linux system calls are converted
65 because of endianness and 32/64 bit mismatches. Wine (Windows
66 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
67
68- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
69 including a processor and various peripherials. It can also be used to
70 provide virtual hosting of several virtual PC on a single server.
cd19124e 71
27b30e9c
JR
72%description -l pl.UTF-8
73QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
74tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
75aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
5a2da1d0 76
27b30e9c 77- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
5a2da1d0 78 procesy linuksowe skompilowane dla jednego procesora na innym
27b30e9c
JR
79 procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
80 niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
81 słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
5a2da1d0
JB
82 cele QEMU.
83
27b30e9c
JR
84- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
85 włączając w to procesor i różne urządzenia peryferyjne. Może być także
86 używane do wirtualnego hostowania kilku wirtualnych pecetów na
8799423b 87 pojedynczym serwerze.
5a2da1d0 88
cd19124e 89%prep
c21a255a 90%setup -q
a9a35ffb 91%patch0 -p1
8d073aaa 92%{?with_nosdlgui:%patch6 -p1}
7b81d160 93#patch8 -p1
137653c3 94%patch17 -p0
0b920c52
95
96%{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
8bb1261c 97%{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
cd19124e 98
c3048014 99# cannot use optflags on x86 - they cause "no register to spill" errors
0b920c52 100%if %{with cflags_passing}
f0ac4619 101%{__sed} -i -e 's/-g $CFLAGS/-Wall %{rpmcflags}/' configure
57d8430f 102%else
f0ac4619 103%{__sed} -i 's/-g $CFLAGS/-Wall -fno-var-tracking-assignments/' configure
0b920c52 104%endif
c3048014 105
80bac37e 106%build
c3048014 107# --extra-cflags don't work (overridden by CFLAGS in Makefile*)
0b920c52 108# they can be passed if the cflags_passing bcond is used
8bd2aee2 109./configure \
110 --prefix=%{_prefix} \
98a1a188
AM
111 --cc="%{__cc}" \
112 --host-cc="%{__cc}" \
b99b1652 113 --enable-mixemu \
98a1a188 114 --audio-drv-list="alsa" \
7b81d160 115 --interp-prefix=%{_libdir}/%{name}
8bb1261c 116%{__make}
cd19124e 117
118%install
119rm -rf $RPM_BUILD_ROOT
5a2da1d0 120
cd19124e 121%{__make} install \
122 DESTDIR=$RPM_BUILD_ROOT
ac6e5743 123
a91fea76 124install -d $RPM_BUILD_ROOT%{_sysconfdir}
125cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
ac6e5743 126#!/bin/sh
a91fea76 127
ac6e5743 128EOF
a62a2d89 129
c33439fc
ER
130# already packaged
131rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
132
cd19124e 133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%files
137%defattr(644,root,root,755)
867764ba 138%doc README qemu-doc.html qemu-tech.html
a91fea76 139%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
003e2129 140%attr(755,root,root) %{_bindir}/*
141%{_datadir}/qemu
cd19124e 142%{_mandir}/man1/qemu.1*
867764ba 143%{_mandir}/man1/qemu-img.1*
98a1a188 144%{_mandir}/man8/qemu-nbd.8*
This page took 0.058405 seconds and 4 git commands to generate.