]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- KVM here looks like a copy-pasto
[packages/qemu.git] / qemu.spec
CommitLineData
0b920c52 1# TODO:
01b9430c 2# - qemu-system-ppc -hda ac-ppc.img says:
fabf5a9c 3# qemu: could not open disk image ac-ppc.img: error "Success"
01b9430c 4# qemu-0.12.2-2.x86_64.rpm - broken
cef095a4 5# qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
fabf5a9c
ER
6# qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
7# qemu-0.11.1-*.x86_64.rpm - OK
0b920c52 8#
6aef4654 9# Conditional build:
78a71650
JB
10%bcond_without sdl # SDL UI and audio support
11%bcond_without opengl # OpenGL support
12%bcond_without ceph # Ceph/RBD support
59bc1300 13%bcond_without spice # SPICE support
78a71650
JB
14%bcond_with esd # EsounD audio support
15%bcond_without oss # OSS audio support
16%bcond_without pulseaudio # PulseAudio audio support
17%bcond_without xen # Xen backend driver support
3f949819 18#
cd19124e 19Summary: QEMU CPU Emulator
eec0535a 20Summary(pl.UTF-8): QEMU - emulator procesora
7b81d160 21Name: qemu
697b0ba8 22Version: 1.2.0
43927cd7 23Release: 4
78a71650 24License: GPL v2+
5a2da1d0 25Group: Applications/Emulators
697b0ba8
PS
26Source0: http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
27# Source0-md5: 78eb1e984f4532aa9f2bdd3c127b5b61
9bcd4ab6 28Patch0: %{name}-cflags.patch
d9002706 29Patch1: vgabios-widescreens.patch
78a71650 30Patch2: %{name}-usbredir.patch
7e3ba765 31Patch3: %{name}-whitelist.patch
81a493f2 32# Proof of concept, for reference, do not remove
7e3ba765 33Patch4: %{name}-kde_virtual_workspaces_hack.patch
d6bd22e9 34URL: http://wiki.qemu.org/Index.html
78a71650
JB
35%{?with_opengl:BuildRequires: OpenGL-GLX-devel}
36%{?with_sdl:BuildRequires: SDL-devel >= 1.2.1}
b0b3ca8d 37BuildRequires: alsa-lib-devel
b99b1652 38BuildRequires: bluez-libs-devel
78a71650
JB
39BuildRequires: brlapi-devel
40%{?with_ceph:BuildRequires: ceph-devel}
41BuildRequires: curl-devel
42BuildRequires: cyrus-sasl-devel >= 2
43%{?with_esd:BuildRequires: esound-devel}
44BuildRequires: glib2-devel >= 1:2.12
b99b1652 45BuildRequires: gnutls-devel
78a71650
JB
46BuildRequires: libcap-devel
47BuildRequires: libcap-ng-devel
48BuildRequires: libfdt-devel
49BuildRequires: libiscsi-devel
50BuildRequires: libjpeg-devel
51BuildRequires: libpng-devel
52BuildRequires: libseccomp-devel
53BuildRequires: libuuid-devel
98a1a188 54BuildRequires: ncurses-devel
78a71650 55BuildRequires: nss-devel >= 3.12.8
995bac8b 56BuildRequires: perl-Encode
2fb8ea02 57BuildRequires: perl-tools-pod
ba84a935 58BuildRequires: pkgconfig
78a71650 59%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
8bb1261c 60BuildRequires: sed >= 4.0
59bc1300 61%if %{with spice}
78a71650
JB
62BuildRequires: spice-protocol >= 0.8.0
63BuildRequires: spice-server-devel >= 0.8.2
59bc1300 64%endif
a1146336 65BuildRequires: texi2html
22f71ecb 66BuildRequires: texinfo
78a71650
JB
67BuildRequires: usbredir-devel >= 0.3.4
68BuildRequires: vde2-devel
cad677a4 69BuildRequires: which
78a71650
JB
70%{?with_xen:BuildRequires: xen-devel >= 3.4}
71BuildRequires: xfsprogs-devel
ba84a935 72BuildRequires: xorg-lib-libX11-devel
78a71650 73BuildRequires: zlib-devel
fabf5a9c
ER
74Requires: %{name}-img = %{version}-%{release}
75Requires: %{name}-system-alpha = %{version}-%{release}
76Requires: %{name}-system-arm = %{version}-%{release}
77Requires: %{name}-system-cris = %{version}-%{release}
78Requires: %{name}-system-lm32 = %{version}-%{release}
79Requires: %{name}-system-m68k = %{version}-%{release}
80Requires: %{name}-system-microblaze = %{version}-%{release}
81Requires: %{name}-system-mips = %{version}-%{release}
82Requires: %{name}-system-ppc = %{version}-%{release}
92c357d4 83Requires: %{name}-system-or32 = %{version}-%{release}
fabf5a9c
ER
84Requires: %{name}-system-s390x = %{version}-%{release}
85Requires: %{name}-system-sh4 = %{version}-%{release}
86Requires: %{name}-system-sparc = %{version}-%{release}
72ddf007 87Requires: %{name}-system-unicore32 = %{version}-%{release}
fabf5a9c
ER
88Requires: %{name}-system-x86 = %{version}-%{release}
89Requires: %{name}-system-xtensa = %{version}-%{release}
90Requires: %{name}-user = %{version}-%{release}
2ef13cb9 91# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
007877cb 92ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
cd19124e 93BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
78a71650
JB
95%define systempkg_req \
96Requires: SDL >= 1.2.1
97
98a1a188 98# some PPC/SPARC boot image in ELF format
22f71ecb 99%define _noautostrip .*%{_datadir}/qemu/.*-.*
a154aede 100
cd19124e 101%description
102QEMU is a FAST! processor emulator. By using dynamic translation it
103achieves a reasonnable speed while being easy to port on new host
104CPUs. QEMU has two operating modes:
105
106- User mode emulation. In this mode, QEMU can launch Linux processes
107 compiled for one CPU on another CPU. Linux system calls are converted
108 because of endianness and 32/64 bit mismatches. Wine (Windows
109 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
110
111- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
112 including a processor and various peripherials. It can also be used to
113 provide virtual hosting of several virtual PC on a single server.
cd19124e 114
27b30e9c
JR
115%description -l pl.UTF-8
116QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
117tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
118aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
5a2da1d0 119
27b30e9c 120- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
5a2da1d0 121 procesy linuksowe skompilowane dla jednego procesora na innym
27b30e9c
JR
122 procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
123 niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
124 słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
5a2da1d0
JB
125 cele QEMU.
126
27b30e9c
JR
127- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
128 włączając w to procesor i różne urządzenia peryferyjne. Może być także
129 używane do wirtualnego hostowania kilku wirtualnych pecetów na
8799423b 130 pojedynczym serwerze.
5a2da1d0 131
d86014ba 132%package common
fabf5a9c 133Summary: QEMU common files needed by all QEMU targets
d86014ba 134Summary(pl.UTF-8): Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
fabf5a9c 135Group: Development/Tools
78a71650 136Requires: glib2 >= 1:2.12
fabf5a9c
ER
137Conflicts: qemu < 1.0-2
138
139%description common
140QEMU is a generic and open source processor emulator which achieves a
141good emulation speed by using dynamic translation.
142
143This package provides the common files needed by all QEMU targets.
144
d86014ba
JB
145%description common -l pl.UTF-8
146QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
147dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
148
149Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
150środowiska QEMU.
151
152%package img
fabf5a9c 153Summary: QEMU command line tool for manipulating disk images
d86014ba 154Summary(pl.UTF-8): Narzędzie QEMU do operacji na obrazach dysków
fabf5a9c
ER
155Group: Development/Tools
156Conflicts: qemu < 1.0-2
157
158%description img
d86014ba
JB
159This package provides a command line tool for manipulating disk
160images.
161
162%description img -l pl.UTF-8
163Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
164na obrazach dysków.
fabf5a9c
ER
165
166%package user
167Summary: QEMU user mode emulation of qemu targets
d86014ba 168Summary(pl.UTF-8): QEMU - emulacja trybu użytkownika środowisk qemu
fabf5a9c
ER
169Group: Development/Tools
170Requires: %{name}-common = %{version}-%{release}
171
172%description user
173QEMU is a generic and open source processor emulator which achieves a
174good emulation speed by using dynamic translation.
175
176This package provides the user mode emulation of QEMU targets.
177
d86014ba
JB
178%description user -l pl.UTF-8
179QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
180dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
181
182Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
183
fabf5a9c 184%package system-alpha
d86014ba
JB
185Summary: QEMU system emulator for Alpha
186Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Alpha
fabf5a9c
ER
187Group: Development/Tools
188Requires: %{name}-common = %{version}-%{release}
78a71650 189%systempkg_req
fabf5a9c
ER
190
191%description system-alpha
192QEMU is a generic and open source processor emulator which achieves a
193good emulation speed by using dynamic translation.
194
d86014ba
JB
195This package provides the system emulator with Alpha CPU.
196
197%description system-alpha -l pl.UTF-8
198QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
199dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
200
201Ten pakiet zawiera emulator systemu z procesorem Alpha.
fabf5a9c
ER
202
203%package system-arm
d86014ba
JB
204Summary: QEMU system emulator for ARM
205Summary(pl.UTF-8): QEMU - emulator systemu z procesorem ARM
fabf5a9c
ER
206Group: Development/Tools
207Requires: %{name}-common = %{version}-%{release}
78a71650 208%systempkg_req
fabf5a9c
ER
209
210%description system-arm
211QEMU is a generic and open source processor emulator which achieves a
212good emulation speed by using dynamic translation.
213
d86014ba
JB
214This package provides the system emulator for ARM.
215
216%description system-arm -l pl.UTF-8
217QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
218dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
219
220Ten pakiet zawiera emulator systemu z procesorem ARM.
fabf5a9c
ER
221
222%package system-cris
59bc1300 223Summary: QEMU system emulator for CRIS
d86014ba 224Summary(pl.UTF-8): QEMU - emulator systemu z procesorem CRIS
fabf5a9c
ER
225Group: Development/Tools
226Requires: %{name}-common = %{version}-%{release}
78a71650 227%systempkg_req
fabf5a9c
ER
228
229%description system-cris
230QEMU is a generic and open source processor emulator which achieves a
231good emulation speed by using dynamic translation.
232
d86014ba
JB
233This package provides the system emulator with CRIS CPU.
234
235%description system-cris -l pl.UTF-8
236QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
237dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
238
239Ten pakiet zawiera emulator systemu z procesorem CRIS.
fabf5a9c
ER
240
241%package system-lm32
d86014ba
JB
242Summary: QEMU system emulator for LM32
243Summary(pl.UTF-8): QEMU - emulator systemu z procesorem LM32
fabf5a9c
ER
244Group: Development/Tools
245Requires: %{name}-common = %{version}-%{release}
78a71650 246%systempkg_req
fabf5a9c
ER
247
248%description system-lm32
249QEMU is a generic and open source processor emulator which achieves a
250good emulation speed by using dynamic translation.
251
d86014ba
JB
252This package provides the system emulator with LM32 CPU.
253
254%description system-lm32 -l pl.UTF-8
255QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
256dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
257
258Ten pakiet zawiera emulator systemu z procesorem LM32.
fabf5a9c
ER
259
260%package system-m68k
261Summary: QEMU system emulator for m68k
d86014ba 262Summary(pl.UTF-8): QEMU - emulator systemu z procesorem m68k
fabf5a9c
ER
263Group: Development/Tools
264Requires: %{name}-common = %{version}-%{release}
78a71650 265%systempkg_req
fabf5a9c
ER
266
267%description system-m68k
268QEMU is a generic and open source processor emulator which achieves a
269good emulation speed by using dynamic translation.
270
d86014ba
JB
271This package provides the system emulator with m68k CPU.
272
273%description system-m68k -l pl.UTF-8
274QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
275dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
276
277Ten pakiet zawiera emulator systemu z procesorem m68k.
fabf5a9c
ER
278
279%package system-microblaze
d86014ba
JB
280Summary: QEMU system emulator for MicroBlaze
281Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MicroBlaze
fabf5a9c
ER
282Group: Development/Tools
283Requires: %{name}-common = %{version}-%{release}
78a71650 284%systempkg_req
fabf5a9c
ER
285
286%description system-microblaze
287QEMU is a generic and open source processor emulator which achieves a
288good emulation speed by using dynamic translation.
289
d86014ba
JB
290This package provides the system emulator with MicroBlaze CPU.
291
292%description system-microblaze -l pl.UTF-8
293QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
294dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
295
296Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
fabf5a9c
ER
297
298%package system-mips
d86014ba
JB
299Summary: QEMU system emulator for MIPS
300Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MIPS
fabf5a9c
ER
301Group: Development/Tools
302Requires: %{name}-common = %{version}-%{release}
78a71650 303%systempkg_req
fabf5a9c
ER
304
305%description system-mips
306QEMU is a generic and open source processor emulator which achieves a
307good emulation speed by using dynamic translation.
308
d86014ba
JB
309This package provides the system emulator with MIPS CPU.
310
311%description system-mips -l pl.UTF-8
312QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
313dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
314
315Ten pakiet zawiera emulator systemu z procesorem MIPS.
fabf5a9c 316
92c357d4 317%package system-or32
d86014ba
JB
318Summary: QEMU system emulator for OpenRISC
319Summary(pl.UTF-8): QEMU - emulator systemu z procesorem OpenRISC
92c357d4
PS
320Group: Development/Tools
321Requires: %{name}-common = %{version}-%{release}
78a71650 322%systempkg_req
92c357d4
PS
323
324%description system-or32
325QEMU is a generic and open source processor emulator which achieves a
326good emulation speed by using dynamic translation.
327
d86014ba
JB
328This package provides the system emulator with OpenRISC CPU.
329
330%description system-or32 -l pl.UTF-8
331QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
332dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
333
334Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
92c357d4 335
fabf5a9c 336%package system-ppc
d86014ba
JB
337Summary: QEMU system emulator for PowerPC
338Summary(pl.UTF-8): QEMU - emulator systemu z procesorem PowerPC
fabf5a9c
ER
339Group: Development/Tools
340Requires: %{name}-common = %{version}-%{release}
78a71650 341%systempkg_req
fabf5a9c
ER
342
343%description system-ppc
344QEMU is a generic and open source processor emulator which achieves a
345good emulation speed by using dynamic translation.
346
d86014ba
JB
347This package provides the system emulator with PowerPC CPU.
348
349%description system-ppc -l pl.UTF-8
350QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
351dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
352
353Ten pakiet zawiera emulator systemu z procesorem PowerPC.
fabf5a9c
ER
354
355%package system-s390x
d86014ba
JB
356Summary: QEMU system emulator for S390
357Summary(pl.UTF-8): QEMU - emulator systemu z procesorem S390
fabf5a9c
ER
358Group: Development/Tools
359Requires: %{name}-common = %{version}-%{release}
78a71650 360%systempkg_req
fabf5a9c
ER
361
362%description system-s390x
363QEMU is a generic and open source processor emulator which achieves a
364good emulation speed by using dynamic translation.
365
d86014ba
JB
366This package provides the system emulator with S390 CPU.
367
368%description system-s390x -l pl.UTF-8
369QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
370dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
371
372Ten pakiet zawiera emulator systemu z procesorem S390.
fabf5a9c
ER
373
374%package system-sh4
d86014ba
JB
375Summary: QEMU system emulator for SH4
376Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SH4
fabf5a9c
ER
377Group: Development/Tools
378Requires: %{name}-common = %{version}-%{release}
78a71650 379%systempkg_req
fabf5a9c
ER
380
381%description system-sh4
382QEMU is a generic and open source processor emulator which achieves a
383good emulation speed by using dynamic translation.
384
d86014ba
JB
385This package provides the system emulator with SH4 CPU.
386
387%description system-sh4 -l pl.UTF-8
388QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
389dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
390
391Ten pakiet zawiera emulator systemu z procesorem SH4.
fabf5a9c
ER
392
393%package system-sparc
d86014ba
JB
394Summary: QEMU system emulator for SPARC
395Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SPARC
fabf5a9c
ER
396Group: Development/Tools
397Requires: %{name}-common = %{version}-%{release}
78a71650 398%systempkg_req
fabf5a9c
ER
399
400%description system-sparc
401QEMU is a generic and open source processor emulator which achieves a
402good emulation speed by using dynamic translation.
403
d86014ba
JB
404This package provides the system emulator with SPARC/SPARC64 CPU.
405
406%description system-sparc -l pl.UTF-8
407QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
408dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
409
410Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
fabf5a9c 411
72ddf007 412%package system-unicore32
d86014ba
JB
413Summary: QEMU system emulator for UniCore32
414Summary(pl.UTF-8): QEMU - emulator systemu z procesorem UniCore32
72ddf007
PS
415Group: Development/Tools
416Requires: %{name}-common = %{version}-%{release}
78a71650 417%systempkg_req
72ddf007
PS
418
419%description system-unicore32
420QEMU is a generic and open source processor emulator which achieves a
421good emulation speed by using dynamic translation.
422
d86014ba
JB
423This package provides the system emulator with UniCore32 CPU.
424
425%description system-unicore32 -l pl.UTF-8
426QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
427dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
428
429Ten pakiet zawiera emulator systemu z procesorem UniCore32.
72ddf007 430
fabf5a9c
ER
431%package system-x86
432Summary: QEMU system emulator for x86
d86014ba 433Summary(pl.UTF-8): QEMU - emulator systemu z procesorem x86
fabf5a9c
ER
434Group: Development/Tools
435Requires: %{name}-common = %{version}-%{release}
78a71650 436%systempkg_req
fabf5a9c
ER
437
438%description system-x86
439QEMU is a generic and open source processor emulator which achieves a
440good emulation speed by using dynamic translation.
441
d86014ba
JB
442%description system-x86 -l pl.UTF-8
443QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
444dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
445
fabf5a9c 446%package system-xtensa
d86014ba
JB
447Summary: QEMU system emulator for Xtensa
448Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Xtensa
fabf5a9c
ER
449Group: Development/Tools
450Requires: %{name}-common = %{version}-%{release}
78a71650 451%systempkg_req
fabf5a9c
ER
452
453%description system-xtensa
454QEMU is a generic and open source processor emulator which achieves a
455good emulation speed by using dynamic translation.
456
d86014ba
JB
457This package provides the system emulator with Xtensa CPU.
458
459%description system-xtensa -l pl.UTF-8
460QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
461dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
462
463Ten pakiet zawiera emulator systemu z procesorem Xtensa.
fabf5a9c 464
cd19124e 465%prep
c21a255a 466%setup -q
3c6e2290 467%patch0 -p1
d9002706 468%patch1 -p1
78a71650 469%patch2 -p1
7e3ba765
JB
470%patch3 -p0
471#patch4 -p1
0b920c52 472
bd30ad73
GP
473# workaround for conflict with alsa/error.h
474ln -s ../error.h qapi/error.h
475
80bac37e 476%build
8bd2aee2 477./configure \
3c6e2290
JR
478 --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
479 --extra-ldflags="%{rpmldflags}" \
7c0786d1 480 --sysconfdir=%{_sysconfdir} \
8bd2aee2 481 --prefix=%{_prefix} \
98a1a188
AM
482 --cc="%{__cc}" \
483 --host-cc="%{__cc}" \
5263f8f5 484 --disable-strip \
78a71650
JB
485 --enable-attr \
486 --enable-bluez \
487 --enable-brlapi \
488 --enable-cap-ng \
489 --enable-curl \
490 --enable-curses \
491 --enable-fdt \
492 --enable-libiscsi \
b99b1652 493 --enable-mixemu \
78a71650
JB
494 %{__enable_disable opengl} \
495 %{__enable_disable ceph rbd} \
496 %{__enable_disable sdl} \
497 --enable-seccomp \
59bc1300 498 %{__enable_disable spice} \
78a71650
JB
499 --enable-smartcard \
500 --enable-smartcard-nss \
501 --enable-usb-redir \
502 --enable-uuid \
503 --enable-vde \
504 --enable-virtfs \
505 --enable-vnc-jpeg \
506 --enable-vnc-sasl \
507 --enable-vnc-tls \
508 %{__enable_disable xen} \
509 --audio-drv-list="alsa oss%{?with_sdl: sdl}%{?with_esd: esd}%{?with_pulseaudio: pa}" \
7b81d160 510 --interp-prefix=%{_libdir}/%{name}
5263f8f5
JB
511# note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
512# --libexecdir in configure is nop
513%{__make} \
514 V=1 \
515 CONFIG_QEMU_HELPERDIR="%{_libdir}"
cd19124e 516
d9002706
PS
517# rebuild patched vesa tables with additional widescreen modes.
518%{__make} -C roms/vgabios stdvga-bios
519
cd19124e 520%install
521rm -rf $RPM_BUILD_ROOT
5a2da1d0 522
cd19124e 523%{__make} install \
5263f8f5
JB
524 DESTDIR=$RPM_BUILD_ROOT \
525 libexecdir=%{_libdir}
ac6e5743 526
a91fea76 527install -d $RPM_BUILD_ROOT%{_sysconfdir}
528cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
ac6e5743 529#!/bin/sh
a91fea76 530
ac6e5743 531EOF
a62a2d89 532
c33439fc 533# already packaged
5263f8f5
JB
534%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
535%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
c33439fc 536
d9002706
PS
537# install patched vesa tables with additional widescreen modes.
538install -m 644 roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
539
cd19124e 540%clean
541rm -rf $RPM_BUILD_ROOT
542
543%files
544%defattr(644,root,root,755)
fabf5a9c
ER
545
546%files common
547%defattr(644,root,root,755)
5263f8f5 548%doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
a91fea76 549%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
fabf5a9c 550%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
7c0786d1 551%dir %{_sysconfdir}/qemu
5263f8f5
JB
552%attr(755,root,root) %{_bindir}/virtfs-proxy-helper
553%attr(755,root,root) %{_bindir}/vscclient
fabf5a9c 554%attr(755,root,root) %{_bindir}/qemu-nbd
5263f8f5 555%attr(755,root,root) %{_libdir}/qemu-bridge-helper
cd19124e 556%{_mandir}/man1/qemu.1*
5263f8f5 557%{_mandir}/man1/virtfs-proxy-helper.1*
98a1a188 558%{_mandir}/man8/qemu-nbd.8*
fabf5a9c
ER
559
560%dir %{_datadir}/qemu
3d0e0752 561%{_datadir}/%{name}/cpus-*.conf
fabf5a9c 562%{_datadir}/%{name}/keymaps
5263f8f5 563%{_datadir}/%{name}/qemu-icon.bmp
fabf5a9c
ER
564# various bios images
565%{_datadir}/%{name}/*.bin
566%{_datadir}/%{name}/*.rom
567%{_datadir}/%{name}/*.dtb
568%{_datadir}/%{name}/openbios-ppc
569%{_datadir}/%{name}/openbios-sparc*
570%{_datadir}/%{name}/palcode-clipper
571
572%files img
573%defattr(644,root,root,755)
574%attr(755,root,root) %{_bindir}/qemu-img
575%{_mandir}/man1/qemu-img.1*
576
577%files user
578%defattr(644,root,root,755)
fabf5a9c
ER
579%attr(755,root,root) %{_bindir}/qemu-alpha
580%attr(755,root,root) %{_bindir}/qemu-arm
581%attr(755,root,root) %{_bindir}/qemu-armeb
582%attr(755,root,root) %{_bindir}/qemu-cris
583%attr(755,root,root) %{_bindir}/qemu-ga
59bc1300 584%attr(755,root,root) %{_bindir}/qemu-i386
fabf5a9c
ER
585%attr(755,root,root) %{_bindir}/qemu-io
586%attr(755,root,root) %{_bindir}/qemu-m68k
587%attr(755,root,root) %{_bindir}/qemu-microblaze
588%attr(755,root,root) %{_bindir}/qemu-microblazeel
589%attr(755,root,root) %{_bindir}/qemu-mips
590%attr(755,root,root) %{_bindir}/qemu-mipsel
92c357d4 591%attr(755,root,root) %{_bindir}/qemu-or32
fabf5a9c
ER
592%attr(755,root,root) %{_bindir}/qemu-ppc
593%attr(755,root,root) %{_bindir}/qemu-ppc64
594%attr(755,root,root) %{_bindir}/qemu-ppc64abi32
595%attr(755,root,root) %{_bindir}/qemu-s390x
596%attr(755,root,root) %{_bindir}/qemu-sh4
597%attr(755,root,root) %{_bindir}/qemu-sh4eb
598%attr(755,root,root) %{_bindir}/qemu-sparc
599%attr(755,root,root) %{_bindir}/qemu-sparc32plus
600%attr(755,root,root) %{_bindir}/qemu-sparc64
601%attr(755,root,root) %{_bindir}/qemu-unicore32
59bc1300 602%attr(755,root,root) %{_bindir}/qemu-x86_64
fabf5a9c
ER
603
604%files system-alpha
605%defattr(644,root,root,755)
606%attr(755,root,root) %{_bindir}/qemu-system-alpha
607
608%files system-arm
609%defattr(644,root,root,755)
610%attr(755,root,root) %{_bindir}/qemu-system-arm
611
612%files system-cris
613%defattr(644,root,root,755)
614%attr(755,root,root) %{_bindir}/qemu-system-cris
615
616%files system-lm32
617%defattr(644,root,root,755)
618%attr(755,root,root) %{_bindir}/qemu-system-lm32
619
620%files system-m68k
621%defattr(644,root,root,755)
622%attr(755,root,root) %{_bindir}/qemu-system-m68k
623
624%files system-microblaze
625%defattr(644,root,root,755)
626%attr(755,root,root) %{_bindir}/qemu-system-microblaze
627%attr(755,root,root) %{_bindir}/qemu-system-microblazeel
628
629%files system-mips
630%defattr(644,root,root,755)
631%attr(755,root,root) %{_bindir}/qemu-system-mips
632%attr(755,root,root) %{_bindir}/qemu-system-mipsel
633%attr(755,root,root) %{_bindir}/qemu-system-mips64
634%attr(755,root,root) %{_bindir}/qemu-system-mips64el
635
92c357d4
PS
636%files system-or32
637%defattr(644,root,root,755)
638%attr(755,root,root) %{_bindir}/qemu-system-or32
639
fabf5a9c
ER
640%files system-ppc
641%defattr(644,root,root,755)
642%attr(755,root,root) %{_bindir}/qemu-system-ppc
643%attr(755,root,root) %{_bindir}/qemu-system-ppc64
644%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
645
646%files system-s390x
647%defattr(644,root,root,755)
648%attr(755,root,root) %{_bindir}/qemu-system-s390x
649
650%files system-sh4
651%defattr(644,root,root,755)
652%attr(755,root,root) %{_bindir}/qemu-system-sh4
653%attr(755,root,root) %{_bindir}/qemu-system-sh4eb
654
655%files system-sparc
656%defattr(644,root,root,755)
657%attr(755,root,root) %{_bindir}/qemu-system-sparc
658%attr(755,root,root) %{_bindir}/qemu-system-sparc64
659
72ddf007
PS
660%files system-unicore32
661%defattr(644,root,root,755)
662%attr(755,root,root) %{_bindir}/qemu-system-unicore32
663
fabf5a9c
ER
664%files system-x86
665%defattr(644,root,root,755)
666%attr(755,root,root) %{_bindir}/qemu-system-i386
667%attr(755,root,root) %{_bindir}/qemu-system-x86_64
668
669%files system-xtensa
670%defattr(644,root,root,755)
671%attr(755,root,root) %{_bindir}/qemu-system-xtensa
672%attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.184979 seconds and 4 git commands to generate.