]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- update modules License
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
6aef4654 5# Conditional build:
8f93639f 6%bcond_without kqemu # disable KQEMU ACCELERATOR support in QEMU
161ffd93 7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
a6d3659e 8%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
63dabd29
AM
9# Note that gcc4 build is very problematic and not supported by qemu team
10%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
8bb1261c 11%bcond_without dist_kernel # without distribution kernel
b337f190 12%bcond_without kernel # build kqemu KERNEL MODULES
8bb1261c
KK
13%bcond_without smp # don't build SMP module
14%bcond_without userspace # don't build userspace utilities
39b50bf0 15#
b337f190 16%define _kqemu_version 1.3.0pre11
17%define _rel 1
cd19124e 18Summary: QEMU CPU Emulator
5a2da1d0 19Summary(pl): QEMU - emulator procesora
cd19124e 20Name: qemu
b337f190 21Version: 0.9.0
8bb1261c 22Release: %{_rel}%{?with_kqemu:k}
5a2da1d0
JB
23License: GPL
24Group: Applications/Emulators
867764ba 25#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
cd19124e 26Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
b337f190 27# Source0-md5: ab11a03ba30cf4a70641f0f170473d69
c33439fc 28Source1: http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
b337f190 29# Source1-md5: 970521874ef8b1ba4598925ace5936c3
8bd2aee2 30Patch0: %{name}-nostatic.patch
c33439fc 31Patch1: %{name}-cc.patch
d8d8cede 32Patch3: %{name}-dot.patch
8d073aaa
ER
33Patch4: %{name}-gcc4_x86.patch
34Patch5: %{name}-gcc4_ppc.patch
35Patch6: %{name}-nosdlgui.patch
36Patch7: %{name}-ifup.patch
81a493f2
MM
37# Proof of concept, for reference, do not remove
38Patch8: %{name}-kde_virtual_workspaces_hack.patch
e05988b9
AM
39# http://gwenole.beauchesne.info/en/projects/qemu
40Patch9: %{name}-0.8.0-gcc4-hacks.patch
e05988b9 41Patch11: %{name}-0.7.2-gcc4-opts.patch
b337f190 42#Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
cd19124e 43URL: http://fabrice.bellard.free.fr/qemu/
d1ae30a6 44%if %{with kernel} && %{with dist_kernel}
45BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
9ea49998 46BuildRequires: rpmbuild(macros) >= 1.330
d1ae30a6 47%endif
48%if %{with userspace}
867764ba 49BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 50BuildRequires: alsa-lib-devel
21c5c008 51%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
2fb8ea02 52BuildRequires: perl-tools-pod
2fb8ea02 53BuildRequires: tetex
8bb1261c 54BuildRequires: sed >= 4.0
d1ae30a6 55%endif
8bb1261c 56Requires: SDL >= 1.2.1
2ef13cb9 57# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
39b50bf0 58ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
cd19124e 59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
867764ba 61# some SPARC boot image in ELF format
ca55b10f 62%define _noautostrip .*%{_datadir}/qemu/openbios-sparc32
867764ba 63
cd19124e 64%description
65QEMU is a FAST! processor emulator. By using dynamic translation it
66achieves a reasonnable speed while being easy to port on new host
67CPUs. QEMU has two operating modes:
68
69- User mode emulation. In this mode, QEMU can launch Linux processes
70 compiled for one CPU on another CPU. Linux system calls are converted
71 because of endianness and 32/64 bit mismatches. Wine (Windows
72 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
73
74- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
75 including a processor and various peripherials. It can also be used to
76 provide virtual hosting of several virtual PC on a single server.
cd19124e 77
5a2da1d0
JB
78%description -l pl
79