]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- options set closer to qemu-kvm.spec
[packages/qemu.git] / qemu.spec
CommitLineData
0b920c52 1# TODO:
01b9430c 2# - qemu-system-ppc -hda ac-ppc.img says:
fabf5a9c 3# qemu: could not open disk image ac-ppc.img: error "Success"
01b9430c 4# qemu-0.12.2-2.x86_64.rpm - broken
cef095a4 5# qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
fabf5a9c
ER
6# qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
7# qemu-0.11.1-*.x86_64.rpm - OK
0b920c52 8#
6aef4654 9# Conditional build:
78a71650
JB
10%bcond_without sdl # SDL UI and audio support
11%bcond_without opengl # OpenGL support
12%bcond_without ceph # Ceph/RBD support
59bc1300 13%bcond_without spice # SPICE support
78a71650
JB
14%bcond_with esd # EsounD audio support
15%bcond_without oss # OSS audio support
16%bcond_without pulseaudio # PulseAudio audio support
17%bcond_without xen # Xen backend driver support
3f949819 18#
cd19124e 19Summary: QEMU CPU Emulator
eec0535a 20Summary(pl.UTF-8): QEMU - emulator procesora
7b81d160 21Name: qemu
697b0ba8 22Version: 1.2.0
1fac928b 23Release: 5
78a71650 24License: GPL v2+
5a2da1d0 25Group: Applications/Emulators
697b0ba8
PS
26Source0: http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
27# Source0-md5: 78eb1e984f4532aa9f2bdd3c127b5b61
9bcd4ab6 28Patch0: %{name}-cflags.patch
d9002706 29Patch1: vgabios-widescreens.patch
78a71650 30Patch2: %{name}-usbredir.patch
7e3ba765 31Patch3: %{name}-whitelist.patch
81a493f2 32# Proof of concept, for reference, do not remove
7e3ba765 33Patch4: %{name}-kde_virtual_workspaces_hack.patch
d6bd22e9 34URL: http://wiki.qemu.org/Index.html
78a71650
JB
35%{?with_opengl:BuildRequires: OpenGL-GLX-devel}
36%{?with_sdl:BuildRequires: SDL-devel >= 1.2.1}
b0b3ca8d 37BuildRequires: alsa-lib-devel
b99b1652 38BuildRequires: bluez-libs-devel
78a71650
JB
39BuildRequires: brlapi-devel
40%{?with_ceph:BuildRequires: ceph-devel}
41BuildRequires: curl-devel
42BuildRequires: cyrus-sasl-devel >= 2
43%{?with_esd:BuildRequires: esound-devel}
44BuildRequires: glib2-devel >= 1:2.12
b99b1652 45BuildRequires: gnutls-devel
87364910 46BuildRequires: libaio-devel
78a71650
JB
47BuildRequires: libcap-devel
48BuildRequires: libcap-ng-devel
49BuildRequires: libfdt-devel
50BuildRequires: libiscsi-devel
51BuildRequires: libjpeg-devel
52BuildRequires: libpng-devel
53BuildRequires: libseccomp-devel
54BuildRequires: libuuid-devel
98a1a188 55BuildRequires: ncurses-devel
78a71650 56BuildRequires: nss-devel >= 3.12.8
995bac8b 57BuildRequires: perl-Encode
2fb8ea02 58BuildRequires: perl-tools-pod
ba84a935 59BuildRequires: pkgconfig
78a71650 60%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
8bb1261c 61BuildRequires: sed >= 4.0
59bc1300 62%if %{with spice}
78a71650
JB
63BuildRequires: spice-protocol >= 0.8.0
64BuildRequires: spice-server-devel >= 0.8.2
59bc1300 65%endif
a1146336 66BuildRequires: texi2html
22f71ecb 67BuildRequires: texinfo
78a71650
JB
68BuildRequires: usbredir-devel >= 0.3.4
69BuildRequires: vde2-devel
cad677a4 70BuildRequires: which
78a71650
JB
71%{?with_xen:BuildRequires: xen-devel >= 3.4}
72BuildRequires: xfsprogs-devel
ba84a935 73BuildRequires: xorg-lib-libX11-devel
78a71650 74BuildRequires: zlib-devel
fabf5a9c
ER
75Requires: %{name}-img = %{version}-%{release}
76Requires: %{name}-system-alpha = %{version}-%{release}
77Requires: %{name}-system-arm = %{version}-%{release}
78Requires: %{name}-system-cris = %{version}-%{release}
79Requires: %{name}-system-lm32 = %{version}-%{release}
80Requires: %{name}-system-m68k = %{version}-%{release}
81Requires: %{name}-system-microblaze = %{version}-%{release}
82Requires: %{name}-system-mips = %{version}-%{release}
83Requires: %{name}-system-ppc = %{version}-%{release}
92c357d4 84Requires: %{name}-system-or32 = %{version}-%{release}
fabf5a9c
ER
85Requires: %{name}-system-s390x = %{version}-%{release}
86Requires: %{name}-system-sh4 = %{version}-%{release}
87Requires: %{name}-system-sparc = %{version}-%{release}
72ddf007 88Requires: %{name}-system-unicore32 = %{version}-%{release}
fabf5a9c
ER
89Requires: %{name}-system-x86 = %{version}-%{release}
90Requires: %{name}-system-xtensa = %{version}-%{release}
91Requires: %{name}-user = %{version}-%{release}
cd19124e 92BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
78a71650
JB
94%define systempkg_req \
95Requires: SDL >= 1.2.1
96
98a1a188 97# some PPC/SPARC boot image in ELF format
22f71ecb 98%define _noautostrip .*%{_datadir}/qemu/.*-.*
a154aede 99
cd19124e 100%description
101QEMU is a FAST! processor emulator. By using dynamic translation it
102achieves a reasonnable speed while being easy to port on new host
103CPUs. QEMU has two operating modes:
104
105- User mode emulation. In this mode, QEMU can launch Linux processes
106 compiled for one CPU on another CPU. Linux system calls are converted
107 because of endianness and 32/64 bit mismatches. Wine (Windows
108 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
109
110- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
111 including a processor and various peripherials. It can also be used to
112 provide virtual hosting of several virtual PC on a single server.
cd19124e 113
27b30e9c
JR
114%description -l pl.UTF-8
115QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
116tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
117aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
5a2da1d0 118
27b30e9c 119- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
5a2da1d0 120 procesy linuksowe skompilowane dla jednego procesora na innym
27b30e9c
JR
121 procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
122 niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
123 słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
5a2da1d0
JB
124 cele QEMU.
125
27b30e9c
JR
126- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
127 włączając w to procesor i różne urządzenia peryferyjne. Może być także
128 używane do wirtualnego hostowania kilku wirtualnych pecetów na
8799423b 129 pojedynczym serwerze.
5a2da1d0 130
d86014ba 131%package common
fabf5a9c 132Summary: QEMU common files needed by all QEMU targets
d86014ba 133Summary(pl.UTF-8): Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
fabf5a9c 134Group: Development/Tools
78a71650 135Requires: glib2 >= 1:2.12
fabf5a9c
ER
136Conflicts: qemu < 1.0-2
137
138%description common
139QEMU is a generic and open source processor emulator which achieves a
140good emulation speed by using dynamic translation.
141
142This package provides the common files needed by all QEMU targets.
143
d86014ba
JB
144%description common -l pl.UTF-8
145QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
146dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
147
148Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
149środowiska QEMU.
150
151%package img
fabf5a9c 152Summary: QEMU command line tool for manipulating disk images
d86014ba 153Summary(pl.UTF-8): Narzędzie QEMU do operacji na obrazach dysków
fabf5a9c
ER
154Group: Development/Tools
155Conflicts: qemu < 1.0-2
156
157%description img
d86014ba
JB
158This package provides a command line tool for manipulating disk
159images.
160
161%description img -l pl.UTF-8
162Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
163na obrazach dysków.
fabf5a9c
ER
164
165%package user
166Summary: QEMU user mode emulation of qemu targets
d86014ba 167Summary(pl.UTF-8): QEMU - emulacja trybu użytkownika środowisk qemu
fabf5a9c
ER
168Group: Development/Tools
169Requires: %{name}-common = %{version}-%{release}
170
171%description user
172QEMU is a generic and open source processor emulator which achieves a
173good emulation speed by using dynamic translation.
174
175This package provides the user mode emulation of QEMU targets.
176
d86014ba
JB
177%description user -l pl.UTF-8
178QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
179dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
180
181Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
182
fabf5a9c 183%package system-alpha
d86014ba
JB
184Summary: QEMU system emulator for Alpha
185Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Alpha
fabf5a9c
ER
186Group: Development/Tools
187Requires: %{name}-common = %{version}-%{release}
78a71650 188%systempkg_req
fabf5a9c
ER
189
190%description system-alpha
191QEMU is a generic and open source processor emulator which achieves a
192good emulation speed by using dynamic translation.
193
d86014ba
JB
194This package provides the system emulator with Alpha CPU.
195
196%description system-alpha -l pl.UTF-8
197QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
198dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
199
200Ten pakiet zawiera emulator systemu z procesorem Alpha.
fabf5a9c
ER
201
202%package system-arm
d86014ba
JB
203Summary: QEMU system emulator for ARM
204Summary(pl.UTF-8): QEMU - emulator systemu z procesorem ARM
fabf5a9c
ER
205Group: Development/Tools
206Requires: %{name}-common = %{version}-%{release}
78a71650 207%systempkg_req
fabf5a9c
ER
208
209%description system-arm
210QEMU is a generic and open source processor emulator which achieves a
211good emulation speed by using dynamic translation.
212
d86014ba
JB
213This package provides the system emulator for ARM.
214
215%description system-arm -l pl.UTF-8
216QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
217dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
218
219Ten pakiet zawiera emulator systemu z procesorem ARM.
fabf5a9c
ER
220
221%package system-cris
59bc1300 222Summary: QEMU system emulator for CRIS
d86014ba 223Summary(pl.UTF-8): QEMU - emulator systemu z procesorem CRIS
fabf5a9c
ER
224Group: Development/Tools
225Requires: %{name}-common = %{version}-%{release}
78a71650 226%systempkg_req
fabf5a9c
ER
227
228%description system-cris
229QEMU is a generic and open source processor emulator which achieves a
230good emulation speed by using dynamic translation.
231
d86014ba
JB
232This package provides the system emulator with CRIS CPU.
233
234%description system-cris -l pl.UTF-8
235QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
236dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
237
238Ten pakiet zawiera emulator systemu z procesorem CRIS.
fabf5a9c
ER
239
240%package system-lm32
d86014ba
JB
241Summary: QEMU system emulator for LM32
242Summary(pl.UTF-8): QEMU - emulator systemu z procesorem LM32
fabf5a9c
ER
243Group: Development/Tools
244Requires: %{name}-common = %{version}-%{release}
78a71650 245%systempkg_req
fabf5a9c
ER
246
247%description system-lm32
248QEMU is a generic and open source processor emulator which achieves a
249good emulation speed by using dynamic translation.
250
d86014ba
JB
251This package provides the system emulator with LM32 CPU.
252
253%description system-lm32 -l pl.UTF-8
254QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
255dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
256
257Ten pakiet zawiera emulator systemu z procesorem LM32.
fabf5a9c
ER
258
259%package system-m68k
260Summary: QEMU system emulator for m68k
d86014ba 261Summary(pl.UTF-8): QEMU - emulator systemu z procesorem m68k
fabf5a9c
ER
262Group: Development/Tools
263Requires: %{name}-common = %{version}-%{release}
78a71650 264%systempkg_req
fabf5a9c
ER
265
266%description system-m68k
267QEMU is a generic and open source processor emulator which achieves a
268good emulation speed by using dynamic translation.
269
d86014ba
JB
270This package provides the system emulator with m68k CPU.
271
272%description system-m68k -l pl.UTF-8
273QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
274dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
275
276Ten pakiet zawiera emulator systemu z procesorem m68k.
fabf5a9c
ER
277
278%package system-microblaze
d86014ba
JB
279Summary: QEMU system emulator for MicroBlaze
280Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MicroBlaze
fabf5a9c
ER
281Group: Development/Tools
282Requires: %{name}-common = %{version}-%{release}
78a71650 283%systempkg_req
fabf5a9c
ER
284
285%description system-microblaze
286QEMU is a generic and open source processor emulator which achieves a
287good emulation speed by using dynamic translation.
288
d86014ba
JB
289This package provides the system emulator with MicroBlaze CPU.
290
291%description system-microblaze -l pl.UTF-8
292QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
293dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
294
295Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
fabf5a9c
ER
296
297%package system-mips
d86014ba
JB
298Summary: QEMU system emulator for MIPS
299Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MIPS
fabf5a9c
ER
300Group: Development/Tools
301Requires: %{name}-common = %{version}-%{release}
78a71650 302%systempkg_req
fabf5a9c
ER
303
304%description system-mips
305QEMU is a generic and open source processor emulator which achieves a
306good emulation speed by using dynamic translation.
307
d86014ba
JB
308This package provides the system emulator with MIPS CPU.
309
310%description system-mips -l pl.UTF-8
311QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
312dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
313
314Ten pakiet zawiera emulator systemu z procesorem MIPS.
fabf5a9c 315
92c357d4 316%package system-or32
d86014ba
JB
317Summary: QEMU system emulator for OpenRISC
318Summary(pl.UTF-8): QEMU - emulator systemu z procesorem OpenRISC
92c357d4
PS
319Group: Development/Tools
320Requires: %{name}-common = %{version}-%{release}
78a71650 321%systempkg_req
92c357d4
PS
322
323%description system-or32
324QEMU is a generic and open source processor emulator which achieves a
325good emulation speed by using dynamic translation.
326
d86014ba
JB
327This package provides the system emulator with OpenRISC CPU.
328
329%description system-or32 -l pl.UTF-8
330QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
331dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
332
333Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
92c357d4 334
fabf5a9c 335%package system-ppc
d86014ba
JB
336Summary: QEMU system emulator for PowerPC
337Summary(pl.UTF-8): QEMU - emulator systemu z procesorem PowerPC
fabf5a9c
ER
338Group: Development/Tools
339Requires: %{name}-common = %{version}-%{release}
78a71650 340%systempkg_req
fabf5a9c
ER
341
342%description system-ppc
343QEMU is a generic and open source processor emulator which achieves a
344good emulation speed by using dynamic translation.
345
d86014ba
JB
346This package provides the system emulator with PowerPC CPU.
347
348%description system-ppc -l pl.UTF-8
349QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
350dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
351
352Ten pakiet zawiera emulator systemu z procesorem PowerPC.
fabf5a9c
ER
353
354%package system-s390x
d86014ba
JB
355Summary: QEMU system emulator for S390
356Summary(pl.UTF-8): QEMU - emulator systemu z procesorem S390
fabf5a9c
ER
357Group: Development/Tools
358Requires: %{name}-common = %{version}-%{release}
78a71650 359%systempkg_req
fabf5a9c
ER
360
361%description system-s390x
362QEMU is a generic and open source processor emulator which achieves a
363good emulation speed by using dynamic translation.
364
d86014ba
JB
365This package provides the system emulator with S390 CPU.
366
367%description system-s390x -l pl.UTF-8
368QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
369dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
370
371Ten pakiet zawiera emulator systemu z procesorem S390.
fabf5a9c
ER
372
373%package system-sh4
d86014ba
JB
374Summary: QEMU system emulator for SH4
375Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SH4
fabf5a9c
ER
376Group: Development/Tools
377Requires: %{name}-common = %{version}-%{release}
78a71650 378%systempkg_req
fabf5a9c
ER
379
380%description system-sh4
381QEMU is a generic and open source processor emulator which achieves a
382good emulation speed by using dynamic translation.
383
d86014ba
JB
384This package provides the system emulator with SH4 CPU.
385
386%description system-sh4 -l pl.UTF-8
387QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
388dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
389
390Ten pakiet zawiera emulator systemu z procesorem SH4.
fabf5a9c
ER
391
392%package system-sparc
d86014ba
JB
393Summary: QEMU system emulator for SPARC
394Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SPARC
fabf5a9c
ER
395Group: Development/Tools
396Requires: %{name}-common = %{version}-%{release}
78a71650 397%systempkg_req
fabf5a9c
ER
398
399%description system-sparc
400QEMU is a generic and open source processor emulator which achieves a
401good emulation speed by using dynamic translation.
402
d86014ba
JB
403This package provides the system emulator with SPARC/SPARC64 CPU.
404
405%description system-sparc -l pl.UTF-8
406QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
407dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
408
409Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
fabf5a9c 410
72ddf007 411%package system-unicore32
d86014ba
JB
412Summary: QEMU system emulator for UniCore32
413Summary(pl.UTF-8): QEMU - emulator systemu z procesorem UniCore32
72ddf007
PS
414Group: Development/Tools
415Requires: %{name}-common = %{version}-%{release}
78a71650 416%systempkg_req
72ddf007
PS
417
418%description system-unicore32
419QEMU is a generic and open source processor emulator which achieves a
420good emulation speed by using dynamic translation.
421
d86014ba
JB
422This package provides the system emulator with UniCore32 CPU.
423
424%description system-unicore32 -l pl.UTF-8
425QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
426dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
427
428Ten pakiet zawiera emulator systemu z procesorem UniCore32.
72ddf007 429
fabf5a9c
ER
430%package system-x86
431Summary: QEMU system emulator for x86
d86014ba 432Summary(pl.UTF-8): QEMU - emulator systemu z procesorem x86
fabf5a9c
ER
433Group: Development/Tools
434Requires: %{name}-common = %{version}-%{release}
78a71650 435%systempkg_req
fabf5a9c
ER
436
437%description system-x86
438QEMU is a generic and open source processor emulator which achieves a
439good emulation speed by using dynamic translation.
440
d86014ba
JB
441%description system-x86 -l pl.UTF-8
442QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
443dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
444
fabf5a9c 445%package system-xtensa
d86014ba
JB
446Summary: QEMU system emulator for Xtensa
447Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Xtensa
fabf5a9c
ER
448Group: Development/Tools
449Requires: %{name}-common = %{version}-%{release}
78a71650 450%systempkg_req
fabf5a9c
ER
451
452%description system-xtensa
453QEMU is a generic and open source processor emulator which achieves a
454good emulation speed by using dynamic translation.
455
d86014ba
JB
456This package provides the system emulator with Xtensa CPU.
457
458%description system-xtensa -l pl.UTF-8
459QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
460dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
461
462Ten pakiet zawiera emulator systemu z procesorem Xtensa.
fabf5a9c 463
cd19124e 464%prep
c21a255a 465%setup -q
3c6e2290 466%patch0 -p1
d9002706 467%patch1 -p1
78a71650 468%patch2 -p1
7e3ba765
JB
469%patch3 -p0
470#patch4 -p1
0b920c52 471
bd30ad73
GP
472# workaround for conflict with alsa/error.h
473ln -s ../error.h qapi/error.h
474
80bac37e 475%build
8bd2aee2 476./configure \
3c6e2290
JR
477 --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
478 --extra-ldflags="%{rpmldflags}" \
8bd2aee2 479 --prefix=%{_prefix} \
87364910 480 --sysconfdir=%{_sysconfdir} \
98a1a188
AM
481 --cc="%{__cc}" \
482 --host-cc="%{__cc}" \
5263f8f5 483 --disable-strip \
78a71650
JB
484 --enable-attr \
485 --enable-bluez \
486 --enable-brlapi \
487 --enable-cap-ng \
488 --enable-curl \
489 --enable-curses \
87364910 490 --enable-docs \
78a71650
JB
491 --enable-fdt \
492 --enable-libiscsi \
b99b1652 493 --enable-mixemu \
78a71650
JB
494 %{__enable_disable opengl} \
495 %{__enable_disable ceph rbd} \
496 %{__enable_disable sdl} \
497 --enable-seccomp \
59bc1300 498 %{__enable_disable spice} \
78a71650
JB
499 --enable-smartcard \
500 --enable-smartcard-nss \
501 --enable-usb-redir \
502 --enable-uuid \
503 --enable-vde \
504 --enable-virtfs \
505 --enable-vnc-jpeg \
87364910 506 --enable-vnc-png \
78a71650
JB
507 --enable-vnc-sasl \
508 --enable-vnc-tls \
509 %{__enable_disable xen} \
87364910
JB
510 --audio-card-list="ac97,es1370,sb16,cs4231a,adlib,gus,hda" \
511 --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
512 --interp-prefix=%{_libdir}/qemu/lib-%%M
5263f8f5
JB
513# note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
514# --libexecdir in configure is nop
515%{__make} \
516 V=1 \
517 CONFIG_QEMU_HELPERDIR="%{_libdir}"
cd19124e 518
d9002706
PS
519# rebuild patched vesa tables with additional widescreen modes.
520%{__make} -C roms/vgabios stdvga-bios
521
cd19124e 522%install
523rm -rf $RPM_BUILD_ROOT
5a2da1d0 524
cd19124e 525%{__make} install \
5263f8f5
JB
526 DESTDIR=$RPM_BUILD_ROOT \
527 libexecdir=%{_libdir}
ac6e5743 528
a91fea76 529install -d $RPM_BUILD_ROOT%{_sysconfdir}
530cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
ac6e5743 531#!/bin/sh
a91fea76 532
ac6e5743 533EOF
a62a2d89 534
c33439fc 535# already packaged
5263f8f5
JB
536%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
537%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
c33439fc 538
d9002706
PS
539# install patched vesa tables with additional widescreen modes.
540install -m 644 roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
541
cd19124e 542%clean
543rm -rf $RPM_BUILD_ROOT
544
545%files
546%defattr(644,root,root,755)
fabf5a9c
ER
547
548%files common
549%defattr(644,root,root,755)
5263f8f5 550%doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
a91fea76 551%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
fabf5a9c 552%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
7c0786d1 553%dir %{_sysconfdir}/qemu
5263f8f5
JB
554%attr(755,root,root) %{_bindir}/virtfs-proxy-helper
555%attr(755,root,root) %{_bindir}/vscclient
fabf5a9c 556%attr(755,root,root) %{_bindir}/qemu-nbd
5263f8f5 557%attr(755,root,root) %{_libdir}/qemu-bridge-helper
cd19124e 558%{_mandir}/man1/qemu.1*
5263f8f5 559%{_mandir}/man1/virtfs-proxy-helper.1*
98a1a188 560%{_mandir}/man8/qemu-nbd.8*
fabf5a9c
ER
561
562%dir %{_datadir}/qemu
3d0e0752 563%{_datadir}/%{name}/cpus-*.conf
fabf5a9c 564%{_datadir}/%{name}/keymaps
5263f8f5 565%{_datadir}/%{name}/qemu-icon.bmp
fabf5a9c
ER
566# various bios images
567%{_datadir}/%{name}/*.bin
568%{_datadir}/%{name}/*.rom
569%{_datadir}/%{name}/*.dtb
570%{_datadir}/%{name}/openbios-ppc
571%{_datadir}/%{name}/openbios-sparc*
572%{_datadir}/%{name}/palcode-clipper
573
574%files img
575%defattr(644,root,root,755)
576%attr(755,root,root) %{_bindir}/qemu-img
577%{_mandir}/man1/qemu-img.1*
578
579%files user
580%defattr(644,root,root,755)
fabf5a9c
ER
581%attr(755,root,root) %{_bindir}/qemu-alpha
582%attr(755,root,root) %{_bindir}/qemu-arm
583%attr(755,root,root) %{_bindir}/qemu-armeb
584%attr(755,root,root) %{_bindir}/qemu-cris
585%attr(755,root,root) %{_bindir}/qemu-ga
59bc1300 586%attr(755,root,root) %{_bindir}/qemu-i386
fabf5a9c
ER
587%attr(755,root,root) %{_bindir}/qemu-io
588%attr(755,root,root) %{_bindir}/qemu-m68k
589%attr(755,root,root) %{_bindir}/qemu-microblaze
590%attr(755,root,root) %{_bindir}/qemu-microblazeel
591%attr(755,root,root) %{_bindir}/qemu-mips
592%attr(755,root,root) %{_bindir}/qemu-mipsel
92c357d4 593%attr(755,root,root) %{_bindir}/qemu-or32
fabf5a9c
ER
594%attr(755,root,root) %{_bindir}/qemu-ppc
595%attr(755,root,root) %{_bindir}/qemu-ppc64
596%attr(755,root,root) %{_bindir}/qemu-ppc64abi32
597%attr(755,root,root) %{_bindir}/qemu-s390x
598%attr(755,root,root) %{_bindir}/qemu-sh4
599%attr(755,root,root) %{_bindir}/qemu-sh4eb
600%attr(755,root,root) %{_bindir}/qemu-sparc
601%attr(755,root,root) %{_bindir}/qemu-sparc32plus
602%attr(755,root,root) %{_bindir}/qemu-sparc64
603%attr(755,root,root) %{_bindir}/qemu-unicore32
59bc1300 604%attr(755,root,root) %{_bindir}/qemu-x86_64
fabf5a9c
ER
605
606%files system-alpha
607%defattr(644,root,root,755)
608%attr(755,root,root) %{_bindir}/qemu-system-alpha
609
610%files system-arm
611%defattr(644,root,root,755)
612%attr(755,root,root) %{_bindir}/qemu-system-arm
613
614%files system-cris
615%defattr(644,root,root,755)
616%attr(755,root,root) %{_bindir}/qemu-system-cris
617
618%files system-lm32
619%defattr(644,root,root,755)
620%attr(755,root,root) %{_bindir}/qemu-system-lm32
621
622%files system-m68k
623%defattr(644,root,root,755)
624%attr(755,root,root) %{_bindir}/qemu-system-m68k
625
626%files system-microblaze
627%defattr(644,root,root,755)
628%attr(755,root,root) %{_bindir}/qemu-system-microblaze
629%attr(755,root,root) %{_bindir}/qemu-system-microblazeel
630
631%files system-mips
632%defattr(644,root,root,755)
633%attr(755,root,root) %{_bindir}/qemu-system-mips
634%attr(755,root,root) %{_bindir}/qemu-system-mipsel
635%attr(755,root,root) %{_bindir}/qemu-system-mips64
636%attr(755,root,root) %{_bindir}/qemu-system-mips64el
637
92c357d4
PS
638%files system-or32
639%defattr(644,root,root,755)
640%attr(755,root,root) %{_bindir}/qemu-system-or32
641
fabf5a9c
ER
642%files system-ppc
643%defattr(644,root,root,755)
644%attr(755,root,root) %{_bindir}/qemu-system-ppc
645%attr(755,root,root) %{_bindir}/qemu-system-ppc64
646%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
647
648%files system-s390x
649%defattr(644,root,root,755)
650%attr(755,root,root) %{_bindir}/qemu-system-s390x
651
652%files system-sh4
653%defattr(644,root,root,755)
654%attr(755,root,root) %{_bindir}/qemu-system-sh4
655%attr(755,root,root) %{_bindir}/qemu-system-sh4eb
656
657%files system-sparc
658%defattr(644,root,root,755)
659%attr(755,root,root) %{_bindir}/qemu-system-sparc
660%attr(755,root,root) %{_bindir}/qemu-system-sparc64
661
72ddf007
PS
662%files system-unicore32
663%defattr(644,root,root,755)
664%attr(755,root,root) %{_bindir}/qemu-system-unicore32
665
fabf5a9c
ER
666%files system-x86
667%defattr(644,root,root,755)
668%attr(755,root,root) %{_bindir}/qemu-system-i386
669%attr(755,root,root) %{_bindir}/qemu-system-x86_64
670
671%files system-xtensa
672%defattr(644,root,root,755)
673%attr(755,root,root) %{_bindir}/qemu-system-xtensa
674%attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.186739 seconds and 4 git commands to generate.