]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- renumbered patches
[packages/qemu.git] / qemu.spec
CommitLineData
0b920c52 1# TODO:
01b9430c 2# - qemu-system-ppc -hda ac-ppc.img says:
fabf5a9c 3# qemu: could not open disk image ac-ppc.img: error "Success"
01b9430c 4# qemu-0.12.2-2.x86_64.rpm - broken
cef095a4 5# qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
fabf5a9c
ER
6# qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
7# qemu-0.11.1-*.x86_64.rpm - OK
0b920c52 8#
6aef4654 9# Conditional build:
78a71650
JB
10%bcond_without sdl # SDL UI and audio support
11%bcond_without opengl # OpenGL support
12%bcond_without ceph # Ceph/RBD support
13%bcond_with esd # EsounD audio support
14%bcond_without oss # OSS audio support
15%bcond_without pulseaudio # PulseAudio audio support
16%bcond_without xen # Xen backend driver support
3f949819 17#
cd19124e 18Summary: QEMU CPU Emulator
eec0535a 19Summary(pl.UTF-8): QEMU - emulator procesora
7b81d160 20Name: qemu
697b0ba8 21Version: 1.2.0
43927cd7 22Release: 4
78a71650 23License: GPL v2+
5a2da1d0 24Group: Applications/Emulators
697b0ba8
PS
25Source0: http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
26# Source0-md5: 78eb1e984f4532aa9f2bdd3c127b5b61
9bcd4ab6 27Patch0: %{name}-cflags.patch
d9002706 28Patch1: vgabios-widescreens.patch
78a71650 29Patch2: %{name}-usbredir.patch
7e3ba765 30Patch3: %{name}-whitelist.patch
81a493f2 31# Proof of concept, for reference, do not remove
7e3ba765 32Patch4: %{name}-kde_virtual_workspaces_hack.patch
d6bd22e9 33URL: http://wiki.qemu.org/Index.html
78a71650
JB
34%{?with_opengl:BuildRequires: OpenGL-GLX-devel}
35%{?with_sdl:BuildRequires: SDL-devel >= 1.2.1}
b0b3ca8d 36BuildRequires: alsa-lib-devel
b99b1652 37BuildRequires: bluez-libs-devel
78a71650
JB
38BuildRequires: brlapi-devel
39%{?with_ceph:BuildRequires: ceph-devel}
40BuildRequires: curl-devel
41BuildRequires: cyrus-sasl-devel >= 2
42%{?with_esd:BuildRequires: esound-devel}
43BuildRequires: glib2-devel >= 1:2.12
b99b1652 44BuildRequires: gnutls-devel
78a71650
JB
45BuildRequires: libcap-devel
46BuildRequires: libcap-ng-devel
47BuildRequires: libfdt-devel
48BuildRequires: libiscsi-devel
49BuildRequires: libjpeg-devel
50BuildRequires: libpng-devel
51BuildRequires: libseccomp-devel
52BuildRequires: libuuid-devel
98a1a188 53BuildRequires: ncurses-devel
78a71650 54BuildRequires: nss-devel >= 3.12.8
995bac8b 55BuildRequires: perl-Encode
2fb8ea02 56BuildRequires: perl-tools-pod
ba84a935 57BuildRequires: pkgconfig
78a71650 58%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
8bb1261c 59BuildRequires: sed >= 4.0
78a71650
JB
60BuildRequires: spice-protocol >= 0.8.0
61BuildRequires: spice-server-devel >= 0.8.2
a1146336 62BuildRequires: texi2html
22f71ecb 63BuildRequires: texinfo
78a71650
JB
64BuildRequires: usbredir-devel >= 0.3.4
65BuildRequires: vde2-devel
cad677a4 66BuildRequires: which
78a71650
JB
67%{?with_xen:BuildRequires: xen-devel >= 3.4}
68BuildRequires: xfsprogs-devel
ba84a935 69BuildRequires: xorg-lib-libX11-devel
78a71650 70BuildRequires: zlib-devel
fabf5a9c
ER
71Requires: %{name}-img = %{version}-%{release}
72Requires: %{name}-system-alpha = %{version}-%{release}
73Requires: %{name}-system-arm = %{version}-%{release}
74Requires: %{name}-system-cris = %{version}-%{release}
75Requires: %{name}-system-lm32 = %{version}-%{release}
76Requires: %{name}-system-m68k = %{version}-%{release}
77Requires: %{name}-system-microblaze = %{version}-%{release}
78Requires: %{name}-system-mips = %{version}-%{release}
79Requires: %{name}-system-ppc = %{version}-%{release}
92c357d4 80Requires: %{name}-system-or32 = %{version}-%{release}
fabf5a9c
ER
81Requires: %{name}-system-s390x = %{version}-%{release}
82Requires: %{name}-system-sh4 = %{version}-%{release}
83Requires: %{name}-system-sparc = %{version}-%{release}
72ddf007 84Requires: %{name}-system-unicore32 = %{version}-%{release}
fabf5a9c
ER
85Requires: %{name}-system-x86 = %{version}-%{release}
86Requires: %{name}-system-xtensa = %{version}-%{release}
87Requires: %{name}-user = %{version}-%{release}
2ef13cb9 88# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
007877cb 89ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
cd19124e 90BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
78a71650
JB
92%define systempkg_req \
93Requires: SDL >= 1.2.1
94
98a1a188 95# some PPC/SPARC boot image in ELF format
22f71ecb 96%define _noautostrip .*%{_datadir}/qemu/.*-.*
a154aede 97
cd19124e 98%description
99QEMU is a FAST! processor emulator. By using dynamic translation it
100achieves a reasonnable speed while being easy to port on new host
101CPUs. QEMU has two operating modes:
102
103- User mode emulation. In this mode, QEMU can launch Linux processes
104 compiled for one CPU on another CPU. Linux system calls are converted
105 because of endianness and 32/64 bit mismatches. Wine (Windows
106 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
107
108- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
109 including a processor and various peripherials. It can also be used to
110 provide virtual hosting of several virtual PC on a single server.
cd19124e 111
27b30e9c
JR
112%description -l pl.UTF-8
113QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
114tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
115aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
5a2da1d0 116
27b30e9c 117- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
5a2da1d0 118 procesy linuksowe skompilowane dla jednego procesora na innym
27b30e9c
JR
119 procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
120 niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
121 słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
5a2da1d0
JB
122 cele QEMU.
123
27b30e9c
JR
124- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
125 włączając w to procesor i różne urządzenia peryferyjne. Może być także
126 używane do wirtualnego hostowania kilku wirtualnych pecetów na
8799423b 127 pojedynczym serwerze.
5a2da1d0 128
d86014ba 129%package common
fabf5a9c 130Summary: QEMU common files needed by all QEMU targets
d86014ba 131Summary(pl.UTF-8): Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
fabf5a9c 132Group: Development/Tools
78a71650 133Requires: glib2 >= 1:2.12
fabf5a9c
ER
134Conflicts: qemu < 1.0-2
135
136%description common
137QEMU is a generic and open source processor emulator which achieves a
138good emulation speed by using dynamic translation.
139
140This package provides the common files needed by all QEMU targets.
141
d86014ba
JB
142%description common -l pl.UTF-8
143QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
144dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
145
146Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
147środowiska QEMU.
148
149%package img
fabf5a9c 150Summary: QEMU command line tool for manipulating disk images
d86014ba 151Summary(pl.UTF-8): Narzędzie QEMU do operacji na obrazach dysków
fabf5a9c
ER
152Group: Development/Tools
153Conflicts: qemu < 1.0-2
154
155%description img
d86014ba
JB
156This package provides a command line tool for manipulating disk
157images.
158
159%description img -l pl.UTF-8
160Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
161na obrazach dysków.
fabf5a9c
ER
162
163%package user
164Summary: QEMU user mode emulation of qemu targets
d86014ba 165Summary(pl.UTF-8): QEMU - emulacja trybu użytkownika środowisk qemu
fabf5a9c
ER
166Group: Development/Tools
167Requires: %{name}-common = %{version}-%{release}
168
169%description user
170QEMU is a generic and open source processor emulator which achieves a
171good emulation speed by using dynamic translation.
172
173This package provides the user mode emulation of QEMU targets.
174
d86014ba
JB
175%description user -l pl.UTF-8
176QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
177dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
178
179Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
180
fabf5a9c 181%package system-alpha
d86014ba
JB
182Summary: QEMU system emulator for Alpha
183Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Alpha
fabf5a9c
ER
184Group: Development/Tools
185Requires: %{name}-common = %{version}-%{release}
78a71650 186%systempkg_req
fabf5a9c
ER
187
188%description system-alpha
189QEMU is a generic and open source processor emulator which achieves a
190good emulation speed by using dynamic translation.
191
d86014ba
JB
192This package provides the system emulator with Alpha CPU.
193
194%description system-alpha -l pl.UTF-8
195QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
196dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
197
198Ten pakiet zawiera emulator systemu z procesorem Alpha.
fabf5a9c
ER
199
200%package system-arm
d86014ba
JB
201Summary: QEMU system emulator for ARM
202Summary(pl.UTF-8): QEMU - emulator systemu z procesorem ARM
fabf5a9c
ER
203Group: Development/Tools
204Requires: %{name}-common = %{version}-%{release}
78a71650 205%systempkg_req
fabf5a9c
ER
206
207%description system-arm
208QEMU is a generic and open source processor emulator which achieves a
209good emulation speed by using dynamic translation.
210
d86014ba
JB
211This package provides the system emulator for ARM.
212
213%description system-arm -l pl.UTF-8
214QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
215dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
216
217Ten pakiet zawiera emulator systemu z procesorem ARM.
fabf5a9c
ER
218
219%package system-cris
220Summary: QEMU system emulator for cris
d86014ba 221Summary(pl.UTF-8): QEMU - emulator systemu z procesorem CRIS
fabf5a9c
ER
222Group: Development/Tools
223Requires: %{name}-common = %{version}-%{release}
78a71650 224%systempkg_req
fabf5a9c
ER
225
226%description system-cris
227QEMU is a generic and open source processor emulator which achieves a
228good emulation speed by using dynamic translation.
229
d86014ba
JB
230This package provides the system emulator with CRIS CPU.
231
232%description system-cris -l pl.UTF-8
233QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
234dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
235
236Ten pakiet zawiera emulator systemu z procesorem CRIS.
fabf5a9c
ER
237
238%package system-lm32
d86014ba
JB
239Summary: QEMU system emulator for LM32
240Summary(pl.UTF-8): QEMU - emulator systemu z procesorem LM32
fabf5a9c
ER
241Group: Development/Tools
242Requires: %{name}-common = %{version}-%{release}
78a71650 243%systempkg_req
fabf5a9c
ER
244
245%description system-lm32
246QEMU is a generic and open source processor emulator which achieves a
247good emulation speed by using dynamic translation.
248
d86014ba
JB
249This package provides the system emulator with LM32 CPU.
250
251%description system-lm32 -l pl.UTF-8
252QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
253dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
254
255Ten pakiet zawiera emulator systemu z procesorem LM32.
fabf5a9c
ER
256
257%package system-m68k
258Summary: QEMU system emulator for m68k
d86014ba 259Summary(pl.UTF-8): QEMU - emulator systemu z procesorem m68k
fabf5a9c
ER
260Group: Development/Tools
261Requires: %{name}-common = %{version}-%{release}
78a71650 262%systempkg_req
fabf5a9c
ER
263
264%description system-m68k
265QEMU is a generic and open source processor emulator which achieves a
266good emulation speed by using dynamic translation.
267
d86014ba
JB
268This package provides the system emulator with m68k CPU.
269
270%description system-m68k -l pl.UTF-8
271QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
272dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
273
274Ten pakiet zawiera emulator systemu z procesorem m68k.
fabf5a9c
ER
275
276%package system-microblaze
d86014ba
JB
277Summary: QEMU system emulator for MicroBlaze
278Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MicroBlaze
fabf5a9c
ER
279Group: Development/Tools
280Requires: %{name}-common = %{version}-%{release}
78a71650 281%systempkg_req
fabf5a9c
ER
282
283%description system-microblaze
284QEMU is a generic and open source processor emulator which achieves a
285good emulation speed by using dynamic translation.
286
d86014ba
JB
287This package provides the system emulator with MicroBlaze CPU.
288
289%description system-microblaze -l pl.UTF-8
290QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
291dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
292
293Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
fabf5a9c
ER
294
295%package system-mips
d86014ba
JB
296Summary: QEMU system emulator for MIPS
297Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MIPS
fabf5a9c
ER
298Group: Development/Tools
299Requires: %{name}-common = %{version}-%{release}
78a71650 300%systempkg_req
fabf5a9c
ER
301
302%description system-mips
303QEMU is a generic and open source processor emulator which achieves a
304good emulation speed by using dynamic translation.
305
d86014ba
JB
306This package provides the system emulator with MIPS CPU.
307
308%description system-mips -l pl.UTF-8
309QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
310dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
311
312Ten pakiet zawiera emulator systemu z procesorem MIPS.
fabf5a9c 313
92c357d4 314%package system-or32
d86014ba
JB
315Summary: QEMU system emulator for OpenRISC
316Summary(pl.UTF-8): QEMU - emulator systemu z procesorem OpenRISC
92c357d4
PS
317Group: Development/Tools
318Requires: %{name}-common = %{version}-%{release}
78a71650 319%systempkg_req
92c357d4
PS
320
321%description system-or32
322QEMU is a generic and open source processor emulator which achieves a
323good emulation speed by using dynamic translation.
324
d86014ba
JB
325This package provides the system emulator with OpenRISC CPU.
326
327%description system-or32 -l pl.UTF-8
328QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
329dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
330
331Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
92c357d4 332
fabf5a9c 333%package system-ppc
d86014ba
JB
334Summary: QEMU system emulator for PowerPC
335Summary(pl.UTF-8): QEMU - emulator systemu z procesorem PowerPC
fabf5a9c
ER
336Group: Development/Tools
337Requires: %{name}-common = %{version}-%{release}
78a71650 338%systempkg_req
fabf5a9c
ER
339
340%description system-ppc
341QEMU is a generic and open source processor emulator which achieves a
342good emulation speed by using dynamic translation.
343
d86014ba
JB
344This package provides the system emulator with PowerPC CPU.
345
346%description system-ppc -l pl.UTF-8
347QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
348dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
349
350Ten pakiet zawiera emulator systemu z procesorem PowerPC.
fabf5a9c
ER
351
352%package system-s390x
d86014ba
JB
353Summary: QEMU system emulator for S390
354Summary(pl.UTF-8): QEMU - emulator systemu z procesorem S390
fabf5a9c
ER
355Group: Development/Tools
356Requires: %{name}-common = %{version}-%{release}
78a71650 357%systempkg_req
fabf5a9c
ER
358
359%description system-s390x
360QEMU is a generic and open source processor emulator which achieves a
361good emulation speed by using dynamic translation.
362
d86014ba
JB
363This package provides the system emulator with S390 CPU.
364
365%description system-s390x -l pl.UTF-8
366QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
367dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
368
369Ten pakiet zawiera emulator systemu z procesorem S390.
fabf5a9c
ER
370
371%package system-sh4
d86014ba
JB
372Summary: QEMU system emulator for SH4
373Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SH4
fabf5a9c
ER
374Group: Development/Tools
375Requires: %{name}-common = %{version}-%{release}
78a71650 376%systempkg_req
fabf5a9c
ER
377
378%description system-sh4
379QEMU is a generic and open source processor emulator which achieves a
380good emulation speed by using dynamic translation.
381
d86014ba
JB
382This package provides the system emulator with SH4 CPU.
383
384%description system-sh4 -l pl.UTF-8
385QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
386dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
387
388Ten pakiet zawiera emulator systemu z procesorem SH4.
fabf5a9c
ER
389
390%package system-sparc
d86014ba
JB
391Summary: QEMU system emulator for SPARC
392Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SPARC
fabf5a9c
ER
393Group: Development/Tools
394Requires: %{name}-common = %{version}-%{release}
78a71650 395%systempkg_req
fabf5a9c
ER
396
397%description system-sparc
398QEMU is a generic and open source processor emulator which achieves a
399good emulation speed by using dynamic translation.
400
d86014ba
JB
401This package provides the system emulator with SPARC/SPARC64 CPU.
402
403%description system-sparc -l pl.UTF-8
404QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
405dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
406
407Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
fabf5a9c 408
72ddf007 409%package system-unicore32
d86014ba
JB
410Summary: QEMU system emulator for UniCore32
411Summary(pl.UTF-8): QEMU - emulator systemu z procesorem UniCore32
72ddf007
PS
412Group: Development/Tools
413Requires: %{name}-common = %{version}-%{release}
78a71650 414%systempkg_req
72ddf007
PS
415
416%description system-unicore32
417QEMU is a generic and open source processor emulator which achieves a
418good emulation speed by using dynamic translation.
419
d86014ba
JB
420This package provides the system emulator with UniCore32 CPU.
421
422%description system-unicore32 -l pl.UTF-8
423QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
424dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
425
426Ten pakiet zawiera emulator systemu z procesorem UniCore32.
72ddf007 427
fabf5a9c
ER
428%package system-x86
429Summary: QEMU system emulator for x86
d86014ba 430Summary(pl.UTF-8): QEMU - emulator systemu z procesorem x86
fabf5a9c
ER
431Group: Development/Tools
432Requires: %{name}-common = %{version}-%{release}
78a71650 433%systempkg_req
fabf5a9c
ER
434
435%description system-x86
436QEMU is a generic and open source processor emulator which achieves a
437good emulation speed by using dynamic translation.
438
d86014ba
JB
439This package provides the system emulator with x86 CPU. When being run
440in a x86 machine that supports it, this package also provides the KVM
fabf5a9c
ER
441virtualization platform.
442
d86014ba
JB
443%description system-x86 -l pl.UTF-8
444QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
445dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
446
447Ten pakiet zawiera emulator systemu z procesorem x86. W przypadku
448uruchomienia na maszynie x86 pozwalającej na to, ten pakiet udostępnia
449także platformę wirtualizacji KVM.
450
fabf5a9c 451%package system-xtensa
d86014ba
JB
452Summary: QEMU system emulator for Xtensa
453Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Xtensa
fabf5a9c
ER
454Group: Development/Tools
455Requires: %{name}-common = %{version}-%{release}
78a71650 456%systempkg_req
fabf5a9c
ER
457
458%description system-xtensa
459QEMU is a generic and open source processor emulator which achieves a
460good emulation speed by using dynamic translation.
461
d86014ba
JB
462This package provides the system emulator with Xtensa CPU.
463
464%description system-xtensa -l pl.UTF-8
465QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
466dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
467
468Ten pakiet zawiera emulator systemu z procesorem Xtensa.
fabf5a9c 469
cd19124e 470%prep
c21a255a 471%setup -q
3c6e2290 472%patch0 -p1
d9002706 473%patch1 -p1
78a71650 474%patch2 -p1
7e3ba765
JB
475%patch3 -p0
476#patch4 -p1
0b920c52 477
bd30ad73
GP
478# workaround for conflict with alsa/error.h
479ln -s ../error.h qapi/error.h
480
80bac37e 481%build
8bd2aee2 482./configure \
3c6e2290
JR
483 --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
484 --extra-ldflags="%{rpmldflags}" \
7c0786d1 485 --sysconfdir=%{_sysconfdir} \
8bd2aee2 486 --prefix=%{_prefix} \
98a1a188
AM
487 --cc="%{__cc}" \
488 --host-cc="%{__cc}" \
5263f8f5 489 --disable-strip \
78a71650
JB
490 --enable-attr \
491 --enable-bluez \
492 --enable-brlapi \
493 --enable-cap-ng \
494 --enable-curl \
495 --enable-curses \
496 --enable-fdt \
497 --enable-libiscsi \
b99b1652 498 --enable-mixemu \
78a71650
JB
499 %{__enable_disable opengl} \
500 %{__enable_disable ceph rbd} \
501 %{__enable_disable sdl} \
502 --enable-seccomp \
503 --enable-smartcard \
504 --enable-smartcard-nss \
505 --enable-usb-redir \
506 --enable-uuid \
507 --enable-vde \
508 --enable-virtfs \
509 --enable-vnc-jpeg \
510 --enable-vnc-sasl \
511 --enable-vnc-tls \
512 %{__enable_disable xen} \
513 --audio-drv-list="alsa oss%{?with_sdl: sdl}%{?with_esd: esd}%{?with_pulseaudio: pa}" \
7b81d160 514 --interp-prefix=%{_libdir}/%{name}
5263f8f5
JB
515# note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
516# --libexecdir in configure is nop
517%{__make} \
518 V=1 \
519 CONFIG_QEMU_HELPERDIR="%{_libdir}"
cd19124e 520
d9002706
PS
521# rebuild patched vesa tables with additional widescreen modes.
522%{__make} -C roms/vgabios stdvga-bios
523
cd19124e 524%install
525rm -rf $RPM_BUILD_ROOT
5a2da1d0 526
cd19124e 527%{__make} install \
5263f8f5
JB
528 DESTDIR=$RPM_BUILD_ROOT \
529 libexecdir=%{_libdir}
ac6e5743 530
a91fea76 531install -d $RPM_BUILD_ROOT%{_sysconfdir}
532cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
ac6e5743 533#!/bin/sh
a91fea76 534
ac6e5743 535EOF
a62a2d89 536
c33439fc 537# already packaged
5263f8f5
JB
538%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
539%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
c33439fc 540
d9002706
PS
541# install patched vesa tables with additional widescreen modes.
542install -m 644 roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
543
cd19124e 544%clean
545rm -rf $RPM_BUILD_ROOT
546
547%files
548%defattr(644,root,root,755)
fabf5a9c
ER
549
550%files common
551%defattr(644,root,root,755)
5263f8f5 552%doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
a91fea76 553%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
fabf5a9c 554%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
7c0786d1 555%dir %{_sysconfdir}/qemu
5263f8f5
JB
556%attr(755,root,root) %{_bindir}/virtfs-proxy-helper
557%attr(755,root,root) %{_bindir}/vscclient
fabf5a9c 558%attr(755,root,root) %{_bindir}/qemu-nbd
5263f8f5 559%attr(755,root,root) %{_libdir}/qemu-bridge-helper
cd19124e 560%{_mandir}/man1/qemu.1*
5263f8f5 561%{_mandir}/man1/virtfs-proxy-helper.1*
98a1a188 562%{_mandir}/man8/qemu-nbd.8*
fabf5a9c
ER
563
564%dir %{_datadir}/qemu
3d0e0752 565%{_datadir}/%{name}/cpus-*.conf
fabf5a9c 566%{_datadir}/%{name}/keymaps
5263f8f5 567%{_datadir}/%{name}/qemu-icon.bmp
fabf5a9c
ER
568# various bios images
569%{_datadir}/%{name}/*.bin
570%{_datadir}/%{name}/*.rom
571%{_datadir}/%{name}/*.dtb
572%{_datadir}/%{name}/openbios-ppc
573%{_datadir}/%{name}/openbios-sparc*
574%{_datadir}/%{name}/palcode-clipper
575
576%files img
577%defattr(644,root,root,755)
578%attr(755,root,root) %{_bindir}/qemu-img
579%{_mandir}/man1/qemu-img.1*
580
581%files user
582%defattr(644,root,root,755)
583%attr(755,root,root) %{_bindir}/qemu-x86_64
584%attr(755,root,root) %{_bindir}/qemu-i386
585%attr(755,root,root) %{_bindir}/qemu-alpha
586%attr(755,root,root) %{_bindir}/qemu-arm
587%attr(755,root,root) %{_bindir}/qemu-armeb
588%attr(755,root,root) %{_bindir}/qemu-cris
589%attr(755,root,root) %{_bindir}/qemu-ga
590%attr(755,root,root) %{_bindir}/qemu-io
591%attr(755,root,root) %{_bindir}/qemu-m68k
592%attr(755,root,root) %{_bindir}/qemu-microblaze
593%attr(755,root,root) %{_bindir}/qemu-microblazeel
594%attr(755,root,root) %{_bindir}/qemu-mips
595%attr(755,root,root) %{_bindir}/qemu-mipsel
92c357d4 596%attr(755,root,root) %{_bindir}/qemu-or32
fabf5a9c
ER
597%attr(755,root,root) %{_bindir}/qemu-ppc
598%attr(755,root,root) %{_bindir}/qemu-ppc64
599%attr(755,root,root) %{_bindir}/qemu-ppc64abi32
600%attr(755,root,root) %{_bindir}/qemu-s390x
601%attr(755,root,root) %{_bindir}/qemu-sh4
602%attr(755,root,root) %{_bindir}/qemu-sh4eb
603%attr(755,root,root) %{_bindir}/qemu-sparc
604%attr(755,root,root) %{_bindir}/qemu-sparc32plus
605%attr(755,root,root) %{_bindir}/qemu-sparc64
606%attr(755,root,root) %{_bindir}/qemu-unicore32
607
608%files system-alpha
609%defattr(644,root,root,755)
610%attr(755,root,root) %{_bindir}/qemu-system-alpha
611
612%files system-arm
613%defattr(644,root,root,755)
614%attr(755,root,root) %{_bindir}/qemu-system-arm
615
616%files system-cris
617%defattr(644,root,root,755)
618%attr(755,root,root) %{_bindir}/qemu-system-cris
619
620%files system-lm32
621%defattr(644,root,root,755)
622%attr(755,root,root) %{_bindir}/qemu-system-lm32
623
624%files system-m68k
625%defattr(644,root,root,755)
626%attr(755,root,root) %{_bindir}/qemu-system-m68k
627
628%files system-microblaze
629%defattr(644,root,root,755)
630%attr(755,root,root) %{_bindir}/qemu-system-microblaze
631%attr(755,root,root) %{_bindir}/qemu-system-microblazeel
632
633%files system-mips
634%defattr(644,root,root,755)
635%attr(755,root,root) %{_bindir}/qemu-system-mips
636%attr(755,root,root) %{_bindir}/qemu-system-mipsel
637%attr(755,root,root) %{_bindir}/qemu-system-mips64
638%attr(755,root,root) %{_bindir}/qemu-system-mips64el
639
92c357d4
PS
640%files system-or32
641%defattr(644,root,root,755)
642%attr(755,root,root) %{_bindir}/qemu-system-or32
643
fabf5a9c
ER
644%files system-ppc
645%defattr(644,root,root,755)
646%attr(755,root,root) %{_bindir}/qemu-system-ppc
647%attr(755,root,root) %{_bindir}/qemu-system-ppc64
648%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
649
650%files system-s390x
651%defattr(644,root,root,755)
652%attr(755,root,root) %{_bindir}/qemu-system-s390x
653
654%files system-sh4
655%defattr(644,root,root,755)
656%attr(755,root,root) %{_bindir}/qemu-system-sh4
657%attr(755,root,root) %{_bindir}/qemu-system-sh4eb
658
659%files system-sparc
660%defattr(644,root,root,755)
661%attr(755,root,root) %{_bindir}/qemu-system-sparc
662%attr(755,root,root) %{_bindir}/qemu-system-sparc64
663
72ddf007
PS
664%files system-unicore32
665%defattr(644,root,root,755)
666%attr(755,root,root) %{_bindir}/qemu-system-unicore32
667
fabf5a9c
ER
668%files system-x86
669%defattr(644,root,root,755)
670%attr(755,root,root) %{_bindir}/qemu-system-i386
671%attr(755,root,root) %{_bindir}/qemu-system-x86_64
672
673%files system-xtensa
674%defattr(644,root,root,755)
675%attr(755,root,root) %{_bindir}/qemu-system-xtensa
676%attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.137945 seconds and 4 git commands to generate.