]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- merged system-libcacard patch from qemu-kvm
[packages/qemu.git] / qemu.spec
CommitLineData
0b920c52 1# TODO:
01b9430c 2# - qemu-system-ppc -hda ac-ppc.img says:
fabf5a9c 3# qemu: could not open disk image ac-ppc.img: error "Success"
01b9430c 4# qemu-0.12.2-2.x86_64.rpm - broken
cef095a4 5# qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
fabf5a9c
ER
6# qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
7# qemu-0.11.1-*.x86_64.rpm - OK
0b920c52 8#
6aef4654 9# Conditional build:
78a71650
JB
10%bcond_without sdl # SDL UI and audio support
11%bcond_without opengl # OpenGL support
12%bcond_without ceph # Ceph/RBD support
59bc1300 13%bcond_without spice # SPICE support
78a71650
JB
14%bcond_with esd # EsounD audio support
15%bcond_without oss # OSS audio support
16%bcond_without pulseaudio # PulseAudio audio support
17%bcond_without xen # Xen backend driver support
ae8bf749 18
cd19124e 19Summary: QEMU CPU Emulator
eec0535a 20Summary(pl.UTF-8): QEMU - emulator procesora
7b81d160 21Name: qemu
697b0ba8 22Version: 1.2.0
abca2fba 23Release: 6
78a71650 24License: GPL v2+
5a2da1d0 25Group: Applications/Emulators
697b0ba8
PS
26Source0: http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
27# Source0-md5: 78eb1e984f4532aa9f2bdd3c127b5b61
9bcd4ab6 28Patch0: %{name}-cflags.patch
d9002706 29Patch1: vgabios-widescreens.patch
78a71650 30Patch2: %{name}-usbredir.patch
7e3ba765 31Patch3: %{name}-whitelist.patch
c18e9cf6 32Patch4: %{name}-system-libcacard.patch
81a493f2 33# Proof of concept, for reference, do not remove
c18e9cf6 34Patch5: %{name}-kde_virtual_workspaces_hack.patch
ae8bf749 35URL: http://www.qemu-project.org/
78a71650
JB
36%{?with_opengl:BuildRequires: OpenGL-GLX-devel}
37%{?with_sdl:BuildRequires: SDL-devel >= 1.2.1}
b0b3ca8d 38BuildRequires: alsa-lib-devel
b99b1652 39BuildRequires: bluez-libs-devel
78a71650
JB
40BuildRequires: brlapi-devel
41%{?with_ceph:BuildRequires: ceph-devel}
42BuildRequires: curl-devel
43BuildRequires: cyrus-sasl-devel >= 2
44%{?with_esd:BuildRequires: esound-devel}
45BuildRequires: glib2-devel >= 1:2.12
b99b1652 46BuildRequires: gnutls-devel
87364910 47BuildRequires: libaio-devel
c18e9cf6 48BuildRequires: libcacard-devel
78a71650
JB
49BuildRequires: libcap-devel
50BuildRequires: libcap-ng-devel
51BuildRequires: libfdt-devel
52BuildRequires: libiscsi-devel
53BuildRequires: libjpeg-devel
54BuildRequires: libpng-devel
55BuildRequires: libseccomp-devel
56BuildRequires: libuuid-devel
98a1a188 57BuildRequires: ncurses-devel
78a71650 58BuildRequires: nss-devel >= 3.12.8
995bac8b 59BuildRequires: perl-Encode
2fb8ea02 60BuildRequires: perl-tools-pod
ba84a935 61BuildRequires: pkgconfig
78a71650 62%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
8bb1261c 63BuildRequires: sed >= 4.0
59bc1300 64%if %{with spice}
78a71650
JB
65BuildRequires: spice-protocol >= 0.8.0
66BuildRequires: spice-server-devel >= 0.8.2
59bc1300 67%endif
a1146336 68BuildRequires: texi2html
22f71ecb 69BuildRequires: texinfo
78a71650
JB
70BuildRequires: usbredir-devel >= 0.3.4
71BuildRequires: vde2-devel
cad677a4 72BuildRequires: which
78a71650
JB
73%{?with_xen:BuildRequires: xen-devel >= 3.4}
74BuildRequires: xfsprogs-devel
ba84a935 75BuildRequires: xorg-lib-libX11-devel
78a71650 76BuildRequires: zlib-devel
fabf5a9c
ER
77Requires: %{name}-img = %{version}-%{release}
78Requires: %{name}-system-alpha = %{version}-%{release}
79Requires: %{name}-system-arm = %{version}-%{release}
80Requires: %{name}-system-cris = %{version}-%{release}
81Requires: %{name}-system-lm32 = %{version}-%{release}
82Requires: %{name}-system-m68k = %{version}-%{release}
83Requires: %{name}-system-microblaze = %{version}-%{release}
84Requires: %{name}-system-mips = %{version}-%{release}
92c357d4 85Requires: %{name}-system-or32 = %{version}-%{release}
ae8bf749 86Requires: %{name}-system-ppc = %{version}-%{release}
fabf5a9c
ER
87Requires: %{name}-system-s390x = %{version}-%{release}
88Requires: %{name}-system-sh4 = %{version}-%{release}
89Requires: %{name}-system-sparc = %{version}-%{release}
72ddf007 90Requires: %{name}-system-unicore32 = %{version}-%{release}
fabf5a9c
ER
91Requires: %{name}-system-x86 = %{version}-%{release}
92Requires: %{name}-system-xtensa = %{version}-%{release}
93Requires: %{name}-user = %{version}-%{release}
cd19124e 94BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
78a71650
JB
96%define systempkg_req \
97Requires: SDL >= 1.2.1
98
98a1a188 99# some PPC/SPARC boot image in ELF format
22f71ecb 100%define _noautostrip .*%{_datadir}/qemu/.*-.*
a154aede 101
cd19124e 102%description
103QEMU is a FAST! processor emulator. By using dynamic translation it
104achieves a reasonnable speed while being easy to port on new host
105CPUs. QEMU has two operating modes:
106
107- User mode emulation. In this mode, QEMU can launch Linux processes
108 compiled for one CPU on another CPU. Linux system calls are converted
109 because of endianness and 32/64 bit mismatches. Wine (Windows
110 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
111
112- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
113 including a processor and various peripherials. It can also be used to
114 provide virtual hosting of several virtual PC on a single server.
cd19124e 115
27b30e9c
JR
116%description -l pl.UTF-8
117QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
118tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
119aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
5a2da1d0 120
27b30e9c 121- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
5a2da1d0 122 procesy linuksowe skompilowane dla jednego procesora na innym
27b30e9c
JR
123 procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
124 niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
125 słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
5a2da1d0
JB
126 cele QEMU.
127
27b30e9c
JR
128- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
129 włączając w to procesor i różne urządzenia peryferyjne. Może być także
130 używane do wirtualnego hostowania kilku wirtualnych pecetów na
8799423b 131 pojedynczym serwerze.
5a2da1d0 132
d86014ba 133%package common
fabf5a9c 134Summary: QEMU common files needed by all QEMU targets
d86014ba 135Summary(pl.UTF-8): Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
fabf5a9c 136Group: Development/Tools
78a71650 137Requires: glib2 >= 1:2.12
fabf5a9c
ER
138Conflicts: qemu < 1.0-2
139
140%description common
141QEMU is a generic and open source processor emulator which achieves a
142good emulation speed by using dynamic translation.
143
144This package provides the common files needed by all QEMU targets.
145
d86014ba
JB
146%description common -l pl.UTF-8
147QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
148dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
149
150Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
151środowiska QEMU.
152
153%package img
fabf5a9c 154Summary: QEMU command line tool for manipulating disk images
d86014ba 155Summary(pl.UTF-8): Narzędzie QEMU do operacji na obrazach dysków
fabf5a9c
ER
156Group: Development/Tools
157Conflicts: qemu < 1.0-2
158
159%description img
d86014ba
JB
160This package provides a command line tool for manipulating disk
161images.
162
163%description img -l pl.UTF-8
164Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
165na obrazach dysków.
fabf5a9c
ER
166
167%package user
168Summary: QEMU user mode emulation of qemu targets
d86014ba 169Summary(pl.UTF-8): QEMU - emulacja trybu użytkownika środowisk qemu
fabf5a9c
ER
170Group: Development/Tools
171Requires: %{name}-common = %{version}-%{release}
172
173%description user
174QEMU is a generic and open source processor emulator which achieves a
175good emulation speed by using dynamic translation.
176
177This package provides the user mode emulation of QEMU targets.
178
d86014ba
JB
179%description user -l pl.UTF-8
180QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
181dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
182
183Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
184
fabf5a9c 185%package system-alpha
d86014ba
JB
186Summary: QEMU system emulator for Alpha
187Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Alpha
fabf5a9c
ER
188Group: Development/Tools
189Requires: %{name}-common = %{version}-%{release}
78a71650 190%systempkg_req
fabf5a9c
ER
191
192%description system-alpha
193QEMU is a generic and open source processor emulator which achieves a
194good emulation speed by using dynamic translation.
195
d86014ba
JB
196This package provides the system emulator with Alpha CPU.
197
198%description system-alpha -l pl.UTF-8
199QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
200dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
201
202Ten pakiet zawiera emulator systemu z procesorem Alpha.
fabf5a9c
ER
203
204%package system-arm
d86014ba
JB
205Summary: QEMU system emulator for ARM
206Summary(pl.UTF-8): QEMU - emulator systemu z procesorem ARM
fabf5a9c
ER
207Group: Development/Tools
208Requires: %{name}-common = %{version}-%{release}
78a71650 209%systempkg_req
fabf5a9c
ER
210
211%description system-arm
212QEMU is a generic and open source processor emulator which achieves a
213good emulation speed by using dynamic translation.
214
d86014ba
JB
215This package provides the system emulator for ARM.
216
217%description system-arm -l pl.UTF-8
218QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
219dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
220
221Ten pakiet zawiera emulator systemu z procesorem ARM.
fabf5a9c
ER
222
223%package system-cris
59bc1300 224Summary: QEMU system emulator for CRIS
d86014ba 225Summary(pl.UTF-8): QEMU - emulator systemu z procesorem CRIS
fabf5a9c
ER
226Group: Development/Tools
227Requires: %{name}-common = %{version}-%{release}
78a71650 228%systempkg_req
fabf5a9c
ER
229
230%description system-cris
231QEMU is a generic and open source processor emulator which achieves a
232good emulation speed by using dynamic translation.
233
d86014ba
JB
234This package provides the system emulator with CRIS CPU.
235
236%description system-cris -l pl.UTF-8
237QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
238dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
239
240Ten pakiet zawiera emulator systemu z procesorem CRIS.
fabf5a9c
ER
241
242%package system-lm32
d86014ba
JB
243Summary: QEMU system emulator for LM32
244Summary(pl.UTF-8): QEMU - emulator systemu z procesorem LM32
fabf5a9c
ER
245Group: Development/Tools
246Requires: %{name}-common = %{version}-%{release}
78a71650 247%systempkg_req
fabf5a9c
ER
248
249%description system-lm32
250QEMU is a generic and open source processor emulator which achieves a
251good emulation speed by using dynamic translation.
252
d86014ba
JB
253This package provides the system emulator with LM32 CPU.
254
255%description system-lm32 -l pl.UTF-8
256QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
257dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
258
259Ten pakiet zawiera emulator systemu z procesorem LM32.
fabf5a9c
ER
260
261%package system-m68k
262Summary: QEMU system emulator for m68k
d86014ba 263Summary(pl.UTF-8): QEMU - emulator systemu z procesorem m68k
fabf5a9c
ER
264Group: Development/Tools
265Requires: %{name}-common = %{version}-%{release}
78a71650 266%systempkg_req
fabf5a9c
ER
267
268%description system-m68k
269QEMU is a generic and open source processor emulator which achieves a
270good emulation speed by using dynamic translation.
271
d86014ba
JB
272This package provides the system emulator with m68k CPU.
273
274%description system-m68k -l pl.UTF-8
275QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
276dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
277
278Ten pakiet zawiera emulator systemu z procesorem m68k.
fabf5a9c
ER
279
280%package system-microblaze
d86014ba
JB
281Summary: QEMU system emulator for MicroBlaze
282Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MicroBlaze
fabf5a9c
ER
283Group: Development/Tools
284Requires: %{name}-common = %{version}-%{release}
78a71650 285%systempkg_req
fabf5a9c
ER
286
287%description system-microblaze
288QEMU is a generic and open source processor emulator which achieves a
289good emulation speed by using dynamic translation.
290
d86014ba
JB
291This package provides the system emulator with MicroBlaze CPU.
292
293%description system-microblaze -l pl.UTF-8
294QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
295dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
296
297Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
fabf5a9c
ER
298
299%package system-mips
d86014ba
JB
300Summary: QEMU system emulator for MIPS
301Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MIPS
fabf5a9c
ER
302Group: Development/Tools
303Requires: %{name}-common = %{version}-%{release}
78a71650 304%systempkg_req
fabf5a9c
ER
305
306%description system-mips
307QEMU is a generic and open source processor emulator which achieves a
308good emulation speed by using dynamic translation.
309
d86014ba
JB
310This package provides the system emulator with MIPS CPU.
311
312%description system-mips -l pl.UTF-8
313QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
314dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
315
316Ten pakiet zawiera emulator systemu z procesorem MIPS.
fabf5a9c 317
92c357d4 318%package system-or32
d86014ba
JB
319Summary: QEMU system emulator for OpenRISC
320Summary(pl.UTF-8): QEMU - emulator systemu z procesorem OpenRISC
92c357d4
PS
321Group: Development/Tools
322Requires: %{name}-common = %{version}-%{release}
78a71650 323%systempkg_req
92c357d4
PS
324
325%description system-or32
326QEMU is a generic and open source processor emulator which achieves a
327good emulation speed by using dynamic translation.
328
d86014ba
JB
329This package provides the system emulator with OpenRISC CPU.
330
331%description system-or32 -l pl.UTF-8
332QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
333dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
334
335Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
92c357d4 336
fabf5a9c 337%package system-ppc
d86014ba
JB
338Summary: QEMU system emulator for PowerPC
339Summary(pl.UTF-8): QEMU - emulator systemu z procesorem PowerPC
fabf5a9c
ER
340Group: Development/Tools
341Requires: %{name}-common = %{version}-%{release}
78a71650 342%systempkg_req
fabf5a9c
ER
343
344%description system-ppc
345QEMU is a generic and open source processor emulator which achieves a
346good emulation speed by using dynamic translation.
347
d86014ba
JB
348This package provides the system emulator with PowerPC CPU.
349
350%description system-ppc -l pl.UTF-8
351QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
352dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
353
354Ten pakiet zawiera emulator systemu z procesorem PowerPC.
fabf5a9c
ER
355
356%package system-s390x
d86014ba
JB
357Summary: QEMU system emulator for S390
358Summary(pl.UTF-8): QEMU - emulator systemu z procesorem S390
fabf5a9c
ER
359Group: Development/Tools
360Requires: %{name}-common = %{version}-%{release}
78a71650 361%systempkg_req
fabf5a9c
ER
362
363%description system-s390x
364QEMU is a generic and open source processor emulator which achieves a
365good emulation speed by using dynamic translation.
366
d86014ba
JB
367This package provides the system emulator with S390 CPU.
368
369%description system-s390x -l pl.UTF-8
370QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
371dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
372
373Ten pakiet zawiera emulator systemu z procesorem S390.
fabf5a9c
ER
374
375%package system-sh4
d86014ba
JB
376Summary: QEMU system emulator for SH4
377Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SH4
fabf5a9c
ER
378Group: Development/Tools
379Requires: %{name}-common = %{version}-%{release}
78a71650 380%systempkg_req
fabf5a9c
ER
381
382%description system-sh4
383QEMU is a generic and open source processor emulator which achieves a
384good emulation speed by using dynamic translation.
385
d86014ba
JB
386This package provides the system emulator with SH4 CPU.
387
388%description system-sh4 -l pl.UTF-8
389QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
390dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
391
392Ten pakiet zawiera emulator systemu z procesorem SH4.
fabf5a9c
ER
393
394%package system-sparc
d86014ba
JB
395Summary: QEMU system emulator for SPARC
396Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SPARC
fabf5a9c
ER
397Group: Development/Tools
398Requires: %{name}-common = %{version}-%{release}
78a71650 399%systempkg_req
fabf5a9c
ER
400
401%description system-sparc
402QEMU is a generic and open source processor emulator which achieves a
403good emulation speed by using dynamic translation.
404
d86014ba
JB
405This package provides the system emulator with SPARC/SPARC64 CPU.
406
407%description system-sparc -l pl.UTF-8
408QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
409dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
410
411Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
fabf5a9c 412
72ddf007 413%package system-unicore32
d86014ba
JB
414Summary: QEMU system emulator for UniCore32
415Summary(pl.UTF-8): QEMU - emulator systemu z procesorem UniCore32
72ddf007
PS
416Group: Development/Tools
417Requires: %{name}-common = %{version}-%{release}
78a71650 418%systempkg_req
72ddf007
PS
419
420%description system-unicore32
421QEMU is a generic and open source processor emulator which achieves a
422good emulation speed by using dynamic translation.
423
d86014ba
JB
424This package provides the system emulator with UniCore32 CPU.
425
426%description system-unicore32 -l pl.UTF-8
427QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
428dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
429
430Ten pakiet zawiera emulator systemu z procesorem UniCore32.
72ddf007 431
fabf5a9c
ER
432%package system-x86
433Summary: QEMU system emulator for x86
d86014ba 434Summary(pl.UTF-8): QEMU - emulator systemu z procesorem x86
fabf5a9c
ER
435Group: Development/Tools
436Requires: %{name}-common = %{version}-%{release}
78a71650 437%systempkg_req
fabf5a9c
ER
438
439%description system-x86
440QEMU is a generic and open source processor emulator which achieves a
441good emulation speed by using dynamic translation.
442
d86014ba
JB
443%description system-x86 -l pl.UTF-8
444QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
445dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
446
fabf5a9c 447%package system-xtensa
d86014ba
JB
448Summary: QEMU system emulator for Xtensa
449Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Xtensa
fabf5a9c
ER
450Group: Development/Tools
451Requires: %{name}-common = %{version}-%{release}
78a71650 452%systempkg_req
fabf5a9c
ER
453
454%description system-xtensa
455QEMU is a generic and open source processor emulator which achieves a
456good emulation speed by using dynamic translation.
457
d86014ba
JB
458This package provides the system emulator with Xtensa CPU.
459
460%description system-xtensa -l pl.UTF-8
461QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
462dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
463
464Ten pakiet zawiera emulator systemu z procesorem Xtensa.
fabf5a9c 465
cd19124e 466%prep
c21a255a 467%setup -q
3c6e2290 468%patch0 -p1
d9002706 469%patch1 -p1
78a71650 470%patch2 -p1
7e3ba765 471%patch3 -p0
c18e9cf6
JB
472%patch4 -p1
473
474%{__mv} libcacard libcacard-use-system-lib
0b920c52 475
bd30ad73
GP
476# workaround for conflict with alsa/error.h
477ln -s ../error.h qapi/error.h
478
80bac37e 479%build
8bd2aee2 480./configure \
3c6e2290
JR
481 --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
482 --extra-ldflags="%{rpmldflags}" \
8bd2aee2 483 --prefix=%{_prefix} \
87364910 484 --sysconfdir=%{_sysconfdir} \
98a1a188
AM
485 --cc="%{__cc}" \
486 --host-cc="%{__cc}" \
5263f8f5 487 --disable-strip \
78a71650
JB
488 --enable-attr \
489 --enable-bluez \
490 --enable-brlapi \
491 --enable-cap-ng \
492 --enable-curl \
493 --enable-curses \
87364910 494 --enable-docs \
78a71650
JB
495 --enable-fdt \
496 --enable-libiscsi \
b99b1652 497 --enable-mixemu \
78a71650
JB
498 %{__enable_disable opengl} \
499 %{__enable_disable ceph rbd} \
500 %{__enable_disable sdl} \
501 --enable-seccomp \
59bc1300 502 %{__enable_disable spice} \
78a71650
JB
503 --enable-smartcard \
504 --enable-smartcard-nss \
505 --enable-usb-redir \
506 --enable-uuid \
507 --enable-vde \
508 --enable-virtfs \
509 --enable-vnc-jpeg \
87364910 510 --enable-vnc-png \
78a71650
JB
511 --enable-vnc-sasl \
512 --enable-vnc-tls \
513 %{__enable_disable xen} \
87364910
JB
514 --audio-card-list="ac97,es1370,sb16,cs4231a,adlib,gus,hda" \
515 --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
516 --interp-prefix=%{_libdir}/qemu/lib-%%M
5263f8f5
JB
517# note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
518# --libexecdir in configure is nop
519%{__make} \
520 V=1 \
521 CONFIG_QEMU_HELPERDIR="%{_libdir}"
cd19124e 522
d9002706
PS
523# rebuild patched vesa tables with additional widescreen modes.
524%{__make} -C roms/vgabios stdvga-bios
525
cd19124e 526%install
527rm -rf $RPM_BUILD_ROOT
5a2da1d0 528
cd19124e 529%{__make} install \
5263f8f5
JB
530 DESTDIR=$RPM_BUILD_ROOT \
531 libexecdir=%{_libdir}
ac6e5743 532
a91fea76 533install -d $RPM_BUILD_ROOT%{_sysconfdir}
534cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
ac6e5743 535#!/bin/sh
a91fea76 536
ac6e5743 537EOF
a62a2d89 538
c33439fc 539# already packaged
5263f8f5
JB
540%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
541%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
c33439fc 542
d9002706 543# install patched vesa tables with additional widescreen modes.
ae8bf749 544cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
d9002706 545
cd19124e 546%clean
547rm -rf $RPM_BUILD_ROOT
548
549%files
550%defattr(644,root,root,755)
fabf5a9c
ER
551
552%files common
553%defattr(644,root,root,755)
5263f8f5 554%doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
a91fea76 555%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
fabf5a9c 556%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
7c0786d1 557%dir %{_sysconfdir}/qemu
5263f8f5 558%attr(755,root,root) %{_bindir}/virtfs-proxy-helper
fabf5a9c 559%attr(755,root,root) %{_bindir}/qemu-nbd
5263f8f5 560%attr(755,root,root) %{_libdir}/qemu-bridge-helper
cd19124e 561%{_mandir}/man1/qemu.1*
5263f8f5 562%{_mandir}/man1/virtfs-proxy-helper.1*
98a1a188 563%{_mandir}/man8/qemu-nbd.8*
fabf5a9c
ER
564
565%dir %{_datadir}/qemu
3d0e0752 566%{_datadir}/%{name}/cpus-*.conf
fabf5a9c 567%{_datadir}/%{name}/keymaps
5263f8f5 568%{_datadir}/%{name}/qemu-icon.bmp
fabf5a9c
ER
569# various bios images
570%{_datadir}/%{name}/*.bin
571%{_datadir}/%{name}/*.rom
572%{_datadir}/%{name}/*.dtb
573%{_datadir}/%{name}/openbios-ppc
574%{_datadir}/%{name}/openbios-sparc*
575%{_datadir}/%{name}/palcode-clipper
576
577%files img
578%defattr(644,root,root,755)
579%attr(755,root,root) %{_bindir}/qemu-img
580%{_mandir}/man1/qemu-img.1*
581
582%files user
583%defattr(644,root,root,755)
fabf5a9c
ER
584%attr(755,root,root) %{_bindir}/qemu-alpha
585%attr(755,root,root) %{_bindir}/qemu-arm
586%attr(755,root,root) %{_bindir}/qemu-armeb
587%attr(755,root,root) %{_bindir}/qemu-cris
588%attr(755,root,root) %{_bindir}/qemu-ga
59bc1300 589%attr(755,root,root) %{_bindir}/qemu-i386
fabf5a9c
ER
590%attr(755,root,root) %{_bindir}/qemu-io
591%attr(755,root,root) %{_bindir}/qemu-m68k
592%attr(755,root,root) %{_bindir}/qemu-microblaze
593%attr(755,root,root) %{_bindir}/qemu-microblazeel
594%attr(755,root,root) %{_bindir}/qemu-mips
595%attr(755,root,root) %{_bindir}/qemu-mipsel
92c357d4 596%attr(755,root,root) %{_bindir}/qemu-or32
fabf5a9c
ER
597%attr(755,root,root) %{_bindir}/qemu-ppc
598%attr(755,root,root) %{_bindir}/qemu-ppc64
599%attr(755,root,root) %{_bindir}/qemu-ppc64abi32
600%attr(755,root,root) %{_bindir}/qemu-s390x
601%attr(755,root,root) %{_bindir}/qemu-sh4
602%attr(755,root,root) %{_bindir}/qemu-sh4eb
603%attr(755,root,root) %{_bindir}/qemu-sparc
604%attr(755,root,root) %{_bindir}/qemu-sparc32plus
605%attr(755,root,root) %{_bindir}/qemu-sparc64
606%attr(755,root,root) %{_bindir}/qemu-unicore32
59bc1300 607%attr(755,root,root) %{_bindir}/qemu-x86_64
fabf5a9c
ER
608
609%files system-alpha
610%defattr(644,root,root,755)
611%attr(755,root,root) %{_bindir}/qemu-system-alpha
612
613%files system-arm
614%defattr(644,root,root,755)
615%attr(755,root,root) %{_bindir}/qemu-system-arm
616
617%files system-cris
618%defattr(644,root,root,755)
619%attr(755,root,root) %{_bindir}/qemu-system-cris
620
621%files system-lm32
622%defattr(644,root,root,755)
623%attr(755,root,root) %{_bindir}/qemu-system-lm32
624
625%files system-m68k
626%defattr(644,root,root,755)
627%attr(755,root,root) %{_bindir}/qemu-system-m68k
628
629%files system-microblaze
630%defattr(644,root,root,755)
631%attr(755,root,root) %{_bindir}/qemu-system-microblaze
632%attr(755,root,root) %{_bindir}/qemu-system-microblazeel
633
634%files system-mips
635%defattr(644,root,root,755)
636%attr(755,root,root) %{_bindir}/qemu-system-mips
637%attr(755,root,root) %{_bindir}/qemu-system-mipsel
638%attr(755,root,root) %{_bindir}/qemu-system-mips64
639%attr(755,root,root) %{_bindir}/qemu-system-mips64el
640
92c357d4
PS
641%files system-or32
642%defattr(644,root,root,755)
643%attr(755,root,root) %{_bindir}/qemu-system-or32
644
fabf5a9c
ER
645%files system-ppc
646%defattr(644,root,root,755)
647%attr(755,root,root) %{_bindir}/qemu-system-ppc
648%attr(755,root,root) %{_bindir}/qemu-system-ppc64
649%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
650
651%files system-s390x
652%defattr(644,root,root,755)
653%attr(755,root,root) %{_bindir}/qemu-system-s390x
654
655%files system-sh4
656%defattr(644,root,root,755)
657%attr(755,root,root) %{_bindir}/qemu-system-sh4
658%attr(755,root,root) %{_bindir}/qemu-system-sh4eb
659
660%files system-sparc
661%defattr(644,root,root,755)
662%attr(755,root,root) %{_bindir}/qemu-system-sparc
663%attr(755,root,root) %{_bindir}/qemu-system-sparc64
664
72ddf007
PS
665%files system-unicore32
666%defattr(644,root,root,755)
667%attr(755,root,root) %{_bindir}/qemu-system-unicore32
668
fabf5a9c
ER
669%files system-x86
670%defattr(644,root,root,755)
671%attr(755,root,root) %{_bindir}/qemu-system-i386
672%attr(755,root,root) %{_bindir}/qemu-system-x86_64
673
674%files system-xtensa
675%defattr(644,root,root,755)
676%attr(755,root,root) %{_bindir}/qemu-system-xtensa
677%attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.152445 seconds and 4 git commands to generate.