]> git.pld-linux.org Git - packages/python3.git/commitdiff
- updated to 3.10.6
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 22 Aug 2022 16:37:13 +0000 (18:37 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 22 Aug 2022 16:37:13 +0000 (18:37 +0200)
- updated multilib,tests_with_pythonpath patches

python3-multilib.patch
python3-tests_with_pythonpath.patch
python3.spec

index cab410e6570bed530cf923d45e47a5f759c46428..b8e2fbdbfadf0e156ecd37d18b0719659a7c3907 100644 (file)
@@ -141,10 +141,10 @@ diff -urNp -x '*.orig' Python-3.9.2.org/setup.py Python-3.9.2/setup.py
                                 extra_link_args=readline_extra_link_args,
                                 libraries=readline_libs))
          else:
---- Python-3.10.3/Lib/test/test_sysconfig.py~  2022-03-16 12:27:11.000000000 +0100
-+++ Python-3.10.3/Lib/test/test_sysconfig.py   2022-03-22 23:11:16.335919644 +0100
-@@ -299,13 +299,13 @@
-                 expected = global_path.replace(base, user, 1)
+--- Python-3.10.6/Lib/test/test_sysconfig.py.orig      2022-08-22 06:15:16.895139554 +0200
++++ Python-3.10.6/Lib/test/test_sysconfig.py   2022-08-22 06:18:57.331178879 +0200
+@@ -299,13 +299,13 @@ class TestSysConfig(unittest.TestCase):
+                 expected = os.path.normpath(global_path.replace(base, user, 1))
                  # bpo-44860: platlib of posix_user doesn't use sys.platlibdir,
                  # whereas posix_prefix does.
 -                if name == 'platlib':
index c24df66e6bf033f870fa715501872c8b25a7c87a..03b450a30f4e9566431a73ebef8affc46031dd08 100644 (file)
@@ -36,33 +36,32 @@ diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_cmd_line.py Python-3.9.2/L
      def test_empty_PYTHONPATH_issue16309(self):
          # On Posix, it is documented that setting PATH to the
          # empty string is equivalent to not setting PATH at all,
-diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_compileall.py Python-3.9.2/Lib/test/test_compileall.py
---- Python-3.9.2.org/Lib/test/test_compileall.py       2021-02-25 18:41:39.412060338 +0100
-+++ Python-3.9.2/Lib/test/test_compileall.py   2021-02-25 18:41:41.098779547 +0100
-@@ -486,6 +486,7 @@ class CommandLineTestsBase:
-         self.initfn = script_helper.make_script(self.pkgdir, '__init__', '')
-         self.barfn = script_helper.make_script(self.pkgdir, 'bar', '')
+--- Python-3.10.6/Lib/test/test_compileall.py.orig     2022-08-21 08:24:26.562151782 +0200
++++ Python-3.10.6/Lib/test/test_compileall.py  2022-08-22 16:36:51.754553471 +0200
+@@ -508,6 +508,7 @@ class CommandLineTestsBase:
+         path = importlib.util.cache_from_source(fn)
+         self.assertFalse(os.path.exists(path))
  
 +    @unittest.skipIf("PYTHONPATH" in os.environ, "$PYTHONPATH set")
      def test_no_args_compiles_path(self):
          # Note that -l is implied for the no args case.
-         self._skip_if_sys_path_not_writable()
-@@ -495,6 +496,7 @@ class CommandLineTestsBase:
-         self.assertNotCompiled(self.initfn)
-         self.assertNotCompiled(self.barfn)
+         bazfn = script_helper.make_script(self.directory, 'baz', '')
+@@ -517,6 +518,7 @@ class CommandLineTestsBase:
+             self.assertNotCompiled(self.initfn)
+             self.assertNotCompiled(self.barfn)
  
 +    @unittest.skipIf("PYTHONPATH" in os.environ, "$PYTHONPATH set")
      @without_source_date_epoch  # timestamp invalidation test
      def test_no_args_respects_force_flag(self):
-         self._skip_if_sys_path_not_writable()
-@@ -513,6 +515,7 @@ class CommandLineTestsBase:
+         bazfn = script_helper.make_script(self.directory, 'baz', '')
+@@ -535,6 +537,7 @@ class CommandLineTestsBase:
          mtime2 = os.stat(pycpath).st_mtime
          self.assertNotEqual(mtime, mtime2)
  
 +    @unittest.skipIf("PYTHONPATH" in os.environ, "$PYTHONPATH set")
      def test_no_args_respects_quiet_flag(self):
-         self._skip_if_sys_path_not_writable()
          script_helper.make_script(self.directory, 'baz', '')
+         with self.temporary_pycache_prefix() as env:
 diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_pydoc.py Python-3.9.2/Lib/test/test_pydoc.py
 --- Python-3.9.2.org/Lib/test/test_pydoc.py    2021-02-19 13:31:44.000000000 +0100
 +++ Python-3.9.2/Lib/test/test_pydoc.py        2021-02-25 18:41:41.098779547 +0100
index 0fcc90ea54cc92a1d8d1db54950002ef1a613985..670676dfb723ac9450491381d27ec74dffec7fb7 100644 (file)
@@ -47,13 +47,13 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.4
-Release:       5
+Version:       %{py_ver}.6
+Release:       1
 Epoch:         1
 License:       PSF
 Group:         Development/Languages/Python
 Source0:       https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
-# Source0-md5: 21f2e113e087083a1e8cf10553d93599
+# Source0-md5: afc7e14f7118d10d1ba95ae8e2134bf0
 Source1:       pyconfig.h.in
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
This page took 0.356437 seconds and 4 git commands to generate.