]> git.pld-linux.org Git - packages/python3.git/commitdiff
- rel 2; atomic fixes auto/th/python3-3.5.0-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 30 Oct 2015 19:20:15 +0000 (20:20 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 30 Oct 2015 19:20:15 +0000 (20:20 +0100)
python3-atomic.patch [new file with mode: 0644]
python3.spec

diff --git a/python3-atomic.patch b/python3-atomic.patch
new file mode 100644 (file)
index 0000000..be77c2a
--- /dev/null
@@ -0,0 +1,78 @@
+
+# HG changeset patch
+# User Victor Stinner <victor.stinner@gmail.com>
+# Date 1442581594 -7200
+# Node ID d4fcb362f7c66b25b22ddc0d27db0cc96acc727b
+# Parent  d04a0954e142f873adee88ec5bc1c1d81cd46bc4
+Issue #25150: Hide the private _Py_atomic_xxx symbols from the public
+Python.h header to fix a compilation error with OpenMP. PyThreadState_GET()
+becomes an alias to PyThreadState_Get() to avoid ABI incompatibilies.
+
+It is important that the _PyThreadState_Current variable is always accessed
+with the same implementation of pyatomic.h. Use the PyThreadState_Get()
+function so extension modules will all reuse the same implementation.
+
+diff --git a/Include/pyatomic.h b/Include/pyatomic.h
+--- a/Include/pyatomic.h
++++ b/Include/pyatomic.h
+@@ -1,8 +1,6 @@
+-/* Issue #23644: <stdatomic.h> is incompatible with C++, see:
+-   https://gcc.gnu.org/bugzilla/show_bug.cgi?id=60932 */
+-#if !defined(Py_LIMITED_API) && !defined(__cplusplus)
+ #ifndef Py_ATOMIC_H
+ #define Py_ATOMIC_H
++#ifdef Py_BUILD_CORE
+ #include "dynamic_annotations.h"
+@@ -248,5 +246,5 @@ static __inline__ void
+ #define _Py_atomic_load_relaxed(ATOMIC_VAL) \
+     _Py_atomic_load_explicit(ATOMIC_VAL, _Py_memory_order_relaxed)
++#endif  /* Py_BUILD_CORE */
+ #endif  /* Py_ATOMIC_H */
+-#endif  /* Py_LIMITED_API */
+diff --git a/Include/pystate.h b/Include/pystate.h
+--- a/Include/pystate.h
++++ b/Include/pystate.h
+@@ -177,20 +177,13 @@ PyAPI_FUNC(int) PyThreadState_SetAsyncEx
+ /* Variable and macro for in-line access to current thread state */
+ /* Assuming the current thread holds the GIL, this is the
+-   PyThreadState for the current thread.
+-
+-   Issue #23644: pyatomic.h is incompatible with C++ (yet). Disable
+-   PyThreadState_GET() optimization: declare it as an alias to
+-   PyThreadState_Get(), as done for limited API. */
+-#if !defined(Py_LIMITED_API) && !defined(__cplusplus)
++   PyThreadState for the current thread. */
++#ifdef Py_BUILD_CORE
+ PyAPI_DATA(_Py_atomic_address) _PyThreadState_Current;
+-#endif
+-
+-#if defined(Py_DEBUG) || defined(Py_LIMITED_API) || defined(__cplusplus)
+-#define PyThreadState_GET() PyThreadState_Get()
++#  define PyThreadState_GET() \
++             ((PyThreadState*)_Py_atomic_load_relaxed(&_PyThreadState_Current))
+ #else
+-#define PyThreadState_GET() \
+-    ((PyThreadState*)_Py_atomic_load_relaxed(&_PyThreadState_Current))
++#  define PyThreadState_GET() PyThreadState_Get()
+ #endif
+ typedef
+diff --git a/Misc/NEWS b/Misc/NEWS
+--- a/Misc/NEWS
++++ b/Misc/NEWS
+@@ -11,6 +11,10 @@ Release date: TBA
+ Core and Builtins
+ -----------------
++- Issue #25150: Hide the private _Py_atomic_xxx symbols from the public
++  Python.h header to fix a compilation error with OpenMP. PyThreadState_GET()
++  becomes an alias to PyThreadState_Get() to avoid ABI incompatibilies.
++
+ Library
+ -------
+
index 2b27057ace4fa4d8878c42e869ab5f0ec8ce13b3..86f2223ced3662440e725cabda01a67574684744 100644 (file)
@@ -38,7 +38,7 @@ Summary(tr.UTF-8):    X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
 Version:       %{py_ver}.0
-Release:       1
+Release:       2
 Epoch:         1
 License:       PSF
 Group:         Applications
@@ -50,7 +50,7 @@ Patch2:               %{name}-lib64.patch
 Patch3:                %{name}-noarch_to_datadir.patch
 Patch4:                %{name}-no_cmdline_tests.patch
 Patch5:                %{name}-makefile-location.patch
-
+Patch6:                python3-atomic.patch
 Patch7:                python-distro.patch
 Patch8:                %{name}-db.patch
 URL:           http://www.python.org/
@@ -472,7 +472,7 @@ Moduły testowe dla Pythona.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-
+%patch6 -p1
 %patch7 -p1
 %patch8 -p1
 
This page took 0.047538 seconds and 4 git commands to generate.