]> git.pld-linux.org Git - packages/python3.git/commitdiff
- ver. 3.3.2 auto/th/python3-3.3.2-1 auto/ti/python3-3.3.2-1
authorwrobell <wrobell@pld-linux.org>
Sun, 26 May 2013 22:59:04 +0000 (23:59 +0100)
committerwrobell <wrobell@pld-linux.org>
Sun, 26 May 2013 22:59:04 +0000 (23:59 +0100)
python3-sysloghandler.patch [deleted file]
python3.spec

diff --git a/python3-sysloghandler.patch b/python3-sysloghandler.patch
deleted file mode 100644 (file)
index 2edaaad..0000000
+++ /dev/null
@@ -1,88 +0,0 @@
-
-# HG changeset patch
-# User Vinay Sajip <vinay_sajip@yahoo.co.uk>
-# Date 1366621660 -3600
-# Node ID d037847137866e850abc5b8e4136ca60404dcfcb
-# Parent  9df9931fae96ab5f1cd2e516f065dccb9c061c18
-Issue #17795: Reverted backwards-incompatible change in SysLogHandler with Unix domain sockets.
-
-diff --git a/Lib/logging/handlers.py b/Lib/logging/handlers.py
---- a/Lib/logging/handlers.py
-+++ b/Lib/logging/handlers.py
-@@ -1,4 +1,4 @@
--# Copyright 2001-2012 by Vinay Sajip. All Rights Reserved.
-+# Copyright 2001-2013 by Vinay Sajip. All Rights Reserved.
- #
- # Permission to use, copy, modify, and distribute this software and its
- # documentation for any purpose and without fee is hereby granted,
-@@ -18,7 +18,7 @@
- Additional handlers for the logging package for Python. The core package is
- based on PEP 282 and comments thereto in comp.lang.python.
--Copyright (C) 2001-2012 Vinay Sajip. All Rights Reserved.
-+Copyright (C) 2001-2013 Vinay Sajip. All Rights Reserved.
- To use, simply 'import logging.handlers' and log away!
- """
-@@ -767,7 +767,7 @@ class SysLogHandler(logging.Handler):
-     }
-     def __init__(self, address=('localhost', SYSLOG_UDP_PORT),
--                 facility=LOG_USER, socktype=socket.SOCK_DGRAM):
-+                 facility=LOG_USER, socktype=None):
-         """
-         Initialize a handler.
-@@ -786,18 +786,37 @@ class SysLogHandler(logging.Handler):
-             self._connect_unixsocket(address)
-         else:
-             self.unixsocket = False
-+            if socktype is None:
-+                socktype = socket.SOCK_DGRAM
-             self.socket = socket.socket(socket.AF_INET, socktype)
-             if socktype == socket.SOCK_STREAM:
-                 self.socket.connect(address)
-+            self.socktype = socktype
-         self.formatter = None
-     def _connect_unixsocket(self, address):
--        self.socket = socket.socket(socket.AF_UNIX, self.socktype)
-+        use_socktype = self.socktype
-+        if use_socktype is None:
-+            use_socktype = socket.SOCK_DGRAM
-+        self.socket = socket.socket(socket.AF_UNIX, use_socktype)
-         try:
-             self.socket.connect(address)
-+            # it worked, so set self.socktype to the used type
-+            self.socktype = use_socktype
-         except socket.error:
-             self.socket.close()
--            raise
-+            if self.socktype is not None:
-+                # user didn't specify falling back, so fail
-+                raise
-+            use_socktype = socket.SOCK_STREAM
-+            self.socket = socket.socket(socket.AF_UNIX, use_socktype)
-+            try:
-+                self.socket.connect(address)
-+                # it worked, so set self.socktype to the used type
-+                self.socktype = use_socktype
-+            except socket.error:
-+                self.socket.close()
-+                raise
-     def encodePriority(self, facility, priority):
-         """
-diff --git a/Misc/NEWS b/Misc/NEWS
---- a/Misc/NEWS
-+++ b/Misc/NEWS
-@@ -15,6 +15,9 @@
- Library
- -------
-+- Issue #17795: Reverted backwards-incompatible change in SysLogHandler with
-+  Unix domain sockets.
-+
- - Issue #17625: In IDLE, close the replace dialog after it is used.
index 19ceab38f48290061a734da7dcc69e04d477e100..92f9c371c046db8feaa2d0cef1b34863ad09fc27 100644 (file)
@@ -37,13 +37,13 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.1
-Release:       3
+Version:       %{py_ver}.2
+Release:       1
 Epoch:         1
 License:       PSF
 Group:         Applications
 Source0:       http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
-# Source0-md5: 993232d9f4d9b4863cc1ec69a792e9cd
+# Source0-md5: c94b78ea3b68a9bbc9906af4d5b4fdc7
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
 Patch2:                %{name}-lib64.patch
@@ -51,8 +51,7 @@ Patch3:               %{name}-noarch_to_datadir.patch
 Patch4:                %{name}-no_cmdline_tests.patch
 Patch5:                %{name}-makefile-location.patch
 Patch6:                libc-cloexec.patch
-Patch7:                %{name}-sysloghandler.patch
-Patch8:                python-distro.patch
+Patch7:                python-distro.patch
 URL:           http://www.python.org/
 BuildRequires: autoconf >= 2.65
 BuildRequires: bluez-libs-devel
@@ -456,7 +455,6 @@ Przykłady te są dla Pythona 2.3.4, nie %{version}.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
 
 %{__rm} -r Modules/zlib
 %{__rm} -r Modules/expat
This page took 0.203879 seconds and 4 git commands to generate.