]> git.pld-linux.org Git - packages/python3.git/commitdiff
- up to 3.4.2; what to do with PIP?
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 18 Oct 2014 23:18:52 +0000 (01:18 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 18 Oct 2014 23:18:52 +0000 (01:18 +0200)
python3-lib64.patch
python3-noarch_to_datadir.patch
python3-pythonpath.patch
python3.spec

index e61ea0e2e6f2e03e84c6182a85c1d5a1eb7b1425..2faac0d3150a0257de134dc1788a40367d4dd670 100644 (file)
  PyAPI_FUNC(const char *) Py_GetBuildInfo(void);
 --- Python-3.2.1.orig/Lib/distutils/command/install.py 2011-07-09 07:58:46.000000000 +0100
 +++ Python-3.2.1/Lib/distutils/command/install.py      2011-07-12 22:20:12.000000000 +0100
-@@ -27,6 +27,8 @@
    from site import USER_SITE
    HAS_USER_SITE = True
+@@ -19,6 +19,8 @@ from site import USER_BASE
+ from site import USER_SITE
+ HAS_USER_SITE = True
  
 +libname = sys.lib
 +
- if sys.version < "2.2":
-     WINDOWS_SCHEME = {
-         'purelib': '$base',
+ WINDOWS_SCHEME = {
+     'purelib': '$base/Lib/site-packages',
+     'platlib': '$base/Lib/site-packages',
 @@ -47,14 +49,14 @@
  INSTALL_SCHEMES = {
      'unix_prefix': {
                     os.path.join(destination, "include", "python", "foopkg"))
 --- Python-3.2.1.orig/Lib/site.py      2011-07-09 07:58:49.000000000 +0100
 +++ Python-3.2.1/Lib/site.py   2011-07-12 22:20:12.000000000 +0100
-@@ -285,13 +285,16 @@
-         if sys.platform in ('os2emx', 'riscos'):
-             sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
-         elif os.sep == '/':
+@@ -304,13 +304,16 @@ def getsitepackages(prefixes=None):
+         seen.add(prefix)
+         if os.sep == '/':
 -            sitepackages.append(os.path.join(prefix, "lib",
 +            sitepackages.append(os.path.join(prefix, sys.lib,
                                          "python" + sys.version[:3],
  
 +#ifndef LIB_PYTHON
 +#if defined(__x86_64__) || (defined(__sparc__) && defined(__arch64__)) || defined(__powerpc64__) || defined(__s390x__)
-+#define LIB_PYTHON L"lib64/python"
++#define LIB_PYTHON "lib64/python"
 +#else
-+#define LIB_PYTHON L"lib/python"
++#define LIB_PYTHON "lib/python"
 +#endif
 +#endif
 +
  #endif
  
  #ifndef LANDMARK
-@@ -135,7 +143,7 @@
static wchar_t progpath[MAXPATHLEN+1];
static wchar_t *module_search_path = NULL;
static int module_search_path_malloced = 0;
--static wchar_t *lib_python = L"lib/python" VERSION;
-++static wchar_t *lib_python = LIB_PYTHON VERSION;
+@@ -502,7 +502,7 @@ calculate_path(void)
    _pythonpath = _Py_char2wchar(PYTHONPATH, NULL);
    _prefix = _Py_char2wchar(PREFIX, NULL);
    _exec_prefix = _Py_char2wchar(EXEC_PREFIX, NULL);
+-    lib_python = _Py_char2wchar("lib/python" VERSION, NULL);
++    lib_python = _Py_char2wchar(LIB_PYTHON VERSION, NULL);
  
- static void
- reduce(wchar_t *dir)
+     if (!_pythonpath || !_prefix || !_exec_prefix || !lib_python) {
+         Py_FatalError(
 --- Python-3.2.1.orig/Python/getplatform.c     2011-07-09 07:58:56.000000000 +0100
 +++ Python-3.2.1/Python/getplatform.c  2011-07-12 22:20:12.000000000 +0100
 @@ -10,3 +10,23 @@
index 4c0810a220b60f659cdd2e90b9ec615654996b5b..f913f5bb42fad3780d1926ef973fbf64dcd41f4c 100644 (file)
@@ -123,58 +123,28 @@ diff -dur Python-3.2.1.orig/Modules/getpath.c Python-3.2.1/Modules/getpath.c
  #endif
  
  #ifndef LANDMARK
-@@ -143,7 +144,8 @@
- static wchar_t progpath[MAXPATHLEN+1];
- static wchar_t *module_search_path = NULL;
- static int module_search_path_malloced = 0;
--+static wchar_t *lib_python = LIB_PYTHON VERSION;
-+static wchar_t *lib_python = LIB_PYTHON VERSION;
-+static wchar_t share_python[] = L"share/python" VERSION;
- static void
- reduce(wchar_t *dir)
-@@ -284,7 +286,7 @@
-         delim = wcschr(prefix, DELIM);
-         if (delim)
-             *delim = L'\0';
--        joinpath(prefix, lib_python);
-+        joinpath(prefix, share_python);
-         joinpath(prefix, LANDMARK);
-         return 1;
+@@ -673,13 +673,13 @@ calculate_path(void)
+         }
      }
-@@ -310,7 +312,7 @@
-     copy_absolute(prefix, argv0_path, MAXPATHLEN+1);
-     do {
-         n = wcslen(prefix);
--        joinpath(prefix, lib_python);
-+        joinpath(prefix, share_python);
-         joinpath(prefix, LANDMARK);
-         if (ismodule(prefix))
-             return 1;
-@@ -379,7 +379,7 @@
-     /* Look at configure's PREFIX */
-     wcsncpy(prefix, _prefix, MAXPATHLEN);
-     prefix[MAXPATHLEN] = L'\0';
--    joinpath(prefix, lib_python);
-+    joinpath(prefix, share_python);
-     joinpath(prefix, LANDMARK);
-     if (ismodule(prefix))
-         return 1;
-@@ -578,7 +580,7 @@
+-    pfound = search_for_prefix(argv0_path, home, _prefix, lib_python);
++    pfound = search_for_prefix(argv0_path, home, _prefix, L"share/python");
+     if (!pfound) {
+         if (!Py_FrozenFlag)
              fprintf(stderr,
                  "Could not find platform independent libraries <prefix>\n");
          wcsncpy(prefix, _prefix, MAXPATHLEN);
 -        joinpath(prefix, lib_python);
-+        joinpath(prefix, share_python);
++        joinpath(prefix, L"share/python");
      }
      else
          reduce(prefix);
-@@ -591,7 +593,7 @@
+@@ -691,7 +693,7 @@
      }
      else
          wcsncpy(zip_path, _prefix, MAXPATHLEN);
 -    joinpath(zip_path, L"lib/python00.zip");
-+    joinpath(zip_path, LIB_PYTHON "00.zip");
++    joinpath(zip_path, L"" LIB_PYTHON "00.zip");
      bufsz = wcslen(zip_path);   /* Replace "00" with version */
      zip_path[bufsz - 6] = VERSION[0];
      zip_path[bufsz - 5] = VERSION[2];
index fe5e48ebfbf956b1cca7e61d733d1c0ec8081447..69be18363a861da6e3540e9923cc9bfd66d40e54 100644 (file)
                        '/usr/bin/env python', line)
          print(filename, ':', repr(line))
          f = open(filename, "w")
---- Python-3.0.1/Doc/README.txt.wiget  2009-02-13 00:46:00.000000000 +0100
-+++ Python-3.0.1/Doc/README.txt        2009-03-14 18:12:32.000000000 +0100
-@@ -37,7 +37,7 @@ the top-level index `build/html/index.ht
- To use a Python interpreter that's not called ``python``, use the standard
- way to set Makefile variables, using e.g. ::
--   make html PYTHON=/usr/bin/python2.5
-+   make html PYTHON=/usr/bin/python3
- Available make targets are:
index ee9e4b6f86745ccefd035de430821fa7d7392afb..aef61a7a7a16492ae5eaeab631e90ca091ed9af9 100644 (file)
@@ -20,7 +20,7 @@
 #   test_gdb: fails, as the gdb uses old python version
 %define                broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib test_gdb test_site
 
-%define py_ver         3.3
+%define py_ver         3.4
 %define py_abi         %{py_ver}m
 %define py_prefix      %{_prefix}
 %define py_libdir      %{py_prefix}/%{_lib}/python%{py_ver}
@@ -37,13 +37,13 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.5
-Release:       2
+Version:       %{py_ver}.2
+Release:       1
 Epoch:         1
 License:       PSF
 Group:         Applications
 Source0:       http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
-# Source0-md5: b2a4df195d934e5b229e8328ca864960
+# Source0-md5: 36fc7327c02c6f12fa24fc9ba78039e3
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
 Patch2:                %{name}-lib64.patch
@@ -476,13 +476,13 @@ for SUBDIR in darwin libffi libffi_arm_wince libffi_msvc libffi_osx; do
        %{__rm} -r Modules/_ctypes/$SUBDIR
 done
 
+%if "%{pld_release}" == "ac"
 files="md5module.c sha1module.c"
-%if !0%(pkg-config  openssl --atleast-version=0.9.8; echo $?)
 files="$files sha256module.c sha512module.c"
-%endif
 for f in $files; do
        %{__rm} Modules/$f
 done
+%endif
 
 %build
 if ! grep -q "tmpfs" /proc/self/mounts; then
@@ -720,14 +720,17 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 /etc/shrc.d/python*-modules*
 %attr(755,root,root) %{_bindir}/pyvenv
-%attr(755,root,root) %{_bindir}/pyvenv-3.3
+%attr(755,root,root) %{_bindir}/pyvenv-3.4
 %{py_scriptdir}/__future__.py
 %{py_scriptdir}/__phello__.foo.py
+%{py_scriptdir}/_bootlocale.py
+%{py_scriptdir}/_collections_abc.py
 %{py_scriptdir}/_compat_pickle.py
 %{py_scriptdir}/_dummy_thread.py
 %{py_scriptdir}/_markupbase.py
 %{py_scriptdir}/_osx_support.py
 %{py_scriptdir}/_pyio.py
+%{py_scriptdir}/_sitebuiltins.py
 %{py_scriptdir}/_strptime.py
 %{py_scriptdir}/_threading_local.py
 %{py_scriptdir}/aifc.py
@@ -761,6 +764,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/dis.py
 %{py_scriptdir}/doctest.py
 %{py_scriptdir}/dummy_threading.py
+%{py_scriptdir}/enum.py
 %{py_scriptdir}/filecmp.py
 %{py_scriptdir}/fileinput.py
 %{py_scriptdir}/fnmatch.py
@@ -792,8 +796,9 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/nturl2path.py
 %{py_scriptdir}/numbers.py
 %{py_scriptdir}/opcode.py
+%{py_scriptdir}/operator.py
 %{py_scriptdir}/optparse.py
-%{py_scriptdir}/os2emxpath.py
+%{py_scriptdir}/pathlib.py
 %{py_scriptdir}/pickle.py
 %{py_scriptdir}/pickletools.py
 %{py_scriptdir}/pipes.py
@@ -811,6 +816,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/rlcompleter.py
 %{py_scriptdir}/runpy.py
 %{py_scriptdir}/sched.py
+%{py_scriptdir}/selectors.py
 %{py_scriptdir}/shelve.py
 %{py_scriptdir}/shlex.py
 %{py_scriptdir}/shutil.py
@@ -820,6 +826,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/socket.py
 %{py_scriptdir}/socketserver.py
 %{py_scriptdir}/ssl.py
+%{py_scriptdir}/statistics.py
 %{py_scriptdir}/string.py
 %{py_scriptdir}/stringprep.py
 %{py_scriptdir}/struct.py
@@ -835,6 +842,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/this.py
 %{py_scriptdir}/threading.py
 %{py_scriptdir}/trace.py
+%{py_scriptdir}/tracemalloc.py
 %{py_scriptdir}/tty.py
 %{py_scriptdir}/turtle.py
 %{py_scriptdir}/uu.py
@@ -846,11 +854,14 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/zipfile.py
 %{py_scriptdir}/__pycache__/__future__.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/__phello__.cpython-*.py[co]
+%{py_scriptdir}/__pycache__/_bootlocale.cpython-*.py[co]
+%{py_scriptdir}/__pycache__/_collections_abc.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/_compat_pickle.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/_dummy_thread.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/_markupbase.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/_osx_support.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/_pyio.cpython-*.py[co]
+%{py_scriptdir}/__pycache__/_sitebuiltins.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/_strptime.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/_threading_local.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/aifc.cpython-*.py[co]
@@ -884,6 +895,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/__pycache__/dis.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/doctest.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/dummy_threading.cpython-*.py[co]
+%{py_scriptdir}/__pycache__/enum.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/filecmp.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/fileinput.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/fnmatch.cpython-*.py[co]
@@ -915,8 +927,9 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/__pycache__/nturl2path.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/numbers.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/opcode.cpython-*.py[co]
+%{py_scriptdir}/__pycache__/operator.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/optparse.cpython-*.py[co]
-%{py_scriptdir}/__pycache__/os2emxpath.cpython-*.py[co]
+%{py_scriptdir}/__pycache__/pathlib.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/pickle.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/pickletools.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/pipes.cpython-*.py[co]
@@ -934,6 +947,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/__pycache__/rlcompleter.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/runpy.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/sched.cpython-*.py[co]
+%{py_scriptdir}/__pycache__/selectors.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/shelve.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/shlex.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/shutil.cpython-*.py[co]
@@ -943,6 +957,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/__pycache__/socket.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/socketserver.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/ssl.cpython-*.py[co]
+%{py_scriptdir}/__pycache__/statistics.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/string.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/stringprep.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/struct.cpython-*.py[co]
@@ -958,6 +973,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/__pycache__/this.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/threading.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/trace.cpython-*.py[co]
+%{py_scriptdir}/__pycache__/tracemalloc.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/tty.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/turtle.cpython-*.py[co]
 %{py_scriptdir}/__pycache__/uu.cpython-*.py[co]
@@ -997,24 +1013,27 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{py_dyndir}/_json.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_lsprof.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_lzma.cpython-*.so
+%attr(755,root,root) %{py_dyndir}/_md5.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_multibytecodec.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_multiprocessing.cpython-*.so
+%attr(755,root,root) %{py_dyndir}/_opcode.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_pickle.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_posixsubprocess.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_random.cpython-*.so
+%attr(755,root,root) %{py_dyndir}/_sha1.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_socket.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_ssl.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_testbuffer.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_testcapi.cpython-*.so
+%attr(755,root,root) %{py_dyndir}/_testimportmultiple.cpython-*.so
 
 # for openssl < 0.9.8 package sha256 and sha512 modules
-%if 0%(pkg-config  openssl --atleast-version=0.9.8; echo $?)
+%if "%{pld_release}" != "ac"
 %attr(755,root,root) %{py_dyndir}/_sha256.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_sha512.cpython-*.so
 %endif
 
 %attr(755,root,root) %{py_dyndir}/array.cpython-*.so
-%attr(755,root,root) %{py_dyndir}/atexit.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/audioop.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/binascii.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/cmath.cpython-*.so
@@ -1040,6 +1059,10 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/plat-*/__pycache__
 %{py_scriptdir}/plat-*/*.py
 
+%dir %{py_scriptdir}/asyncio
+%{py_scriptdir}/asyncio/__pycache__
+%{py_scriptdir}/asyncio/*.py
+
 %{py_scriptdir}/concurrent
 
 %dir %{py_scriptdir}/ctypes
@@ -1076,6 +1099,11 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/email/*.py
 %{py_scriptdir}/email/mime/*.py
 
+%dir %{py_scriptdir}/ensurepip
+%{py_scriptdir}/ensurepip/__pycache__
+%{py_scriptdir}/ensurepip/*.py
+%{py_scriptdir}/ensurepip/_bundled
+
 %dir %{py_scriptdir}/html
 %{py_scriptdir}/html/*.py
 %{py_scriptdir}/html/__pycache__
@@ -1154,7 +1182,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -n pydoc3
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/pydoc3
-%attr(755,root,root) %{_bindir}/pydoc3.3
+%attr(755,root,root) %{_bindir}/pydoc3.4
 %{py_scriptdir}/pydoc.py
 %{py_scriptdir}/__pycache__/pydoc.cpython-*.py[co]
 %dir %{py_scriptdir}/pydoc_data
@@ -1165,7 +1193,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -n idle3
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/idle3
-%attr(755,root,root) %{_bindir}/idle3.3
+%attr(755,root,root) %{_bindir}/idle3.4
 %dir %{py_scriptdir}/idlelib/Icons
 %{py_scriptdir}/idlelib/__pycache__
 %{py_scriptdir}/idlelib/*.py
@@ -1189,6 +1217,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/config-%{py_abi}/config.c
 %{py_libdir}/config-%{py_abi}/config.c.in
 %{py_libdir}/config-%{py_abi}/python.o
+%{py_libdir}/config-%{py_abi}/python-config.py
 %{_pkgconfigdir}/python-%{py_ver}.pc
 %{_pkgconfigdir}/python-%{py_abi}.pc
 %{_pkgconfigdir}/python3.pc
This page took 0.100529 seconds and 4 git commands to generate.