]> git.pld-linux.org Git - packages/python3.git/commitdiff
- up to 3.5.2 auto/th/python3-3.5.2-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 14 Aug 2016 20:17:50 +0000 (22:17 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 14 Aug 2016 20:17:50 +0000 (22:17 +0200)
python3-multilib.patch
python3-test-pyexpat.patch [new file with mode: 0644]
python3.spec

index f5a49b02a80c4b6aa391cda5a5ccece553478791..f9e35545e214814f7037358d9c0751fac5482de5 100644 (file)
@@ -196,8 +196,8 @@ diff -dur Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
 diff -dur Python-3.5.0.orig/Modules/getpath.c Python-3.5.0/Modules/getpath.c
 --- Python-3.5.0.orig/Modules/getpath.c        2015-09-13 13:41:24.000000000 +0200
 +++ Python-3.5.0/Modules/getpath.c     2015-12-03 17:31:03.874280444 +0100
-@@ -117,9 +117,21 @@
- #define EXEC_PREFIX PREFIX
+@@ -100,6 +100,17 @@
+  extern "C" {
  #endif
  
 +#ifndef LIB_PYTHON
@@ -211,15 +211,9 @@ diff -dur Python-3.5.0.orig/Modules/getpath.c Python-3.5.0/Modules/getpath.c
 +#define LIB_PYTHON "lib/python"
 +#endif
 +#endif
-+
- #ifndef PYTHONPATH
--#define PYTHONPATH PREFIX "/lib/python" VERSION ":" \
--              EXEC_PREFIX "/lib/python" VERSION "/lib-dynload"
-+#define PYTHONPATH PREFIX "/" LIB_PYTHON VERSION ":" \
-+              EXEC_PREFIX "/" LIB_PYTHON VERSION "/lib-dynload:"
- #endif
  
- #ifndef LANDMARK
+ #if !defined(PREFIX) || !defined(EXEC_PREFIX) || !defined(VERSION) || !defined(VPATH)
+ #error "PREFIX, EXEC_PREFIX, VERSION, and VPATH must be constant defined"
 @@ -511,7 +523,7 @@
      _pythonpath = Py_DecodeLocale(PYTHONPATH, NULL);
      _prefix = Py_DecodeLocale(PREFIX, NULL);
diff --git a/python3-test-pyexpat.patch b/python3-test-pyexpat.patch
new file mode 100644 (file)
index 0000000..728b7c8
--- /dev/null
@@ -0,0 +1,11 @@
+--- Python-3.5.2/Lib/test/test_pyexpat.py~     2016-06-25 23:38:37.000000000 +0200
++++ Python-3.5.2/Lib/test/test_pyexpat.py      2016-08-14 22:01:10.891946983 +0200
+@@ -660,7 +660,7 @@ class MalformedInputTest(unittest.TestCa
+             parser.Parse(xml, True)
+             self.fail()
+         except expat.ExpatError as e:
+-            self.assertEqual(str(e), 'XML declaration not well-formed: line 1, column 14')
++            self.assertEqual(str(e), 'XML declaration not well-formed: line 1, column 13')
+ class ErrorMessageTest(unittest.TestCase):
+     def test_codes(self):
index 19ceb09f8ba10fa2c28509a6793e4c9a4a739941..e78304d2024729593100eab147589680845d9270 100644 (file)
@@ -33,13 +33,13 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.1
-Release:       4
+Version:       %{py_ver}.2
+Release:       1
 Epoch:         1
 License:       PSF
 Group:         Development/Languages/Python
 Source0:       https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
-# Source0-md5: e9ea6f2623fffcdd871b7b19113fde80
+# Source0-md5: 8906efbacfcdc7c3c9198aeefafd159e
 Source1:       pyconfig.h.in
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
@@ -53,7 +53,8 @@ Patch9:               %{name}-tests_with_pythonpath.patch
 Patch10:       %{name}-bdist_rpm.patch
 Patch11:       %{name}-installcompile.patch
 Patch12:                https://bugs.python.org/file21896/nonexistent_user.patch
-# Patch12-md5:  db706fbe6de467c6e4c97c675eddf29a
+# Patch12-md5: db706fbe6de467c6e4c97c675eddf29a
+Patch13:       python3-test-pyexpat.patch
 URL:           https://www.python.org/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake
@@ -481,6 +482,7 @@ Moduły testowe dla Pythona.
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
+%patch13 -p1
 
 %{__rm} -r Modules/zlib
 %{__rm} -r Modules/expat
This page took 0.255009 seconds and 4 git commands to generate.