]> git.pld-linux.org Git - packages/python3.git/commitdiff
- run imap4_host_default_value test with ipv4, so it should work on our vserver build...
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 5 Aug 2019 18:10:05 +0000 (20:10 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 5 Aug 2019 18:10:05 +0000 (20:10 +0200)
python3-tests.patch [new file with mode: 0644]
python3.spec

diff --git a/python3-tests.patch b/python3-tests.patch
new file mode 100644 (file)
index 0000000..7d19d37
--- /dev/null
@@ -0,0 +1,11 @@
+--- Python-3.7.4/Lib/test/test_imaplib.py~     2019-07-08 20:03:50.000000000 +0200
++++ Python-3.7.4/Lib/test/test_imaplib.py      2019-08-05 19:25:53.119629647 +0200
+@@ -73,7 +73,7 @@ class TestImaplib(unittest.TestCase):
+     def test_imap4_host_default_value(self):
+         # Check whether the IMAP4_PORT is truly unavailable.
+-        with socket.socket() as s:
++        with socket.socket(socket.AF_INET, socket.SOCK_STREAM) as s:
+             try:
+                 s.connect(('', imaplib.IMAP4_PORT))
+                 self.skipTest(
index 4ebc77fd34b18b9aa1e180a011c58d3f0ae49b96..f6648002aec781136b2e15afa1ba00fafbef2663 100644 (file)
@@ -65,6 +65,7 @@ Patch11:      %{name}-installcompile.patch
 Patch12:        nonexistent_user.patch
 Patch13:       %{name}-no-randomize-tests.patch
 Patch14:       python3-profile-tests.patch
+Patch15:       python3-tests.patch
 URL:           https://www.python.org/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake
@@ -498,6 +499,7 @@ Moduły testowe dla Pythona.
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
+%patch15 -p1
 
 %{__rm} -r Modules/expat
 
This page took 0.064007 seconds and 4 git commands to generate.