]> git.pld-linux.org Git - packages/python3.git/commitdiff
- added redundant_declaration patch (kill warning caused by import.h header); release 3 auto/th/python3-3.7.0-3
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 17 Jul 2018 19:53:47 +0000 (21:53 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 17 Jul 2018 19:53:47 +0000 (21:53 +0200)
python3-redundant_declaration.patch [new file with mode: 0644]
python3.spec

diff --git a/python3-redundant_declaration.patch b/python3-redundant_declaration.patch
new file mode 100644 (file)
index 0000000..34af370
--- /dev/null
@@ -0,0 +1,28 @@
+From c919252a28f4e9dd326dc2c703b4eee6e247be83 Mon Sep 17 00:00:00 2001
+From: "Miss Islington (bot)"
+ <31488909+miss-islington@users.noreply.github.com>
+Date: Fri, 29 Jun 2018 16:03:07 -0700
+Subject: [PATCH] Fix redundant declaration of _PyImport_AddModuleObject
+ (GH-7992)
+
+(cherry picked from commit f874bd1f0630644f3e3faaa2d51e6749465c70bd)
+
+Co-authored-by: Jeremy Cline <jeremy@jcline.org>
+---
+ Include/import.h | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/Include/import.h b/Include/import.h
+index 13f32a1004cf..c664803478a5 100644
+--- a/Include/import.h
++++ b/Include/import.h
+@@ -54,9 +54,6 @@ PyAPI_FUNC(PyObject *) PyImport_AddModuleObject(
+     PyObject *name
+     );
+ #endif
+-#ifndef Py_LIMITED_API
+-PyAPI_FUNC(PyObject *) _PyImport_AddModuleObject(PyObject *, PyObject *);
+-#endif
+ PyAPI_FUNC(PyObject *) PyImport_AddModule(
+     const char *name            /* UTF-8 encoded string */
+     );
index 26aad2e2b37c518c4b6b4b8dc34dcbe2220c8bd9..300f6f51763046ffd595362dee5b5e7942ee3171 100644 (file)
@@ -42,7 +42,7 @@ Summary(tr.UTF-8):    X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
 Version:       %{py_ver}.0
-Release:       2
+Release:       3
 Epoch:         1
 License:       PSF
 Group:         Development/Languages/Python
@@ -62,7 +62,9 @@ Patch10:      %{name}-bdist_rpm.patch
 Patch11:       %{name}-installcompile.patch
 # https://bugs.python.org/file21896/nonexistent_user.patch
 Patch12:        nonexistent_user.patch
-Patch13:       python3-no-randomize-tests.patch
+Patch13:       %{name}-no-randomize-tests.patch
+# https://github.com/python/cpython/commit/c919252a28f4e9dd326dc2c703b4eee6e247be83.patch
+Patch14:       %{name}-redundant_declaration.patch
 URL:           https://www.python.org/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake
@@ -494,6 +496,7 @@ Moduły testowe dla Pythona.
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
+%patch14 -p1
 
 %{__rm} -r Modules/expat
 
This page took 0.201135 seconds and 4 git commands to generate.