]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3.spec
- avoid /usr/bin/env shebang, use direct python3 path
[packages/python3.git] / python3.spec
index 62720ba9ac4a25db81858ce53d3abb0594a82b30..64917bd2e2edd14f47f3bfe9ad4ac1d97cff4e17 100644 (file)
@@ -486,6 +486,8 @@ for f in $files; do
 done
 %endif
 
+find . -name '*.py' | xargs -r grep -El '^#! */usr/bin/env python3?' | xargs %{__sed} -i -e '1s,^#! */usr/bin/env python3\?,#!/usr/bin/python3,'
+
 %build
 if ! grep -q "tmpfs" /proc/self/mounts; then
        echo "You need to have /dev/shm mounted in order to build this package!" >&2
This page took 0.038348 seconds and 4 git commands to generate.