]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3.spec
- up to 3.6.2
[packages/python3.git] / python3.spec
index cb8732f5abe78d8d9d7147656b25a772796e9698..62cd3c6b5c9209bd2574e062f724821642cf1f1d 100644 (file)
@@ -9,16 +9,20 @@
 # tests which will not work on 64-bit platforms
 %define                no64bit_tests   test_audioop test_rgbimg test_imageop
 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
-%define                nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty test_asyncio test_os
+%define                nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty test_asyncio test_os test_readline
 
 # tests which fail because of some unknown/unresolved reason (this list should be %{nil})
 #   test_site: fails because our site.py is patched to include both /usr/share/... and /usr/lib...
 #   test_gdb: fails, as the gdb uses old python version
-%define                broken_tests    test_nntplib test_gdb test_site
+#   test_time: test_AsTimeval (test.test_time.TestCPyTime), rounding error
+%ifarch x32
+%define                broken_tests_x32        test_time
+%endif
+%define                broken_tests    test_nntplib test_gdb test_site test_ssl %{?broken_tests_x32}
 
 %define py_ver         3.6
 %define py_abi         %{py_ver}m
-%define        py_platform     %{py_abi}-%{_host_cpu}-%{_host_os}%{?_gnu}
+%define        py_platform     %{py_abi}-%{_target_base_arch}-%{_target_os}%{?_gnu}
 %define py_prefix      %{_prefix}
 %define py_libdir      %{py_prefix}/%{_lib}/python%{py_ver}
 %define py_incdir      %{_includedir}/python%{py_abi}
@@ -34,13 +38,13 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.0
+Version:       %{py_ver}.2
 Release:       1
 Epoch:         1
 License:       PSF
 Group:         Development/Languages/Python
 Source0:       https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
-# Source0-md5: 82b143ebbf4514d7e05876bed7a6b1f5
+# Source0-md5: 2c68846471994897278364fc18730dd9
 Source1:       pyconfig.h.in
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
@@ -519,19 +523,15 @@ fi
        --enable-ipv6 \
        --enable-shared \
        --with-computed-gotos \
-       --with-dbmliborder=gdbm:bdb \
+       --with-dbmliborder=gdbm:ndbm:bdb \
        --with-doc-strings \
        --without-ensurepip \
        --with-fpectl \
        %{?with_debug:--with-pydebug} \
-       --with-signal-module \
        --with-system-expat \
        --with-system-ffi \
        %{?with_system_mpdecimal:--with-system-libmpdec} \
-       --with-threads \
-%ifarch %{ix86} %{x8664} ppc ppc64
-       --with-tsc
-%endif
+       --with-threads
 
 %{__make} 2>&1 | awk '
 BEGIN { fail = 0; logmsg = ""; }
@@ -618,7 +618,7 @@ install -p Tools/scripts/reindent.py $RPM_BUILD_ROOT%{_bindir}/pyreindent%{py_ve
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/idlelib/*.bat
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/idlelib/*.pyw
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/idlelib/help.html
-%{__rm} $RPM_BUILD_ROOT%{py_libdir}/site-packages/README
+%{__rm} $RPM_BUILD_ROOT%{py_libdir}/site-packages/README.txt
 
 # currently provided by python-2to3, consider switching to this one
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/2to3
@@ -689,6 +689,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/linecache.py
 %{py_libdir}/locale.py
 %{py_libdir}/io.py
+%{py_libdir}/operator.py
 %{py_libdir}/posixpath.py
 %{py_libdir}/re.py
 %{py_libdir}/reprlib.py
@@ -718,6 +719,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/__pycache__/linecache.cpython-*.py[co]
 %{py_libdir}/__pycache__/locale.cpython-*.py[co]
 %{py_libdir}/__pycache__/io.cpython-*.py[co]
+%{py_libdir}/__pycache__/operator.cpython-*.py[co]
 %{py_libdir}/__pycache__/posixpath.cpython-*.py[co]
 %{py_libdir}/__pycache__/re.cpython-*.py[co]
 %{py_libdir}/__pycache__/reprlib.cpython-*.py[co]
@@ -826,7 +828,6 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/nturl2path.py
 %{py_libdir}/numbers.py
 %{py_libdir}/opcode.py
-%{py_libdir}/operator.py
 %{py_libdir}/optparse.py
 %{py_libdir}/pathlib.py
 %{py_libdir}/pickle.py
@@ -961,7 +962,6 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/__pycache__/nturl2path.cpython-*.py[co]
 %{py_libdir}/__pycache__/numbers.cpython-*.py[co]
 %{py_libdir}/__pycache__/opcode.cpython-*.py[co]
-%{py_libdir}/__pycache__/operator.cpython-*.py[co]
 %{py_libdir}/__pycache__/optparse.cpython-*.py[co]
 %{py_libdir}/__pycache__/pathlib.cpython-*.py[co]
 %{py_libdir}/__pycache__/pickle.cpython-*.py[co]
@@ -1184,8 +1184,9 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/venv/__pycache__
 %{py_libdir}/venv/*.py
 %dir %{py_libdir}/venv/scripts
+%dir %{py_libdir}/venv/scripts/common
+%{py_libdir}/venv/scripts/common/activate
 %dir %{py_libdir}/venv/scripts/posix
-%{py_libdir}/venv/scripts/posix/activate
 %{py_libdir}/venv/scripts/posix/activate.csh
 %{py_libdir}/venv/scripts/posix/activate.fish
 
This page took 0.068602 seconds and 4 git commands to generate.