]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3.spec
- started playing with python 3.7
[packages/python3.git] / python3.spec
index 3d772886e0d5e8703561c2f75a052810bd2d0423..5e875ff3b844f93ace76fe429475974217f27f15 100644 (file)
@@ -20,7 +20,7 @@
 %endif
 %define                broken_tests    test_nntplib test_gdb test_site test_ssl %{?broken_tests_x32}
 
-%define py_ver         3.6
+%define py_ver         3.7
 %define py_abi         %{py_ver}m
 %define        py_platform     %{py_abi}-%{_target_base_arch}-%{_target_os}%{?_gnu}
 %define py_prefix      %{_prefix}
@@ -38,13 +38,13 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.5
-Release:       1
+Version:       %{py_ver}.0
+Release:       0.1
 Epoch:         1
 License:       PSF
 Group:         Development/Languages/Python
 Source0:       https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
-# Source0-md5: 9f49654a4d6f733ff3284ab9d227e9fd
+# Source0-md5: eb8c2a6b1447d50813c02714af4681f3
 Source1:       pyconfig.h.in
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
@@ -214,6 +214,8 @@ Group:              Libraries/Python
 Provides:      python(abi) = %{py_ver}
 # for compatibility with existing Ac packages
 Provides:      python(bytecode) = %{py_ver}
+Provides:      python3-enum
+Obsoletes:     python3-enum
 %{!?with_info:Obsoletes: python3-doc-info}
 
 %description libs
@@ -229,8 +231,6 @@ Summary(pl.UTF-8):  Moduły języka Python
 Group:         Libraries/Python
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 %{?with_system_mpdecimal:Requires:     mpdecimal >= 2.4.1}
-Provides:      python3-enum
-Obsoletes:     python3-enum
 Obsoletes:     python3-modules-sqlite
 %requires_ge_to        openssl openssl-devel
 
@@ -487,10 +487,9 @@ Moduły testowe dla Pythona.
 %patch11 -p1
 %patch12 -p1
 
-%{__rm} -r Modules/zlib
 %{__rm} -r Modules/expat
 
-for SUBDIR in darwin libffi libffi_msvc libffi_osx; do
+for SUBDIR in darwin libffi_msvc libffi_osx; do
        %{__rm} -r Modules/_ctypes/$SUBDIR/*
 done
 
@@ -526,12 +525,10 @@ fi
        --with-dbmliborder=gdbm:ndbm:bdb \
        --with-doc-strings \
        --without-ensurepip \
-       --with-fpectl \
        %{?with_debug:--with-pydebug} \
        --with-system-expat \
        --with-system-ffi \
-       %{?with_system_mpdecimal:--with-system-libmpdec} \
-       --with-threads
+       %{?with_system_mpdecimal:--with-system-libmpdec}
 
 %{__make} 2>&1 | awk '
 BEGIN { fail = 0; logmsg = ""; }
@@ -682,6 +679,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/bisect.py
 %{py_libdir}/codecs.py
 %{py_libdir}/copyreg.py
+%{py_libdir}/enum.py
 %{py_libdir}/functools.py
 %{py_libdir}/genericpath.py
 %{py_libdir}/heapq.py
@@ -712,6 +710,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/__pycache__/codecs.cpython-*.py[co]
 %{py_libdir}/__pycache__/_collections_abc.cpython-*.py[co]
 %{py_libdir}/__pycache__/copyreg.cpython-*.py[co]
+%{py_libdir}/__pycache__/enum.cpython-*.py[co]
 %{py_libdir}/__pycache__/functools.cpython-*.py[co]
 %{py_libdir}/__pycache__/genericpath.cpython-*.py[co]
 %{py_libdir}/__pycache__/heapq.cpython-*.py[co]
@@ -796,7 +795,6 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/dis.py
 %{py_libdir}/doctest.py
 %{py_libdir}/dummy_threading.py
-%{py_libdir}/enum.py
 %{py_libdir}/filecmp.py
 %{py_libdir}/fileinput.py
 %{py_libdir}/fnmatch.py
@@ -930,7 +928,6 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/__pycache__/dis.cpython-*.py[co]
 %{py_libdir}/__pycache__/doctest.cpython-*.py[co]
 %{py_libdir}/__pycache__/dummy_threading.cpython-*.py[co]
-%{py_libdir}/__pycache__/enum.cpython-*.py[co]
 %{py_libdir}/__pycache__/filecmp.cpython-*.py[co]
 %{py_libdir}/__pycache__/fileinput.cpython-*.py[co]
 %{py_libdir}/__pycache__/fnmatch.cpython-*.py[co]
This page took 0.077282 seconds and 4 git commands to generate.