]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3.spec
Release 2 (by relup.sh)
[packages/python3.git] / python3.spec
index 7681a485678246638aa4c565d0ead23d6f42fbac..21386671ae2ce8ec558e1a26f8aa4cf860a4708f 100644 (file)
@@ -9,23 +9,29 @@
 %bcond_without optimizations           # expensive, stable optimizations (PGO etc.) + LTO
 #
 # tests which will not work on 64-bit platforms
-%define                no64bit_tests   test_audioop test_rgbimg test_imageop
+%define                no64bit_tests   -x test_audioop -x test_rgbimg -x test_imageop
 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
-%define                nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty test_asyncio test_os test_readline test_normalization
+%define                nobuilder_tests -u-network -x test_resource -x test_openpty -x test_socket -x test_nis -x test_posix -x test_locale -x test_pty -x test_asyncio -x test_os -x test_readline -x test_normalization
 
 # tests which fail because of some unknown/unresolved reason (this list should be %{nil})
 #   test_site: fails because our site.py is patched to include both /usr/share/... and /usr/lib...
 #   test_gdb: fails, as the gdb uses old python version
 #   test_time: test_AsTimeval (test.test_time.TestCPyTime), rounding error
 %ifarch x32
-%define                broken_tests_x32        test_time
+%define                broken_tests_x32        -x test_time
 %undefine      with_optimizations
 %endif
-%define                broken_tests    test_nntplib test_gdb test_site test_distutils test_bdist_rpm test_ssl %{?broken_tests_x32}
+%define                broken_tests    -x test_embed -x test_nntplib -x test_gdb -x test_site -x test_distutils -x test_bdist_rpm -x test_ssl %{?broken_tests_x32}
 
-%define py_ver         3.7
-%define py_abi         %{py_ver}m
-%define        py_platform     %{py_abi}-%{_target_base_arch}-%{_target_os}%{?_gnu}
+%ifarch armv6hl armv7hl armv7hnl
+%define                _python_target_abi      %{?_gnu}hf
+%else
+%define                _python_target_abi      %{?_gnu}
+%endif
+
+%define py_ver         3.10
+%define py_abi         %{py_ver}
+%define        py_platform     %{py_abi}-%{_target_base_arch}-%{_target_os}%{?_python_target_abi}
 %define py_prefix      %{_prefix}
 %define py_libdir      %{py_prefix}/%{_lib}/python%{py_ver}
 %define py_incdir      %{_includedir}/python%{py_abi}
@@ -41,32 +47,31 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.0
-Release:       4
+Version:       %{py_ver}.8
+Release:       2
 Epoch:         1
 License:       PSF
 Group:         Development/Languages/Python
 Source0:       https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
-# Source0-md5: eb8c2a6b1447d50813c02714af4681f3
+# Source0-md5: e92356b012ed4d0e09675131d39b1bde
 Source1:       pyconfig.h.in
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
 Patch2:                %{name}-multilib.patch
 Patch3:                %{name}-no_cmdline_tests.patch
-Patch4:                %{name}-makefile-location.patch
-Patch6:                python-distro.patch
+Patch4:                %{name}-BLDLIBRARY.patch
+Patch5:                %{name}-config.patch
 Patch7:                %{name}-db.patch
-Patch8:                %{name}-install_prefix.patch
 Patch9:                %{name}-tests_with_pythonpath.patch
 Patch10:       %{name}-bdist_rpm.patch
 Patch11:       %{name}-installcompile.patch
-# https://bugs.python.org/file21896/nonexistent_user.patch
-Patch12:        nonexistent_user.patch
+
 Patch13:       %{name}-no-randomize-tests.patch
-# https://github.com/python/cpython/commit/c919252a28f4e9dd326dc2c703b4eee6e247be83.patch
-Patch14:       %{name}-redundant_declaration.patch
+Patch14:       python3-profile-tests.patch
+Patch15:       python3-tests.patch
 URL:           https://www.python.org/
 BuildRequires: autoconf >= 2.65
+BuildRequires: autoconf-archive
 BuildRequires: automake
 BuildRequires: bluez-libs-devel
 BuildRequires: bzip2-devel
@@ -80,8 +85,10 @@ BuildRequires:       glibc-localedb-all
 %endif
 BuildRequires: gmp-devel >= 4.0
 BuildRequires: libffi-devel
+BuildRequires: libnsl-devel
 BuildRequires: libstdc++-devel
-%{?with_system_mpdecimal:BuildRequires:        mpdecimal-devel >= 2.4.1}
+BuildRequires: libtirpc-devel
+%{?with_system_mpdecimal:BuildRequires:        mpdecimal-devel >= 2.5.0}
 BuildRequires: ncurses-ext-devel >= 5.2
 BuildRequires: openssl-devel >= 0.9.7
 BuildRequires: pkgconfig
@@ -103,9 +110,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                specflags_ppc64 -D__ppc64__=1
 
 %if %{with verbose_tests}
-%define test_flags -v -x
+%define test_flags -v
 %else
-%define test_flags -wW -x
+%define test_flags -wW
 %endif
 
 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
@@ -115,7 +122,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %endif
 
 %ifarch sparc
-%define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
+%define test_list %{nobuilder_tests} %{broken_tests} -x test_fcntl -x test_ioctl
 %endif
 
 %description
@@ -224,8 +231,8 @@ Provides:   python(abi) = %{py_ver}
 # for compatibility with existing Ac packages
 Provides:      python(bytecode) = %{py_ver}
 Provides:      python3-enum
-Obsoletes:     python3-enum
-%{!?with_info:Obsoletes: python3-doc-info}
+Obsoletes:     python3-enum < 0.5
+%{!?with_info:Obsoletes:       python3-doc-info < %{epoch}:%{version}-%{release}}
 
 %description libs
 Python shared library and very essental modules for Python binary.
@@ -239,8 +246,8 @@ Summary:    Python modules
 Summary(pl.UTF-8):     Moduły języka Python
 Group:         Libraries/Python
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
-%{?with_system_mpdecimal:Requires:     mpdecimal >= 2.4.1}
-Obsoletes:     python3-modules-sqlite
+%{?with_system_mpdecimal:Requires:     mpdecimal >= 2.4.2-2}
+Obsoletes:     python3-modules-sqlite < 1:3.1-2
 %requires_ge_to        openssl openssl-devel
 
 %description modules
@@ -285,6 +292,7 @@ Summary(tr.UTF-8):  Python ile geliştirme yapmak için gerekli dosyalar
 Summary(uk.UTF-8):     Бібліотеки та хедери для програмування на мові Python
 Group:         Development/Languages/Python
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
+Obsoletes:     python3-devel-src < 1:3.2-1
 
 %description devel
 The Python interpreter is relatively easy to extend with dynamically
@@ -337,18 +345,6 @@ dosyalarını ve kitaplıkları içerir.
 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
 
-%package devel-src
-Summary:       Python module sources
-Summary(pl.UTF-8):     Pliki źródłowe modułów Pythona
-Group:         Development/Languages/Python
-Requires:      %{name}-modules = %{epoch}:%{version}-%{release}
-
-%description devel-src
-Python module sources.
-
-%description devel-src -l pl.UTF-8
-Pliki źródłowe modułów Pythona.
-
 %package devel-tools
 Summary:       Python development tools
 Summary(pl.UTF-8):     Narzędzia programistyczne języka Python
@@ -459,6 +455,7 @@ kullanılan grafik bir arayüzdür.
 Summary:       Example programs in Python
 Summary(pl.UTF-8):     Przykładowe programy w Pythonie
 Group:         Development/Languages/Python
+BuildArch:     noarch
 
 %description examples
 Example programs in Python.
@@ -488,19 +485,19 @@ Moduły testowe dla Pythona.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch6 -p1
+%patch5 -p1
 %patch7 -p1
-%patch8 -p1
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
-%patch12 -p1
+
 %patch13 -p1
 %patch14 -p1
+%patch15 -p1
 
 %{__rm} -r Modules/expat
 
-for SUBDIR in darwin libffi_msvc libffi_osx; do
+for SUBDIR in darwin libffi_osx; do
        %{__rm} -r Modules/_ctypes/$SUBDIR/*
 done
 
@@ -512,8 +509,21 @@ for f in $files; do
 done
 %endif
 
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
+      Tools/gdb/libpython.py \
+      Tools/pynche/pynche \
+      Tools/pynche/pynche.pyw \
+      Tools/scripts/2to3
+
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
+      Tools/scripts/idle3 \
+      Tools/scripts/pydoc3
+
 find . -name '*.py' | xargs -r grep -El '^#! */usr/bin/env python3?' | xargs %{__sed} -i -e '1s,^#! */usr/bin/env python3\?,#!/usr/bin/python3,'
 
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
+       Tools/c-analyzer/must-resolve.sh
+
 %build
 if ! grep -q "tmpfs" /proc/self/mounts; then
        echo "You need to have /dev/shm mounted in order to build this package!" >&2
@@ -521,13 +531,16 @@ if ! grep -q "tmpfs" /proc/self/mounts; then
        exit 1
 fi
 
+export SETUPTOOLS_USE_DISTUTILS=stdlib
+
 %{__aclocal}
 %{__autoconf}
 %configure \
        CC="%{__cc}" \
-       OPT="%{rpmcflags} -fno-caller-saves" \
+       OPT="%{rpmcflags}" \
        CPPFLAGS="%{rpmcppflags}" \
        LDFLAGS="%{rpmldflags}" \
+       LDFLAGS_NODIST="%{debuginfocflags}" \
        ac_cv_posix_semaphores_enabled=yes \
        ac_cv_broken_sem_getvalue=no \
        --enable-ipv6 \
@@ -536,7 +549,9 @@ fi
        --with-dbmliborder=gdbm:ndbm:bdb \
        --with-doc-strings \
        --without-ensurepip \
+        --with-platlibdir="%{_lib}" \
        %{?with_debug:--with-pydebug} \
+        --with-ssl-default-suites=openssl \
        --with-system-expat \
        --with-system-ffi \
        %{?with_system_mpdecimal:--with-system-libmpdec} \
@@ -545,7 +560,14 @@ fi
        --with-lto
 %endif
 
-%{__make} 2>&1 | awk '
+if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+      echo "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777." >&2
+      exit 1
+fi
+
+%{__make} \
+       TESTOPTS="%{_smp_mflags} %{test_list}" \
+       2>&1 | awk '
 BEGIN { fail = 0; logmsg = ""; }
 {
                if ($0 ~ /\*\*\* WARNING:/) {
@@ -559,24 +581,29 @@ END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
 LC_ALL=C.UTF-8
 export LC_ALL
 %if %{with tests}
-WITHIN_PYTHON_RPM_BUILD=1 %{__make} -j1 test \
+WITHIN_PYTHON_RPM_BUILD=1 %{__make} test \
        TESTOPTS="%{test_flags} %{test_list}"
 %endif
 
+%if %{with info}
+%{__make} -C Doc texinfo
+%{__make} -C Doc/build/texinfo info
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pkgconfigdir}} \
        $RPM_BUILD_ROOT{%{py_sitedir},%{py_sitescriptdir}}/__pycache__ \
        $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
        $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1} \
-       $RPM_BUILD_ROOT/etc/shrc.d
+       $RPM_BUILD_ROOT/etc/shrc.d \
+       $RPM_BUILD_ROOT%{_prefix}/lib/debug/%{_libdir}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 %if %{with info}
-%{__make} -C Doc/info
-cp -p Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
+cp -p Doc/build/texinfo/python*info* $RPM_BUILD_ROOT%{_infodir}
 %endif
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
@@ -586,6 +613,10 @@ cp -a Tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libpython3.so
 ln -s libpython%{py_abi}.so $RPM_BUILD_ROOT%{_libdir}/libpython3.so
 
+# gdb helper that will end up in -debuginfo package
+soname=$(ls -1d $RPM_BUILD_ROOT%{_libdir}/libpython%{py_abi}.so.*.* | sed -e "s#^$RPM_BUILD_ROOT##g")
+cp -a Tools/gdb/libpython.py "$RPM_BUILD_ROOT%{_prefix}/lib/debug/$soname-gdb.py"
+
 #
 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
 #
@@ -623,7 +654,6 @@ install -p Tools/scripts/reindent.py $RPM_BUILD_ROOT%{_bindir}/pyreindent%{py_ve
 
 # just to cut the noise, as they are not packaged (now)
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/ctypes/macholib/fetch_macholib*
-%{__rm} $RPM_BUILD_ROOT%{py_libdir}/distutils/command/wininst*.exe
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/idlelib/*.bat
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/idlelib/*.pyw
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/idlelib/help.html
@@ -634,7 +664,7 @@ install -p Tools/scripts/reindent.py $RPM_BUILD_ROOT%{_bindir}/pyreindent%{py_ve
 
 # that seems to be only an empty extension template,
 # which seems to be built only {with tests}
-%{__rm} -f $RPM_BUILD_ROOT%{py_dyndir}/xxlimited.*.so
+%{__rm} $RPM_BUILD_ROOT%{py_dyndir}/xxlimited*.*.so
 
 # already in %%doc
 %{__rm} $RPM_BUILD_ROOT%{py_libdir}/LICENSE.txt
@@ -657,10 +687,11 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/python%{py_ver}
+%if "%{py_ver}" != "%{py_abi}"
 %attr(755,root,root) %{_bindir}/python%{py_abi}
+%endif
 %attr(755,root,root) %{_bindir}/python3
-%{_mandir}/man1/python%{py_ver}.1*
-%{_mandir}/man1/python3.1*
+%{_mandir}/man1/python3*.1*
 
 %files libs
 %defattr(644,root,root,755)
@@ -761,14 +792,12 @@ rm -rf $RPM_BUILD_ROOT
 %files modules
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) /etc/shrc.d/python*-modules*
-%attr(755,root,root) %{_bindir}/pyvenv
-%attr(755,root,root) %{_bindir}/pyvenv-%{py_ver}
 %{py_libdir}/__future__.py
 %{py_libdir}/__phello__.foo.py
-%{py_libdir}/_bootlocale.py
+%{py_libdir}/_aix_support.py
+%{py_libdir}/_bootsubprocess.py
 %{py_libdir}/_compat_pickle.py
 %{py_libdir}/_compression.py
-%{py_libdir}/_dummy_thread.py
 %{py_libdir}/_markupbase.py
 %{py_libdir}/_osx_support.py
 %{py_libdir}/_pydecimal.py
@@ -808,17 +837,16 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/difflib.py
 %{py_libdir}/dis.py
 %{py_libdir}/doctest.py
-%{py_libdir}/dummy_threading.py
 %{py_libdir}/filecmp.py
 %{py_libdir}/fileinput.py
 %{py_libdir}/fnmatch.py
-%{py_libdir}/formatter.py
 %{py_libdir}/fractions.py
 %{py_libdir}/ftplib.py
 %{py_libdir}/getopt.py
 %{py_libdir}/getpass.py
 %{py_libdir}/gettext.py
 %{py_libdir}/glob.py
+%{py_libdir}/graphlib.py
 %{py_libdir}/gzip.py
 %{py_libdir}/hashlib.py
 %{py_libdir}/hmac.py
@@ -828,7 +856,6 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/inspect.py
 %{py_libdir}/ipaddress.py
 %{py_libdir}/lzma.py
-%{py_libdir}/macpath.py
 %{py_libdir}/mailbox.py
 %{py_libdir}/mailcap.py
 %{py_libdir}/mimetypes.py
@@ -876,7 +903,6 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/struct.py
 %{py_libdir}/subprocess.py
 %{py_libdir}/sunau.py
-%{py_libdir}/symbol.py
 %{py_libdir}/symtable.py
 %{py_libdir}/tabnanny.py
 %{py_libdir}/tarfile.py
@@ -898,12 +924,13 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/xdrlib.py
 %{py_libdir}/zipapp.py
 %{py_libdir}/zipfile.py
+%{py_libdir}/zipimport.py
 %{py_libdir}/__pycache__/__future__.cpython-*.py[co]
 %{py_libdir}/__pycache__/__phello__.foo.cpython-*.py[co]
-%{py_libdir}/__pycache__/_bootlocale.cpython-*.py[co]
+%{py_libdir}/__pycache__/_aix_support.cpython-*.py[co]
+%{py_libdir}/__pycache__/_bootsubprocess.cpython-*.py[co]
 %{py_libdir}/__pycache__/_compat_pickle.cpython-*.py[co]
 %{py_libdir}/__pycache__/_compression.cpython-*.py[co]
-%{py_libdir}/__pycache__/_dummy_thread.cpython-*.py[co]
 %{py_libdir}/__pycache__/_markupbase.cpython-*.py[co]
 %{py_libdir}/__pycache__/_osx_support.cpython-*.py[co]
 %{py_libdir}/__pycache__/_pydecimal.cpython-*.py[co]
@@ -943,17 +970,16 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/__pycache__/difflib.cpython-*.py[co]
 %{py_libdir}/__pycache__/dis.cpython-*.py[co]
 %{py_libdir}/__pycache__/doctest.cpython-*.py[co]
-%{py_libdir}/__pycache__/dummy_threading.cpython-*.py[co]
 %{py_libdir}/__pycache__/filecmp.cpython-*.py[co]
 %{py_libdir}/__pycache__/fileinput.cpython-*.py[co]
 %{py_libdir}/__pycache__/fnmatch.cpython-*.py[co]
-%{py_libdir}/__pycache__/formatter.cpython-*.py[co]
 %{py_libdir}/__pycache__/fractions.cpython-*.py[co]
 %{py_libdir}/__pycache__/ftplib.cpython-*.py[co]
 %{py_libdir}/__pycache__/getopt.cpython-*.py[co]
 %{py_libdir}/__pycache__/getpass.cpython-*.py[co]
 %{py_libdir}/__pycache__/gettext.cpython-*.py[co]
 %{py_libdir}/__pycache__/glob.cpython-*.py[co]
+%{py_libdir}/__pycache__/graphlib.cpython-*.py[co]
 %{py_libdir}/__pycache__/gzip.cpython-*.py[co]
 %{py_libdir}/__pycache__/hashlib.cpython-*.py[co]
 %{py_libdir}/__pycache__/hmac.cpython-*.py[co]
@@ -963,7 +989,6 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/__pycache__/inspect.cpython-*.py[co]
 %{py_libdir}/__pycache__/ipaddress.cpython-*.py[co]
 %{py_libdir}/__pycache__/lzma.cpython-*.py[co]
-%{py_libdir}/__pycache__/macpath.cpython-*.py[co]
 %{py_libdir}/__pycache__/mailbox.cpython-*.py[co]
 %{py_libdir}/__pycache__/mailcap.cpython-*.py[co]
 %{py_libdir}/__pycache__/mimetypes.cpython-*.py[co]
@@ -1011,7 +1036,6 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/__pycache__/struct.cpython-*.py[co]
 %{py_libdir}/__pycache__/subprocess.cpython-*.py[co]
 %{py_libdir}/__pycache__/sunau.cpython-*.py[co]
-%{py_libdir}/__pycache__/symbol.cpython-*.py[co]
 %{py_libdir}/__pycache__/symtable.cpython-*.py[co]
 %{py_libdir}/__pycache__/tabnanny.cpython-*.py[co]
 %{py_libdir}/__pycache__/tarfile.cpython-*.py[co]
@@ -1033,6 +1057,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/__pycache__/xdrlib.cpython-*.py[co]
 %{py_libdir}/__pycache__/zipapp.cpython-*.py[co]
 %{py_libdir}/__pycache__/zipfile.cpython-*.py[co]
+%{py_libdir}/__pycache__/zipimport.cpython-*.py[co]
 
 #
 # list .so modules to be sure that all of them are built
@@ -1071,6 +1096,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{py_dyndir}/_multiprocessing.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_opcode.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_pickle.cpython-*.so
+%attr(755,root,root) %{py_dyndir}/_posixshmem.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_posixsubprocess.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_queue.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_random.cpython-*.so
@@ -1078,11 +1104,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{py_dyndir}/_sha3.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_socket.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_ssl.cpython-*.so
+%attr(755,root,root) %{py_dyndir}/_statistics.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_testbuffer.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_testcapi.cpython-*.so
+%attr(755,root,root) %{py_dyndir}/_testinternalcapi.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_testimportmultiple.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_testmultiphase.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_uuid.cpython-*.so
+%attr(755,root,root) %{py_dyndir}/_xxsubinterpreters.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/_xxtestfuzz.cpython-*.so
 
 # for openssl < 0.9.8 package sha256 and sha512 modules
@@ -1101,7 +1130,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{py_dyndir}/mmap.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/nis.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/ossaudiodev.cpython-*.so
-%attr(755,root,root) %{py_dyndir}/parser.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/pyexpat.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/readline.cpython-*.so
 %attr(755,root,root) %{py_dyndir}/resource.cpython-*.so
@@ -1170,6 +1198,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py_libdir}/importlib
 %{py_libdir}/importlib/__pycache__
 %{py_libdir}/importlib/*.py
+%dir %{py_libdir}/importlib/metadata
+%{py_libdir}/importlib/metadata/__pycache__
+%{py_libdir}/importlib/metadata/*.py
 
 %dir %{py_libdir}/json
 %{py_libdir}/json/__pycache__
@@ -1201,6 +1232,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/venv/*.py
 %dir %{py_libdir}/venv/scripts
 %dir %{py_libdir}/venv/scripts/common
+%{py_libdir}/venv/scripts/common/Activate.ps1
 %{py_libdir}/venv/scripts/common/activate
 %dir %{py_libdir}/venv/scripts/posix
 %{py_libdir}/venv/scripts/posix/activate.csh
@@ -1235,6 +1267,11 @@ rm -rf $RPM_BUILD_ROOT
 %{py_libdir}/sqlite3/__pycache__
 %{py_libdir}/sqlite3/*.py
 
+%attr(755,root,root) %{py_dyndir}/_zoneinfo.cpython-*.so
+%dir %{py_libdir}/zoneinfo
+%{py_libdir}/zoneinfo/__pycache__
+%{py_libdir}/zoneinfo/*.py
+
 %files -n pydoc3
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/pydoc3
@@ -1262,12 +1299,16 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
 %attr(755,root,root) %{_bindir}/python%{py_ver}-config
+%if "%{py_ver}" != "%{py_abi}"
 %attr(755,root,root) %{_bindir}/python%{py_abi}-config
+%endif
 %attr(755,root,root) %{_bindir}/python3-config
 %attr(755,root,root) %{_libdir}/libpython%{py_abi}.so
 %attr(755,root,root) %{_libdir}/libpython3.so
 %{py_incdir}/*.h
 %exclude %{py_incdir}/pyconfig.h
+%{py_incdir}/cpython
+%{py_incdir}/internal
 %attr(755,root,root) %{py_libdir}/config-%{py_platform}/makesetup
 %attr(755,root,root) %{py_libdir}/config-%{py_platform}/install-sh
 %{py_libdir}/config-%{py_platform}/config.c
@@ -1277,7 +1318,11 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py_libdir}/config-%{py_platform}/__pycache__
 %{py_libdir}/config-%{py_platform}/__pycache__/python-config.*
 %{_pkgconfigdir}/python-%{py_ver}.pc
+%{_pkgconfigdir}/python-%{py_ver}-embed.pc
+%{_pkgconfigdir}/python3-embed.pc
+%if "%{py_ver}" != "%{py_abi}"
 %{_pkgconfigdir}/python-%{py_abi}.pc
+%endif
 %{_pkgconfigdir}/python3.pc
 
 %files devel-tools
@@ -1331,7 +1376,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with info}
 %files doc-info
 %defattr(644,root,root,755)
-%{_infodir}/*.info*
+%{_infodir}/python.info*
 %endif
 
 %if %{with tkinter}
This page took 0.076499 seconds and 4 git commands to generate.