]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3-multilib.patch
- disable test_time on x32
[packages/python3.git] / python3-multilib.patch
index bea8dcf631d749bb2e8dd08beee8b919455e68f1..3075ba414204c7bb744d1e1e7b15314a6b9725f0 100644 (file)
@@ -1,6 +1,6 @@
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Include/pylifecycle.h Python-3.5.0/Include/pylifecycle.h
+diff -dur Python-3.5.0.orig/Include/pylifecycle.h Python-3.5.0/Include/pylifecycle.h
 --- Python-3.5.0.orig/Include/pylifecycle.h    2015-09-13 13:41:20.000000000 +0200
-+++ Python-3.5.0/Include/pylifecycle.h 2015-12-02 20:26:50.853793088 +0100
++++ Python-3.5.0/Include/pylifecycle.h 2015-12-03 17:31:03.874280444 +0100
 @@ -65,6 +65,8 @@
  /* In their own files */
  PyAPI_FUNC(const char *) Py_GetVersion(void);
@@ -10,9 +10,9 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Include/pylifecycle.h Python-3.5
  PyAPI_FUNC(const char *) Py_GetCopyright(void);
  PyAPI_FUNC(const char *) Py_GetCompiler(void);
  PyAPI_FUNC(const char *) Py_GetBuildInfo(void);
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/distutils/command/install.py Python-3.5.0/Lib/distutils/command/install.py
+diff -dur Python-3.5.0.orig/Lib/distutils/command/install.py Python-3.5.0/Lib/distutils/command/install.py
 --- Python-3.5.0.orig/Lib/distutils/command/install.py 2015-09-13 13:41:20.000000000 +0200
-+++ Python-3.5.0/Lib/distutils/command/install.py      2015-12-02 20:27:40.150761675 +0100
++++ Python-3.5.0/Lib/distutils/command/install.py      2015-12-03 17:31:03.874280444 +0100
 @@ -19,6 +19,8 @@
  from site import USER_SITE
  HAS_USER_SITE = True
@@ -42,9 +42,9 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/distutils/command/install.py
          'headers': '$base/include/python/$dist_name',
          'scripts': '$base/bin',
          'data'   : '$base',
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/distutils/sysconfig.py Python-3.5.0/Lib/distutils/sysconfig.py
+diff -dur Python-3.5.0.orig/Lib/distutils/sysconfig.py Python-3.5.0/Lib/distutils/sysconfig.py
 --- Python-3.5.0.orig/Lib/distutils/sysconfig.py       2015-09-13 13:41:21.000000000 +0200
-+++ Python-3.5.0/Lib/distutils/sysconfig.py    2015-12-02 20:26:50.853793088 +0100
++++ Python-3.5.0/Lib/distutils/sysconfig.py    2015-12-03 17:31:03.874280444 +0100
 @@ -132,8 +132,12 @@
              prefix = plat_specific and EXEC_PREFIX or PREFIX
  
@@ -52,16 +52,16 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/distutils/sysconfig.py Pytho
 +        if plat_specific:
 +            lib = sys.lib
 +        else:
-+            lib = 'lib'
++            lib = 'share'
          libpython = os.path.join(prefix,
 -                                 "lib", "python" + get_python_version())
 +                                 lib, "python" + get_python_version())
          if standard_lib:
              return libpython
          else:
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/distutils/tests/test_install.py Python-3.5.0/Lib/distutils/tests/test_install.py
+diff -dur Python-3.5.0.orig/Lib/distutils/tests/test_install.py Python-3.5.0/Lib/distutils/tests/test_install.py
 --- Python-3.5.0.orig/Lib/distutils/tests/test_install.py      2015-09-13 13:41:21.000000000 +0200
-+++ Python-3.5.0/Lib/distutils/tests/test_install.py   2015-12-02 20:26:50.853793088 +0100
++++ Python-3.5.0/Lib/distutils/tests/test_install.py   2015-12-03 17:31:03.874280444 +0100
 @@ -55,7 +55,7 @@
              expected = os.path.normpath(expected)
              self.assertEqual(got, expected)
@@ -71,20 +71,18 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/distutils/tests/test_install
          check_path(cmd.install_lib, libdir)
          check_path(cmd.install_platlib, libdir)
          check_path(cmd.install_purelib, libdir)
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/site.py Python-3.5.0/Lib/site.py
+diff -dur Python-3.5.0.orig/Lib/site.py Python-3.5.0/Lib/site.py
 --- Python-3.5.0.orig/Lib/site.py      2015-09-13 13:41:21.000000000 +0200
-+++ Python-3.5.0/Lib/site.py   2015-12-02 20:28:51.431199018 +0100
-@@ -303,12 +303,16 @@
++++ Python-3.5.0/Lib/site.py   2015-12-03 17:31:03.874280444 +0100
+@@ -304,12 +304,14 @@ def getsitepackages(prefixes=None):
          seen.add(prefix)
  
          if os.sep == '/':
 -            sitepackages.append(os.path.join(prefix, "lib",
 +            sitepackages.append(os.path.join(prefix, sys.lib,
-                                         "python" + sys.version[:3],
+                                         "python%d.%d" % sys.version_info[:2],
                                          "site-packages"))
 +            sitepackages.append(os.path.join(prefix, sys.lib, "site-python"))
-+            if sys.lib != 'lib':
-+                sitepackages.append(os.path.join(prefix, "lib", "python" + sys.version[:3], "site-packages"))
 +            sitepackages.append(os.path.join(prefix, "share", "python" + sys.version[:3], "site-packages"))
          else:
              sitepackages.append(prefix)
@@ -93,9 +91,9 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/site.py Python-3.5.0/Lib/sit
          if sys.platform == "darwin":
              # for framework builds *only* we add the standard Apple
              # locations.
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/sysconfig.py Python-3.5.0/Lib/sysconfig.py
+diff -dur Python-3.5.0.orig/Lib/sysconfig.py Python-3.5.0/Lib/sysconfig.py
 --- Python-3.5.0.orig/Lib/sysconfig.py 2015-09-13 13:41:21.000000000 +0200
-+++ Python-3.5.0/Lib/sysconfig.py      2015-12-02 20:26:50.853793088 +0100
++++ Python-3.5.0/Lib/sysconfig.py      2015-12-03 17:31:51.974741432 +0100
 @@ -20,10 +20,10 @@
  
  _INSTALL_SCHEMES = {
@@ -126,9 +124,37 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/sysconfig.py Python-3.5.0/Li
          'include': '{installed_base}/include/python',
          'platinclude': '{installed_base}/include/python',
          'scripts': '{base}/bin',
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
+@@ -61,10 +61,10 @@
+         'data': '{userbase}',
+         },
+     'posix_user': {
+-        'stdlib': '{userbase}/lib/python{py_version_short}',
+-        'platstdlib': '{userbase}/lib/python{py_version_short}',
+-        'purelib': '{userbase}/lib/python{py_version_short}/site-packages',
+-        'platlib': '{userbase}/lib/python{py_version_short}/site-packages',
++        'stdlib': '{userbase}/' + sys.lib + '/python{py_version_short}',
++        'platstdlib': '{userbase}/' + sys.lib + '/python{py_version_short}',
++        'purelib': '{userbase}/' + sys.lib + '/python{py_version_short}/site-packages',
++        'platlib': '{userbase}/' + sys.lib + '/python{py_version_short}/site-packages',
+         'include': '{userbase}/include/python{py_version_short}',
+         'scripts': '{userbase}/bin',
+         'data': '{userbase}',
+@@ -459,7 +459,11 @@
+         else:
+             inc_dir = _sys_home or _PROJECT_BASE
+     else:
+-        inc_dir = get_path('platinclude')
++        if hasattr(sys, 'abiflags'):
++            config_dir_name = 'config-%s%s' % (_PY_VERSION_SHORT, sys.abiflags)
++        else:
++            config_dir_name = 'config'
++        inc_dir = os.path.join(get_path('stdlib'), config_dir_name)
+     return os.path.join(inc_dir, 'pyconfig.h')
+diff -dur Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
 --- Python-3.5.0.orig/Makefile.pre.in  2015-09-13 13:41:23.000000000 +0200
-+++ Python-3.5.0/Makefile.pre.in       2015-12-02 20:28:51.434532372 +0100
++++ Python-3.5.0/Makefile.pre.in       2015-12-03 17:31:03.874280444 +0100
 @@ -101,6 +101,8 @@
  
  # Machine-dependent subdirectories
@@ -167,11 +193,11 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Mak
                        fi; \
                else \
                        echo Skip install of $(LIBRARY) - use make frameworkinstall; \
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Modules/getpath.c Python-3.5.0/Modules/getpath.c
+diff -dur Python-3.5.0.orig/Modules/getpath.c Python-3.5.0/Modules/getpath.c
 --- Python-3.5.0.orig/Modules/getpath.c        2015-09-13 13:41:24.000000000 +0200
-+++ Python-3.5.0/Modules/getpath.c     2015-12-02 20:26:50.857126441 +0100
-@@ -117,9 +117,21 @@
- #define EXEC_PREFIX PREFIX
++++ Python-3.5.0/Modules/getpath.c     2015-12-03 17:31:03.874280444 +0100
+@@ -100,6 +100,17 @@
+  extern "C" {
  #endif
  
 +#ifndef LIB_PYTHON
@@ -185,15 +211,9 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Modules/getpath.c Python-3.5.0/M
 +#define LIB_PYTHON "lib/python"
 +#endif
 +#endif
-+
- #ifndef PYTHONPATH
--#define PYTHONPATH PREFIX "/lib/python" VERSION ":" \
--              EXEC_PREFIX "/lib/python" VERSION "/lib-dynload"
-+#define PYTHONPATH PREFIX "/" LIB_PYTHON VERSION ":" \
-+              EXEC_PREFIX "/" LIB_PYTHON VERSION "/lib-dynload:"
- #endif
  
- #ifndef LANDMARK
+ #if !defined(PREFIX) || !defined(EXEC_PREFIX) || !defined(VERSION) || !defined(VPATH)
+ #error "PREFIX, EXEC_PREFIX, VERSION, and VPATH must be constant defined"
 @@ -511,7 +523,7 @@
      _pythonpath = Py_DecodeLocale(PYTHONPATH, NULL);
      _prefix = Py_DecodeLocale(PREFIX, NULL);
@@ -212,9 +232,9 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Modules/getpath.c Python-3.5.0/M
      bufsz = wcslen(zip_path);   /* Replace "00" with version */
      zip_path[bufsz - 6] = VERSION[0];
      zip_path[bufsz - 5] = VERSION[2];
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Python/getplatform.c Python-3.5.0/Python/getplatform.c
+diff -dur Python-3.5.0.orig/Python/getplatform.c Python-3.5.0/Python/getplatform.c
 --- Python-3.5.0.orig/Python/getplatform.c     2015-09-13 13:41:26.000000000 +0200
-+++ Python-3.5.0/Python/getplatform.c  2015-12-02 20:26:50.857126441 +0100
++++ Python-3.5.0/Python/getplatform.c  2015-12-03 17:31:03.874280444 +0100
 @@ -10,3 +10,23 @@
  {
        return PLATFORM;
@@ -239,9 +259,9 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Python/getplatform.c Python-3.5.
 +{
 +      return LIB;
 +}
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Python/sysmodule.c Python-3.5.0/Python/sysmodule.c
+diff -dur Python-3.5.0.orig/Python/sysmodule.c Python-3.5.0/Python/sysmodule.c
 --- Python-3.5.0.orig/Python/sysmodule.c       2015-09-13 13:41:26.000000000 +0200
-+++ Python-3.5.0/Python/sysmodule.c    2015-12-02 20:26:50.857126441 +0100
++++ Python-3.5.0/Python/sysmodule.c    2015-12-03 17:31:03.874280444 +0100
 @@ -1767,6 +1767,10 @@
                          PyUnicode_FromString(Py_GetCopyright()));
      SET_SYS_FROM_STRING("platform",
@@ -253,9 +273,9 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Python/sysmodule.c Python-3.5.0/
      SET_SYS_FROM_STRING("executable",
                          PyUnicode_FromWideChar(
                                 Py_GetProgramFullPath(), -1));
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/configure.ac Python-3.5.0/configure.ac
---- Python-3.5.0.orig/configure.ac     2015-12-02 20:26:33.157018154 +0100
-+++ Python-3.5.0/configure.ac  2015-12-02 20:28:51.431199018 +0100
+diff -dur Python-3.5.0.orig/configure.ac Python-3.5.0/configure.ac
+--- Python-3.5.0.orig/configure.ac     2015-12-03 17:30:32.777292009 +0100
++++ Python-3.5.0/configure.ac  2015-12-03 17:31:03.877613811 +0100
 @@ -722,6 +722,45 @@
    ])
  fi
@@ -302,18 +322,21 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/configure.ac Python-3.5.0/config
  
  MULTIARCH=$($CC --print-multiarch 2>/dev/null)
  AC_SUBST(MULTIARCH)
-@@ -4331,7 +4370,7 @@
+@@ -4640,9 +4640,9 @@ AC_MSG_RESULT($LDVERSION)
  dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
  AC_SUBST(PY_ENABLE_SHARED)
--LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
-+LIBPL='$(LIBDIR)/python'"${VERSION}/config-${LDVERSION}"
+ if test x$PLATFORM_TRIPLET = x; then
+-  LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
++  LIBPL='$(LIBDIR)/python'"${VERSION}/config-${LDVERSION}"
+ else
+-  LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
++  LIBPL='$(LIBDIR)/python'"${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
+ fi
  AC_SUBST(LIBPL)
  
- # Check whether right shifting a negative integer extends the sign bit
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/setup.py Python-3.5.0/setup.py
+diff -dur Python-3.5.0.orig/setup.py Python-3.5.0/setup.py
 --- Python-3.5.0.orig/setup.py 2015-09-13 13:41:26.000000000 +0200
-+++ Python-3.5.0/setup.py      2015-12-02 20:26:50.857126441 +0100
++++ Python-3.5.0/setup.py      2015-12-03 17:31:03.877613811 +0100
 @@ -526,8 +526,7 @@
          # be assumed that no additional -I,-L directives are needed.
          if not cross_compiling:
This page took 0.077196 seconds and 4 git commands to generate.