]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3-lib64.patch
- updated lib64 and noarch_to_datadir patches
[packages/python3.git] / python3-lib64.patch
index 2319b63f7a42faa7c32e9ff94b8e6f47bca32285..de28a24f537e94cd3a56e68062b3567fa16c58fa 100644 (file)
@@ -55,25 +55,24 @@ diff -Nur Python-2.5b2.orig/Include/pythonrun.h Python-2.5b2/Include/pythonrun.h
  PyAPI_FUNC(const char *) Py_GetCopyright(void);
  PyAPI_FUNC(const char *) Py_GetCompiler(void);
  PyAPI_FUNC(const char *) Py_GetBuildInfo(void);
-diff -Nur Python-2.5b2.orig/Lib/distutils/command/install.py Python-2.5b2/Lib/distutils/command/install.py
---- Python-2.5b2.orig/Lib/distutils/command/install.py 2006-03-27 22:55:21.000000000 +0100
-+++ Python-2.5b2/Lib/distutils/command/install.py      2006-07-12 17:42:51.000000000 +0100
-@@ -19,6 +19,8 @@
- from distutils.errors import DistutilsOptionError
- from glob import glob
+--- Python-3.2/Lib/distutils/command/install.py.orig   2010-11-25 04:46:44.000000000 +0100
++++ Python-3.2/Lib/distutils/command/install.py        2011-04-02 08:13:23.765733920 +0200
+@@ -27,6 +27,8 @@
+     from site import USER_SITE
+     HAS_USER_SITE = True
  
 +libname = sys.lib
 +
  if sys.version < "2.2":
      WINDOWS_SCHEME = {
          'purelib': '$base',
-@@ -39,14 +41,14 @@
+@@ -47,14 +49,14 @@
  INSTALL_SCHEMES = {
      'unix_prefix': {
          'purelib': '$base/lib/python$py_version_short/site-packages',
 -        'platlib': '$platbase/lib/python$py_version_short/site-packages',
 +        'platlib': '$platbase/'+libname+'/python$py_version_short/site-packages',
-         'headers': '$base/include/python$py_version_short/$dist_name',
+         'headers': '$base/include/python$py_version_short$abiflags/$dist_name',
          'scripts': '$base/bin',
          'data'   : '$base',
          },
@@ -115,36 +114,31 @@ diff -Nur Python-2.5b2.orig/Lib/distutils/tests/test_install.py Python-2.5b2/Lib
          check_path(cmd.install_purelib, libdir)
          check_path(cmd.install_headers,
                     os.path.join(destination, "include", "python", "foopkg"))
-diff -Nur Python-2.5b2.orig/Lib/site.py Python-2.5b2/Lib/site.py
---- Python-2.5b2.orig/Lib/site.py      2006-06-12 09:23:02.000000000 +0100
-+++ Python-2.5b2/Lib/site.py   2006-07-12 17:42:51.000000000 +0100
-@@ -258,13 +258,19 @@
+--- Python-3.2/Lib/site.py.orig        2010-12-26 20:54:29.000000000 +0100
++++ Python-3.2/Lib/site.py     2011-04-02 08:16:21.341737273 +0200
+@@ -285,13 +285,16 @@
          if sys.platform in ('os2emx', 'riscos'):
-             sitedirs.append(os.path.join(prefix, "Lib", "site-packages"))
+             sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
          elif os.sep == '/':
--            sitedirs.append(os.path.join(prefix, "lib",
-+            sitedirs.append(os.path.join(prefix, sys.lib,
+-            sitepackages.append(os.path.join(prefix, "lib",
++            sitepackages.append(os.path.join(prefix, sys.lib,
                                          "python" + sys.version[:3],
                                          "site-packages"))
--            sitedirs.append(os.path.join(prefix, "lib", "site-python"))
-+            sitedirs.append(os.path.join(prefix, sys.lib, "site-python"))
+-            sitepackages.append(os.path.join(prefix, "lib", "site-python"))
++            sitepackages.append(os.path.join(prefix, sys.lib, "site-python"))
 +            if sys.lib != 'lib':
-+                sitedirs.append(os.path.join(prefix, 'lib',
-+                                            "python" + sys.version[:3],
-+                                            "site-packages"))
-+                sitedirs.append(os.path.join(prefix, 'lib', "site-python"))
-+              
++                sitepackages.append(os.path.join(prefix, "lib", "python" + sys.version[:3], "site-packages"))
++                sitepackages.append(os.path.join(prefix, "lib", "site-python"))
          else:
-             sitedirs.append(prefix)
--            sitedirs.append(os.path.join(prefix, "lib", "site-packages"))
-+            sitedirs.append(os.path.join(prefix, sys.lib, "site-packages"))
+             sitepackages.append(prefix)
+-            sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
++            sitepackages.append(os.path.join(prefix, sys.lib, "site-packages"))
          if sys.platform == "darwin":
              # for framework builds *only* we add the standard Apple
-diff -Nur Python-2.5b2.orig/Makefile.pre.in Python-2.5b2/Makefile.pre.in
---- Python-2.5b2.orig/Makefile.pre.in  2006-06-27 16:45:32.000000000 +0100
-+++ Python-2.5b2/Makefile.pre.in       2006-07-12 17:42:51.000000000 +0100
-@@ -75,6 +75,8 @@
+             # locations.
+--- Python-3.2/Makefile.pre.in.orig    2011-02-19 09:47:14.000000000 +0100
++++ Python-3.2/Makefile.pre.in 2011-04-02 08:17:59.357737273 +0200
+@@ -86,6 +86,8 @@
  
  # Machine-dependent subdirectories
  MACHDEP=      @MACHDEP@
@@ -153,33 +147,27 @@ diff -Nur Python-2.5b2.orig/Makefile.pre.in Python-2.5b2/Makefile.pre.in
  
  # Install prefix for architecture-independent files
  prefix=               @prefix@
-@@ -84,11 +86,11 @@
- # Expanded directories
- BINDIR=               $(exec_prefix)/bin
--LIBDIR=               $(exec_prefix)/lib
-+LIBDIR=               $(exec_prefix)/$(LIB)
+@@ -102,7 +104,7 @@
  MANDIR=               @mandir@
  INCLUDEDIR=   @includedir@
  CONFINCLUDEDIR=       $(exec_prefix)/include
 -SCRIPTDIR=    $(prefix)/lib
 +SCRIPTDIR=    $(prefix)/$(LIB)
+ ABIFLAGS=     @ABIFLAGS@
  
  # Detailed destination directories
- BINLIBDEST=   $(LIBDIR)/python$(VERSION)
-@@ -489,7 +491,7 @@
- Python/compile.o Python/symtable.o: $(GRAMMAR_H) $(AST_H)
+@@ -605,7 +607,7 @@
+ Python/compile.o Python/symtable.o Python/ast.o: $(GRAMMAR_H) $(AST_H)
  
  Python/getplatform.o: $(srcdir)/Python/getplatform.c
--              $(CC) -c $(PY_CFLAGS) -DPLATFORM='"$(MACHDEP)"' -o $@ $(srcdir)/Python/getplatform.c
-+              $(CC) -c $(PY_CFLAGS) -DPLATFORM='"$(MACHDEP)"' -DARCH='"$(ARCH)"' -DLIB='"$(LIB)"' -o $@ $(srcdir)/Python/getplatform.c
+-              $(CC) -c $(PY_CORE_CFLAGS) -DPLATFORM='"$(MACHDEP)"' -o $@ $(srcdir)/Python/getplatform.c
++              $(CC) -c $(PY_CORE_CFLAGS) -DPLATFORM='"$(MACHDEP)"' -DARCH='"$(ARCH)"' -DLIB='"$(LIB)"' -o $@ $(srcdir)/Python/getplatform.c
  
  Python/importdl.o: $(srcdir)/Python/importdl.c
-               $(CC) -c $(PY_CFLAGS) -I$(DLINCLDIR) -o $@ $(srcdir)/Python/importdl.c
-diff -Nur Python-2.5b2.orig/Modules/getpath.c Python-2.5b2/Modules/getpath.c
---- Python-2.5b2.orig/Modules/getpath.c        2006-07-10 02:18:57.000000000 +0100
-+++ Python-2.5b2/Modules/getpath.c     2006-07-12 17:42:51.000000000 +0100
-@@ -116,9 +116,17 @@
+               $(CC) -c $(PY_CORE_CFLAGS) -I$(DLINCLDIR) -o $@ $(srcdir)/Python/importdl.c
+--- Python-3.2/Modules/getpath.c.orig  2010-12-03 21:14:31.000000000 +0100
++++ Python-3.2/Modules/getpath.c       2011-04-02 08:18:39.573738111 +0200
+@@ -121,9 +121,17 @@
  #define EXEC_PREFIX PREFIX
  #endif
  
@@ -199,15 +187,15 @@ diff -Nur Python-2.5b2.orig/Modules/getpath.c Python-2.5b2/Modules/getpath.c
  #endif
  
  #ifndef LANDMARK
-@@ -137,7 +137,7 @@
+@@ -134,7 +142,7 @@
  static wchar_t exec_prefix[MAXPATHLEN+1];
  static wchar_t progpath[MAXPATHLEN+1];
  static wchar_t *module_search_path = NULL;
--static wchar_t lib_python[] = L"lib/python" VERSION;
-+static wchar_t lib_python[] = LIB_PYTHON VERSION;
+-static wchar_t *lib_python = L"lib/python" VERSION;
++static wchar_t *lib_python = LIB_PYTHON VERSION;
  
- /* In principle, this should use HAVE__WSTAT, and _wstat
-    should be detected by autoconf. However, no current
+ static void
+ reduce(wchar_t *dir)
 diff -Nur Python-2.5b2.orig/Python/getplatform.c Python-2.5b2/Python/getplatform.c
 --- Python-2.5b2.orig/Python/getplatform.c     2000-09-02 00:29:29.000000000 +0100
 +++ Python-2.5b2/Python/getplatform.c  2006-07-12 17:42:51.000000000 +0100
@@ -235,26 +223,24 @@ diff -Nur Python-2.5b2.orig/Python/getplatform.c Python-2.5b2/Python/getplatform
 +{
 +      return LIB;
 +}
-diff -Nur Python-2.5b2.orig/Python/sysmodule.c Python-2.5b2/Python/sysmodule.c
---- Python-2.5b2.orig/Python/sysmodule.c       2006-07-10 22:08:24.000000000 +0100
-+++ Python-2.5b2/Python/sysmodule.c    2006-07-12 17:42:51.000000000 +0100
-@@ -1080,6 +1080,10 @@
-                           PyUnicode_FromString(Py_GetCopyright()));
-       SET_SYS_FROM_STRING("platform",
-                           PyUnicode_FromString(Py_GetPlatform()));
-+      SET_SYS_FROM_STRING("arch",
-+                          PyUnicode_FromString(Py_GetArch()));
-+      SET_SYS_FROM_STRING("lib",
-+                          PyUnicode_FromString(Py_GetLib()));
-       SET_SYS_FROM_STRING("executable",
-                           PyUnicode_FromString(Py_GetProgramFullPath()));
-       SET_SYS_FROM_STRING("prefix",
-diff -Nur Python-2.5b2.orig/setup.py Python-2.5b2/setup.py
---- Python-2.5b2.orig/setup.py 2006-06-30 07:18:39.000000000 +0100
-+++ Python-2.5b2/setup.py      2006-07-12 17:45:14.000000000 +0100
-@@ -290,12 +290,12 @@
-         except NameError:
-             have_unicode = 0
+--- Python-3.2/Python/sysmodule.c.orig 2011-01-05 21:08:25.000000000 +0100
++++ Python-3.2/Python/sysmodule.c      2011-04-02 08:20:16.773734758 +0200
+@@ -1608,6 +1608,10 @@
+                         PyUnicode_FromString(Py_GetCopyright()));
+     SET_SYS_FROM_STRING("platform",
+                         PyUnicode_FromString(Py_GetPlatform()));
++    SET_SYS_FROM_STRING("arch",
++                        PyUnicode_FromString(Py_GetArch()));
++    SET_SYS_FROM_STRING("lib",
++                        PyUnicode_FromString(Py_GetLib()));
+     SET_SYS_FROM_STRING("executable",
+                         PyUnicode_FromWideChar(
+                                Py_GetProgramFullPath(), -1));
+--- Python-3.2/setup.py.orig   2010-12-28 10:51:43.000000000 +0100
++++ Python-3.2/setup.py        2011-04-02 08:21:49.597738949 +0200
+@@ -422,12 +422,12 @@
+             add_dir_to_list(self.compiler.include_dirs,
+                             sysconfig.get_config_var("INCLUDEDIR"))
  
 +        libname = sys.lib
          # lib_dirs and inc_dirs are used to search for files;
@@ -267,17 +253,17 @@ diff -Nur Python-2.5b2.orig/setup.py Python-2.5b2/setup.py
              ]
          inc_dirs = self.compiler.include_dirs + ['/usr/include']
          exts = []
-@@ -496,11 +496,11 @@
-             elif self.compiler.find_library_file(lib_dirs, 'curses'):
-                 readline_libs.append('curses')
+@@ -620,11 +620,11 @@
+             elif curses_library:
+                 readline_libs.append(curses_library)
              elif self.compiler.find_library_file(lib_dirs +
--                                               ['/usr/lib/termcap'],
-+                                               ['/usr' + libname + '/termcap'],
-                                                'termcap'):
+-                                                     ['/usr/lib/termcap'],
++                                                     ['/usr/' + libname + '/termcap'],
+                                                      'termcap'):
                  readline_libs.append('termcap')
              exts.append( Extension('readline', ['readline.c'],
 -                                   library_dirs=['/usr/lib/termcap'],
-+                                   library_dirs=['/usr' + libname + 'termcap'],
++                                   library_dirs=['/usr/' + libname + '/termcap'],
                                     extra_link_args=readline_extra_link_args,
                                     libraries=readline_libs) )
-         if platform not in ['mac']:
+         else:
This page took 0.10639 seconds and 4 git commands to generate.