]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3-lib64.patch
- up to 3.5.0
[packages/python3.git] / python3-lib64.patch
index cf4493e6af2c09558e430247f7295322c65f9ad2..50bca29dc4c92a22f7a557262cf012dafa0d6b07 100644 (file)
@@ -1,9 +1,8 @@
-diff -Nur Python-2.5b2.orig/configure.in Python-2.5b2/configure.in
---- Python-2.5b2.orig/configure.in     2006-07-06 11:13:35.000000000 +0100
-+++ Python-2.5b2/configure.in  2006-07-12 17:42:51.000000000 +0100
-@@ -503,6 +503,41 @@
-     ;;
- esac
+--- Python-3.3.1/configure.ac.orig     2013-04-18 16:31:07.244030129 +0200
++++ Python-3.3.1/configure.ac  2013-04-18 17:30:31.800622500 +0200
+@@ -769,6 +769,45 @@
+ MULTIARCH=$($CC --print-multiarch 2>/dev/null)
+ AC_SUBST(MULTIARCH)
  
 +AC_SUBST(ARCH)
 +AC_MSG_CHECKING(ARCH)
@@ -35,18 +34,21 @@ diff -Nur Python-2.5b2.orig/configure.in Python-2.5b2/configure.in
 +powerpc64:yes | s390x:yes | sparc64:yes | x86_64:yes)
 +  LIB="lib64"
 +  ;;
++x86_64:no)
++  LIB="libx32"
++  ;;
 +*:*)
 +  LIB="lib"
 +  ;;
 +esac
 +AC_MSG_RESULT($LIB)
++
  
  AC_SUBST(LIBRARY)
  AC_MSG_CHECKING(LIBRARY)
-diff -Nur Python-2.5b2.orig/Include/pythonrun.h Python-2.5b2/Include/pythonrun.h
---- Python-2.5b2.orig/Include/pythonrun.h      2006-04-03 07:26:32.000000000 +0100
-+++ Python-2.5b2/Include/pythonrun.h   2006-07-12 17:42:51.000000000 +0100
-@@ -107,6 +107,8 @@
+--- Python-3.5.0/Include/pylifecycle.h~        2015-09-13 13:41:20.000000000 +0200
++++ Python-3.5.0/Include/pylifecycle.h 2015-09-13 20:08:24.017308537 +0200
+@@ -65,6 +65,8 @@ int _Py_CheckPython3();
  /* In their own files */
  PyAPI_FUNC(const char *) Py_GetVersion(void);
  PyAPI_FUNC(const char *) Py_GetPlatform(void);
@@ -55,25 +57,24 @@ diff -Nur Python-2.5b2.orig/Include/pythonrun.h Python-2.5b2/Include/pythonrun.h
  PyAPI_FUNC(const char *) Py_GetCopyright(void);
  PyAPI_FUNC(const char *) Py_GetCompiler(void);
  PyAPI_FUNC(const char *) Py_GetBuildInfo(void);
-diff -Nur Python-2.5b2.orig/Lib/distutils/command/install.py Python-2.5b2/Lib/distutils/command/install.py
---- Python-2.5b2.orig/Lib/distutils/command/install.py 2006-03-27 22:55:21.000000000 +0100
-+++ Python-2.5b2/Lib/distutils/command/install.py      2006-07-12 17:42:51.000000000 +0100
-@@ -19,6 +19,8 @@
- from distutils.errors import DistutilsOptionError
- from glob import glob
+--- Python-3.2.1.orig/Lib/distutils/command/install.py 2011-07-09 07:58:46.000000000 +0100
++++ Python-3.2.1/Lib/distutils/command/install.py      2011-07-12 22:20:12.000000000 +0100
+@@ -19,6 +19,8 @@ from site import USER_BASE
+ from site import USER_SITE
+ HAS_USER_SITE = True
  
 +libname = sys.lib
 +
- if sys.version < "2.2":
-     WINDOWS_SCHEME = {
-         'purelib': '$base',
-@@ -39,14 +41,14 @@
+ WINDOWS_SCHEME = {
+     'purelib': '$base/Lib/site-packages',
+     'platlib': '$base/Lib/site-packages',
+@@ -47,14 +49,14 @@
  INSTALL_SCHEMES = {
      'unix_prefix': {
          'purelib': '$base/lib/python$py_version_short/site-packages',
 -        'platlib': '$platbase/lib/python$py_version_short/site-packages',
 +        'platlib': '$platbase/'+libname+'/python$py_version_short/site-packages',
-         'headers': '$base/include/python$py_version_short/$dist_name',
+         'headers': '$base/include/python$py_version_short$abiflags/$dist_name',
          'scripts': '$base/bin',
          'data'   : '$base',
          },
@@ -84,10 +85,9 @@ diff -Nur Python-2.5b2.orig/Lib/distutils/command/install.py Python-2.5b2/Lib/di
          'headers': '$base/include/python/$dist_name',
          'scripts': '$base/bin',
          'data'   : '$base',
-diff -Nur Python-2.5b2.orig/Lib/distutils/sysconfig.py Python-2.5b2/Lib/distutils/sysconfig.py
---- Python-2.5b2.orig/Lib/distutils/sysconfig.py       2006-06-27 11:08:25.000000000 +0100
-+++ Python-2.5b2/Lib/distutils/sysconfig.py    2006-07-12 17:42:51.000000000 +0100
-@@ -99,8 +99,12 @@
+--- Python-3.2.1.orig/Lib/distutils/sysconfig.py       2011-07-09 07:58:47.000000000 +0100
++++ Python-3.2.1/Lib/distutils/sysconfig.py    2011-07-12 22:20:12.000000000 +0100
+@@ -124,8 +124,12 @@
          prefix = plat_specific and EXEC_PREFIX or PREFIX
  
      if os.name == "posix":
@@ -101,10 +101,9 @@ diff -Nur Python-2.5b2.orig/Lib/distutils/sysconfig.py Python-2.5b2/Lib/distutil
          if standard_lib:
              return libpython
          else:
-diff -Nur Python-2.5b2.orig/Lib/distutils/tests/test_install.py Python-2.5b2/Lib/distutils/tests/test_install.py
---- Python-2.5b2.orig/Lib/distutils/tests/test_install.py      2004-06-26 00:02:59.000000000 +0100
-+++ Python-2.5b2/Lib/distutils/tests/test_install.py   2006-07-12 17:42:51.000000000 +0100
-@@ -39,8 +39,9 @@
+--- Python-3.2.1.orig/Lib/distutils/tests/test_install.py      2011-07-09 07:58:47.000000000 +0100
++++ Python-3.2.1/Lib/distutils/tests/test_install.py   2011-07-12 22:20:12.000000000 +0100
+@@ -49,8 +49,9 @@
              self.assertEqual(got, expected)
  
          libdir = os.path.join(destination, "lib", "python")
@@ -115,36 +114,59 @@ diff -Nur Python-2.5b2.orig/Lib/distutils/tests/test_install.py Python-2.5b2/Lib
          check_path(cmd.install_purelib, libdir)
          check_path(cmd.install_headers,
                     os.path.join(destination, "include", "python", "foopkg"))
-diff -Nur Python-2.5b2.orig/Lib/site.py Python-2.5b2/Lib/site.py
---- Python-2.5b2.orig/Lib/site.py      2006-06-12 09:23:02.000000000 +0100
-+++ Python-2.5b2/Lib/site.py   2006-07-12 17:42:51.000000000 +0100
-@@ -258,13 +258,19 @@
-         if sys.platform in ('os2emx', 'riscos'):
-             sitedirs.append(os.path.join(prefix, "Lib", "site-packages"))
-         elif os.sep == '/':
--            sitedirs.append(os.path.join(prefix, "lib",
-+            sitedirs.append(os.path.join(prefix, sys.lib,
+--- Python-3.2.1.orig/Lib/site.py      2011-07-09 07:58:49.000000000 +0100
++++ Python-3.2.1/Lib/site.py   2011-07-12 22:20:12.000000000 +0100
+@@ -304,12 +304,15 @@ def getsitepackages(prefixes=None):
+         seen.add(prefix)
+         if os.sep == '/':
+-            sitepackages.append(os.path.join(prefix, "lib",
++            sitepackages.append(os.path.join(prefix, sys.lib,
                                          "python" + sys.version[:3],
                                          "site-packages"))
--            sitedirs.append(os.path.join(prefix, "lib", "site-python"))
-+            sitedirs.append(os.path.join(prefix, sys.lib, "site-python"))
++            sitepackages.append(os.path.join(prefix, sys.lib, "site-python"))
 +            if sys.lib != 'lib':
-+                sitedirs.append(os.path.join(prefix, 'lib',
-+                                            "python" + sys.version[:3],
-+                                            "site-packages"))
-+                sitedirs.append(os.path.join(prefix, 'lib', "site-python"))
-+              
++                sitepackages.append(os.path.join(prefix, "lib", "python" + sys.version[:3], "site-packages"))
          else:
-             sitedirs.append(prefix)
--            sitedirs.append(os.path.join(prefix, "lib", "site-packages"))
-+            sitedirs.append(os.path.join(prefix, sys.lib, "site-packages"))
+             sitepackages.append(prefix)
+-            sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
++            sitepackages.append(os.path.join(prefix, sys.lib, "site-packages"))
          if sys.platform == "darwin":
              # for framework builds *only* we add the standard Apple
-diff -Nur Python-2.5b2.orig/Makefile.pre.in Python-2.5b2/Makefile.pre.in
---- Python-2.5b2.orig/Makefile.pre.in  2006-06-27 16:45:32.000000000 +0100
-+++ Python-2.5b2/Makefile.pre.in       2006-07-12 17:42:51.000000000 +0100
-@@ -75,6 +75,8 @@
+             # locations.
+--- Python-3.2.1.orig/Lib/sysconfig.py 2011-07-09 07:58:49.000000000 +0100
++++ Python-3.2.1/Lib/sysconfig.py      2011-07-12 22:20:12.000000000 +0100
+@@ -21,10 +21,10 @@
+ _INSTALL_SCHEMES = {
+     'posix_prefix': {
+-        'stdlib': '{installed_base}/lib/python{py_version_short}',
+-        'platstdlib': '{platbase}/lib/python{py_version_short}',
++        'stdlib': '{installed_base}/' + sys.lib + '/python{py_version_short}',
++        'platstdlib': '{platbase}/' + sys.lib + '/python{py_version_short}',
+         'purelib': '{base}/lib/python{py_version_short}/site-packages',
+-        'platlib': '{platbase}/lib/python{py_version_short}/site-packages',
++        'platlib': '{platbase}/' + sys.lib + '/python{py_version_short}/site-packages',
+         'include':
+             '{installed_base}/include/python{py_version_short}{abiflags}',
+         'platinclude':
+@@ -33,10 +33,10 @@
+         'data': '{base}',
+         },
+     'posix_home': {
+-        'stdlib': '{installed_base}/lib/python',
+-        'platstdlib': '{base}/lib/python',
++        'stdlib': '{installed_base}/' + sys.lib + '/python',
++        'platstdlib': '{base}/' + sys.lib + '/python',
+         'purelib': '{base}/lib/python',
+-        'platlib': '{base}/lib/python',
++        'platlib': '{base}/' + sys.lib + '/python',
+         'include': '{installed_base}/include/python',
+         'platinclude': '{installed_base}/include/python',
+         'scripts': '{base}/bin',
+--- Python-3.2.1.orig/Makefile.pre.in  2011-07-09 07:58:52.000000000 +0100
++++ Python-3.2.1/Makefile.pre.in       2011-07-12 22:20:12.000000000 +0100
+@@ -90,6 +90,8 @@
  
  # Machine-dependent subdirectories
  MACHDEP=      @MACHDEP@
@@ -153,41 +175,39 @@ diff -Nur Python-2.5b2.orig/Makefile.pre.in Python-2.5b2/Makefile.pre.in
  
  # Install prefix for architecture-independent files
  prefix=               @prefix@
-@@ -84,11 +86,11 @@
- # Expanded directories
- BINDIR=               $(exec_prefix)/bin
--LIBDIR=               $(exec_prefix)/lib
-+LIBDIR=               $(exec_prefix)/$(LIB)
+@@ -106,7 +108,7 @@
  MANDIR=               @mandir@
  INCLUDEDIR=   @includedir@
  CONFINCLUDEDIR=       $(exec_prefix)/include
 -SCRIPTDIR=    $(prefix)/lib
 +SCRIPTDIR=    $(prefix)/$(LIB)
+ ABIFLAGS=     @ABIFLAGS@
  
  # Detailed destination directories
- BINLIBDEST=   $(LIBDIR)/python$(VERSION)
-@@ -489,7 +491,7 @@
- Python/compile.o Python/symtable.o: $(GRAMMAR_H) $(AST_H)
+@@ -611,7 +613,7 @@
+ Python/compile.o Python/symtable.o Python/ast.o: $(GRAMMAR_H) $(AST_H)
  
  Python/getplatform.o: $(srcdir)/Python/getplatform.c
--              $(CC) -c $(PY_CFLAGS) -DPLATFORM='"$(MACHDEP)"' -o $@ $(srcdir)/Python/getplatform.c
-+              $(CC) -c $(PY_CFLAGS) -DPLATFORM='"$(MACHDEP)"' -DARCH='"$(ARCH)"' -DLIB='"$(LIB)"' -o $@ $(srcdir)/Python/getplatform.c
+-              $(CC) -c $(PY_CORE_CFLAGS) -DPLATFORM='"$(MACHDEP)"' -o $@ $(srcdir)/Python/getplatform.c
++              $(CC) -c $(PY_CORE_CFLAGS) -DPLATFORM='"$(MACHDEP)"' -DARCH='"$(ARCH)"' -DLIB='"$(LIB)"' -o $@ $(srcdir)/Python/getplatform.c
  
  Python/importdl.o: $(srcdir)/Python/importdl.c
-               $(CC) -c $(PY_CFLAGS) -I$(DLINCLDIR) -o $@ $(srcdir)/Python/importdl.c
-diff -Nur Python-2.5b2.orig/Modules/getpath.c Python-2.5b2/Modules/getpath.c
---- Python-2.5b2.orig/Modules/getpath.c        2006-07-10 02:18:57.000000000 +0100
-+++ Python-2.5b2/Modules/getpath.c     2006-07-12 17:42:51.000000000 +0100
-@@ -116,9 +116,17 @@
+               $(CC) -c $(PY_CORE_CFLAGS) -I$(DLINCLDIR) -o $@ $(srcdir)/Python/importdl.c
+--- Python-3.2.1.orig/Modules/getpath.c        2011-07-09 07:58:54.000000000 +0100
++++ Python-3.2.1/Modules/getpath.c     2011-07-12 22:21:48.000000000 +0100
+@@ -121,9 +121,21 @@
  #define EXEC_PREFIX PREFIX
  #endif
  
 +#ifndef LIB_PYTHON
 +#if defined(__x86_64__) || (defined(__sparc__) && defined(__arch64__)) || defined(__powerpc64__) || defined(__s390x__)
-+#define LIB_PYTHON L"lib64/python"
++#if defined(__ILP32__)
++#define LIB_PYTHON "libx32/python"
++#else
++#define LIB_PYTHON "lib64/python"
++#endif
 +#else
-+#define LIB_PYTHON L"lib/python"
++#define LIB_PYTHON "lib/python"
 +#endif
 +#endif
 +
@@ -199,18 +219,17 @@ diff -Nur Python-2.5b2.orig/Modules/getpath.c Python-2.5b2/Modules/getpath.c
  #endif
  
  #ifndef LANDMARK
-@@ -137,7 +137,7 @@
static wchar_t exec_prefix[MAXPATHLEN+1];
static wchar_t progpath[MAXPATHLEN+1];
static wchar_t *module_search_path = NULL;
--static wchar_t lib_python[] = L"lib/python" VERSION;
-+static wchar_t lib_python[] = LIB_PYTHON VERSION;
+@@ -502,7 +514,7 @@ calculate_path(void)
    _pythonpath = Py_DecodeLocale(PYTHONPATH, NULL);
    _prefix = Py_DecodeLocale(PREFIX, NULL);
    _exec_prefix = Py_DecodeLocale(EXEC_PREFIX, NULL);
+-    lib_python = Py_DecodeLocale("lib/python" VERSION, NULL);
++    lib_python = Py_DecodeLocale(LIB_PYTHON VERSION, NULL);
  
- /* In principle, this should use HAVE__WSTAT, and _wstat
-    should be detected by autoconf. However, no current
-diff -Nur Python-2.5b2.orig/Python/getplatform.c Python-2.5b2/Python/getplatform.c
---- Python-2.5b2.orig/Python/getplatform.c     2000-09-02 00:29:29.000000000 +0100
-+++ Python-2.5b2/Python/getplatform.c  2006-07-12 17:42:51.000000000 +0100
+     if (!_pythonpath || !_prefix || !_exec_prefix || !lib_python) {
+         Py_FatalError(
+--- Python-3.2.1.orig/Python/getplatform.c     2011-07-09 07:58:56.000000000 +0100
++++ Python-3.2.1/Python/getplatform.c  2011-07-12 22:20:12.000000000 +0100
 @@ -10,3 +10,23 @@
  {
        return PLATFORM;
@@ -235,60 +254,42 @@ diff -Nur Python-2.5b2.orig/Python/getplatform.c Python-2.5b2/Python/getplatform
 +{
 +      return LIB;
 +}
-diff -Nur Python-2.5b2.orig/Python/sysmodule.c Python-2.5b2/Python/sysmodule.c
---- Python-2.5b2.orig/Python/sysmodule.c       2006-07-10 22:08:24.000000000 +0100
-+++ Python-2.5b2/Python/sysmodule.c    2006-07-12 17:42:51.000000000 +0100
-@@ -1080,6 +1080,10 @@
-                           PyUnicode_FromString(Py_GetCopyright()));
-       SET_SYS_FROM_STRING("platform",
-                           PyUnicode_FromString(Py_GetPlatform()));
-+      SET_SYS_FROM_STRING("arch",
-+                          PyUnicode_FromString(Py_GetArch()));
-+      SET_SYS_FROM_STRING("lib",
-+                          PyUnicode_FromString(Py_GetLib()));
-       SET_SYS_FROM_STRING("executable",
-                           PyUnicode_FromString(Py_GetProgramFullPath()));
-       SET_SYS_FROM_STRING("prefix",
-diff -Nur Python-2.5b2.orig/setup.py Python-2.5b2/setup.py
---- Python-2.5b2.orig/setup.py 2006-06-30 07:18:39.000000000 +0100
-+++ Python-2.5b2/setup.py      2006-07-12 17:45:14.000000000 +0100
-@@ -290,12 +290,12 @@
-         except NameError:
-             have_unicode = 0
-+        libname = sys.lib
-         # lib_dirs and inc_dirs are used to search for files;
-         # if a file is found in one of those directories, it can
+--- Python-3.2.1.orig/Python/sysmodule.c       2011-07-09 07:58:56.000000000 +0100
++++ Python-3.2.1/Python/sysmodule.c    2011-07-12 22:20:12.000000000 +0100
+@@ -1560,6 +1560,10 @@
+                         PyUnicode_FromString(Py_GetCopyright()));
+     SET_SYS_FROM_STRING("platform",
+                         PyUnicode_FromString(Py_GetPlatform()));
++    SET_SYS_FROM_STRING("arch",
++                        PyUnicode_FromString(Py_GetArch()));
++    SET_SYS_FROM_STRING("lib",
++                        PyUnicode_FromString(Py_GetLib()));
+     SET_SYS_FROM_STRING("executable",
+                         PyUnicode_FromWideChar(
+                                Py_GetProgramFullPath(), -1));
+--- Python-3.2.1.orig/setup.py 2011-07-09 07:58:56.000000000 +0100
++++ Python-3.2.1/setup.py      2011-07-12 22:20:12.000000000 +0100
+@@ -516,8 +516,7 @@
          # be assumed that no additional -I,-L directives are needed.
-         lib_dirs = self.compiler.library_dirs + [
--            '/lib64', '/usr/lib64',
--            '/lib', '/usr/lib',
-+            libname, '/usr/'+libname
-             ]
-         inc_dirs = self.compiler.include_dirs + ['/usr/include']
+         if not cross_compiling:
+             lib_dirs = self.compiler.library_dirs + [
+-                '/lib64', '/usr/lib64',
+-                '/lib', '/usr/lib',
++                '/' + sys.lib, '/usr/' + sys.lib
+                 ]
+             inc_dirs = self.compiler.include_dirs + ['/usr/include']
          exts = []
-@@ -496,11 +496,11 @@
-             elif self.compiler.find_library_file(lib_dirs, 'curses'):
-                 readline_libs.append('curses')
+@@ -643,11 +642,11 @@
+             elif curses_library:
+                 readline_libs.append(curses_library)
              elif self.compiler.find_library_file(lib_dirs +
--                                               ['/usr/lib/termcap'],
-+                                               ['/usr' + libname + '/termcap'],
-                                                'termcap'):
+-                                                     ['/usr/lib/termcap'],
++                                                     ['/usr/' + sys.lib + '/termcap'],
+                                                      'termcap'):
                  readline_libs.append('termcap')
              exts.append( Extension('readline', ['readline.c'],
 -                                   library_dirs=['/usr/lib/termcap'],
-+                                   library_dirs=['/usr' + libname + 'termcap'],
++                                   library_dirs=['/usr/' + sys.lib + '/termcap'],
                                     extra_link_args=readline_extra_link_args,
                                     libraries=readline_libs) )
-         if platform not in ['mac']:
-@@ -1244,8 +1244,8 @@
-             added_lib_dirs.append('/usr/openwin/lib')
-         elif os.path.exists('/usr/X11R6/include'):
-             include_dirs.append('/usr/X11R6/include')
--            added_lib_dirs.append('/usr/X11R6/lib64')
--            added_lib_dirs.append('/usr/X11R6/lib')
-+            added_lib_dirs.append('/usr/X11R6/'+sys.lib)
-+            #added_lib_dirs.append('/usr/X11R6/lib')
-         elif os.path.exists('/usr/X11R5/include'):
-             include_dirs.append('/usr/X11R5/include')
-             added_lib_dirs.append('/usr/X11R5/lib')
+         else:
This page took 0.07294 seconds and 4 git commands to generate.