]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3-lib64.patch
- up to 3.5.0
[packages/python3.git] / python3-lib64.patch
index a6c13e66a9920a212aaebbf072bdbb7e976cc3ee..50bca29dc4c92a22f7a557262cf012dafa0d6b07 100644 (file)
@@ -1,6 +1,6 @@
 --- Python-3.3.1/configure.ac.orig     2013-04-18 16:31:07.244030129 +0200
 +++ Python-3.3.1/configure.ac  2013-04-18 17:30:31.800622500 +0200
-@@ -769,6 +768,45 @@
+@@ -769,6 +769,45 @@
  MULTIARCH=$($CC --print-multiarch 2>/dev/null)
  AC_SUBST(MULTIARCH)
  
@@ -46,9 +46,9 @@
  
  AC_SUBST(LIBRARY)
  AC_MSG_CHECKING(LIBRARY)
---- Python-3.2.1.orig/Include/pythonrun.h      2011-07-09 07:58:46.000000000 +0100
-+++ Python-3.2.1/Include/pythonrun.h   2011-07-12 22:20:12.000000000 +0100
-@@ -175,6 +175,8 @@
+--- Python-3.5.0/Include/pylifecycle.h~        2015-09-13 13:41:20.000000000 +0200
++++ Python-3.5.0/Include/pylifecycle.h 2015-09-13 20:08:24.017308537 +0200
+@@ -65,6 +65,8 @@ int _Py_CheckPython3();
  /* In their own files */
  PyAPI_FUNC(const char *) Py_GetVersion(void);
  PyAPI_FUNC(const char *) Py_GetPlatform(void);
                     os.path.join(destination, "include", "python", "foopkg"))
 --- Python-3.2.1.orig/Lib/site.py      2011-07-09 07:58:49.000000000 +0100
 +++ Python-3.2.1/Lib/site.py   2011-07-12 22:20:12.000000000 +0100
-@@ -304,13 +304,16 @@ def getsitepackages(prefixes=None):
+@@ -304,12 +304,15 @@ def getsitepackages(prefixes=None):
          seen.add(prefix)
  
          if os.sep == '/':
 +            sitepackages.append(os.path.join(prefix, sys.lib,
                                          "python" + sys.version[:3],
                                          "site-packages"))
--            sitepackages.append(os.path.join(prefix, "lib", "site-python"))
 +            sitepackages.append(os.path.join(prefix, sys.lib, "site-python"))
 +            if sys.lib != 'lib':
 +                sitepackages.append(os.path.join(prefix, "lib", "python" + sys.version[:3], "site-packages"))
-+                sitepackages.append(os.path.join(prefix, "lib", "site-python"))
          else:
              sitepackages.append(prefix)
 -            sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
  #endif
  
  #ifndef LANDMARK
-@@ -502,7 +502,7 @@ calculate_path(void)
-     _pythonpath = _Py_char2wchar(PYTHONPATH, NULL);
-     _prefix = _Py_char2wchar(PREFIX, NULL);
-     _exec_prefix = _Py_char2wchar(EXEC_PREFIX, NULL);
--    lib_python = _Py_char2wchar("lib/python" VERSION, NULL);
-+    lib_python = _Py_char2wchar(LIB_PYTHON VERSION, NULL);
+@@ -502,7 +514,7 @@ calculate_path(void)
+     _pythonpath = Py_DecodeLocale(PYTHONPATH, NULL);
+     _prefix = Py_DecodeLocale(PREFIX, NULL);
+     _exec_prefix = Py_DecodeLocale(EXEC_PREFIX, NULL);
+-    lib_python = Py_DecodeLocale("lib/python" VERSION, NULL);
++    lib_python = Py_DecodeLocale(LIB_PYTHON VERSION, NULL);
  
      if (!_pythonpath || !_prefix || !_exec_prefix || !lib_python) {
          Py_FatalError(
                  ]
              inc_dirs = self.compiler.include_dirs + ['/usr/include']
          exts = []
-@@ -643,11 +643,11 @@
+@@ -643,11 +642,11 @@
              elif curses_library:
                  readline_libs.append(curses_library)
              elif self.compiler.find_library_file(lib_dirs +
This page took 0.060779 seconds and 4 git commands to generate.