]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3-lib64.patch
- up to 3.5.0
[packages/python3.git] / python3-lib64.patch
index 2813a1a727a46caf5acd0e02f2133547a2ec4dcf..50bca29dc4c92a22f7a557262cf012dafa0d6b07 100644 (file)
@@ -1,6 +1,6 @@
 --- Python-3.3.1/configure.ac.orig     2013-04-18 16:31:07.244030129 +0200
 +++ Python-3.3.1/configure.ac  2013-04-18 17:30:31.800622500 +0200
-@@ -769,6 +768,42 @@
+@@ -769,6 +769,45 @@
  MULTIARCH=$($CC --print-multiarch 2>/dev/null)
  AC_SUBST(MULTIARCH)
  
@@ -34,6 +34,9 @@
 +powerpc64:yes | s390x:yes | sparc64:yes | x86_64:yes)
 +  LIB="lib64"
 +  ;;
++x86_64:no)
++  LIB="libx32"
++  ;;
 +*:*)
 +  LIB="lib"
 +  ;;
@@ -43,9 +46,9 @@
  
  AC_SUBST(LIBRARY)
  AC_MSG_CHECKING(LIBRARY)
---- Python-3.2.1.orig/Include/pythonrun.h      2011-07-09 07:58:46.000000000 +0100
-+++ Python-3.2.1/Include/pythonrun.h   2011-07-12 22:20:12.000000000 +0100
-@@ -175,6 +175,8 @@
+--- Python-3.5.0/Include/pylifecycle.h~        2015-09-13 13:41:20.000000000 +0200
++++ Python-3.5.0/Include/pylifecycle.h 2015-09-13 20:08:24.017308537 +0200
+@@ -65,6 +65,8 @@ int _Py_CheckPython3();
  /* In their own files */
  PyAPI_FUNC(const char *) Py_GetVersion(void);
  PyAPI_FUNC(const char *) Py_GetPlatform(void);
  PyAPI_FUNC(const char *) Py_GetBuildInfo(void);
 --- Python-3.2.1.orig/Lib/distutils/command/install.py 2011-07-09 07:58:46.000000000 +0100
 +++ Python-3.2.1/Lib/distutils/command/install.py      2011-07-12 22:20:12.000000000 +0100
-@@ -27,6 +27,8 @@
    from site import USER_SITE
    HAS_USER_SITE = True
+@@ -19,6 +19,8 @@ from site import USER_BASE
+ from site import USER_SITE
+ HAS_USER_SITE = True
  
 +libname = sys.lib
 +
- if sys.version < "2.2":
-     WINDOWS_SCHEME = {
-         'purelib': '$base',
+ WINDOWS_SCHEME = {
+     'purelib': '$base/Lib/site-packages',
+     'platlib': '$base/Lib/site-packages',
 @@ -47,14 +49,14 @@
  INSTALL_SCHEMES = {
      'unix_prefix': {
                     os.path.join(destination, "include", "python", "foopkg"))
 --- Python-3.2.1.orig/Lib/site.py      2011-07-09 07:58:49.000000000 +0100
 +++ Python-3.2.1/Lib/site.py   2011-07-12 22:20:12.000000000 +0100
-@@ -285,13 +285,16 @@
-         if sys.platform in ('os2emx', 'riscos'):
-             sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
-         elif os.sep == '/':
+@@ -304,12 +304,15 @@ def getsitepackages(prefixes=None):
+         seen.add(prefix)
+         if os.sep == '/':
 -            sitepackages.append(os.path.join(prefix, "lib",
 +            sitepackages.append(os.path.join(prefix, sys.lib,
                                          "python" + sys.version[:3],
                                          "site-packages"))
--            sitepackages.append(os.path.join(prefix, "lib", "site-python"))
 +            sitepackages.append(os.path.join(prefix, sys.lib, "site-python"))
 +            if sys.lib != 'lib':
 +                sitepackages.append(os.path.join(prefix, "lib", "python" + sys.version[:3], "site-packages"))
-+                sitepackages.append(os.path.join(prefix, "lib", "site-python"))
          else:
              sitepackages.append(prefix)
 -            sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
 -        'stdlib': '{installed_base}/lib/python',
 -        'platstdlib': '{base}/lib/python',
 +        'stdlib': '{installed_base}/' + sys.lib + '/python',
-+        'platstdlib': '{base}/' + sys.lib + ' /python',
++        'platstdlib': '{base}/' + sys.lib + '/python',
          'purelib': '{base}/lib/python',
 -        'platlib': '{base}/lib/python',
 +        'platlib': '{base}/' + sys.lib + '/python',
                $(CC) -c $(PY_CORE_CFLAGS) -I$(DLINCLDIR) -o $@ $(srcdir)/Python/importdl.c
 --- Python-3.2.1.orig/Modules/getpath.c        2011-07-09 07:58:54.000000000 +0100
 +++ Python-3.2.1/Modules/getpath.c     2011-07-12 22:21:48.000000000 +0100
-@@ -121,9 +121,17 @@
+@@ -121,9 +121,21 @@
  #define EXEC_PREFIX PREFIX
  #endif
  
 +#ifndef LIB_PYTHON
 +#if defined(__x86_64__) || (defined(__sparc__) && defined(__arch64__)) || defined(__powerpc64__) || defined(__s390x__)
-+#define LIB_PYTHON L"lib64/python"
++#if defined(__ILP32__)
++#define LIB_PYTHON "libx32/python"
++#else
++#define LIB_PYTHON "lib64/python"
++#endif
 +#else
-+#define LIB_PYTHON L"lib/python"
++#define LIB_PYTHON "lib/python"
 +#endif
 +#endif
 +
  #endif
  
  #ifndef LANDMARK
-@@ -135,7 +143,7 @@
static wchar_t progpath[MAXPATHLEN+1];
static wchar_t *module_search_path = NULL;
static int module_search_path_malloced = 0;
--static wchar_t *lib_python = L"lib/python" VERSION;
-++static wchar_t *lib_python = LIB_PYTHON VERSION;
+@@ -502,7 +514,7 @@ calculate_path(void)
    _pythonpath = Py_DecodeLocale(PYTHONPATH, NULL);
    _prefix = Py_DecodeLocale(PREFIX, NULL);
    _exec_prefix = Py_DecodeLocale(EXEC_PREFIX, NULL);
+-    lib_python = Py_DecodeLocale("lib/python" VERSION, NULL);
++    lib_python = Py_DecodeLocale(LIB_PYTHON VERSION, NULL);
  
- static void
- reduce(wchar_t *dir)
+     if (!_pythonpath || !_prefix || !_exec_prefix || !lib_python) {
+         Py_FatalError(
 --- Python-3.2.1.orig/Python/getplatform.c     2011-07-09 07:58:56.000000000 +0100
 +++ Python-3.2.1/Python/getplatform.c  2011-07-12 22:20:12.000000000 +0100
 @@ -10,3 +10,23 @@
                  ]
              inc_dirs = self.compiler.include_dirs + ['/usr/include']
          exts = []
-@@ -643,11 +643,11 @@
+@@ -643,11 +642,11 @@
              elif curses_library:
                  readline_libs.append(curses_library)
              elif self.compiler.find_library_file(lib_dirs +
This page took 0.370701 seconds and 4 git commands to generate.