]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3-lib64.patch
- up to 3.5.0
[packages/python3.git] / python3-lib64.patch
index 13caf623ff844d8760b454973e21b8654b562e18..50bca29dc4c92a22f7a557262cf012dafa0d6b07 100644 (file)
@@ -1,9 +1,8 @@
-diff -Nur Python-3.2.1.orig//configure.in Python-3.2.1/configure.in
---- Python-3.2.1.orig//configure.in    2011-07-09 07:58:56.000000000 +0100
-+++ Python-3.2.1/configure.in  2011-07-12 22:20:12.000000000 +0100
-@@ -592,6 +592,41 @@
-     esac;;
- esac
+--- Python-3.3.1/configure.ac.orig     2013-04-18 16:31:07.244030129 +0200
++++ Python-3.3.1/configure.ac  2013-04-18 17:30:31.800622500 +0200
+@@ -769,6 +769,45 @@
+ MULTIARCH=$($CC --print-multiarch 2>/dev/null)
+ AC_SUBST(MULTIARCH)
  
 +AC_SUBST(ARCH)
 +AC_MSG_CHECKING(ARCH)
@@ -35,18 +34,21 @@ diff -Nur Python-3.2.1.orig//configure.in Python-3.2.1/configure.in
 +powerpc64:yes | s390x:yes | sparc64:yes | x86_64:yes)
 +  LIB="lib64"
 +  ;;
++x86_64:no)
++  LIB="libx32"
++  ;;
 +*:*)
 +  LIB="lib"
 +  ;;
 +esac
 +AC_MSG_RESULT($LIB)
++
  
  AC_SUBST(LIBRARY)
  AC_MSG_CHECKING(LIBRARY)
-diff -Nur Python-3.2.1.orig//Include/pythonrun.h Python-3.2.1/Include/pythonrun.h
---- Python-3.2.1.orig//Include/pythonrun.h     2011-07-09 07:58:46.000000000 +0100
-+++ Python-3.2.1/Include/pythonrun.h   2011-07-12 22:20:12.000000000 +0100
-@@ -175,6 +175,8 @@
+--- Python-3.5.0/Include/pylifecycle.h~        2015-09-13 13:41:20.000000000 +0200
++++ Python-3.5.0/Include/pylifecycle.h 2015-09-13 20:08:24.017308537 +0200
+@@ -65,6 +65,8 @@ int _Py_CheckPython3();
  /* In their own files */
  PyAPI_FUNC(const char *) Py_GetVersion(void);
  PyAPI_FUNC(const char *) Py_GetPlatform(void);
@@ -55,18 +57,17 @@ diff -Nur Python-3.2.1.orig//Include/pythonrun.h Python-3.2.1/Include/pythonrun.
  PyAPI_FUNC(const char *) Py_GetCopyright(void);
  PyAPI_FUNC(const char *) Py_GetCompiler(void);
  PyAPI_FUNC(const char *) Py_GetBuildInfo(void);
-diff -Nur Python-3.2.1.orig//Lib/distutils/command/install.py Python-3.2.1/Lib/distutils/command/install.py
---- Python-3.2.1.orig//Lib/distutils/command/install.py        2011-07-09 07:58:46.000000000 +0100
+--- Python-3.2.1.orig/Lib/distutils/command/install.py 2011-07-09 07:58:46.000000000 +0100
 +++ Python-3.2.1/Lib/distutils/command/install.py      2011-07-12 22:20:12.000000000 +0100
-@@ -27,6 +27,8 @@
    from site import USER_SITE
    HAS_USER_SITE = True
+@@ -19,6 +19,8 @@ from site import USER_BASE
+ from site import USER_SITE
+ HAS_USER_SITE = True
  
 +libname = sys.lib
 +
- if sys.version < "2.2":
-     WINDOWS_SCHEME = {
-         'purelib': '$base',
+ WINDOWS_SCHEME = {
+     'purelib': '$base/Lib/site-packages',
+     'platlib': '$base/Lib/site-packages',
 @@ -47,14 +49,14 @@
  INSTALL_SCHEMES = {
      'unix_prefix': {
@@ -84,8 +85,7 @@ diff -Nur Python-3.2.1.orig//Lib/distutils/command/install.py Python-3.2.1/Lib/d
          'headers': '$base/include/python/$dist_name',
          'scripts': '$base/bin',
          'data'   : '$base',
-diff -Nur Python-3.2.1.orig//Lib/distutils/sysconfig.py Python-3.2.1/Lib/distutils/sysconfig.py
---- Python-3.2.1.orig//Lib/distutils/sysconfig.py      2011-07-09 07:58:47.000000000 +0100
+--- Python-3.2.1.orig/Lib/distutils/sysconfig.py       2011-07-09 07:58:47.000000000 +0100
 +++ Python-3.2.1/Lib/distutils/sysconfig.py    2011-07-12 22:20:12.000000000 +0100
 @@ -124,8 +124,12 @@
          prefix = plat_specific and EXEC_PREFIX or PREFIX
@@ -101,8 +101,7 @@ diff -Nur Python-3.2.1.orig//Lib/distutils/sysconfig.py Python-3.2.1/Lib/distuti
          if standard_lib:
              return libpython
          else:
-diff -Nur Python-3.2.1.orig//Lib/distutils/tests/test_install.py Python-3.2.1/Lib/distutils/tests/test_install.py
---- Python-3.2.1.orig//Lib/distutils/tests/test_install.py     2011-07-09 07:58:47.000000000 +0100
+--- Python-3.2.1.orig/Lib/distutils/tests/test_install.py      2011-07-09 07:58:47.000000000 +0100
 +++ Python-3.2.1/Lib/distutils/tests/test_install.py   2011-07-12 22:20:12.000000000 +0100
 @@ -49,8 +49,9 @@
              self.assertEqual(got, expected)
@@ -115,22 +114,19 @@ diff -Nur Python-3.2.1.orig//Lib/distutils/tests/test_install.py Python-3.2.1/Li
          check_path(cmd.install_purelib, libdir)
          check_path(cmd.install_headers,
                     os.path.join(destination, "include", "python", "foopkg"))
-diff -Nur Python-3.2.1.orig//Lib/site.py Python-3.2.1/Lib/site.py
---- Python-3.2.1.orig//Lib/site.py     2011-07-09 07:58:49.000000000 +0100
+--- Python-3.2.1.orig/Lib/site.py      2011-07-09 07:58:49.000000000 +0100
 +++ Python-3.2.1/Lib/site.py   2011-07-12 22:20:12.000000000 +0100
-@@ -285,13 +285,16 @@
-         if sys.platform in ('os2emx', 'riscos'):
-             sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
-         elif os.sep == '/':
+@@ -304,12 +304,15 @@ def getsitepackages(prefixes=None):
+         seen.add(prefix)
+         if os.sep == '/':
 -            sitepackages.append(os.path.join(prefix, "lib",
 +            sitepackages.append(os.path.join(prefix, sys.lib,
                                          "python" + sys.version[:3],
                                          "site-packages"))
--            sitepackages.append(os.path.join(prefix, "lib", "site-python"))
 +            sitepackages.append(os.path.join(prefix, sys.lib, "site-python"))
 +            if sys.lib != 'lib':
 +                sitepackages.append(os.path.join(prefix, "lib", "python" + sys.version[:3], "site-packages"))
-+                sitepackages.append(os.path.join(prefix, "lib", "site-python"))
          else:
              sitepackages.append(prefix)
 -            sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
@@ -138,39 +134,37 @@ diff -Nur Python-3.2.1.orig//Lib/site.py Python-3.2.1/Lib/site.py
          if sys.platform == "darwin":
              # for framework builds *only* we add the standard Apple
              # locations.
-diff -Nur Python-3.2.1.orig//Lib/sysconfig.py Python-3.2.1/Lib/sysconfig.py
---- Python-3.2.1.orig//Lib/sysconfig.py        2011-07-09 07:58:49.000000000 +0100
+--- Python-3.2.1.orig/Lib/sysconfig.py 2011-07-09 07:58:49.000000000 +0100
 +++ Python-3.2.1/Lib/sysconfig.py      2011-07-12 22:20:12.000000000 +0100
 @@ -21,10 +21,10 @@
  
  _INSTALL_SCHEMES = {
      'posix_prefix': {
--        'stdlib': '{base}/lib/python{py_version_short}',
+-        'stdlib': '{installed_base}/lib/python{py_version_short}',
 -        'platstdlib': '{platbase}/lib/python{py_version_short}',
-+        'stdlib': '{base}/' + sys.lib + '/python{py_version_short}',
++        'stdlib': '{installed_base}/' + sys.lib + '/python{py_version_short}',
 +        'platstdlib': '{platbase}/' + sys.lib + '/python{py_version_short}',
          'purelib': '{base}/lib/python{py_version_short}/site-packages',
 -        'platlib': '{platbase}/lib/python{py_version_short}/site-packages',
 +        'platlib': '{platbase}/' + sys.lib + '/python{py_version_short}/site-packages',
          'include':
-             '{base}/include/python{py_version_short}{abiflags}',
+             '{installed_base}/include/python{py_version_short}{abiflags}',
          'platinclude':
 @@ -33,10 +33,10 @@
          'data': '{base}',
          },
      'posix_home': {
--        'stdlib': '{base}/lib/python',
+-        'stdlib': '{installed_base}/lib/python',
 -        'platstdlib': '{base}/lib/python',
-+        'stdlib': '{base}/' + sys.lib + '/python',
++        'stdlib': '{installed_base}/' + sys.lib + '/python',
 +        'platstdlib': '{base}/' + sys.lib + '/python',
          'purelib': '{base}/lib/python',
 -        'platlib': '{base}/lib/python',
 +        'platlib': '{base}/' + sys.lib + '/python',
-         'include': '{base}/include/python',
-         'platinclude': '{base}/include/python',
+         'include': '{installed_base}/include/python',
+         'platinclude': '{installed_base}/include/python',
          'scripts': '{base}/bin',
-diff -Nur Python-3.2.1.orig//Makefile.pre.in Python-3.2.1/Makefile.pre.in
---- Python-3.2.1.orig//Makefile.pre.in 2011-07-09 07:58:52.000000000 +0100
+--- Python-3.2.1.orig/Makefile.pre.in  2011-07-09 07:58:52.000000000 +0100
 +++ Python-3.2.1/Makefile.pre.in       2011-07-12 22:20:12.000000000 +0100
 @@ -90,6 +90,8 @@
  
@@ -199,18 +193,21 @@ diff -Nur Python-3.2.1.orig//Makefile.pre.in Python-3.2.1/Makefile.pre.in
  
  Python/importdl.o: $(srcdir)/Python/importdl.c
                $(CC) -c $(PY_CORE_CFLAGS) -I$(DLINCLDIR) -o $@ $(srcdir)/Python/importdl.c
-diff -Nur Python-3.2.1.orig//Modules/getpath.c Python-3.2.1/Modules/getpath.c
---- Python-3.2.1.orig//Modules/getpath.c       2011-07-09 07:58:54.000000000 +0100
+--- Python-3.2.1.orig/Modules/getpath.c        2011-07-09 07:58:54.000000000 +0100
 +++ Python-3.2.1/Modules/getpath.c     2011-07-12 22:21:48.000000000 +0100
-@@ -121,9 +121,17 @@
+@@ -121,9 +121,21 @@
  #define EXEC_PREFIX PREFIX
  #endif
  
 +#ifndef LIB_PYTHON
 +#if defined(__x86_64__) || (defined(__sparc__) && defined(__arch64__)) || defined(__powerpc64__) || defined(__s390x__)
-+#define LIB_PYTHON L"lib64/python"
++#if defined(__ILP32__)
++#define LIB_PYTHON "libx32/python"
 +#else
-+#define LIB_PYTHON L"lib/python"
++#define LIB_PYTHON "lib64/python"
++#endif
++#else
++#define LIB_PYTHON "lib/python"
 +#endif
 +#endif
 +
@@ -222,17 +219,16 @@ diff -Nur Python-3.2.1.orig//Modules/getpath.c Python-3.2.1/Modules/getpath.c
  #endif
  
  #ifndef LANDMARK
-@@ -135,7 +143,7 @@
static wchar_t progpath[MAXPATHLEN+1];
static wchar_t *module_search_path = NULL;
static int module_search_path_malloced = 0;
--static wchar_t *lib_python = L"lib/python" VERSION;
-++static wchar_t *lib_python = LIB_PYTHON VERSION;
+@@ -502,7 +514,7 @@ calculate_path(void)
    _pythonpath = Py_DecodeLocale(PYTHONPATH, NULL);
    _prefix = Py_DecodeLocale(PREFIX, NULL);
    _exec_prefix = Py_DecodeLocale(EXEC_PREFIX, NULL);
+-    lib_python = Py_DecodeLocale("lib/python" VERSION, NULL);
++    lib_python = Py_DecodeLocale(LIB_PYTHON VERSION, NULL);
  
- static void
- reduce(wchar_t *dir)
-diff -Nur Python-3.2.1.orig//Python/getplatform.c Python-3.2.1/Python/getplatform.c
---- Python-3.2.1.orig//Python/getplatform.c    2011-07-09 07:58:56.000000000 +0100
+     if (!_pythonpath || !_prefix || !_exec_prefix || !lib_python) {
+         Py_FatalError(
+--- Python-3.2.1.orig/Python/getplatform.c     2011-07-09 07:58:56.000000000 +0100
 +++ Python-3.2.1/Python/getplatform.c  2011-07-12 22:20:12.000000000 +0100
 @@ -10,3 +10,23 @@
  {
@@ -258,8 +254,7 @@ diff -Nur Python-3.2.1.orig//Python/getplatform.c Python-3.2.1/Python/getplatfor
 +{
 +      return LIB;
 +}
-diff -Nur Python-3.2.1.orig//Python/sysmodule.c Python-3.2.1/Python/sysmodule.c
---- Python-3.2.1.orig//Python/sysmodule.c      2011-07-09 07:58:56.000000000 +0100
+--- Python-3.2.1.orig/Python/sysmodule.c       2011-07-09 07:58:56.000000000 +0100
 +++ Python-3.2.1/Python/sysmodule.c    2011-07-12 22:20:12.000000000 +0100
 @@ -1560,6 +1560,10 @@
                          PyUnicode_FromString(Py_GetCopyright()));
@@ -272,35 +267,29 @@ diff -Nur Python-3.2.1.orig//Python/sysmodule.c Python-3.2.1/Python/sysmodule.c
      SET_SYS_FROM_STRING("executable",
                          PyUnicode_FromWideChar(
                                 Py_GetProgramFullPath(), -1));
-diff -Nur Python-3.2.1.orig//setup.py Python-3.2.1/setup.py
---- Python-3.2.1.orig//setup.py        2011-07-09 07:58:56.000000000 +0100
+--- Python-3.2.1.orig/setup.py 2011-07-09 07:58:56.000000000 +0100
 +++ Python-3.2.1/setup.py      2011-07-12 22:20:12.000000000 +0100
-@@ -445,12 +445,12 @@
-             add_dir_to_list(self.compiler.include_dirs,
-                             sysconfig.get_config_var("INCLUDEDIR"))
-+        libname = sys.lib
-         # lib_dirs and inc_dirs are used to search for files;
-         # if a file is found in one of those directories, it can
+@@ -516,8 +516,7 @@
          # be assumed that no additional -I,-L directives are needed.
-         lib_dirs = self.compiler.library_dirs + [
--            '/lib64', '/usr/lib64',
--            '/lib', '/usr/lib',
-+            libname, '/usr/'+libname
-             ]
-         inc_dirs = self.compiler.include_dirs + ['/usr/include']
+         if not cross_compiling:
+             lib_dirs = self.compiler.library_dirs + [
+-                '/lib64', '/usr/lib64',
+-                '/lib', '/usr/lib',
++                '/' + sys.lib, '/usr/' + sys.lib
+                 ]
+             inc_dirs = self.compiler.include_dirs + ['/usr/include']
          exts = []
-@@ -643,11 +643,11 @@
+@@ -643,11 +642,11 @@
              elif curses_library:
                  readline_libs.append(curses_library)
              elif self.compiler.find_library_file(lib_dirs +
 -                                                     ['/usr/lib/termcap'],
-+                                                     ['/usr/' + libname + '/termcap'],
++                                                     ['/usr/' + sys.lib + '/termcap'],
                                                       'termcap'):
                  readline_libs.append('termcap')
              exts.append( Extension('readline', ['readline.c'],
 -                                   library_dirs=['/usr/lib/termcap'],
-+                                   library_dirs=['/usr/' + libname + '/termcap'],
++                                   library_dirs=['/usr/' + sys.lib + '/termcap'],
                                     extra_link_args=readline_extra_link_args,
                                     libraries=readline_libs) )
          else:
This page took 0.074272 seconds and 4 git commands to generate.