]> git.pld-linux.org Git - packages/python3.git/blame - python3.spec
- do not include minor number in %%{py_ver}
[packages/python3.git] / python3.spec
CommitLineData
19221b23
AG
1#
2# TODO:
3# - fix tests
4# - check unpackaged files
9416f74d
AM
5
6# Conditional build:
7%bcond_with info # info pages (requires emacs)
8%bcond_without tkinter # disables tkinter module building
48e785bb 9%bcond_with tests # disables Python testing
9416f74d 10%bcond_with verbose_tests # runs tests in verbose mode
9416f74d
AM
11#
12# tests which will not work on 64-bit platforms
13%define no64bit_tests test_audioop test_rgbimg test_imageop
14# tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15%define nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
48e785bb 16
9416f74d 17# tests which fail because of some unknown/unresolved reason (this list should be empty)
48e785bb
JK
18# test_site: fails because our site.py is patched to include both /usr/share/... and /usr/lib...
19# test_gdb: fails, as the gdb uses old python version
20%define broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib test_gdb test_site
9416f74d 21
e612243a 22%define py_ver 3.2
c7fdbe10 23%define py_abi %{py_ver}mu
9416f74d
AM
24%define py_prefix %{_prefix}
25%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
c7fdbe10 26%define py_incdir %{_includedir}/python%{py_abi}
9416f74d
AM
27%define py_sitedir %{py_libdir}/site-packages
28%define py_dyndir %{py_libdir}/lib-dynload
29
30Summary: Very high level scripting language with X interface
31Summary(es.UTF-8): Lenguaje script de alto nivel con interfaz X
32Summary(fr.UTF-8): Langage de script de très haut niveau avec interface X
33Summary(pl.UTF-8): Python - język obiektowy wysokiego poziomu
34Summary(pt_BR.UTF-8): Linguagem de programação interpretada de alto nível
35Summary(ru.UTF-8): Язык программирования очень высокого уровня с X-интерфейсом
36Summary(tr.UTF-8): X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
37Summary(uk.UTF-8): Мова програмування дуже високого рівня з X-інтерфейсом
2072c60e 38Name: python3
e612243a 39Version: %{py_ver}.1
51865898 40Release: 1
9416f74d
AM
41Epoch: 1
42License: PSF
43Group: Applications
0cf503a8 44Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
58aa28a5 45# Source0-md5: 2cf014296afc18897daa7b79414ad773
a20e3138
AG
46Patch0: %{name}-pythonpath.patch
47Patch1: %{name}-ac_fixes.patch
48Patch2: %{name}-lib64.patch
49Patch3: %{name}-noarch_to_datadir.patch
7dd2ca46 50Patch4: %{name}-bug11254.patch
48e785bb 51Patch5: %{name}-no_cmdline_tests.patch
9416f74d 52URL: http://www.python.org/
7daf2f83 53BuildRequires: autoconf >= 2.65
9416f74d
AM
54BuildRequires: bluez-libs-devel
55BuildRequires: bzip2-devel
56BuildRequires: db-devel >= 4
57%{?with_info:BuildRequires: emacs >= 21}
58BuildRequires: expat-devel >= 1:1.95.7
59BuildRequires: file
60BuildRequires: gdbm-devel >= 1.8.3
61BuildRequires: gmp-devel >= 4.0
3ba70ac2 62BuildRequires: libffi-devel
9416f74d
AM
63BuildRequires: libstdc++-devel
64BuildRequires: ncurses-ext-devel >= 5.2
9416f74d 65BuildRequires: openssl-devel >= 0.9.8
9416f74d
AM
66BuildRequires: readline-devel >= 5.0
67BuildRequires: rpm-pythonprov
68BuildRequires: sed >= 4.0
69BuildRequires: sqlite3-devel >= 3.3.5
91e93ac7 70BuildRequires: tar >= 1:1.22
9416f74d
AM
71%{?with_info:BuildRequires: tetex-makeindex}
72%{?with_tkinter:BuildRequires: tix-devel >= 1:8.1.4-4}
73%{?with_tkinter:BuildRequires: tk-devel >= 8.4.3}
74BuildRequires: zlib-devel
75Requires: %{name}-libs = %{epoch}:%{version}-%{release}
9416f74d 76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34dfde61 77
8d0b0882 78%define specflags_ppc -D__ppc__=1
34dfde61 79%define specflags_ppc64 -D__ppc64__=1
9416f74d
AM
80
81%if %{with verbose_tests}
82%define test_flags -v -l -x
83%else
f488a705 84%define test_flags -w -l -x
9416f74d
AM
85%endif
86
87%ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
88%define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
89%else
90%define test_list %{nobuilder_tests} %{broken_tests}
91%endif
92
93%ifarch sparc
94%define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
95%endif
96
97%description
98Python is an interpreted, interactive, object-oriented programming
99language. It incorporates modules, exceptions, dynamic typing, very
100high level dynamic data types, and classes. Python combines remarkable
101power with very clear syntax. It has interfaces to many system calls
102and libraries, as well as to various window systems, and is extensible
103in C or C++. It is also usable as an extension language for
104applications that need a programmable interface. Finally, Python is
105portable: it runs on many brands of UNIX, on the Mac, and on PCs under
106MS-DOS, Windows, Windows NT, and OS/2.
107
108This package contains the Python binary.
109
110%description -l de.UTF-8
111Python ist eine interpretierte, interaktive, objektorientierte
112Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
113Python enthält Module, Klassen, Exceptions, High-Level dynamische
114Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
115zu vielen Systemaufrufen und Libraries, sowie verschiedene
116Fenstersysteme (X11, Motif, Tk, Mac und MFC)
117
118Programmierer können neue built-in-Module für Python in C oder C++
119schreiben. Python kann auch als Erweiterungssprache für Applikationen
120benutzt werden, die ein programmierbares Interface brauchen. Dieses
121Paket enthält die meisten Standard-Python-Module, und Module zum
122Ansprechen von Tix (Tk-widget set) und RPM.
123
124%description -l es.UTF-8
125Python es un lenguaje de scripts interpretado orientado a objetos.
126Contiene soporte para carga dinámica de objetos, clases, módulos y
127excepciones.
128
129Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
130través de código C, tornando Python fácil de usar en ambientes
131particulares/personalizados. Este paquete Python incluye la mayoría de
132los módulos padrón Python, junto con módulos para crear interfaces
133para el conjunto de componentes Tix para Tk y RPM.
134
135%description -l fr.UTF-8
136Python est un langage de script interprété et orienté objet. Il gère
137le chargement dynamique des objets, les classes, les modules et les
138exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
139avec du code C est simple, ce qui rend Python facile à utiliser dans
140des configs personnalisées.
141
142Ce paquetage Python contient la plupart des modules Python standards,
143ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
144et RPM.
145
146%description -l pl.UTF-8
147Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
148językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
149typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
150sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
151wielu wywołań systemowych i bibliotek, w tym również do różnych
152bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
153poprzez odpowiednie moduły pisane w C lub C++. Python może być również
154użyty jako element aplikacji, którym potrzebny jest interpreter do
155skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
156odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
157OS/2.
158
159Ten pakiet zawiera binarkę Pythona.
160
161%description -l pt_BR.UTF-8
162Python é uma linguagem de scripts interpretada orientada a objetos.
163Contém suporte para carga dinâmica de objetos, classes, módulos e
164exceções. Adicionar interfaces para novos sistemas de biblioteca
165através de código C é simples, tornando Python fácil de usar em
166ambientes particulares/personalizados.
167
168Este pacote Python inclui a maioria do módulos padrão Python, junto
169com módulos para interfaceamento para o conjunto de componentes Tix
170para Tk e RPM.
171
172%description -l ru.UTF-8
173Python - это интерпретируемый, объектно-ориентированный язык
174программирования. Он поддерживает динамическую загрузку объектов,
175классы, модули и обработку исключительных ситуаций (exceptions).
176Простота добавления интерфейсов к новым системным библиотекам через
177код на языке C делает Python хорошим выбором для использования в
178специальных конфигурациях.
179
180%description -l tr.UTF-8
181Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
182sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
183destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
184paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
185arayüz birimlerini de içerir.
186
187%description -l uk.UTF-8
188Python - це інтерпретована, об'єктно-орієнтована мова програмування.
189Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
190виключних ситуацій (exceptions). Простота додавання інтерфейсів для
191нових системних бібліотек через код на мові C робить Python добрим
192вибором для використання в спеціальних конфігураціях.
193
194%package libs
195Summary: Python library
196Summary(pl.UTF-8): Biblioteka języka Python
197Group: Libraries/Python
198# broken detection in rpm/pythondeps.sh
199Provides: python(abi) = %{py_ver}
200# for compatibility with existing Ac packages
201Provides: python(bytecode) = %{py_ver}
2072c60e 202%{!?with_info:Obsoletes: python3-doc-info}
9416f74d
AM
203
204%description libs
205Python shared library and very essental modules for Python binary.
206
207%description libs -l pl.UTF-8
208Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
209dla Pythona.
210
211%package modules
212Summary: Python modules
213Summary(pl.UTF-8): Moduły języka Python
214Group: Libraries/Python
215Requires: %{name}-libs = %{epoch}:%{version}-%{release}
fef40d51 216Obsoletes: python3-modules-sqlite
9416f74d
AM
217
218%description modules
219Python officially distributed modules.
220
221%description modules -l pl.UTF-8
222Oficjalnie rozprowadzane moduły języka Python.
223
2072c60e 224%package -n pydoc3
9416f74d
AM
225Summary: Python interactive module documentation access support
226Summary(pl.UTF-8): Interaktywne korzystanie z dokumentacji modułów języka Python
227Group: Applications
228Requires: %{name}-modules = %{epoch}:%{version}-%{release}
229
2072c60e 230%description -n pydoc3
9416f74d
AM
231Python interactive module documentation access support.
232
2072c60e 233%description -n pydoc3 -l pl.UTF-8
9416f74d
AM
234Interaktywne korzystanie z dokumentacji modułów języka Python.
235
2072c60e 236%package -n idle3
9416f74d
AM
237Summary: IDE for Python language
238Summary(pl.UTF-8): IDE dla języka Python
239Group: Applications
240Requires: %{name}-tkinter = %{epoch}:%{version}-%{release}
241
2072c60e 242%description -n idle3
9416f74d
AM
243IDE for Python language.
244
2072c60e 245%description -n idle3 -l pl.UTF-8
9416f74d
AM
246IDE dla języka Python.
247
248%package devel
249Summary: Libraries and header files for building python code
250Summary(de.UTF-8): Libraries und Header-Dateien zum Erstellen von Python-Code
251Summary(es.UTF-8): Bibliotecas y archivos de inclusión para construir programas en python
252Summary(fr.UTF-8): Bibliothèques et en-têtes pour construire du code python
253Summary(pl.UTF-8): Pliki nagłówkowe i biblioteki Pythona
254Summary(pt_BR.UTF-8): Bibliotecas e arquivos de inclusão para o Python
255Summary(ru.UTF-8): Библиотеки и хедеры для построения кода на языке Python
256Summary(tr.UTF-8): Python ile geliştirme yapmak için gerekli dosyalar
257Summary(uk.UTF-8): Бібліотеки та хедери для програмування на мові Python
258Group: Development/Languages/Python
259Requires: %{name}-libs = %{epoch}:%{version}-%{release}
260
261%description devel
262The Python interpreter is relatively easy to extend with dynamically
263loaded extensions and to embed in other programs. This package
264contains the header files and libraries which are needed to do both of
265these tasks.
266
267%description devel -l de.UTF-8
268Der Python-Interpretierer ist relativ einfach anhand von dynamisch
269ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
270integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
271die für beide Aufgaben erforderlich sind.
272
273%description devel -l es.UTF-8
274El interpretador Python permite incluir con facilidad extensiones
275cargadas dinámicamente. Python es también fácil de ser empotrado en
276otros programas. Este paquete contiene los archivos de inclusión y
277bibliotecas necesarios para estas dos tareas.
278
279%description devel -l fr.UTF-8
280L'interpréteur Python est relativement facile à étendre avec des
281extensions chargées dynamiquement et à insérer dans d'autres
282programmes. Ce paquetage contient les en-têtes et les bibliothèques
283nécessaires à ces deux tâches.
284
285%description devel -l pl.UTF-8
286Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
287dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
288osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
289wszystko inne co potrzebne do tych celów.
290
291%description devel -l pt_BR.UTF-8
292O interpretador Python permite incluir com facilidade extensões
293carregadas dinamicamente. Python é também fácil de ser embutido em
294outros programas. Este pacote contém os arquivos de inclusão e
295bibliotecas necessários para estas duas tarefas.
296
297%description devel -l ru.UTF-8
298Интерпретатор Python относительно легко расширяется при помощи
299динамически загружаемых расширений и встраивается в другие программы.
300Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
301задач.
302
303%description devel -l tr.UTF-8
304Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
305dosyalarını ve kitaplıkları içerir.
306
307%description devel -l uk.UTF-8
308Інтерпретатор Python відносно легко розширюється за допомогою
309розширень з динамічною загрузкою та вбудовується в інші програми. Цей
310пакет містить хедери та бібліотеки, необхідні для обох цих задач.
311
312%package devel-src
313Summary: Python module sources
314Summary(pl.UTF-8): Pliki źródłowe modułów Pythona
315Group: Development/Languages/Python
316Requires: %{name}-modules = %{epoch}:%{version}-%{release}
317
318%description devel-src
319Python module sources.
320
321%description devel-src -l pl.UTF-8
322Pliki źródłowe modułów Pythona.
323
324%package devel-tools
325Summary: Python development tools
326Summary(pl.UTF-8): Narzędzia programistyczne języka Python
327Group: Development/Languages/Python
328Requires: %{name}-modules = %{epoch}:%{version}-%{release}
329
330%description devel-tools
331Python development tools such as profilers and debugger.
332
333%description devel-tools -l pl.UTF-8
334Narzędzia programistyczne języka Python takie jak profiler oraz
335debugger.
336
30b0ff7b
AF
337%package 2to3
338Summary: Automated Python 2 to 3 code translation
0cf503a8 339Summary(pl.UTF-8): Automatyczne tłumaczenie kodu Pythona 2 do 3
30b0ff7b
AF
340Group: Development/Languages/Pythona
341
342%description 2to3
0cf503a8
JB
3432to3 is a Python program that reads Python 2.x source code and applies
344a series of fixers to transform it into valid Python 3.x code. The
345standard library contains a rich set of fixers that will handle almost
346all code. 2to3 supporting library lib2to3 is, however, a flexible and
347generic library, so it is possible to write your own fixers for 2to3.
348lib2to3 could also be adapted to custom applications in which Python
349code needs to be edited automatically.
350
351%description 2to3 -l pl.UTF-8
3522to3 to program w Pythonie czytający od źródłowy w Pythonie 2.x i
353aplikujący serię poprawek przekształcających go w poprawny kod w
354Pythonie 3.x. Biblioteka standardowa zawiera duży zbiór poprawek
355obsługujących większość kodu. Biblioteka wspierająca 2to3 (lib2to3)
356jest jednak elastyczną i ogólną biblioteką, więc można pisać własne
357poprawki dla 2to3. lib2to3 można także zaadaptować na potrzeby
358własnych zastosowań, w których kod w Pythonie musi być modyfikowany
359automatycznie.
30b0ff7b 360
9416f74d
AM
361%package static
362Summary: Static python library
363Summary(pl.UTF-8): Statyczna biblioteka Pythona
364Group: Development/Languages/Python
365Requires: %{name}-devel = %{epoch}:%{version}-%{release}
366
367%description static
368Static python library.
369
370%description static -l pl.UTF-8
371Statyczna biblioteka Pythona.
372
9416f74d
AM
373%package doc-info
374Summary: Documentation on Python in texinfo format
375Summary(pl.UTF-8): Dokumentacja do Pythona w formacie texinfo
376Group: Documentation
377
378%description doc-info
379Documentation on Python in texinfo format.
380
381%description doc-info -l pl.UTF-8
382Dokumentacja do Pythona w formacie texinfo.
383
384%package tkinter
385Summary: Standard Python interface to the Tk GUI toolkit
386Summary(de.UTF-8): Grafische Tk-Schnittstelle für Python
387Summary(es.UTF-8): Interfaz de GUI Tk para Python
388Summary(fr.UTF-8): Interface graphique Tk pour Python
389Summary(pl.UTF-8): Standardowy interfejs Pythona do biblioteki Tk
390Summary(pt_BR.UTF-8): Interface GUI Tk para Phyton
391Summary(tr.UTF-8): Python için grafik kullanıcı arayüzü
392Group: Libraries/Python
393Requires: %{name}-modules = %{epoch}:%{version}-%{release}
394Requires: tcl >= 8.4.3
395Requires: tix >= 1:8.1.4-4
396Requires: tk >= 8.4.3
397
398%description tkinter
399Standard Python interface to the Tk GUI toolkit.
400
401%description tkinter -l de.UTF-8
402Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
403vielen Konfigurations-Tools genutzt.
404
405%description tkinter -l es.UTF-8
406Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
407herramientas de configuración.
408
409%description tkinter -l fr.UTF-8
410Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
411beaucoup des outils de configuration.
412
413%description tkinter -l pl.UTF-8
414Standardowy interfejs Pythona do biblioteki Tk.
415
416%description tkinter -l pt_BR.UTF-8
417Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
418muitas ferramentas de configuração.
419
420%description tkinter -l ru.UTF-8
421Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
422
423%description tkinter -l tr.UTF-8
424Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
425kullanılan grafik bir arayüzdür.
426
427%description tkinter -l uk.UTF-8
428Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
429
430%package examples
431Summary: Example programs in Python
432Summary(pl.UTF-8): Przykładowe programy w Pythonie
433Group: Development/Languages/Python
434
435%description examples
436Example programs in Python.
437
438These are for Python 2.3.4, not %{version}.
439
440%description examples -l pl.UTF-8
441Przykładowe programy w Pythonie.
442
443Przykłady te są dla Pythona 2.3.4, nie %{version}.
444
445%prep
0cf503a8 446%setup -q -n Python-%{version}
a20e3138 447%patch0 -p1
30b0ff7b 448%patch1 -p1
e3852288
JB
449%patch2 -p1
450%patch3 -p1
7dd2ca46 451%patch4 -p1
48e785bb 452%patch5 -p1
9416f74d
AM
453
454%build
9416f74d 455%{__autoconf}
31552fa6 456CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
9416f74d 457%configure \
3ba70ac2 458 --with-cxx-main="%{__cxx}" \
9416f74d
AM
459 --enable-shared \
460 --enable-ipv6 \
19221b23 461 --with-dbmliborder=gdbm:bdb \
3ba70ac2 462 --with-wide-unicode \
9416f74d
AM
463 --with-signal-module \
464 --with-tsc \
465 --with-threads \
466 --with-doc-strings \
9416f74d 467 --with-fpectl \
3ba70ac2 468 --with-system-ffi \
23f5417d 469 --with-computed-gotos \
9416f74d
AM
470 LINKCC='$(PURIFY) $(CXX)' \
471 LDSHARED='$(CC) $(CFLAGS) -shared' \
472 BLDSHARED='$(CC) $(CFLAGS) -shared' \
473 LDFLAGS="%{rpmcflags} %{rpmldflags}"
474
475%{__make} \
23f5417d 476 OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
9416f74d
AM
477BEGIN { fail = 0; logmsg = ""; }
478{
479 if ($0 ~ /\*\*\* WARNING:/) {
480 fail = 1;
481 logmsg = logmsg $0;
482 }
483 print $0;
484}
485END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
486
487LC_ALL=C
488export LC_ALL
489%if %{with tests}
490binlibdir=`echo build/lib.*`
491%{__make} test \
492 TESTOPTS="%{test_flags} %{test_list}" \
48e785bb 493 TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:`pwd`/$binlibdir ./python -tt"
9416f74d
AM
494%endif
495
496%install
497rm -rf $RPM_BUILD_ROOT
498install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
499 $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
500 $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
501 $RPM_BUILD_ROOT%{_infodir} \
502 $RPM_BUILD_ROOT/etc/shrc.d
503
504%{__make} install \
505 DESTDIR=$RPM_BUILD_ROOT
506
507%if %{with info}
508%{__make} -C Doc/info
509install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
510%endif
511
9416f74d 512install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
4449431f 513cp -a Tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
9416f74d
AM
514
515#
516# create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
517#
518
519# for python devel tools
520for script in timeit profile pdb pstats; do
24586eb0
AM
521 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
522done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d 523
24586eb0
AM
524echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
525 >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d
AM
526
527sed 's/=/ /' \
24586eb0
AM
528 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
529 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
9416f74d
AM
530
531# for python modules
532for script in smtpd webbrowser; do
24586eb0
AM
533 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
534done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
9416f74d
AM
535
536sed 's/=/ /' \
24586eb0
AM
537 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
538 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
9416f74d
AM
539
540# xgettext specific for Python code
541#
542# we will have two commands: pygettext.py (an alias) and pygettext;
543# this way there are no import (which is impossible now) conflicts and
544# pygettext.py is provided for compatibility
24586eb0
AM
545install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
546
9416f74d
AM
547# just to cut the noise, as they are not packaged (now)
548# first tests
e3852288
JB
549%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/test
550%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
551%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
552%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/email/test
553%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
554%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
555%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
556%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
dceb7408 557%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/unittest/test
9416f74d
AM
558
559# other files
e3852288
JB
560%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
561%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
562%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
563%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
564%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
565%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
acd14a9e 566# already in %%doc
e3852288 567%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
9416f74d
AM
568
569%clean
570rm -rf $RPM_BUILD_ROOT
571
572%post libs -p /sbin/ldconfig
573%postun libs -p /sbin/ldconfig
574
e3852288 575%post doc-info -p /sbin/postshell
a20bb9dc 576-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d 577
e3852288 578%postun doc-info -p /sbin/postshell
a20bb9dc 579-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d
AM
580
581%files
582%defattr(644,root,root,755)
24586eb0 583%attr(755,root,root) %{_bindir}/python%{py_ver}
c7fdbe10 584%attr(755,root,root) %{_bindir}/python%{py_abi}
306c0f2d 585%attr(755,root,root) %{_bindir}/python3
c7fdbe10
JB
586%{_mandir}/man1/python%{py_ver}.1*
587
588%files libs
589%defattr(644,root,root,755)
590%doc LICENSE
591%attr(755,root,root) %{_libdir}/libpython%{py_abi}.so.*.*
592
593%dir %{py_libdir}
594%dir %{py_dyndir}
595%dir %{py_sitedir}
596%dir %{py_scriptdir}
597%dir %{py_sitescriptdir}
dceb7408 598%{py_scriptdir}/__pycache__
c7fdbe10
JB
599
600# shared modules required by python library
601%attr(755,root,root) %{py_dyndir}/_struct.cpython-*.so
602
603# modules required by python library
dceb7408 604%{py_scriptdir}/_abcoll.py
605%{py_scriptdir}/_weakrefset.py
606%{py_scriptdir}/abc.py
607%{py_scriptdir}/codecs.py
608%{py_scriptdir}/copyreg.py
609%{py_scriptdir}/genericpath.py
610%{py_scriptdir}/locale.py
611%{py_scriptdir}/io.py
612%{py_scriptdir}/posixpath.py
613%{py_scriptdir}/site.py
614%{py_scriptdir}/stat.py
615%{py_scriptdir}/os.py
c7fdbe10 616# needed by the dynamic sys.lib patch
dceb7408 617%{py_scriptdir}/types.py
c7fdbe10
JB
618
619# encodings required by python library
620%dir %{py_scriptdir}/encodings
dceb7408 621%{py_scriptdir}/encodings/__pycache__
622%{py_scriptdir}/encodings/*.py
9416f74d
AM
623
624%files modules
625%defattr(644,root,root,755)
24586eb0 626/etc/shrc.d/python*-modules*
dceb7408 627%exclude %{py_scriptdir}/_abcoll.py
628%exclude %{py_scriptdir}/_weakrefset.py
629%exclude %{py_scriptdir}/abc.py
630%exclude %{py_scriptdir}/codecs.py
631%exclude %{py_scriptdir}/copyreg.py
632%exclude %{py_scriptdir}/genericpath.py
633%exclude %{py_scriptdir}/io.py
634%exclude %{py_scriptdir}/locale.py
635%exclude %{py_scriptdir}/posixpath.py
636%exclude %{py_scriptdir}/pdb.py
637%exclude %{py_scriptdir}/profile.py
638%exclude %{py_scriptdir}/pstats.py
639%exclude %{py_scriptdir}/pydoc.py
640%exclude %{py_scriptdir}/site.py
641%exclude %{py_scriptdir}/stat.py
642%exclude %{py_scriptdir}/timeit.py
643%exclude %{py_scriptdir}/os.py
644%exclude %{py_scriptdir}/encodings/*.py
645%exclude %{py_scriptdir}/types.py
646
647%{py_scriptdir}/*.py
9416f74d 648
c7fdbe10 649%{py_dyndir}/Python-%{py_ver}-py*.egg-info
9416f74d
AM
650
651#
652# list .so modules to be sure that all of them are built
653#
654
929a5a93 655# modules below do not work on 64-bit architectures
9416f74d
AM
656# see Python README file for explanation
657%ifnarch alpha ia64 ppc64 sparc64 %{x8664}
c7fdbe10 658%attr(755,root,root) %{py_dyndir}/audioop.cpython-*.so
9416f74d
AM
659%endif
660
c7fdbe10
JB
661%attr(755,root,root) %{py_dyndir}/_bisect.cpython-*.so
662%attr(755,root,root) %{py_dyndir}/_codecs_cn.cpython-*.so
663%attr(755,root,root) %{py_dyndir}/_codecs_hk.cpython-*.so
664%attr(755,root,root) %{py_dyndir}/_codecs_iso2022.cpython-*.so
665%attr(755,root,root) %{py_dyndir}/_codecs_jp.cpython-*.so
666%attr(755,root,root) %{py_dyndir}/_codecs_kr.cpython-*.so
667%attr(755,root,root) %{py_dyndir}/_codecs_tw.cpython-*.so
668%attr(755,root,root) %{py_dyndir}/_csv.cpython-*.so
669%attr(755,root,root) %{py_dyndir}/_ctypes*.cpython-*.so
670%attr(755,root,root) %{py_dyndir}/_curses_panel.cpython-*.so
671%attr(755,root,root) %{py_dyndir}/_curses.cpython-*.so
672%attr(755,root,root) %{py_dyndir}/_datetime.cpython-*.so
9416f74d 673%ifnarch sparc64
c7fdbe10 674%attr(755,root,root) %{py_dyndir}/_dbm.cpython-*.so
9416f74d 675%endif
c7fdbe10
JB
676%attr(755,root,root) %{py_dyndir}/_elementtree.cpython-*.so
677%attr(755,root,root) %{py_dyndir}/_gdbm.cpython-*.so
678%attr(755,root,root) %{py_dyndir}/_hashlib.cpython-*.so
679%attr(755,root,root) %{py_dyndir}/_heapq.cpython-*.so
680%attr(755,root,root) %{py_dyndir}/_json.cpython-*.so
681%attr(755,root,root) %{py_dyndir}/_lsprof.cpython-*.so
682%attr(755,root,root) %{py_dyndir}/_multibytecodec.cpython-*.so
683%attr(755,root,root) %{py_dyndir}/_multiprocessing.cpython-*.so
684%attr(755,root,root) %{py_dyndir}/_pickle.cpython-*.so
dceb7408 685%attr(755,root,root) %{py_dyndir}/_posixsubprocess.cpython-*.so
c7fdbe10
JB
686%attr(755,root,root) %{py_dyndir}/_random.cpython-*.so
687%attr(755,root,root) %{py_dyndir}/_socket.cpython-*.so
688%attr(755,root,root) %{py_dyndir}/_ssl.cpython-*.so
689%attr(755,root,root) %{py_dyndir}/_testcapi.cpython-*.so
690%attr(755,root,root) %{py_dyndir}/array.cpython-*.so
691%attr(755,root,root) %{py_dyndir}/atexit.cpython-*.so
dceb7408 692%attr(755,root,root) %{py_dyndir}/audioop.cpython-*.so
c7fdbe10
JB
693%attr(755,root,root) %{py_dyndir}/binascii.cpython-*.so
694%attr(755,root,root) %{py_dyndir}/bz2.cpython-*.so
695%attr(755,root,root) %{py_dyndir}/cmath.cpython-*.so
696%attr(755,root,root) %{py_dyndir}/crypt.cpython-*.so
697%attr(755,root,root) %{py_dyndir}/fcntl.cpython-*.so
698%attr(755,root,root) %{py_dyndir}/grp.cpython-*.so
699%attr(755,root,root) %{py_dyndir}/math.cpython-*.so
700%attr(755,root,root) %{py_dyndir}/mmap.cpython-*.so
701%attr(755,root,root) %{py_dyndir}/nis.cpython-*.so
702%attr(755,root,root) %{py_dyndir}/ossaudiodev.cpython-*.so
703%attr(755,root,root) %{py_dyndir}/parser.cpython-*.so
704%attr(755,root,root) %{py_dyndir}/pyexpat.cpython-*.so
705%attr(755,root,root) %{py_dyndir}/readline.cpython-*.so
706%attr(755,root,root) %{py_dyndir}/resource.cpython-*.so
707%attr(755,root,root) %{py_dyndir}/select.cpython-*.so
708%attr(755,root,root) %{py_dyndir}/syslog.cpython-*.so
709%attr(755,root,root) %{py_dyndir}/termios.cpython-*.so
710%attr(755,root,root) %{py_dyndir}/time.cpython-*.so
711%attr(755,root,root) %{py_dyndir}/spwd.cpython-*.so
712%attr(755,root,root) %{py_dyndir}/unicodedata.cpython-*.so
713%attr(755,root,root) %{py_dyndir}/zlib.cpython-*.so
9416f74d
AM
714
715%dir %{py_scriptdir}/plat-*
dceb7408 716%{py_scriptdir}/plat-*/__pycache__
717%{py_scriptdir}/plat-*/*.py
718
719%{py_scriptdir}/concurrent
9416f74d 720
9416f74d
AM
721%dir %{py_scriptdir}/ctypes
722%dir %{py_scriptdir}/ctypes/macholib
dceb7408 723%{py_scriptdir}/ctypes/__pycache__
724%{py_scriptdir}/ctypes/macholib/__pycache__
35ff21ac 725
dceb7408 726%{py_scriptdir}/ctypes/*.py
727%{py_scriptdir}/ctypes/macholib/*.py
acd14a9e 728%doc %{py_scriptdir}/ctypes/macholib/README.ctypes
9416f74d
AM
729
730%dir %{py_scriptdir}/curses
dceb7408 731%{py_scriptdir}/curses/__pycache__
732%{py_scriptdir}/curses/*.py
9416f74d 733
acd14a9e 734%dir %{py_scriptdir}/dbm
dceb7408 735%{py_scriptdir}/dbm/__pycache__
736%{py_scriptdir}/dbm/*.py
acd14a9e 737
9416f74d
AM
738%dir %{py_scriptdir}/distutils
739%dir %{py_scriptdir}/distutils/command
acd14a9e 740%doc %{py_scriptdir}/distutils/README
dceb7408 741%{py_scriptdir}/distutils/__pycache__
742%{py_scriptdir}/distutils/command/__pycache__
743%{py_scriptdir}/distutils/*.py
744%{py_scriptdir}/distutils/command/*.py
acd14a9e 745%{py_scriptdir}/distutils/command/command_template
9416f74d
AM
746
747%dir %{py_scriptdir}/email
748%dir %{py_scriptdir}/email/mime
dceb7408 749%{py_scriptdir}/email/__pycache__
750%{py_scriptdir}/email/mime/__pycache__
751%{py_scriptdir}/email/*.py
752%{py_scriptdir}/email/mime/*.py
9416f74d 753
acd14a9e 754%dir %{py_scriptdir}/html
dceb7408 755%{py_scriptdir}/html/*.py
756%{py_scriptdir}/html/__pycache__
acd14a9e
AF
757
758%dir %{py_scriptdir}/http
dceb7408 759%{py_scriptdir}/http/__pycache__
760%{py_scriptdir}/http/*.py
acd14a9e 761
fef40d51 762%dir %{py_scriptdir}/importlib
dceb7408 763%{py_scriptdir}/importlib/__pycache__
764%{py_scriptdir}/importlib/*.py
fef40d51 765
acd14a9e 766%dir %{py_scriptdir}/json
dceb7408 767%{py_scriptdir}/json/__pycache__
768%{py_scriptdir}/json/*.py
acd14a9e 769
9416f74d 770%dir %{py_scriptdir}/logging
dceb7408 771%{py_scriptdir}/logging/__pycache__
772%{py_scriptdir}/logging/*.py
9416f74d 773
acd14a9e 774%dir %{py_scriptdir}/multiprocessing
dceb7408 775%{py_scriptdir}/multiprocessing/__pycache__
776%{py_scriptdir}/multiprocessing/*.py
acd14a9e 777%dir %{py_scriptdir}/multiprocessing/dummy
dceb7408 778%{py_scriptdir}/multiprocessing/dummy/__pycache__
779%{py_scriptdir}/multiprocessing/dummy/*.py
780
781%{py_scriptdir}/turtledemo
782%{py_scriptdir}/unittest
acd14a9e
AF
783
784%dir %{py_scriptdir}/urllib
dceb7408 785%{py_scriptdir}/urllib/__pycache__
786%{py_scriptdir}/urllib/*.py
acd14a9e 787
9416f74d 788%dir %{py_scriptdir}/wsgiref
dceb7408 789%{py_scriptdir}/wsgiref/__pycache__
790%{py_scriptdir}/wsgiref/*.py
acd14a9e 791%{py_scriptdir}/wsgiref.egg-info
9416f74d
AM
792
793%dir %{py_scriptdir}/xml
794%dir %{py_scriptdir}/xml/dom
795%dir %{py_scriptdir}/xml/etree
796%dir %{py_scriptdir}/xml/parsers
797%dir %{py_scriptdir}/xml/sax
dceb7408 798%{py_scriptdir}/xml/__pycache__
799%{py_scriptdir}/xml/dom/__pycache__
800%{py_scriptdir}/xml/etree/__pycache__
801%{py_scriptdir}/xml/parsers/__pycache__
802%{py_scriptdir}/xml/sax/__pycache__
803%{py_scriptdir}/xml/*.py
804%{py_scriptdir}/xml/dom/*.py
805%{py_scriptdir}/xml/etree/*.py
806%{py_scriptdir}/xml/parsers/*.py
807%{py_scriptdir}/xml/sax/*.py
9416f74d 808
acd14a9e 809%dir %{py_scriptdir}/xmlrpc
dceb7408 810%{py_scriptdir}/xmlrpc/__pycache__
811%{py_scriptdir}/xmlrpc/*.py
acd14a9e 812
c7fdbe10 813%attr(755,root,root) %{py_dyndir}/_sqlite3.cpython-*.so
9416f74d 814%dir %{py_scriptdir}/sqlite3
dceb7408 815%{py_scriptdir}/sqlite3/__pycache__
816%{py_scriptdir}/sqlite3/*.py
9416f74d 817
2072c60e 818%files -n pydoc3
9416f74d 819%defattr(644,root,root,755)
19221b23 820%attr(755,root,root) %{_bindir}/pydoc3
dceb7408 821%attr(755,root,root) %{_bindir}/pydoc3.2
822%{py_scriptdir}/pydoc.py
fef40d51 823%dir %{py_scriptdir}/pydoc_data
dceb7408 824%{py_scriptdir}/pydoc_data/__pycache__
825%{py_scriptdir}/pydoc_data/*.py
826%{py_scriptdir}/pydoc_data/*.css
9416f74d 827
2072c60e 828%files -n idle3
9416f74d 829%defattr(644,root,root,755)
19221b23 830%attr(755,root,root) %{_bindir}/idle3
dceb7408 831%attr(755,root,root) %{_bindir}/idle3.2
9416f74d
AM
832%dir %{py_scriptdir}/idlelib
833%dir %{py_scriptdir}/idlelib/Icons
dceb7408 834%{py_scriptdir}/idlelib/__pycache__
835%{py_scriptdir}/idlelib/*.py
acd14a9e
AF
836%doc %{py_scriptdir}/idlelib/*.txt
837%doc %{py_scriptdir}/idlelib/ChangeLog
9416f74d
AM
838%{py_scriptdir}/idlelib/Icons/*
839%{py_scriptdir}/idlelib/*.def
840
841%files devel
842%defattr(644,root,root,755)
843%doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
c7fdbe10
JB
844%attr(755,root,root) %{_bindir}/python%{py_ver}-config
845%attr(755,root,root) %{_bindir}/python%{py_abi}-config
846%attr(755,root,root) %{_bindir}/python3-config
847%attr(755,root,root) %{_libdir}/libpython%{py_abi}.so
848%attr(755,root,root) %{_libdir}/libpython3.so
9416f74d
AM
849%dir %{py_incdir}
850%{py_incdir}/*.h
c7fdbe10 851%{_pkgconfigdir}/python-%{py_ver}.pc
c7fdbe10
JB
852
853%dir %{py_libdir}/config-%{py_abi}
854%attr(755,root,root) %{py_libdir}/config-%{py_abi}/makesetup
855%attr(755,root,root) %{py_libdir}/config-%{py_abi}/install-sh
856%{py_libdir}/config-%{py_abi}/Makefile
857%{py_libdir}/config-%{py_abi}/Setup
858%{py_libdir}/config-%{py_abi}/Setup.config
859%{py_libdir}/config-%{py_abi}/Setup.local
860%{py_libdir}/config-%{py_abi}/config.c
861%{py_libdir}/config-%{py_abi}/config.c.in
862%{py_libdir}/config-%{py_abi}/python.o
9416f74d 863
9416f74d
AM
864%files devel-tools
865%defattr(644,root,root,755)
24586eb0 866/etc/shrc.d/python*-devel*
9416f74d 867
24586eb0 868%attr(755,root,root) %{_bindir}/pygettext%{py_ver}
9416f74d 869
dceb7408 870%{py_scriptdir}/pdb.py
871%{py_scriptdir}/profile.py
872%{py_scriptdir}/pstats.py
873%{py_scriptdir}/timeit.py
9416f74d 874
30b0ff7b 875%files 2to3
eb7b678c 876%attr(755,root,root) %{_bindir}/2to3-%{py_ver}
30b0ff7b 877%dir %{py_scriptdir}/lib2to3
dceb7408 878%{py_scriptdir}/lib2to3/__pycache__
30b0ff7b
AF
879%{py_scriptdir}/lib2to3/*.txt
880%{py_scriptdir}/lib2to3/*.pickle
dceb7408 881%{py_scriptdir}/lib2to3/*.py
30b0ff7b 882%dir %{py_scriptdir}/lib2to3/fixes
dceb7408 883%{py_scriptdir}/lib2to3/fixes/__pycache__
be43ead0 884%{py_scriptdir}/lib2to3/fixes/*.py
30b0ff7b 885%dir %{py_scriptdir}/lib2to3/pgen2
dceb7408 886%{py_scriptdir}/lib2to3/pgen2/__pycache__
887%{py_scriptdir}/lib2to3/pgen2/*.py
30b0ff7b 888
9416f74d
AM
889%files static
890%defattr(644,root,root,755)
6eede82b 891%{_libdir}/libpython%{py_abi}.a
9416f74d
AM
892
893%files examples
894%defattr(644,root,root,755)
895%{_examplesdir}/%{name}-%{version}
896
9416f74d
AM
897%if %{with info}
898%files doc-info
899%defattr(644,root,root,755)
900%{_infodir}/*.info*
901%endif
902
903%if %{with tkinter}
904%files tkinter
905%defattr(644,root,root,755)
acd14a9e 906%dir %{py_scriptdir}/tkinter
dceb7408 907%{py_scriptdir}/tkinter/__pycache__
908%{py_scriptdir}/tkinter/*.py
c7fdbe10 909%attr(755,root,root) %{py_dyndir}/_tkinter.cpython-*.so
9416f74d 910%endif
This page took 0.192838 seconds and 4 git commands to generate.