]> git.pld-linux.org Git - packages/python3-werkzeug.git/commitdiff
Up to 2.0.2 (supports python 3.6+) auto/th/python-werkzeug-2.0.2-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 13 Oct 2021 10:29:05 +0000 (10:29 +0000)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 13 Oct 2021 10:29:05 +0000 (10:29 +0000)
python3-werkzeug.spec [moved from python-werkzeug.spec with 55% similarity]

similarity index 55%
rename from python-werkzeug.spec
rename to python3-werkzeug.spec
index 5e328663210abdb9eba8d333e222cc403c20396c..d6f688919a800bacda7b7cc4c0ad7fdb9d408045 100644 (file)
@@ -2,15 +2,13 @@
 # Conditional build:
 %bcond_without doc     # Sphinx documentation
 %bcond_without tests   # test action
-%bcond_without python2 # CPython 2.x module
-%bcond_without python3 # CPython 3.x module
 
 %define                module  werkzeug
 Summary:       The Swiss Army knife of Python web development
 Summary(pl.UTF-8):     Scyzoryk szwajcarski programisty aplikacji WWW
 Name:          python-%{module}
-Version:       1.0.1
-Release:       2
+Version:       2.0.2
+Release:       1
 License:       BSD
 Group:         Development/Languages/Python
 # pypi release misses docs/_themes directory
@@ -18,29 +16,10 @@ Group:              Development/Languages/Python
 #Source0:      https://files.pythonhosted.org/packages/source/W/Werkzeug/Werkzeug-%{version}.tar.gz
 #Source0Download: https://github.com/pallets/werkzeug/releases
 Source0:       https://github.com/pallets/werkzeug/archive/%{version}/werkzeug-%{version}.tar.gz
-# Source0-md5: 31e05a3d8e8e64e06b96c1c6a1a559ee
+# Source0-md5: 83f72a2fe8bbbe851a0e9e75994f8c49
 URL:           https://werkzeug.palletsprojects.com/
-%if %{with python2}
-BuildRequires: python-devel >= 1:2.7
-BuildRequires: python-modules >= 1:2.7
-BuildRequires: python-setuptools
-%if %{with tests}
-BuildRequires: python-cryptography
-BuildRequires: python-greenlet
-BuildRequires: python-pyOpenSSL
-BuildRequires: python-pytest
-BuildRequires: python-pytest-timeout
-# optional
-#BuildRequires:        python-pytest-xprocess
-BuildRequires: python-requests
-BuildRequires: python-requests-mock
-# optional
-#BuildRequires:        python-watchdog
-%endif
-%endif
-%if %{with python3}
-BuildRequires: python3-devel >= 1:3.5
-BuildRequires: python3-modules >= 1:3.5
+BuildRequires: python3-devel >= 1:3.6
+BuildRequires: python3-modules >= 1:3.6
 BuildRequires: python3-setuptools
 %if %{with tests}
 BuildRequires: python3-cryptography
@@ -54,7 +33,6 @@ BuildRequires:        python3-requests
 # optional
 #BuildRequires:        python3-watchdog
 %endif
-%endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with doc}
@@ -84,29 +62,6 @@ znaczników encji, nagłówki sterujące buforowaniem, daty HTTP, obsługę
 ciasteczek, przesyłanie plików, potężny system trasowania URL oraz
 wiele dodatkowych modułów udostępnionych przez społeczność.
 
-%package -n python3-%{module}
-Summary:       The Swiss Army knife of Python web development
-Summary(pl.UTF-8):     Scyzoryk szwajcarski programisty aplikacji WWW
-Group:         Libraries/Python
-Requires:      python3-modules >= 1:3.5
-
-%description -n python3-%{module}
-Werkzeug started as simple collection of various utilities for WSGI
-applications and has become one of the most advanced WSGI utility
-modules. It includes a powerful debugger, full featured request and
-response objects, HTTP utilities to handle entity tags, cache control
-headers, HTTP dates, cookie handling, file uploads, a powerful URL
-routing system and a bunch of community contributed addon modules.
-
-%description -n python3-%{module} -l pl.UTF-8
-Werkzeug początkowo był prostym zbiorem różnych narzędzi dla aplikacji
-WSGI, a stał się jednym z najbardziej zaawansowanych modułów
-narzędziowych WSGI. Zawiera potężny debugger, obiekty żądania i
-odpowiedzi z pełną funkcjonalnością, narzędzia HTTP do obsługi
-znaczników encji, nagłówki sterujące buforowaniem, daty HTTP, obsługę
-ciasteczek, przesyłanie plików, potężny system trasowania URL oraz
-wiele dodatkowych modułów udostępnionych przez społeczność.
-
 %package apidocs
 Summary:       Documentation for Python Werkzeug package
 Summary(pl.UTF-8):     Dokumentacja do pakietu Pythona Werkzeug
@@ -122,20 +77,6 @@ Dokumentacja do pakietu Pythona Werkzeug.
 %setup -q -n werkzeug-%{version}
 
 %build
-%if %{with python2}
-%py_build
-
-%if %{with tests}
-# requests_mock.contrib._pytest_plugin helps to workaround crash on cryptography deprecation warning(?)
-LC_ALL=C.UTF-8 \
-PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
-PYTEST_PLUGINS=pytest_timeout,requests_mock.contrib._pytest_plugin \
-PYTHONPATH=$(pwd)/src \
-%{__python} -m pytest tests
-%endif
-%endif
-
-%if %{with python3}
 %py3_build
 
 %if %{with tests}
@@ -145,7 +86,6 @@ PYTEST_PLUGINS=pytest_timeout \
 PYTHONPATH=$(pwd)/src \
 %{__python3} -m pytest tests
 %endif
-%endif
 
 %if %{with doc}
 PYTHONPATH=$(pwd)/src \
@@ -155,45 +95,23 @@ PYTHONPATH=$(pwd)/src \
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%if %{with python2}
-%py_install
-%py_postclean
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
-cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
-find $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version} -name '*.py' \
-       | xargs sed -i '1s|^#!.*python\b|#!%{__python}|'
-%endif
 
-%if %{with python3}
 %py3_install
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
 find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
        | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
-%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with python2}
 %files
 %defattr(644,root,root,755)
 %doc CHANGES.rst LICENSE.rst README.rst
-%{py_sitescriptdir}/werkzeug
-%{py_sitescriptdir}/Werkzeug-%{version}-py*.egg-info
-%{_examplesdir}/python-%{module}-%{version}
-%endif
-
-%if %{with python3}
-%files -n python3-%{module}
-%defattr(644,root,root,755)
-%doc CHANGES.rst LICENSE.rst README.rst
 %{py3_sitescriptdir}/werkzeug
 %{py3_sitescriptdir}/Werkzeug-%{version}-py*.egg-info
 %{_examplesdir}/python3-%{module}-%{version}
-%endif
 
 %if %{with doc}
 %files apidocs
This page took 0.052232 seconds and 4 git commands to generate.