]> git.pld-linux.org Git - packages/python3-werkzeug.git/blobdiff - python-werkzeug.spec
cleanups; drop empty pl description
[packages/python3-werkzeug.git] / python-werkzeug.spec
index 94b1b167a36657af2e44980639a0f94135f229dc..b27df734866635a67a5b3a1111e28754b94f2981 100644 (file)
@@ -1,7 +1,6 @@
-# TODO: rename to  python-werkzeug
-#
 # Conditional build:
-# %bcond_without  doc             # don't build doc
+#
+%bcond_with  doc             # don't build doc
 %bcond_with  tests   # do not perform "make test"
 %bcond_without  python2 # CPython 2.x module
 %bcond_without  python3 # CPython 3.x module
@@ -9,27 +8,25 @@
 %define        module  werkzeug
 Summary:       The Swiss Army knife of Python web development
 Name:          python-%{module}
-Version:       0.9.6
+Version:       0.11.10
 Release:       2
 License:       BSD
 Group:         Development/Languages/Python
-Source0:       http://pypi.python.org/packages/source/W/Werkzeug/Werkzeug-%{version}.tar.gz
-# Source0-md5: f7afcadc03b0f2267bdc156c34586043
+# Source0:     http://pypi.python.org/packages/source/W/Werkzeug/Werkzeug-%{version}.tar.gz
+Source0:       https://github.com/pallets/werkzeug/archive/%{version}.tar.gz
+# Source0-md5: 5010591f97c36722027bd23ade0029e3
 URL:           http://werkzeug.pocoo.org/
 %if %{with python2}
 BuildRequires: python-distribute
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: rpmbuild(macros) >= 1.710
 Requires:      python-modules
 %endif
 %if %{with python3}
 BuildRequires: python3-devel
 BuildRequires: python3-distribute
 BuildRequires: python3-modules
-Requires:      python3-modules
 %endif
-
-
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -45,6 +42,7 @@ routing system and a bunch of community contributed addon modules.
 Summary:       The Swiss Army knife of Python web development
 Summary(pl.UTF-8):     Zbiór narzędzi dla rozwouju aplikacji sieciowych dla Pythona
 Group:         Libraries/Python
+Requires:      python3-modules
 
 %description -n python3-%{module}
 Werkzeug started as simple collection of various utilities for WSGI
@@ -54,57 +52,38 @@ response objects, HTTP utilities to handle entity tags, cache control
 headers, HTTP dates, cookie handling, file uploads, a powerful URL
 routing system and a bunch of community contributed addon modules.
 
-# %description -n python3-%{module} -l pl.UTF-8
-
 %prep
-%setup -q -n Werkzeug-%{version}
+%setup -q -n werkzeug-%{version}
 
 %build
 %if %{with python2}
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+%py_build %{?with_tests:test}
 %endif
 
 %if %{with python3}
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%py3_build %{?with_tests:test}
 %endif
 
-
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %if %{with python2}
-%{__python} setup.py \
-        build --build-base build-2 \
-        install --skip-build \
-        --optimize=2 \
-        --root=$RPM_BUILD_ROOT
-
+%py_install
 %py_postclean
-%endif
 
-%if %{with python3}
-%{__python3} setup.py \
-        build --build-base build-3 \
-        install --skip-build \
-        --optimize=2 \
-        --root=$RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
+cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
+find $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version} -name '*.py' \
+       | xargs sed -i '1s|^#!.*python\b|#!%{__python}|'
 %endif
 
-%if %{with python2}
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-%endif
 %if %{with python3}
+%py3_install
+
 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
 find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
-        | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
+       | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
 %endif
-%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -114,10 +93,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS CHANGES
 %{py_sitescriptdir}/werkzeug
-%if "%{py_ver}" > "2.4"
 %{py_sitescriptdir}/Werkzeug-%{version}-py*.egg-info
-%endif
-%{_examplesdir}/%{name}-%{version}
+%{_examplesdir}/python-%{module}-%{version}
 %endif
 
 %if %{with python3}
This page took 0.06512 seconds and 4 git commands to generate.