]> git.pld-linux.org Git - packages/python3-werkzeug.git/blobdiff - python-werkzeug.spec
- updated to 0.12.1
[packages/python3-werkzeug.git] / python-werkzeug.spec
index 5d597935e68a4e2ad696a969b3363dab5eaad587..8adb371fd672b7c6845cfce2433b0ec549441f77 100644 (file)
@@ -1,35 +1,71 @@
-# TODO: rename to  python-werkzeug
 #
 # Conditional build:
-# %bcond_without  doc             # don't build doc
-%bcond_with  tests   # do not perform "make test"
-%bcond_without  python2 # CPython 2.x module
-%bcond_without  python3 # CPython 3.x module
+%bcond_without doc     # Sphinx documentation
+%bcond_with    tests   # test action
+%bcond_without python2 # CPython 2.x module
+%bcond_without python3 # CPython 3.x module
 
 %define        module  werkzeug
 Summary:       The Swiss Army knife of Python web development
+Summary(pl.UTF-8):     Scyzoryk szwajcarski programisty aplikacji WWW
 Name:          python-%{module}
-Version:       0.9.6
-Release:       4
+Version:       0.12.1
+Release:       1
 License:       BSD
 Group:         Development/Languages/Python
-Source0:       http://pypi.python.org/packages/source/W/Werkzeug/Werkzeug-%{version}.tar.gz
-# Source0-md5: f7afcadc03b0f2267bdc156c34586043
+# pypi release misses docs/_themes directory
+##Source0Download: https://pypi.python.org/simple/Werkzeug
+#Source0:      https://files.pythonhosted.org/packages/source/W/Werkzeug/Werkzeug-%{version}.tar.gz
+#Source0Download: https://github.com/pallets/werkzeug/releases
+Source0:       https://github.com/pallets/werkzeug/archive/%{version}/werkzeug-%{version}.tar.gz
+# Source0-md5: d49e5b9e4c5c1fa2e1d783f5ad69cc87
 URL:           http://werkzeug.pocoo.org/
 %if %{with python2}
-BuildRequires: python-distribute
-BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
-Requires:      python-modules
+BuildRequires: python-devel >= 1:2.6
+BuildRequires: python-modules >= 1:2.6
+BuildRequires: python-setuptools
+%if %{with tests}
+BuildRequires: python-greenlet
+BuildRequires: python-hypothesis
+# optional
+#BuildRequires:        python-memcached
+BuildRequires: python-pyOpenSSL
+BuildRequires: python-pytest
+# optional
+#BuildRequires:        python-pytest-xprocess
+# optional
+#BuildRequires:        python-redis
+BuildRequires: python-requests
+# optional
+#BuildRequires:        python-watchdog
+%endif
 %endif
 %if %{with python3}
-BuildRequires: python3-devel
-BuildRequires: python3-distribute
-BuildRequires: python3-modules
-Requires:      python3-modules
+BuildRequires: python3-devel >= 1:3.3
+BuildRequires: python3-modules >= 1:3.3
+BuildRequires: python3-setuptools
+%if %{with tests}
+BuildRequires: python3-greenlet
+BuildRequires: python3-hypothesis
+# optional
+#BuildRequires:        python3-memcached
+BuildRequires: python3-pyOpenSSL
+BuildRequires: python3-pytest
+# optional
+#BuildRequires:        python3-pytest-xprocess
+# optional
+#BuildRequires:        python3-redis
+BuildRequires: python3-requests
+# optional
+#BuildRequires:        python3-watchdog
 %endif
-
-
+%endif
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.714
+%if %{with doc}
+BuildRequires: sphinx-pdg
+%endif
+Requires:      python-modules >= 1:2.6
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -41,10 +77,20 @@ response objects, HTTP utilities to handle entity tags, cache control
 headers, HTTP dates, cookie handling, file uploads, a powerful URL
 routing system and a bunch of community contributed addon modules.
 
+%description -l pl.UTF-8
+Werkzeug początkowo był prostym zbiorem różnych narzędzi dla aplikacji
+WSGI, a stał się jednym z najbardziej zaawansowanych modułów
+narzędziowych WSGI. Zawiera potężny debugger, obiekty żądania i
+odpowiedzi z pełną funkcjonalnością, narzędzia HTTP do obsługi
+znaczników encji, nagłówki sterujące buforowaniem, daty HTTP, obsługę
+ciasteczek, przesyłanie plików, potężny system trasowania URL oraz
+wiele dodatkowych modułów udostępnionych przez społeczność.
+
 %package -n python3-%{module}
 Summary:       The Swiss Army knife of Python web development
-Summary(pl.UTF-8):     Zbiór narzędzi dla rozwouju aplikacji sieciowych dla Pythona
+Summary(pl.UTF-8):     Scyzoryk szwajcarski programisty aplikacji WWW
 Group:         Libraries/Python
+Requires:      python3-modules >= 1:3.3
 
 %description -n python3-%{module}
 Werkzeug started as simple collection of various utilities for WSGI
@@ -54,57 +100,63 @@ response objects, HTTP utilities to handle entity tags, cache control
 headers, HTTP dates, cookie handling, file uploads, a powerful URL
 routing system and a bunch of community contributed addon modules.
 
-# %description -n python3-%{module} -l pl.UTF-8
+%description -n python3-%{module} -l pl.UTF-8
+Werkzeug początkowo był prostym zbiorem różnych narzędzi dla aplikacji
+WSGI, a stał się jednym z najbardziej zaawansowanych modułów
+narzędziowych WSGI. Zawiera potężny debugger, obiekty żądania i
+odpowiedzi z pełną funkcjonalnością, narzędzia HTTP do obsługi
+znaczników encji, nagłówki sterujące buforowaniem, daty HTTP, obsługę
+ciasteczek, przesyłanie plików, potężny system trasowania URL oraz
+wiele dodatkowych modułów udostępnionych przez społeczność.
+
+%package apidocs
+Summary:       Documentation for Python Werkzeug package
+Summary(pl.UTF-8):     Dokumentacja do pakietu Pythona Werkzeug
+Group:         Documentation
+
+%description apidocs
+Documentation for Python Werkzeug package.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja do pakietu Pythona Werkzeug.
 
 %prep
-%setup -q -n Werkzeug-%{version}
+%setup -q -n werkzeug-%{version}
 
 %build
 %if %{with python2}
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+%py_build %{?with_tests:test}
 %endif
 
 %if %{with python3}
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%py3_build %{?with_tests:test}
 %endif
 
+%if %{with doc}
+PYTHONPATH=$(pwd) \
+%{__make} -C docs html
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %if %{with python2}
-%{__python} setup.py \
-        build --build-base build-2 \
-        install --skip-build \
-        --optimize=2 \
-        --root=$RPM_BUILD_ROOT
-
+%py_install
 %py_postclean
-%endif
 
-%if %{with python3}
-%{__python3} setup.py \
-        build --build-base build-3 \
-        install --skip-build \
-        --optimize=2 \
-        --root=$RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
+cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
+find $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version} -name '*.py' \
+       | xargs sed -i '1s|^#!.*python\b|#!%{__python}|'
 %endif
 
-%if %{with python2}
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-%endif
 %if %{with python3}
+%py3_install
+
 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
 find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
-        | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
+       | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
 %endif
-%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -112,19 +164,23 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS CHANGES
+%doc AUTHORS CHANGES LICENSE README.rst
 %{py_sitescriptdir}/werkzeug
-%if "%{py_ver}" > "2.4"
 %{py_sitescriptdir}/Werkzeug-%{version}-py*.egg-info
-%endif
-%{_examplesdir}/%{name}-%{version}
+%{_examplesdir}/python-%{module}-%{version}
 %endif
 
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc AUTHORS CHANGES LICENSE
-%{py3_sitescriptdir}/%{module}
+%doc AUTHORS CHANGES LICENSE README.rst
+%{py3_sitescriptdir}/werkzeug
 %{py3_sitescriptdir}/Werkzeug-%{version}-py*.egg-info
 %{_examplesdir}/python3-%{module}-%{version}
 %endif
+
+%if %{with doc}
+%files apidocs
+%defattr(644,root,root,755)
+%doc docs/_build/html/{_images,_static,contrib,deployment,*.html,*.js}
+%endif
This page took 0.034886 seconds and 4 git commands to generate.