]> git.pld-linux.org Git - packages/python3-werkzeug.git/blobdiff - python-werkzeug.spec
Version 0.11.10.
[packages/python3-werkzeug.git] / python-werkzeug.spec
index 310e5c56e33b165a847b97452d74700fe8959c96..8a7f8769077506719dc61c3e26b54c4bd0cce34b 100644 (file)
@@ -6,20 +6,21 @@
 %bcond_without  python2 # CPython 2.x module
 %bcond_without  python3 # CPython 3.x module
 
-%define        module  Werkzeug
+%define        module  werkzeug
 Summary:       The Swiss Army knife of Python web development
 Name:          python-%{module}
-Version:       0.9.6
+Version:       0.11.10
 Release:       1
 License:       BSD
 Group:         Development/Languages/Python
-Source0:       http://pypi.python.org/packages/source/W/Werkzeug/%{module}-%{version}.tar.gz
-# Source0-md5: f7afcadc03b0f2267bdc156c34586043
+# Source0:     http://pypi.python.org/packages/source/W/Werkzeug/Werkzeug-%{version}.tar.gz
+Source0:       https://github.com/pallets/werkzeug/archive/%{version}.tar.gz
+# Source0-md5: 5010591f97c36722027bd23ade0029e3
 URL:           http://werkzeug.pocoo.org/
 %if %{with python2}
 BuildRequires: python-distribute
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: rpmbuild(macros) >= 1.710
 Requires:      python-modules
 %endif
 %if %{with python3}
@@ -57,19 +58,15 @@ routing system and a bunch of community contributed addon modules.
 # %description -n python3-%{module} -l pl.UTF-8
 
 %prep
-%setup -q -n %{module}-%{version}
+%setup -q -n werkzeug-%{version}
 
 %build
 %if %{with python2}
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+%py_build %{?with_tests:test}
 %endif
 
 %if %{with python3}
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%py3_build %{?with_tests:test}
 %endif
 
 
@@ -77,21 +74,13 @@ CFLAGS="%{rpmcflags}" \
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
-%{__python} setup.py \
-        build --build-base build-2 \
-        install --skip-build \
-        --optimize=2 \
-        --root=$RPM_BUILD_ROOT
+%py_install
 
 %py_postclean
 %endif
 
 %if %{with python3}
-%{__python3} setup.py \
-        build --build-base build-3 \
-        install --skip-build \
-        --optimize=2 \
-        --root=$RPM_BUILD_ROOT
+%py3_install
 %endif
 
 %if %{with python2}
@@ -115,7 +104,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS CHANGES
 %{py_sitescriptdir}/werkzeug
 %if "%{py_ver}" > "2.4"
-%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
+%{py_sitescriptdir}/Werkzeug-%{version}-py*.egg-info
 %endif
 %{_examplesdir}/%{name}-%{version}
 %endif
@@ -124,7 +113,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -n python3-%{module}
 %defattr(644,root,root,755)
 %doc AUTHORS CHANGES LICENSE
-%{py3_sitescriptdir}/werkzeug
-%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
+%{py3_sitescriptdir}/%{module}
+%{py3_sitescriptdir}/Werkzeug-%{version}-py*.egg-info
 %{_examplesdir}/python3-%{module}-%{version}
 %endif
This page took 0.099599 seconds and 4 git commands to generate.