]> git.pld-linux.org Git - packages/python3-werkzeug.git/blobdiff - python-Werkzeug.spec
Version 0.9.6-1. python3 added.
[packages/python3-werkzeug.git] / python-Werkzeug.spec
index 28c308f65f641c9b6e5da10107a7d7c81bcadf21..310e5c56e33b165a847b97452d74700fe8959c96 100644 (file)
@@ -1,24 +1,35 @@
+# TODO: rename to  python-werkzeug
 #
 # Conditional build:
-%bcond_without tests   # do not perform "make test"
+# %bcond_without  doc             # don't build doc
+%bcond_with  tests   # do not perform "make test"
+%bcond_without  python2 # CPython 2.x module
+%bcond_without  python3 # CPython 3.x module
 
 %define        module  Werkzeug
 Summary:       The Swiss Army knife of Python web development
-#Summary(pl.UTF-8):    -
 Name:          python-%{module}
-Version:       0.8.3
-Release:       0.1
+Version:       0.9.6
+Release:       1
 License:       BSD
 Group:         Development/Languages/Python
 Source0:       http://pypi.python.org/packages/source/W/Werkzeug/%{module}-%{version}.tar.gz
-# Source0-md5: 12aa03e302ce49da98703938f257347a
+# Source0-md5: f7afcadc03b0f2267bdc156c34586043
 URL:           http://werkzeug.pocoo.org/
+%if %{with python2}
 BuildRequires: python-distribute
 BuildRequires: rpm-pythonprov
-# if py_postclean is used
 BuildRequires: rpmbuild(macros) >= 1.219
-#Requires:             python-libs
-Requires:              python-modules
+Requires:      python-modules
+%endif
+%if %{with python3}
+BuildRequires: python3-devel
+BuildRequires: python3-distribute
+BuildRequires: python3-modules
+Requires:      python3-modules
+%endif
+
+
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -30,38 +41,90 @@ response objects, HTTP utilities to handle entity tags, cache control
 headers, HTTP dates, cookie handling, file uploads, a powerful URL
 routing system and a bunch of community contributed addon modules.
 
-%description -l pl.UTF-8
+%package -n python3-%{module}
+Summary:       The Swiss Army knife of Python web development
+Summary(pl.UTF-8):     Zbiór narzędzi dla rozwouju aplikacji sieciowych dla Pythona
+Group:         Libraries/Python
+
+%description -n python3-%{module}
+Werkzeug started as simple collection of various utilities for WSGI
+applications and has become one of the most advanced WSGI utility
+modules. It includes a powerful debugger, full featured request and
+response objects, HTTP utilities to handle entity tags, cache control
+headers, HTTP dates, cookie handling, file uploads, a powerful URL
+routing system and a bunch of community contributed addon modules.
+
+# %description -n python3-%{module} -l pl.UTF-8
 
 %prep
 %setup -q -n %{module}-%{version}
 
 %build
-%{__python} setup.py build
+%if %{with python2}
+CC="%{__cc}" \
+CFLAGS="%{rpmcflags}" \
+%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+%endif
+
+%if %{with python3}
+CC="%{__cc}" \
+CFLAGS="%{rpmcflags}" \
+%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%endif
 
-%{?with_tests:%{__python} setup.py test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__python} setup.py install \
-       --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
 
+%if %{with python2}
+%{__python} setup.py \
+        build --build-base build-2 \
+        install --skip-build \
+        --optimize=2 \
+        --root=$RPM_BUILD_ROOT
+
+%py_postclean
+%endif
+
+%if %{with python3}
+%{__python3} setup.py \
+        build --build-base build-3 \
+        install --skip-build \
+        --optimize=2 \
+        --root=$RPM_BUILD_ROOT
+%endif
+
+%if %{with python2}
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-
-%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
-%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
+%endif
+%if %{with python3}
+install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
+cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
+find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
+        | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
+%endif
 %py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with python2}
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS CHANGES
 %{py_sitescriptdir}/werkzeug
 %if "%{py_ver}" > "2.4"
-%{py_sitescriptdir}/%{module}-*.egg-info
+%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
 %endif
 %{_examplesdir}/%{name}-%{version}
+%endif
+
+%if %{with python3}
+%files -n python3-%{module}
+%defattr(644,root,root,755)
+%doc AUTHORS CHANGES LICENSE
+%{py3_sitescriptdir}/werkzeug
+%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
+%{_examplesdir}/python3-%{module}-%{version}
+%endif
This page took 0.063052 seconds and 4 git commands to generate.