]> git.pld-linux.org Git - packages/python3-werkzeug.git/blob - python3-werkzeug.spec
Rel 3; fix name
[packages/python3-werkzeug.git] / python3-werkzeug.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # test action
5
6 %define         module  werkzeug
7 Summary:        The Swiss Army knife of Python web development
8 Summary(pl.UTF-8):      Scyzoryk szwajcarski programisty aplikacji WWW
9 Name:           python3-%{module}
10 Version:        2.0.2
11 Release:        2
12 License:        BSD
13 Group:          Development/Languages/Python
14 # pypi release misses docs/_themes directory
15 ##Source0Download: https://pypi.python.org/simple/Werkzeug
16 #Source0:       https://files.pythonhosted.org/packages/source/W/Werkzeug/Werkzeug-%{version}.tar.gz
17 #Source0Download: https://github.com/pallets/werkzeug/releases
18 Source0:        https://github.com/pallets/werkzeug/archive/%{version}/werkzeug-%{version}.tar.gz
19 # Source0-md5:  83f72a2fe8bbbe851a0e9e75994f8c49
20 URL:            https://werkzeug.palletsprojects.com/
21 BuildRequires:  python3-devel >= 1:3.6
22 BuildRequires:  python3-modules >= 1:3.6
23 BuildRequires:  python3-setuptools
24 %if %{with tests}
25 BuildRequires:  python3-cryptography
26 BuildRequires:  python3-greenlet
27 BuildRequires:  python3-pyOpenSSL
28 BuildRequires:  python3-pytest
29 BuildRequires:  python3-pytest-timeout
30 # optional
31 #BuildRequires: python3-pytest-xprocess
32 BuildRequires:  python3-requests
33 # optional
34 #BuildRequires: python3-watchdog
35 %endif
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  rpmbuild(macros) >= 1.714
38 %if %{with doc}
39 BuildRequires:  python3-pallets-sphinx-themes
40 BuildRequires:  python3-sphinx_issues
41 BuildRequires:  python3-sphinxcontrib-log-cabinet
42 BuildRequires:  sphinx-pdg-3
43 %endif
44 Requires:       python-modules >= 1:2.7
45 BuildArch:      noarch
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Werkzeug started as simple collection of various utilities for WSGI
50 applications and has become one of the most advanced WSGI utility
51 modules. It includes a powerful debugger, full featured request and
52 response objects, HTTP utilities to handle entity tags, cache control
53 headers, HTTP dates, cookie handling, file uploads, a powerful URL
54 routing system and a bunch of community contributed addon modules.
55
56 %description -l pl.UTF-8
57 Werkzeug początkowo był prostym zbiorem różnych narzędzi dla aplikacji
58 WSGI, a stał się jednym z najbardziej zaawansowanych modułów
59 narzędziowych WSGI. Zawiera potężny debugger, obiekty żądania i
60 odpowiedzi z pełną funkcjonalnością, narzędzia HTTP do obsługi
61 znaczników encji, nagłówki sterujące buforowaniem, daty HTTP, obsługę
62 ciasteczek, przesyłanie plików, potężny system trasowania URL oraz
63 wiele dodatkowych modułów udostępnionych przez społeczność.
64
65 %package apidocs
66 Summary:        Documentation for Python Werkzeug package
67 Summary(pl.UTF-8):      Dokumentacja do pakietu Pythona Werkzeug
68 Group:          Documentation
69
70 %description apidocs
71 Documentation for Python Werkzeug package.
72
73 %description apidocs -l pl.UTF-8
74 Dokumentacja do pakietu Pythona Werkzeug.
75
76 %prep
77 %setup -q -n werkzeug-%{version}
78
79 %build
80 %py3_build
81
82 %if %{with tests}
83 LC_ALL=C.UTF-8 \
84 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
85 PYTEST_PLUGINS=pytest_timeout \
86 PYTHONPATH=$(pwd)/src \
87 %{__python3} -m pytest tests
88 %endif
89
90 %if %{with doc}
91 PYTHONPATH=$(pwd)/src \
92 %{__make} -C docs html \
93         SPHINXBUILD=sphinx-build-3
94 %endif
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %py3_install
100
101 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
102 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
103 find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
104         | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %doc CHANGES.rst LICENSE.rst README.rst
112 %{py3_sitescriptdir}/werkzeug
113 %{py3_sitescriptdir}/Werkzeug-%{version}-py*.egg-info
114 %{_examplesdir}/python3-%{module}-%{version}
115
116 %if %{with doc}
117 %files apidocs
118 %defattr(644,root,root,755)
119 %doc docs/_build/html/{_images,_static,deployment,middleware,*.html,*.js}
120 %endif
This page took 0.081294 seconds and 4 git commands to generate.