]> git.pld-linux.org Git - packages/python3-werkzeug.git/blob - python-werkzeug.spec
- release 5 (by relup.sh)
[packages/python3-werkzeug.git] / python-werkzeug.spec
1 # TODO: rename to  python-werkzeug
2 #
3 # Conditional build:
4 # %bcond_without  doc             # don't build doc
5 %bcond_with  tests   # do not perform "make test"
6 %bcond_without  python2 # CPython 2.x module
7 %bcond_without  python3 # CPython 3.x module
8
9 %define         module  werkzeug
10 Summary:        The Swiss Army knife of Python web development
11 Name:           python-%{module}
12 Version:        0.9.6
13 Release:        5
14 License:        BSD
15 Group:          Development/Languages/Python
16 Source0:        http://pypi.python.org/packages/source/W/Werkzeug/Werkzeug-%{version}.tar.gz
17 # Source0-md5:  f7afcadc03b0f2267bdc156c34586043
18 URL:            http://werkzeug.pocoo.org/
19 %if %{with python2}
20 BuildRequires:  python-distribute
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.219
23 Requires:       python-modules
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-devel
27 BuildRequires:  python3-distribute
28 BuildRequires:  python3-modules
29 Requires:       python3-modules
30 %endif
31
32
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Werkzeug started as simple collection of various utilities for WSGI
38 applications and has become one of the most advanced WSGI utility
39 modules. It includes a powerful debugger, full featured request and
40 response objects, HTTP utilities to handle entity tags, cache control
41 headers, HTTP dates, cookie handling, file uploads, a powerful URL
42 routing system and a bunch of community contributed addon modules.
43
44 %package -n python3-%{module}
45 Summary:        The Swiss Army knife of Python web development
46 Summary(pl.UTF-8):      Zbiór narzędzi dla rozwouju aplikacji sieciowych dla Pythona
47 Group:          Libraries/Python
48
49 %description -n python3-%{module}
50 Werkzeug started as simple collection of various utilities for WSGI
51 applications and has become one of the most advanced WSGI utility
52 modules. It includes a powerful debugger, full featured request and
53 response objects, HTTP utilities to handle entity tags, cache control
54 headers, HTTP dates, cookie handling, file uploads, a powerful URL
55 routing system and a bunch of community contributed addon modules.
56
57 # %description -n python3-%{module} -l pl.UTF-8
58
59 %prep
60 %setup -q -n Werkzeug-%{version}
61
62 %build
63 %if %{with python2}
64 %py_build %{?with_tests:test}
65 %endif
66
67 %if %{with python3}
68 %py3_build %{?with_tests:test}
69 %endif
70
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %if %{with python2}
76 %py_install
77
78 %py_postclean
79 %endif
80
81 %if %{with python3}
82 %py3_install
83 %endif
84
85 %if %{with python2}
86 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
87 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
88 %endif
89 %if %{with python3}
90 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
91 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
92 find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
93         | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
94 %endif
95 %py_postclean
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %if %{with python2}
101 %files
102 %defattr(644,root,root,755)
103 %doc AUTHORS CHANGES
104 %{py_sitescriptdir}/werkzeug
105 %if "%{py_ver}" > "2.4"
106 %{py_sitescriptdir}/Werkzeug-%{version}-py*.egg-info
107 %endif
108 %{_examplesdir}/%{name}-%{version}
109 %endif
110
111 %if %{with python3}
112 %files -n python3-%{module}
113 %defattr(644,root,root,755)
114 %doc AUTHORS CHANGES LICENSE
115 %{py3_sitescriptdir}/%{module}
116 %{py3_sitescriptdir}/Werkzeug-%{version}-py*.egg-info
117 %{_examplesdir}/python3-%{module}-%{version}
118 %endif
This page took 0.069886 seconds and 4 git commands to generate.