]> git.pld-linux.org Git - packages/python3-werkzeug.git/blob - python-Werkzeug.spec
- do not create empty pl translation. cleanups
[packages/python3-werkzeug.git] / python-Werkzeug.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  Werkzeug
6 Summary:        The Swiss Army knife of Python web development
7 Name:           python-%{module}
8 Version:        0.8.3
9 Release:        0.1
10 License:        BSD
11 Group:          Development/Languages/Python
12 Source0:        http://pypi.python.org/packages/source/W/Werkzeug/%{module}-%{version}.tar.gz
13 # Source0-md5:  12aa03e302ce49da98703938f257347a
14 URL:            http://werkzeug.pocoo.org/
15 BuildRequires:  python-distribute
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.219
18 Requires:       python-modules
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Werkzeug started as simple collection of various utilities for WSGI
24 applications and has become one of the most advanced WSGI utility
25 modules. It includes a powerful debugger, full featured request and
26 response objects, HTTP utilities to handle entity tags, cache control
27 headers, HTTP dates, cookie handling, file uploads, a powerful URL
28 routing system and a bunch of community contributed addon modules.
29
30 %prep
31 %setup -q -n %{module}-%{version}
32
33 %build
34 %{__python} setup.py build
35
36 %{?with_tests:%{__python} setup.py test}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 %{__python} setup.py install \
41         --skip-build \
42         --optimize=2 \
43         --root=$RPM_BUILD_ROOT
44
45 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
46 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
47
48 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
49 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
50 %py_postclean
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc AUTHORS CHANGES
58 %{py_sitescriptdir}/werkzeug
59 %if "%{py_ver}" > "2.4"
60 %{py_sitescriptdir}/%{module}-*.egg-info
61 %endif
62 %{_examplesdir}/%{name}-%{version}
This page took 0.057528 seconds and 3 git commands to generate.