]> git.pld-linux.org Git - packages/python3-werkzeug.git/blame - python-werkzeug.spec
- updated to 0.12.1
[packages/python3-werkzeug.git] / python-werkzeug.spec
CommitLineData
2f8691a4 1#
7c90b45b
JB
2# Conditional build:
3%bcond_without doc # Sphinx documentation
4%bcond_with tests # test action
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
c6a9fbf4 7
b1dbdc2a 8%define module werkzeug
c6a9fbf4 9Summary: The Swiss Army knife of Python web development
7c90b45b 10Summary(pl.UTF-8): Scyzoryk szwajcarski programisty aplikacji WWW
c6a9fbf4 11Name: python-%{module}
7800109b 12Version: 0.12.1
7c90b45b 13Release: 1
c6a9fbf4 14License: BSD
15Group: Development/Languages/Python
7c90b45b
JB
16# pypi release misses docs/_themes directory
17##Source0Download: https://pypi.python.org/simple/Werkzeug
18#Source0: https://files.pythonhosted.org/packages/source/W/Werkzeug/Werkzeug-%{version}.tar.gz
19#Source0Download: https://github.com/pallets/werkzeug/releases
20Source0: https://github.com/pallets/werkzeug/archive/%{version}/werkzeug-%{version}.tar.gz
7800109b 21# Source0-md5: d49e5b9e4c5c1fa2e1d783f5ad69cc87
c6a9fbf4 22URL: http://werkzeug.pocoo.org/
9fb4e136 23%if %{with python2}
7c90b45b
JB
24BuildRequires: python-devel >= 1:2.6
25BuildRequires: python-modules >= 1:2.6
26BuildRequires: python-setuptools
7800109b
JB
27%if %{with tests}
28BuildRequires: python-greenlet
29BuildRequires: python-hypothesis
30# optional
31#BuildRequires: python-memcached
32BuildRequires: python-pyOpenSSL
33BuildRequires: python-pytest
34# optional
35#BuildRequires: python-pytest-xprocess
36# optional
37#BuildRequires: python-redis
38BuildRequires: python-requests
39# optional
40#BuildRequires: python-watchdog
41%endif
9fb4e136
MK
42%endif
43%if %{with python3}
7c90b45b
JB
44BuildRequires: python3-devel >= 1:3.3
45BuildRequires: python3-modules >= 1:3.3
46BuildRequires: python3-setuptools
7800109b
JB
47%if %{with tests}
48BuildRequires: python3-greenlet
49BuildRequires: python3-hypothesis
50# optional
51#BuildRequires: python3-memcached
52BuildRequires: python3-pyOpenSSL
53BuildRequires: python3-pytest
54# optional
55#BuildRequires: python3-pytest-xprocess
56# optional
57#BuildRequires: python3-redis
58BuildRequires: python3-requests
59# optional
60#BuildRequires: python3-watchdog
61%endif
7c90b45b
JB
62%endif
63BuildRequires: rpm-pythonprov
64BuildRequires: rpmbuild(macros) >= 1.714
65%if %{with doc}
66BuildRequires: sphinx-pdg
9fb4e136 67%endif
7c90b45b 68Requires: python-modules >= 1:2.6
c6a9fbf4 69BuildArch: noarch
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72%description
73Werkzeug started as simple collection of various utilities for WSGI
74applications and has become one of the most advanced WSGI utility
75modules. It includes a powerful debugger, full featured request and
76response objects, HTTP utilities to handle entity tags, cache control
77headers, HTTP dates, cookie handling, file uploads, a powerful URL
78routing system and a bunch of community contributed addon modules.
79
7c90b45b
JB
80%description -l pl.UTF-8
81Werkzeug początkowo był prostym zbiorem różnych narzędzi dla aplikacji
82WSGI, a stał się jednym z najbardziej zaawansowanych modułów
83narzędziowych WSGI. Zawiera potężny debugger, obiekty żądania i
84odpowiedzi z pełną funkcjonalnością, narzędzia HTTP do obsługi
85znaczników encji, nagłówki sterujące buforowaniem, daty HTTP, obsługę
86ciasteczek, przesyłanie plików, potężny system trasowania URL oraz
87wiele dodatkowych modułów udostępnionych przez społeczność.
88
9fb4e136
MK
89%package -n python3-%{module}
90Summary: The Swiss Army knife of Python web development
7c90b45b 91Summary(pl.UTF-8): Scyzoryk szwajcarski programisty aplikacji WWW
9fb4e136 92Group: Libraries/Python
7c90b45b 93Requires: python3-modules >= 1:3.3
9fb4e136
MK
94
95%description -n python3-%{module}
96Werkzeug started as simple collection of various utilities for WSGI
97applications and has become one of the most advanced WSGI utility
98modules. It includes a powerful debugger, full featured request and
99response objects, HTTP utilities to handle entity tags, cache control
100headers, HTTP dates, cookie handling, file uploads, a powerful URL
101routing system and a bunch of community contributed addon modules.
102
7c90b45b
JB
103%description -n python3-%{module} -l pl.UTF-8
104Werkzeug początkowo był prostym zbiorem różnych narzędzi dla aplikacji
105WSGI, a stał się jednym z najbardziej zaawansowanych modułów
106narzędziowych WSGI. Zawiera potężny debugger, obiekty żądania i
107odpowiedzi z pełną funkcjonalnością, narzędzia HTTP do obsługi
108znaczników encji, nagłówki sterujące buforowaniem, daty HTTP, obsługę
109ciasteczek, przesyłanie plików, potężny system trasowania URL oraz
110wiele dodatkowych modułów udostępnionych przez społeczność.
111
112%package apidocs
113Summary: Documentation for Python Werkzeug package
114Summary(pl.UTF-8): Dokumentacja do pakietu Pythona Werkzeug
115Group: Documentation
116
117%description apidocs
118Documentation for Python Werkzeug package.
119
120%description apidocs -l pl.UTF-8
121Dokumentacja do pakietu Pythona Werkzeug.
122
c6a9fbf4 123%prep
fdb1d6ee 124%setup -q -n werkzeug-%{version}
c6a9fbf4 125
126%build
9fb4e136 127%if %{with python2}
5db35e26 128%py_build %{?with_tests:test}
9fb4e136
MK
129%endif
130
131%if %{with python3}
5db35e26 132%py3_build %{?with_tests:test}
9fb4e136 133%endif
c6a9fbf4 134
7c90b45b
JB
135%if %{with doc}
136PYTHONPATH=$(pwd) \
137%{__make} -C docs html
138%endif
139
c6a9fbf4 140%install
141rm -rf $RPM_BUILD_ROOT
9fb4e136 142%if %{with python2}
5db35e26 143%py_install
9fb4e136 144%py_postclean
2f8691a4
ER
145
146install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
147cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
148find $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version} -name '*.py' \
149 | xargs sed -i '1s|^#!.*python\b|#!%{__python}|'
9fb4e136
MK
150%endif
151
152%if %{with python3}
5db35e26 153%py3_install
9fb4e136 154
9fb4e136
MK
155install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
156cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
157find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
2f8691a4 158 | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
9fb4e136 159%endif
c6a9fbf4 160
161%clean
162rm -rf $RPM_BUILD_ROOT
163
9fb4e136 164%if %{with python2}
c6a9fbf4 165%files
166%defattr(644,root,root,755)
7c90b45b 167%doc AUTHORS CHANGES LICENSE README.rst
c6a9fbf4 168%{py_sitescriptdir}/werkzeug
b1dbdc2a 169%{py_sitescriptdir}/Werkzeug-%{version}-py*.egg-info
2f8691a4 170%{_examplesdir}/python-%{module}-%{version}
9fb4e136
MK
171%endif
172
173%if %{with python3}
174%files -n python3-%{module}
175%defattr(644,root,root,755)
7c90b45b
JB
176%doc AUTHORS CHANGES LICENSE README.rst
177%{py3_sitescriptdir}/werkzeug
b1dbdc2a 178%{py3_sitescriptdir}/Werkzeug-%{version}-py*.egg-info
9fb4e136
MK
179%{_examplesdir}/python3-%{module}-%{version}
180%endif
7c90b45b
JB
181
182%if %{with doc}
183%files apidocs
184%defattr(644,root,root,755)
185%doc docs/_build/html/{_images,_static,contrib,deployment,*.html,*.js}
186%endif
This page took 0.116725 seconds and 4 git commands to generate.