]> git.pld-linux.org Git - packages/python3-werkzeug.git/blame - python-Werkzeug.spec
- new
[packages/python3-werkzeug.git] / python-Werkzeug.spec
CommitLineData
c6a9fbf4 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define module Werkzeug
6Summary: The Swiss Army knife of Python web development
7#Summary(pl.UTF-8): -
8Name: python-%{module}
9Version: 0.8.3
10Release: 0.1
11License: BSD
12Group: Development/Languages/Python
13Source0: http://pypi.python.org/packages/source/W/Werkzeug/%{module}-%{version}.tar.gz
14# Source0-md5: 12aa03e302ce49da98703938f257347a
15URL: http://werkzeug.pocoo.org/
16BuildRequires: python-distribute
17BuildRequires: rpm-pythonprov
18# if py_postclean is used
19BuildRequires: rpmbuild(macros) >= 1.219
20#Requires: python-libs
21Requires: python-modules
22BuildArch: noarch
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Werkzeug started as simple collection of various utilities for WSGI
27applications and has become one of the most advanced WSGI utility
28modules. It includes a powerful debugger, full featured request and
29response objects, HTTP utilities to handle entity tags, cache control
30headers, HTTP dates, cookie handling, file uploads, a powerful URL
31routing system and a bunch of community contributed addon modules.
32
33%description -l pl.UTF-8
34
35%prep
36%setup -q -n %{module}-%{version}
37
38%build
39%{__python} setup.py build
40
41%{?with_tests:%{__python} setup.py test}
42
43%install
44rm -rf $RPM_BUILD_ROOT
45%{__python} setup.py install \
46 --skip-build \
47 --optimize=2 \
48 --root=$RPM_BUILD_ROOT
49
50install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
54%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
55%py_postclean
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files
61%defattr(644,root,root,755)
62%doc AUTHORS CHANGES
63%{py_sitescriptdir}/werkzeug
64%if "%{py_ver}" > "2.4"
65%{py_sitescriptdir}/%{module}-*.egg-info
66%endif
67%{_examplesdir}/%{name}-%{version}
This page took 0.052527 seconds and 4 git commands to generate.