]> git.pld-linux.org Git - packages/python3-setuptools.git/blame - python3-setuptools.spec
- rel 1.2 for second bootstrap to let rpm generate provides deps
[packages/python3-setuptools.git] / python3-setuptools.spec
CommitLineData
2f649423
MK
1#
2# Conditional build:
e2cd79ed 3%bcond_without apidocs # Sphinx based documentation
828f076c 4%bcond_with system_libs # use system modules (appdirs, packaging, pyparsing) # TODO
6502ae9a 5%bcond_with tests # py.test tests (few failures)
744badc2 6%bcond_with bootstrap # convenience alias for without: apidocs,system_libs,tests
25fb9ea9 7
744badc2
JB
8%if %{with bootstrap}
9%undefine with_apidocs
10%undefine with_system_libs
11%undefine with_tests
12%endif
2f649423 13
744badc2 14%define module setuptools
9fded6eb 15%define pypi_name setuptools
b79e62bc 16Summary: A collection of enhancements to the Python distutils
e4a6c4e2 17Summary(pl.UTF-8): Zestaw rozszerzeń dla pythonowych distutils
34676580 18Name: python3-setuptools
6a8a63ea 19Version: 54.2.0
a4f7ab37 20Release: 1.2
67093d8e 21Epoch: 1
744badc2 22License: MIT
b79e62bc 23Group: Development/Languages/Python
744badc2 24#Source0Download: https://pypi.org/simple/setuptools/
6a8a63ea
AM
25Source0: https://files.pythonhosted.org/packages/source/s/setuptools/%{pypi_name}-%{version}.tar.gz
26# Source0-md5: 09f693b5d5ca8bf4fdb1da82f8110a9c
828f076c 27Patch0: setuptools-missing.patch
1ca207b5 28URL: https://github.com/pypa/setuptools
744badc2 29%if %(locale -a | grep -q '^C\.utf8$'; echo $?)
c034c756
JB
30BuildRequires: glibc-localedb-all
31%endif
828f076c 32BuildRequires: python3-modules >= 1:3.6
744badc2
JB
33%if %{with system_libs}
34# versions from pkg_resources/_vendor/vendored.txt
35BuildRequires: python3-appdirs >= 1.4.3
828f076c 36BuildRequires: python3-packaging >= 20.4
744badc2 37BuildRequires: python3-pyparsing >= 2.2.1
744badc2 38%endif
b6cbc91d 39BuildConflicts: python3-distribute < 0.7
e2cd79ed 40%if %{with tests}
828f076c 41BuildRequires: python3-Sphinx
744badc2 42BuildRequires: python3-coverage >= 4.5.1
828f076c
JB
43BuildRequires: python3-flake8-2020
44BuildRequires: python3-jaraco.envs
45BuildRequires: python3-jaraco.path >= 3.2.0
744badc2
JB
46# FIXME: patch to use unittest.mock
47#BuildRequires: python3-mock
744badc2 48BuildRequires: python3-paver
403a922f 49BuildRequires: python3-pip >= 19.1
828f076c
JB
50BuildRequires: python3-pytest >= 4.6
51BuildRequires: python3-pytest-black >= 0.3.7
52BuildRequires: python3-pytest-checkdocs >= 2.4
744badc2 53BuildRequires: python3-pytest-cov >= 2.5.1
828f076c 54BuildRequires: python3-pytest-enabler >= 1.0.1
6502ae9a 55BuildRequires: python3-pytest-flake8
828f076c 56BuildRequires: python3-pytest-mypy
744badc2 57BuildRequires: python3-pytest-virtualenv >= 1.2.7
828f076c 58BuildRequires: python3-pytest-xdist
744badc2
JB
59BuildRequires: python3-virtualenv >= 13.0.0
60BuildRequires: python3-wheel
e2cd79ed 61%endif
5c02125b 62%if %{with apidocs}
828f076c 63BuildRequires: python3-Sphinx
be14e546 64BuildRequires: python3-jaraco
828f076c 65BuildRequires: python3-jaraco.packaging >= 8.2
744badc2 66BuildRequires: python3-rst.linker >= 1.9
828f076c
JB
67# specified but not required(?)
68#BuildRequires: python3-pygments-github-lexers >= 0.0.5
69BuildRequires: python3-setuptools >= 1:34
70BuildRequires: python3-sphinx_inline_tabs
5c02125b 71%endif
20a0801e 72%{!?with_bootstrap:BuildRequires: rpm-pythonprov}
6502ae9a 73BuildRequires: rpmbuild(macros) >= 1.714
6ef7e1f8 74BuildRequires: unzip
828f076c 75Requires: python3-modules >= 1:3.6
744badc2
JB
76%if %{with system_libs}
77# versions from pkg_resources/_vendor/vendored.txt
828f076c
JB
78Requires: python3-appdirs >= 1.4.3
79Requires: python3-packaging >= 20.4
80Requires: python3-pyparsing >= 2.2.1
744badc2 81%endif
b79e62bc
AM
82BuildArch: noarch
83BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85%description
86setuptools is a collection of enhancements to the Python distutils
c034c756
JB
87that allow you to more easily build and distribute Python 2.x
88packages, especially ones that have dependencies on other packages.
b79e62bc 89
1c17442b 90%description -l pl.UTF-8
d539774b 91setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
c034c756
JB
92łatwiejsze budowanie i rozprowadzanie pakietów Pythona 2.x,
93szczególnie tych mających zależności od innych pakietów.
d539774b
JB
94
95Ten pakiet zawiera składniki uruchomieniowe setuptools, potrzebne do
c034c756
JB
96uruchamiania kodu wymagającego pkg_resources.py, przeznaczone dla
97Pythona 2.x.
eadb908c 98
2f649423
MK
99%package apidocs
100Summary: %{module} API documentation
101Summary(pl.UTF-8): Dokumentacja API %{module}
102Group: Documentation
103
104%description apidocs
105API documentation for %{module}.
106
107%description apidocs -l pl.UTF-8
108Dokumentacja API %{module}.
109
b79e62bc 110%prep
2f649423 111%setup -q -n %{module}-%{version}
828f076c 112%patch0 -p1
b79e62bc 113
744badc2
JB
114%if %{with system_libs}
115exit 1 # TODO: unvendor modules from pkg_resources/_vendor
116%endif
117
b79e62bc 118%build
6502ae9a
JB
119LC_ALL=C.UTF-8 \
120%py3_build
121
122%{?with_tests:%{__python3} -m pytest pkg_resources/tests setuptools/tests tests}
b79e62bc 123
c034c756 124%if %{with apidocs}
828f076c
JB
125cd docs
126%{__python3} -m sphinx -W . build/html
c034c756
JB
127%endif
128
b79e62bc
AM
129%install
130rm -rf $RPM_BUILD_ROOT
131
a21b5be7 132%py3_install
991fba2b 133
b79e62bc
AM
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%files
138%defattr(644,root,root,755)
744badc2 139%doc CHANGES.rst LICENSE README.rst
6a8a63ea 140%{py3_sitescriptdir}/_distutils_hack
828f076c 141%{py3_sitescriptdir}/distutils-precedence.pth
5c02125b
JB
142%{py3_sitescriptdir}/pkg_resources
143%{py3_sitescriptdir}/setuptools
2f649423 144%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
2f649423 145
c034c756 146%if %{with apidocs}
2f649423
MK
147%files apidocs
148%defattr(644,root,root,755)
828f076c 149%doc docs/build/html/{_static,deprecated,development,references,userguide,*.html,*.js}
2f649423 150%endif
This page took 0.241125 seconds and 4 git commands to generate.