]> git.pld-linux.org Git - packages/python3-requests.git/commitdiff
- try with tests, added reqs,disable-xdist patches, but one test fails
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 5 Mar 2022 20:50:06 +0000 (21:50 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 5 Mar 2022 20:50:06 +0000 (21:50 +0100)
python-requests-disable-xdist.patch [new file with mode: 0644]
python-requests-reqs.patch [new file with mode: 0644]
python-requests.spec

diff --git a/python-requests-disable-xdist.patch b/python-requests-disable-xdist.patch
new file mode 100644 (file)
index 0000000..fc4987a
--- /dev/null
@@ -0,0 +1,23 @@
+--- requests-2.25.1/setup.py.orig      2021-01-24 18:27:39.728966387 +0100
++++ requests-2.25.1/setup.py   2021-01-24 18:29:53.264909627 +0100
+@@ -16,11 +16,7 @@
+     def initialize_options(self):
+         TestCommand.initialize_options(self)
+-        try:
+-            from multiprocessing import cpu_count
+-            self.pytest_args = ['-n', str(cpu_count()), '--boxed']
+-        except (ImportError, NotImplementedError):
+-            self.pytest_args = ['-n', '1', '--boxed']
++        self.pytest_args = []
+     def finalize_options(self):
+         TestCommand.finalize_options(self)
+@@ -52,7 +48,6 @@
+     'pytest-httpbin>=0.0.7',
+     'pytest-cov',
+     'pytest-mock',
+-    'pytest-xdist',
+     'PySocks>=1.5.6, !=1.5.7',
+     'pytest>=3'
+ ]
diff --git a/python-requests-reqs.patch b/python-requests-reqs.patch
new file mode 100644 (file)
index 0000000..4b7f381
--- /dev/null
@@ -0,0 +1,11 @@
+--- requests-2.25.1/setup.py.orig      2020-12-16 18:43:25.000000000 +0100
++++ requests-2.25.1/setup.py   2021-01-24 18:05:52.042717398 +0100
+@@ -49,7 +49,7 @@
+ ]
+ test_requirements = [
+-    'pytest-httpbin==0.0.7',
++    'pytest-httpbin>=0.0.7',
+     'pytest-cov',
+     'pytest-mock',
+     'pytest-xdist',
index cae64e22deb9d2e4887ba55b7ef02c61bb972556..9b4b39b24111c4d441b741805c4359370768e0aa 100644 (file)
@@ -1,6 +1,6 @@
 #
 # Conditional build:
-%bcond_with    tests   # test target [Pipfile file missing as of 2.19.1]
+%bcond_with    tests   # pytest tests (one test fails with pytest-httpbin 1.0.0)
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
@@ -18,7 +18,9 @@ Group:                Development/Languages/Python
 Source0:       https://files.pythonhosted.org/packages/source/r/requests/%{module}-%{version}.tar.gz
 # Source0-md5: 8c745949ad3e9ae83d9927fed213db8a
 Patch0:                system-cert.patch
-URL:           http://python-requests.org/
+Patch1:                %{name}-reqs.patch
+Patch2:                %{name}-disable-xdist.patch
+URL:           https://docs.python-requests.org/
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.713
 %if %{with python2}
@@ -50,7 +52,6 @@ BuildRequires:        python3-certifi >= 2017.4.17
 BuildRequires: python3-chardet >= 3.0.2
 BuildRequires: python3-chardet < 5
 BuildRequires: python3-idna >= 2.5
-BuildRequires: python3-idna
 BuildRequires: python3-pytest >= 3
 BuildRequires: python3-pytest-cov
 BuildRequires: python3-pytest-httpbin >= 0.0.7
@@ -130,14 +131,24 @@ Ten pakiet zawiera moduĊ‚ dla Pythona 3.x.
 %prep
 %setup -q -n %{module}-%{version}
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 %if %{with python2}
-%py_build %{?with_tests:test}
+%py_build
+
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS="pytest_httpbin.plugin,pytest_mock" \
+%{__python} -m pytest tests
 %endif
 
 %if %{with python3}
-%py3_build %{?with_tests:test}
+%py3_build
+
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS="pytest_httpbin.plugin,pytest_mock" \
+%{__python3} -m pytest tests
 %endif
 
 %install
This page took 0.059051 seconds and 4 git commands to generate.