]> git.pld-linux.org Git - packages/python3-requests.git/blobdiff - python-requests.spec
Version: 2.18.2
[packages/python3-requests.git] / python-requests.spec
index 4811453565b18959219f837f2960aa7aea0ebda4..ad0da4deed1e90b1a747fb84c5e7e25143b19c87 100644 (file)
@@ -1,56 +1,58 @@
 #
 # Conditional build:
-%bcond_with    tests   # perform "make test"
+%bcond_with    tests   # test target (tests not included in dist tarball as of 2.13.0)
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
-%bcond_without bundled # bundled libraries
 #
-%define                urllib3ver      1.13
+%define                urllib3ver      1.21.1
 %define        module  requests
 Summary:       HTTP library for Python 2
 Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona 2
 Name:          python-%{module}
-Version:       2.9.1
+Version:       2.18.2
 Release:       1
-License:       Apache2
+License:       Apache v2.0
 Group:         Development/Languages/Python
-Source0:       https://pypi.python.org/packages/source/r/requests/%{module}-%{version}.tar.gz
-# Source0-md5: 0b7f480d19012ec52bab78292efd976d
-URL:           http://python-requests.org
-# find . -name '*.py' -exec sed -i -e 's#requests\.packages\.urllib3#urllib3#g' "{}" ";"
-# find . -name '*.py' -exec sed -i -e 's#\.packages\.urllib3#urllib3#g' "{}" ";"
-# find . -name '*.py' -exec sed -i -e 's#from \.packages import chardet#import charade as chardet#g' "{}" ";"
-# + manual removal from setup.py
-Patch0:                system-charade-and-urllib3.patch
-Patch1:                system-cert.patch
+Source0:       https://pypi.python.org/packages/07/2e/81fdfdfac91cf3cb2518fb149ac67caf0e081b485eab68e9aee63396f7e8/requests-2.18.2.tar.gz
+# Source0-md5: 49bd9924d3be341871bc922cde6f372e
+Patch0:                system-cert.patch
+URL:           http://python-requests.org/
 %if %{with python2}
 BuildRequires: python-modules >= 1:2.6
-%if %{without bundled}
-BuildRequires: python-charade
+%if %{with tests}
+BuildRequires: python-chardet >= 3.0.2
+BuildRequires: python-idna >= 2.5
 BuildRequires: python-urllib3 >= %{urllib3ver}
+BuildRequires: python-certifi >= 2017.4.17
+BuildRequires: python-pytest >= 2.8.0
+BuildRequires: python-pytest-cov
+BuildRequires: python-pytest-httpbin >= 0.0.7
+BuildRequires: python-pytest-mock
 %endif
-%{?with_tests:BuildRequires:   python-pytest >= 2.3.4}
 %endif
 %if %{with python3}
 BuildRequires: python3-modules >= 1:3.2
-%if %{without bundled}
-BuildRequires: python3-charade
+%if %{with tests}
+BuildRequires: python3-chardet >= 3.0.2
+BuildRequires: python3-idna >= 2.5
 BuildRequires: python3-urllib3 >= %{urllib3ver}
+BuildRequires: python3-certifi >= 2017.4.17
+BuildRequires: python3-pytest >= 2.8.0
+BuildRequires: python3-pytest-cov
+BuildRequires: python3-pytest-httpbin >= 0.0.7
+BuildRequires: python3-pytest-mock
 %endif
-%{?with_tests:BuildRequires:   python3-pytest >= 2.3.4}
 %endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.713
-Requires:      ca-certificates
-Requires:      python-modules >= 1:2.6
-%if %{without bundled}
-Requires:      python-charade
+Suggests:      ca-certificates
+Requires:      python-chardet >= 3.0.2
+Requires:      python-idna >= 2.5
 Requires:      python-urllib3 >= %{urllib3ver}
-%endif
 # for python2 only to get SNI working. python3 doesn't need this
 Requires:      python-ndg-httpsclient
 Requires:      python-pyasn1
-Requires:      python-pyOpenSSL
+Requires:      python-pyOpenSSL >= 0.14
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -81,12 +83,10 @@ Ten pakiet zawiera moduł dla Pythona 2.x.
 Summary:       HTTP library for Python 3
 Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona 3
 Group:         Development/Languages/Python
-Requires:      ca-certificates
-Requires:      python3-modules >= 1:3.2
-%if %{without bundled}
-Requires:      python3-charade
-Requires:      python3-urllib3 >= %{urllib3ver}
-%endif
+Suggests:      ca-certificates
+Requires:      python-chardet >= 3.0.2
+Requires:      python-idna >= 2.5
+Requires:      python-urllib3 >= %{urllib3ver}
 
 %description -n python3-requests
 Requests is a HTTP library, written in Python, for human beings.
@@ -113,18 +113,15 @@ Ten pakiet zawiera moduł dla Pythona 3.x.
 
 %prep
 %setup -q -n %{module}-%{version}
-%{!?with_bundled:%patch0 -p1}
-%patch1 -p1
+%patch0 -p1
 
 %build
 %if %{with python2}
 %py_build %{?with_tests:test}
-%{?with_tests:cp requirements.txt test_requests.py build-2; cd build-2; PYTHONPATH=$(pwd)/lib %{__python} test_requests.py; cd ..}
 %endif
 
 %if %{with python3}
 %py3_build %{?with_tests:test}
-%{?with_tests:cp requirements.txt test_requests.py build-3; cd build-3; PYTHONPATH=$(pwd)/lib %{__python3} test_requests.py; cd ..}
 %endif
 
 %install
@@ -141,9 +138,6 @@ rm -rf $RPM_BUILD_ROOT
 %py3_install
 %endif
 
-%{__rm} $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/cacert.pem
-%{!?with_bundled:%{__rm} -r $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/packages}
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.117393 seconds and 4 git commands to generate.