]> git.pld-linux.org Git - packages/python3-requests.git/blobdiff - python-requests.spec
- release 2 (by relup.sh)
[packages/python3-requests.git] / python-requests.spec
index ad0da4deed1e90b1a747fb84c5e7e25143b19c87..9d1f31f2674802a6caf99acee1431e513d68dbc7 100644 (file)
@@ -1,58 +1,69 @@
 #
 # Conditional build:
-%bcond_with    tests   # test target (tests not included in dist tarball as of 2.13.0)
+%bcond_with    tests   # test target [Pipfile file missing as of 2.19.1]
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
-#
-%define                urllib3ver      1.21.1
-%define        module  requests
+
+%define                urllib3_ver     1.21.1
+%define                module          requests
+%define                egg_name        requests
 Summary:       HTTP library for Python 2
 Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona 2
 Name:          python-%{module}
-Version:       2.18.2
-Release:       1
+Version:       2.23.0
+Release:       2
 License:       Apache v2.0
 Group:         Development/Languages/Python
-Source0:       https://pypi.python.org/packages/07/2e/81fdfdfac91cf3cb2518fb149ac67caf0e081b485eab68e9aee63396f7e8/requests-2.18.2.tar.gz
-# Source0-md5: 49bd9924d3be341871bc922cde6f372e
+#Source0Download: https://pypi.org/simple/requests/
+Source0:       https://files.pythonhosted.org/packages/source/r/requests/%{module}-%{version}.tar.gz
+# Source0-md5: abfdc28db1065bbd0bc32592ac9d27a6
 Patch0:                system-cert.patch
 URL:           http://python-requests.org/
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.713
 %if %{with python2}
-BuildRequires: python-modules >= 1:2.6
+BuildRequires: python-modules >= 1:2.7
+BuildRequires: python-setuptools
 %if %{with tests}
+BuildRequires: python-PySocks >= 1.5.8
+BuildRequires: python-certifi >= 2017.4.17
 BuildRequires: python-chardet >= 3.0.2
+BuildRequires: python-chardet < 4
 BuildRequires: python-idna >= 2.5
-BuildRequires: python-urllib3 >= %{urllib3ver}
-BuildRequires: python-certifi >= 2017.4.17
-BuildRequires: python-pytest >= 2.8.0
+BuildRequires: python-idna < 3
+BuildRequires: python-pytest >= 3
 BuildRequires: python-pytest-cov
 BuildRequires: python-pytest-httpbin >= 0.0.7
 BuildRequires: python-pytest-mock
+BuildRequires: python-pytest-xdist
+BuildRequires: python-urllib3 >= %{urllib3_ver}
+BuildRequires: python-urllib3 < 1.26
 %endif
 %endif
 %if %{with python3}
-BuildRequires: python3-modules >= 1:3.2
+BuildRequires: python3-modules >= 1:3.5
+BuildRequires: python3-setuptools
 %if %{with tests}
+BuildRequires: python3-PySocks >= 1.5.8
+BuildRequires: python3-certifi >= 2017.4.17
 BuildRequires: python3-chardet >= 3.0.2
+BuildRequires: python3-chardet < 4
 BuildRequires: python3-idna >= 2.5
-BuildRequires: python3-urllib3 >= %{urllib3ver}
-BuildRequires: python3-certifi >= 2017.4.17
-BuildRequires: python3-pytest >= 2.8.0
+BuildRequires: python3-idna < 3
+BuildRequires: python3-pytest >= 3
 BuildRequires: python3-pytest-cov
 BuildRequires: python3-pytest-httpbin >= 0.0.7
 BuildRequires: python3-pytest-mock
+BuildRequires: python3-pytest-xdist
+BuildRequires: python3-urllib3 >= %{urllib3_ver}
+BuildRequires: python3-urllib3 < 1.26
 %endif
 %endif
-BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.713
 Suggests:      ca-certificates
-Requires:      python-chardet >= 3.0.2
-Requires:      python-idna >= 2.5
-Requires:      python-urllib3 >= %{urllib3ver}
 # for python2 only to get SNI working. python3 doesn't need this
-Requires:      python-ndg-httpsclient
-Requires:      python-pyasn1
+Requires:      python-cryptography >= 1.3.4
 Requires:      python-pyOpenSSL >= 0.14
+Requires:      python-urllib3 >= 1.22-2
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -83,10 +94,12 @@ Ten pakiet zawiera moduĊ‚ dla Pythona 2.x.
 Summary:       HTTP library for Python 3
 Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona 3
 Group:         Development/Languages/Python
+Requires:      python3-modules >= 1:3.5
+# for https
+Requires:      python3-cryptography >= 1.3.4
+Requires:      python3-pyOpenSSL >= 0.14
+Requires:      python3-urllib3 >= 1.22-2
 Suggests:      ca-certificates
-Requires:      python-chardet >= 3.0.2
-Requires:      python-idna >= 2.5
-Requires:      python-urllib3 >= %{urllib3ver}
 
 %description -n python3-requests
 Requests is a HTTP library, written in Python, for human beings.
@@ -144,15 +157,15 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc HISTORY.rst README.rst
+%doc HISTORY.md README.md
 %{py_sitescriptdir}/%{module}
-%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
+%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
 %endif
 
 %if %{with python3}
 %files -n python3-requests
 %defattr(644,root,root,755)
-%doc HISTORY.rst README.rst
+%doc HISTORY.md README.md
 %{py3_sitescriptdir}/%{module}
-%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
+%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
 %endif
This page took 0.130212 seconds and 4 git commands to generate.