]> git.pld-linux.org Git - packages/python3-requests.git/blobdiff - python-requests.spec
- release 2 (by relup.sh)
[packages/python3-requests.git] / python-requests.spec
index 315ffe69b7f2284ff7c1e80dec83c0803eb48958..9d1f31f2674802a6caf99acee1431e513d68dbc7 100644 (file)
@@ -1,36 +1,69 @@
-# Conditional build:
-%bcond_without  python2         # build python 2 module
-%bcond_without  python3         # build python 3 module
 #
 #
-%define        module  requests
-Summary:       HTTP library for Python
-Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona
+# Conditional build:
+%bcond_with    tests   # test target [Pipfile file missing as of 2.19.1]
+%bcond_without python2 # CPython 2.x module
+%bcond_without python3 # CPython 3.x module
+
+%define                urllib3_ver     1.21.1
+%define                module          requests
+%define                egg_name        requests
+Summary:       HTTP library for Python 2
+Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona 2
 Name:          python-%{module}
 Name:          python-%{module}
-Version:       2.4.1
-Release:       1
-License:       Apache2
+Version:       2.23.0
+Release:       2
+License:       Apache v2.0
 Group:         Development/Languages/Python
 Group:         Development/Languages/Python
-Source0:       https://pypi.python.org/packages/source/r/requests/%{module}-%{version}.tar.gz
-# Source0-md5: 931461f761c70708c46ea65b7889da58
-URL:           http://python-requests.org
-Patch0:                system-charade-and-urllib3.patch
-Patch1:                system-cert.patch
+#Source0Download: https://pypi.org/simple/requests/
+Source0:       https://files.pythonhosted.org/packages/source/r/requests/%{module}-%{version}.tar.gz
+# Source0-md5: abfdc28db1065bbd0bc32592ac9d27a6
+Patch0:                system-cert.patch
+URL:           http://python-requests.org/
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.713
 %if %{with python2}
 %if %{with python2}
-BuildRequires: python-charade
-BuildRequires: python-modules >= 1:2.6
-BuildRequires: python-urllib3 >= 1.9.1
+BuildRequires: python-modules >= 1:2.7
+BuildRequires: python-setuptools
+%if %{with tests}
+BuildRequires: python-PySocks >= 1.5.8
+BuildRequires: python-certifi >= 2017.4.17
+BuildRequires: python-chardet >= 3.0.2
+BuildRequires: python-chardet < 4
+BuildRequires: python-idna >= 2.5
+BuildRequires: python-idna < 3
+BuildRequires: python-pytest >= 3
+BuildRequires: python-pytest-cov
+BuildRequires: python-pytest-httpbin >= 0.0.7
+BuildRequires: python-pytest-mock
+BuildRequires: python-pytest-xdist
+BuildRequires: python-urllib3 >= %{urllib3_ver}
+BuildRequires: python-urllib3 < 1.26
+%endif
 %endif
 %if %{with python3}
 %endif
 %if %{with python3}
-BuildRequires: python3-charade
-BuildRequires: python3-modules >= 3.2
-BuildRequires: python3-urllib3 >= 1.9.1
+BuildRequires: python3-modules >= 1:3.5
+BuildRequires: python3-setuptools
+%if %{with tests}
+BuildRequires: python3-PySocks >= 1.5.8
+BuildRequires: python3-certifi >= 2017.4.17
+BuildRequires: python3-chardet >= 3.0.2
+BuildRequires: python3-chardet < 4
+BuildRequires: python3-idna >= 2.5
+BuildRequires: python3-idna < 3
+BuildRequires: python3-pytest >= 3
+BuildRequires: python3-pytest-cov
+BuildRequires: python3-pytest-httpbin >= 0.0.7
+BuildRequires: python3-pytest-mock
+BuildRequires: python3-pytest-xdist
+BuildRequires: python3-urllib3 >= %{urllib3_ver}
+BuildRequires: python3-urllib3 < 1.26
 %endif
 %endif
-BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
-Requires:      ca-certificates
-Requires:      python-charade
-Requires:      python-modules >= 1:2.6
-Requires:      python-urllib3 >= 1.9.1
+%endif
+Suggests:      ca-certificates
+# for python2 only to get SNI working. python3 doesn't need this
+Requires:      python-cryptography >= 1.3.4
+Requires:      python-pyOpenSSL >= 0.14
+Requires:      python-urllib3 >= 1.22-2
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -44,6 +77,8 @@ broken. It requires an enormous amount of work (even method overrides)
 to perform the simplest of tasks. Things shouldn't be this way. Not in
 Python.
 
 to perform the simplest of tasks. Things shouldn't be this way. Not in
 Python.
 
+This package contains Python 2.x module.
+
 %description -l pl.UTF-8
 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
 
 %description -l pl.UTF-8
 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
 
@@ -53,14 +88,18 @@ zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
 
 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
 
+Ten pakiet zawiera moduł dla Pythona 2.x.
+
 %package -n python3-requests
 %package -n python3-requests
-Summary:       HTTP library, written in Python, for human beings
-Summary(pl.UTF-8):     Biblioteka HTTP library napisana w Pythonie dla ludzi
+Summary:       HTTP library for Python 3
+Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona 3
 Group:         Development/Languages/Python
 Group:         Development/Languages/Python
-Requires:      ca-certificates
-Requires:      python3-charade
-Requires:      python3-modules >= 3.2
-Requires:      python3-urllib3 >= 1.9.1
+Requires:      python3-modules >= 1:3.5
+# for https
+Requires:      python3-cryptography >= 1.3.4
+Requires:      python3-pyOpenSSL >= 0.14
+Requires:      python3-urllib3 >= 1.22-2
+Suggests:      ca-certificates
 
 %description -n python3-requests
 Requests is a HTTP library, written in Python, for human beings.
 
 %description -n python3-requests
 Requests is a HTTP library, written in Python, for human beings.
@@ -72,6 +111,8 @@ broken. It requires an enormous amount of work (even method overrides)
 to perform the simplest of tasks. Things shouldn't be this way. Not in
 Python.
 
 to perform the simplest of tasks. Things shouldn't be this way. Not in
 Python.
 
+This package contains Python 3.x module.
+
 %description -n python3-requests -l pl.UTF-8
 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
 
 %description -n python3-requests -l pl.UTF-8
 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
 
@@ -81,63 +122,50 @@ zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
 
 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
 
+Ten pakiet zawiera moduł dla Pythona 3.x.
+
 %prep
 %setup -q -n %{module}-%{version}
 %patch0 -p1
 %prep
 %setup -q -n %{module}-%{version}
 %patch0 -p1
-%patch1 -p1
 
 %build
 %if %{with python2}
 
 %build
 %if %{with python2}
-%{__python} setup.py build -b py2
+%py_build %{?with_tests:test}
 %endif
 
 %if %{with python3}
 %endif
 
 %if %{with python3}
-%{__python3} setup.py build -b py3
+%py3_build %{?with_tests:test}
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
-%{__python} setup.py \
-       build -b py2 \
-       install \
-       --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
 %py_postclean
 %endif
 
 %if %{with python3}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
 %py_postclean
 %endif
 
 %if %{with python3}
-%{__python3} setup.py  \
-       build -b py3 \
-       install \
-       --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 %endif
 
 %endif
 
-%{__rm} -rf $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py3_sitescriptdir}}/%{module}/{cacert.pem,packages}
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc HISTORY.rst README.rst
+%doc HISTORY.md README.md
 %{py_sitescriptdir}/%{module}
 %{py_sitescriptdir}/%{module}
-%if "%{py_ver}" > "2.4"
-%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
-%endif
+%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
 %endif
 
 %if %{with python3}
 %files -n python3-requests
 %defattr(644,root,root,755)
 %endif
 
 %if %{with python3}
 %files -n python3-requests
 %defattr(644,root,root,755)
-%doc HISTORY.rst README.rst
+%doc HISTORY.md README.md
 %{py3_sitescriptdir}/%{module}
 %{py3_sitescriptdir}/%{module}
-%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
+%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
 %endif
 %endif
This page took 0.09913 seconds and 4 git commands to generate.