]> git.pld-linux.org Git - packages/python3-requests.git/blobdiff - python-requests.spec
- updated to 2.27.1
[packages/python3-requests.git] / python-requests.spec
index 00d3423b8d9fb5716bb528bc634ee512e8ed668b..03f6c5c8db6ae5fb70c66867eee11140a3b80c4d 100644 (file)
@@ -1,6 +1,6 @@
 #
 # Conditional build:
-%bcond_with    tests   # test target [Pipfile file missing as of 2.19.1]
+%bcond_with    tests   # pytest tests (one test fails with pytest-httpbin 1.0.0)
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
 Summary:       HTTP library for Python 2
 Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona 2
 Name:          python-%{module}
-Version:       2.22.0
-Release:       3
+# keep 2.27.x here for python2 support
+Version:       2.27.1
+Release:       1
 License:       Apache v2.0
 Group:         Development/Languages/Python
 #Source0Download: https://pypi.org/simple/requests/
 Source0:       https://files.pythonhosted.org/packages/source/r/requests/%{module}-%{version}.tar.gz
-# Source0-md5: ee28bee2de76e9198fc41e48f3a7dd47
+# Source0-md5: bcc01b73974a305cc7c5b092e7d07004
 Patch0:                system-cert.patch
-URL:           http://python-requests.org/
+Patch1:                %{name}-reqs.patch
+Patch2:                %{name}-disable-xdist.patch
+URL:           https://docs.python-requests.org/
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.713
 %if %{with python2}
@@ -28,35 +31,36 @@ BuildRequires:      python-setuptools
 BuildRequires: python-PySocks >= 1.5.8
 BuildRequires: python-certifi >= 2017.4.17
 BuildRequires: python-chardet >= 3.0.2
-BuildRequires: python-chardet < 3.1.0
+BuildRequires: python-chardet < 5
+# idna 3 not supported for python2
 BuildRequires: python-idna >= 2.5
-BuildRequires: python-idna < 2.9
-BuildRequires: python-pytest >= 2.8.0
+BuildRequires: python-idna < 3
+BuildRequires: python-pytest >= 3
 BuildRequires: python-pytest-cov
 BuildRequires: python-pytest-httpbin >= 0.0.7
-BuildRequires: python-pytest-mock
+BuildRequires: python-pytest-mock >= 2.0.0
 BuildRequires: python-pytest-xdist
 BuildRequires: python-urllib3 >= %{urllib3_ver}
-BuildRequires: python-urllib3 < 1.26
+BuildRequires: python-urllib3 < 1.27
 %endif
 %endif
 %if %{with python3}
-BuildRequires: python3-modules >= 1:3.5
+BuildRequires: python3-modules >= 1:3.6
 BuildRequires: python3-setuptools
 %if %{with tests}
 BuildRequires: python3-PySocks >= 1.5.8
 BuildRequires: python3-certifi >= 2017.4.17
-BuildRequires: python3-chardet >= 3.0.2
-BuildRequires: python3-chardet < 3.1.0
+BuildRequires: python3-charset_normalizer >= 2
+BuildRequires: python3-charset_normalizer < 2.1
 BuildRequires: python3-idna >= 2.5
-BuildRequires: python3-idna < 2.9
-BuildRequires: python3-pytest >= 2.8.0
+BuildRequires: python3-idna < 4
+BuildRequires: python3-pytest >= 3
 BuildRequires: python3-pytest-cov
 BuildRequires: python3-pytest-httpbin >= 0.0.7
-BuildRequires: python3-pytest-mock
+BuildRequires: python3-pytest-mock >= 2.0.0
 BuildRequires: python3-pytest-xdist
 BuildRequires: python3-urllib3 >= %{urllib3_ver}
-BuildRequires: python3-urllib3 < 1.26
+BuildRequires: python3-urllib3 < 1.27
 %endif
 %endif
 Suggests:      ca-certificates
@@ -94,9 +98,11 @@ Ten pakiet zawiera moduł dla Pythona 2.x.
 Summary:       HTTP library for Python 3
 Summary(pl.UTF-8):     Biblioteka HTTP dla Pythona 3
 Group:         Development/Languages/Python
-Requires:      python3-modules >= 1:3.5
+Requires:      python3-modules >= 1:3.6
+Requires:      python3-charset_normalizer >= 2
 # for https
 Requires:      python3-cryptography >= 1.3.4
+Requires:      python3-idna >= 2.5
 Requires:      python3-pyOpenSSL >= 0.14
 Requires:      python3-urllib3 >= 1.22-2
 Suggests:      ca-certificates
@@ -127,14 +133,28 @@ Ten pakiet zawiera moduł dla Pythona 3.x.
 %prep
 %setup -q -n %{module}-%{version}
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 %if %{with python2}
-%py_build %{?with_tests:test}
+%py_build
+
+%if %{with tests}
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS="pytest_httpbin.plugin,pytest_mock" \
+%{__python} -m pytest tests
+%endif
 %endif
 
 %if %{with python3}
-%py3_build %{?with_tests:test}
+%py3_build
+
+%if %{with tests}
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS="pytest_httpbin.plugin,pytest_mock" \
+%{__python3} -m pytest tests
+%endif
 %endif
 
 %install
@@ -142,8 +162,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
 %py_install
-%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
-%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
+
 %py_postclean
 %endif
 
This page took 0.032028 seconds and 4 git commands to generate.