]> git.pld-linux.org Git - packages/python3-requests.git/blob - python-requests.spec
- up to 2.25.1
[packages/python3-requests.git] / python-requests.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # test target [Pipfile file missing as of 2.19.1]
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         urllib3_ver     1.21.1
8 %define         module          requests
9 %define         egg_name        requests
10 Summary:        HTTP library for Python 2
11 Summary(pl.UTF-8):      Biblioteka HTTP dla Pythona 2
12 Name:           python-%{module}
13 Version:        2.25.1
14 Release:        1
15 License:        Apache v2.0
16 Group:          Development/Languages/Python
17 #Source0Download: https://pypi.org/simple/requests/
18 Source0:        https://files.pythonhosted.org/packages/source/r/requests/%{module}-%{version}.tar.gz
19 # Source0-md5:  514d6f7eba77ada0b8c98ec7818828db
20 Patch0:         system-cert.patch
21 URL:            http://python-requests.org/
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.713
24 %if %{with python2}
25 BuildRequires:  python-modules >= 1:2.7
26 BuildRequires:  python-setuptools
27 %if %{with tests}
28 BuildRequires:  python-PySocks >= 1.5.8
29 BuildRequires:  python-certifi >= 2017.4.17
30 BuildRequires:  python-chardet >= 3.0.2
31 BuildRequires:  python-chardet < 4
32 BuildRequires:  python-idna >= 2.5
33 BuildRequires:  python-idna < 3
34 BuildRequires:  python-pytest >= 3
35 BuildRequires:  python-pytest-cov
36 BuildRequires:  python-pytest-httpbin >= 0.0.7
37 BuildRequires:  python-pytest-mock
38 BuildRequires:  python-pytest-xdist
39 BuildRequires:  python-urllib3 >= %{urllib3_ver}
40 BuildRequires:  python-urllib3 < 1.26
41 %endif
42 %endif
43 %if %{with python3}
44 BuildRequires:  python3-modules >= 1:3.5
45 BuildRequires:  python3-setuptools
46 %if %{with tests}
47 BuildRequires:  python3-PySocks >= 1.5.8
48 BuildRequires:  python3-certifi >= 2017.4.17
49 BuildRequires:  python3-chardet >= 3.0.2
50 BuildRequires:  python3-chardet < 4
51 BuildRequires:  python3-idna >= 2.5
52 BuildRequires:  python3-idna < 3
53 BuildRequires:  python3-pytest >= 3
54 BuildRequires:  python3-pytest-cov
55 BuildRequires:  python3-pytest-httpbin >= 0.0.7
56 BuildRequires:  python3-pytest-mock
57 BuildRequires:  python3-pytest-xdist
58 BuildRequires:  python3-urllib3 >= %{urllib3_ver}
59 BuildRequires:  python3-urllib3 < 1.26
60 %endif
61 %endif
62 Suggests:       ca-certificates
63 # for python2 only to get SNI working. python3 doesn't need this
64 Requires:       python-cryptography >= 1.3.4
65 Requires:       python-pyOpenSSL >= 0.14
66 Requires:       python-urllib3 >= 1.22-2
67 BuildArch:      noarch
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 Requests is a HTTP library, written in Python, for human beings.
72
73 Most existing Python modules for sending HTTP requests are extremely
74 verbose and cumbersome. Python's builtin urllib2 module provides most
75 of the HTTP capabilities you should need, but the API is thoroughly
76 broken. It requires an enormous amount of work (even method overrides)
77 to perform the simplest of tasks. Things shouldn't be this way. Not in
78 Python.
79
80 This package contains Python 2.x module.
81
82 %description -l pl.UTF-8
83 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
84
85 Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
86 zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
87 zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
88 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
89 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
90
91 Ten pakiet zawiera moduł dla Pythona 2.x.
92
93 %package -n python3-requests
94 Summary:        HTTP library for Python 3
95 Summary(pl.UTF-8):      Biblioteka HTTP dla Pythona 3
96 Group:          Development/Languages/Python
97 Requires:       python3-modules >= 1:3.5
98 # for https
99 Requires:       python3-cryptography >= 1.3.4
100 Requires:       python3-pyOpenSSL >= 0.14
101 Requires:       python3-urllib3 >= 1.22-2
102 Suggests:       ca-certificates
103
104 %description -n python3-requests
105 Requests is a HTTP library, written in Python, for human beings.
106
107 Most existing Python modules for sending HTTP requests are extremely
108 verbose and cumbersome. Python's builtin urllib2 module provides most
109 of the HTTP capabilities you should need, but the api is thoroughly
110 broken. It requires an enormous amount of work (even method overrides)
111 to perform the simplest of tasks. Things shouldn't be this way. Not in
112 Python.
113
114 This package contains Python 3.x module.
115
116 %description -n python3-requests -l pl.UTF-8
117 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
118
119 Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
120 zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
121 zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
122 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
123 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
124
125 Ten pakiet zawiera moduł dla Pythona 3.x.
126
127 %prep
128 %setup -q -n %{module}-%{version}
129 %patch0 -p1
130
131 %build
132 %if %{with python2}
133 %py_build %{?with_tests:test}
134 %endif
135
136 %if %{with python3}
137 %py3_build %{?with_tests:test}
138 %endif
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %if %{with python2}
144 %py_install
145 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
146 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
147 %py_postclean
148 %endif
149
150 %if %{with python3}
151 %py3_install
152 %endif
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %if %{with python2}
158 %files
159 %defattr(644,root,root,755)
160 %doc HISTORY.md README.md
161 %{py_sitescriptdir}/%{module}
162 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
163 %endif
164
165 %if %{with python3}
166 %files -n python3-requests
167 %defattr(644,root,root,755)
168 %doc HISTORY.md README.md
169 %{py3_sitescriptdir}/%{module}
170 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
171 %endif
This page took 0.059324 seconds and 3 git commands to generate.