]> git.pld-linux.org Git - packages/python3-requests.git/blame - python-requests.spec
- updated dependencies, removed redundant py_*comp
[packages/python3-requests.git] / python-requests.spec
CommitLineData
ef9212ce 1#
8d099eee 2# Conditional build:
44a39070 3%bcond_with tests # test target [Pipfile file missing as of 2.19.1]
ef9212ce
JB
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
dd9a8c31 6
44a39070 7%define urllib3_ver 1.21.1
dd9a8c31
ER
8%define module requests
9%define egg_name requests
ef9212ce
JB
10Summary: HTTP library for Python 2
11Summary(pl.UTF-8): Biblioteka HTTP dla Pythona 2
8ba13116 12Name: python-%{module}
a5ef80ca 13Version: 2.26.0
24e1d820 14Release: 2
017795a9 15License: Apache v2.0
8ba13116 16Group: Development/Languages/Python
44a39070
JB
17#Source0Download: https://pypi.org/simple/requests/
18Source0: https://files.pythonhosted.org/packages/source/r/requests/%{module}-%{version}.tar.gz
a5ef80ca 19# Source0-md5: 8c745949ad3e9ae83d9927fed213db8a
0989c03f 20Patch0: system-cert.patch
017795a9 21URL: http://python-requests.org/
dd9a8c31
ER
22BuildRequires: rpm-pythonprov
23BuildRequires: rpmbuild(macros) >= 1.713
a8d01621 24%if %{with python2}
d04d981e 25BuildRequires: python-modules >= 1:2.7
dd9a8c31 26BuildRequires: python-setuptools
017795a9 27%if %{with tests}
d04d981e 28BuildRequires: python-PySocks >= 1.5.8
dd9a8c31 29BuildRequires: python-certifi >= 2017.4.17
0989c03f 30BuildRequires: python-chardet >= 3.0.2
fa360ea6 31BuildRequires: python-chardet < 5
a5ef80ca 32# idna 3 not supported for python2
0989c03f 33BuildRequires: python-idna >= 2.5
0ecc0c85
JB
34BuildRequires: python-idna < 3
35BuildRequires: python-pytest >= 3
017795a9
JB
36BuildRequires: python-pytest-cov
37BuildRequires: python-pytest-httpbin >= 0.0.7
fa360ea6 38BuildRequires: python-pytest-mock >= 2.0.0
d04d981e 39BuildRequires: python-pytest-xdist
44a39070 40BuildRequires: python-urllib3 >= %{urllib3_ver}
fa360ea6 41BuildRequires: python-urllib3 < 1.27
017795a9 42%endif
27c2bafe 43%endif
a8d01621 44%if %{with python3}
a5ef80ca 45BuildRequires: python3-modules >= 1:3.6
616851f8 46BuildRequires: python3-setuptools
017795a9 47%if %{with tests}
d04d981e 48BuildRequires: python3-PySocks >= 1.5.8
dd9a8c31 49BuildRequires: python3-certifi >= 2017.4.17
0989c03f 50BuildRequires: python3-chardet >= 3.0.2
fa360ea6 51BuildRequires: python3-chardet < 5
0989c03f 52BuildRequires: python3-idna >= 2.5
a5ef80ca 53BuildRequires: python3-idna
0ecc0c85 54BuildRequires: python3-pytest >= 3
017795a9
JB
55BuildRequires: python3-pytest-cov
56BuildRequires: python3-pytest-httpbin >= 0.0.7
fa360ea6 57BuildRequires: python3-pytest-mock >= 2.0.0
d04d981e 58BuildRequires: python3-pytest-xdist
44a39070 59BuildRequires: python3-urllib3 >= %{urllib3_ver}
fa360ea6 60BuildRequires: python3-urllib3 < 1.27
017795a9 61%endif
27c2bafe 62%endif
dd9a8c31 63Suggests: ca-certificates
e7d50ac0 64# for python2 only to get SNI working. python3 doesn't need this
d04d981e 65Requires: python-cryptography >= 1.3.4
017795a9 66Requires: python-pyOpenSSL >= 0.14
ecc66759 67Requires: python-urllib3 >= 1.22-2
8ba13116
MM
68BuildArch: noarch
69BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71%description
a8d01621 72Requests is a HTTP library, written in Python, for human beings.
8ba13116
MM
73
74Most existing Python modules for sending HTTP requests are extremely
75verbose and cumbersome. Python's builtin urllib2 module provides most
8d099eee 76of the HTTP capabilities you should need, but the API is thoroughly
8ba13116 77broken. It requires an enormous amount of work (even method overrides)
8d099eee
JB
78to perform the simplest of tasks. Things shouldn't be this way. Not in
79Python.
80
ef9212ce
JB
81This package contains Python 2.x module.
82
8d099eee 83%description -l pl.UTF-8
a8d01621 84Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
8ba13116 85
8d099eee
JB
86Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
87zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
88zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
89wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
90najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
8ba13116 91
ef9212ce
JB
92Ten pakiet zawiera moduł dla Pythona 2.x.
93
a0c91a8e 94%package -n python3-requests
ef9212ce
JB
95Summary: HTTP library for Python 3
96Summary(pl.UTF-8): Biblioteka HTTP dla Pythona 3
a0c91a8e 97Group: Development/Languages/Python
a5ef80ca 98Requires: python3-modules >= 1:3.6
24e1d820 99Requires: python3-charset_normalizer >= 2
d04d981e
JB
100# for https
101Requires: python3-cryptography >= 1.3.4
24e1d820 102Requires: python3-idna >= 2.5
d04d981e 103Requires: python3-pyOpenSSL >= 0.14
ecc66759 104Requires: python3-urllib3 >= 1.22-2
dd9a8c31 105Suggests: ca-certificates
a0c91a8e
KK
106
107%description -n python3-requests
a8d01621 108Requests is a HTTP library, written in Python, for human beings.
a0c91a8e
KK
109
110Most existing Python modules for sending HTTP requests are extremely
111verbose and cumbersome. Python's builtin urllib2 module provides most
112of the HTTP capabilities you should need, but the api is thoroughly
113broken. It requires an enormous amount of work (even method overrides)
8d099eee
JB
114to perform the simplest of tasks. Things shouldn't be this way. Not in
115Python.
116
ef9212ce
JB
117This package contains Python 3.x module.
118
8d099eee 119%description -n python3-requests -l pl.UTF-8
a8d01621 120Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
a0c91a8e 121
a8d01621
ŁK
122Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
123zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
124zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
125wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
126najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
a0c91a8e 127
ef9212ce
JB
128Ten pakiet zawiera moduł dla Pythona 3.x.
129
8ba13116 130%prep
a8d01621 131%setup -q -n %{module}-%{version}
0989c03f 132%patch0 -p1
e16ab944 133
8ba13116 134%build
a8d01621 135%if %{with python2}
b4dcbe07 136%py_build %{?with_tests:test}
a8d01621 137%endif
a0c91a8e 138
a8d01621 139%if %{with python3}
b4dcbe07 140%py3_build %{?with_tests:test}
8d099eee 141%endif
8ba13116
MM
142
143%install
144rm -rf $RPM_BUILD_ROOT
a8d01621
ŁK
145
146%if %{with python2}
b4dcbe07 147%py_install
fa360ea6 148
a8d01621
ŁK
149%py_postclean
150%endif
8ba13116 151
a8d01621 152%if %{with python3}
b4dcbe07 153%py3_install
a8d01621 154%endif
8ba13116
MM
155
156%clean
157rm -rf $RPM_BUILD_ROOT
158
a8d01621 159%if %{with python2}
8ba13116
MM
160%files
161%defattr(644,root,root,755)
283f39fa 162%doc HISTORY.md README.md
8ba13116 163%{py_sitescriptdir}/%{module}
dd9a8c31 164%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
a8d01621 165%endif
a0c91a8e 166
a8d01621 167%if %{with python3}
a0c91a8e
KK
168%files -n python3-requests
169%defattr(644,root,root,755)
283f39fa 170%doc HISTORY.md README.md
a0c91a8e 171%{py3_sitescriptdir}/%{module}
dd9a8c31 172%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
a8d01621 173%endif
This page took 0.11294 seconds and 4 git commands to generate.